18:36:35 <SumitNaiksatam> #startmeeting Networking FWaaS
18:36:36 <openstack> Meeting started Wed Jun 18 18:36:35 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:36:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:36:39 <openstack> The meeting name has been set to 'networking_fwaas'
18:36:44 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/FWaaS
18:36:53 <SumitNaiksatam> #topic bugs
18:37:19 <SumitNaiksatam> #undo
18:37:20 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x2690910>
18:37:26 <SumitNaiksatam> #topic Action item review
18:37:51 <SumitNaiksatam> i basically copy pasted the action items from last weeks meeting
18:38:02 <SumitNaiksatam> #link https://wiki.openstack.org/wiki/Meetings/FWaaS#Action_items_from_previous_meeting
18:38:24 <SumitNaiksatam> do we need to discuss any of them first?
18:38:42 <SumitNaiksatam> i think we accomplised some of them
18:39:42 <SridarK> i have updated the plan with some vendor stuff as well
18:39:51 <SumitNaiksatam> beyounn: perhaps you can do the DVR udpate as a separate agenda item
18:39:55 <SumitNaiksatam> SridarK: sure, thanks
18:40:03 <SridarK> and talked to Rajesh as i mentioned in email
18:40:06 <beyounn> Same here
18:40:19 <SridarK> so we may need to plan for prad's requirements
18:40:41 <SumitNaiksatam> beyounn: you mean you updated the wiki page?
18:41:04 <SumitNaiksatam> SridarK: yeah, lets discuss that as a separate item, thanks for the follow up with rajesh
18:41:05 <beyounn> Sumit: right, for the DVR, there are no progress in past two or three weeks
18:41:11 <SumitNaiksatam> beyounn: ok
18:41:22 <SumitNaiksatam> beyounn: your plan was to send an email to the -dev mailer?
18:41:29 <beyounn> Sumit: it is mainly be cause I'm too busy to follow it up
18:41:30 <SumitNaiksatam> beyounn: just for the record
18:41:44 <beyounn> Sumit: I will kick out the email to ML
18:41:46 <SumitNaiksatam> beyounn: i can totally understand
18:41:57 <SumitNaiksatam> beyounn: nice, at least that way it will be on whoever’s radar
18:42:09 <beyounn> Sumit: right
18:42:16 <SumitNaiksatam> #action beyounn to send DVR issues related to -dev mailer
18:42:25 <beyounn> Sumit: I will try to do it this evening
18:42:31 <SumitNaiksatam> beyounn: thanks much
18:42:39 <SumitNaiksatam> #topic bugs
18:43:13 <SumitNaiksatam> so our bug count is increasing: #link
18:43:16 <SumitNaiksatam> #link https://bugs.launchpad.net/openstack/+bugs?field.searchtext=fwaas&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package
18:43:29 <SumitNaiksatam> and we have quite a few untriaged bugs
18:43:38 <SumitNaiksatam> i had the action item to triage them but has not happened
18:44:21 <SumitNaiksatam> i brought this one up in the neutron IRC meeting: #link https://review.openstack.org/#/c/90575/
18:44:29 <SumitNaiksatam> since it has a -2 from markmcclain
18:45:06 <SumitNaiksatam> in parallel we also need to reach out to the owner of this patch
18:45:13 <SridarK> SumitNaiksatam: yes good - i was out on Mon and could not make the mtg
18:45:26 <mestery> SumitNaiksatam: ack (sorry, had to step out for a phone call)
18:45:32 <SridarK> i think the comments there are valid - not sure if this is the approach on the fix
18:45:37 <SumitNaiksatam> SridarK: yes, i brought up two things, this bug, and beyounn’s service objects spec
18:45:59 <SumitNaiksatam> does anyone know the owner of this patch?
18:46:15 <SridarK> SumitNaiksatam: seems to be enovance - i can also send an email
18:46:34 <SumitNaiksatam> SridarK: okay that will be good if you can follow up
18:46:41 <SridarK> SumitNaiksatam: will do
18:47:03 <SumitNaiksatam> #action SridarK will follow up with owner of https://review.openstack.org/#/c/90575/
18:47:42 <SumitNaiksatam> does anyone else want to pitch in with triaging the New and Undecided bugs in the link above?
18:47:53 <SridarK> SumitNaiksatam: i can take a shot
18:48:34 <SumitNaiksatam> SridarK: great, thanks again
18:48:55 <SridarK> SumitNaiksatam: will be a bit slow next 2 days though
18:49:04 <SumitNaiksatam> #action SridarK SumitNaiksatam to triage new/undecided bugs in the next couple of days
18:49:14 <SumitNaiksatam> SridarK: oops said that too soon, np
18:49:47 <SridarK> SumitNaiksatam:  no worries need to wrap on vendor bp - but should be done soon
18:50:13 <SumitNaiksatam> i think you all already chimed in on #link https://review.openstack.org/#/c/99956/
18:50:49 <SumitNaiksatam> i have not seen an update to that patch
18:50:59 <SridarK> yes i am not sure this is the right approach as u have also mentioned
18:51:11 <SumitNaiksatam> jlibosva: ping
18:51:35 <jlibosva> SumitNaiksatam: hi
18:51:52 <SumitNaiksatam> jlibosva: hi, we wanted to check with you on #link https://review.openstack.org/#/c/99956/
18:52:04 <SumitNaiksatam> jlibosva: the fwaas team has commented
18:52:14 <jlibosva> SumitNaiksatam: yeah, I was about to ask what will be the correct approach
18:52:37 <SumitNaiksatam> jlibosva: this needs to be handled on the agent side
18:52:49 <SumitNaiksatam> i think SridarK put a more specific comment to that effect
18:53:09 <jlibosva> SumitNaiksatam: so l3 agent will contact neutron-server and that will set different status of FW or fail the creation?
18:53:24 <SridarK> jlibosva: yes and it is handled when a new router is added
18:53:51 <SridarK> jlibosva: no it will not fail the creation - will be in PENDING
18:54:20 <jlibosva> SridarK: but that's confusing for user
18:54:31 <SridarK> and when router is added will go to ACTIVE
18:54:36 <jlibosva> aha
18:55:04 <jlibosva> but I still think it would be nice to let user know that he needs to have a router
18:55:10 <SumitNaiksatam> jlibosva: yeah, those are already handled
18:55:17 <SridarK> jlibosva: i agree that it is confusing but as we move to the insertion model - we will get away from this
18:55:50 <SumitNaiksatam> jlibosva: yes, as SridarK mentions this is more an issue with not beig able to provide a service insertion context
18:56:07 <SumitNaiksatam> jlibosva: so by default we try to apply the firewall on all the routers
18:56:30 <SumitNaiksatam> jlibosva: or any routers that will be created later
18:57:19 <jlibosva> SumitNaiksatam: should I understand it that nothing can be done at this point until the service insertion bp is ready?
18:57:52 <SumitNaiksatam> jlibosva: what we have currently is working as designed
18:58:11 <SumitNaiksatam> jlibosva: thats as much as we can do without the service insertion
18:58:22 <SumitNaiksatam> jlibosva: the notion of the pending state is used in other services too
18:58:22 <jlibosva> SumitNaiksatam: got it, thanks
18:58:34 <SumitNaiksatam> jlibosva: so i believe the user should be familiar with this
18:58:51 <SumitNaiksatam> jlibosva: if the documentation is not clear, i think we should definitely address it
18:59:22 <SumitNaiksatam> in general, i think the issue when the router or interface is deleted in probably not being handled
18:59:24 <SumitNaiksatam> SridarK: can you confirm
18:59:38 <SridarK> SumitNaiksatam: yes
19:00:15 <SridarK> and again we will probab rework those areas with serv insertion
19:00:43 <SridarK> jlibosva: i believe there is  a log msg on the agent side to this effect
19:01:15 <jlibosva> ok, thanks for the help
19:01:18 <SumitNaiksatam> SridarK: but i beleive we need to set the status to pending, if all the routers go away, right?
19:01:31 <SridarK> jlibosva: let me point that out - perhaps if it is not sufficient - we can improve it but we cannot really do much on the plugin side
19:01:51 <SridarK> SumitNaiksatam: i believe so
19:02:24 <SridarK> SumitNaiksatam:  i will double check that to be sure -
19:02:28 <SumitNaiksatam> SridarK:  i think there is a bug to that effect
19:03:34 <SridarK> SumitNaiksatam: the router going away had an issue to deal with it - will need to refresh my memory - at that point we discussed this - just don't recall exactly now
19:03:46 <SumitNaiksatam> SridarK: ah ok
19:04:11 <SumitNaiksatam> #action SridarK to revisit discussion on router delete
19:04:28 <SumitNaiksatam> i am also waiting for the owner of #link https://bugs.launchpad.net/neutron/+bug/1323299 to post a patch
19:04:29 <SridarK> SumitNaiksatam: the all routers makes it difficult to enforce any foreign key type constraints on delete of routers
19:04:40 <SumitNaiksatam> SridarK: ok
19:04:59 <SumitNaiksatam> does any one else want to take a crack at the above issue?
19:05:10 <SumitNaiksatam> garyduan beyounn: is Vishnu around?
19:05:15 <badveli> yes
19:05:19 <SridarK> SumitNaiksatam:  on that bug there was a response on the ML
19:05:24 <SumitNaiksatam> badveli: hi
19:05:29 <badveli> hello sumit
19:05:35 <SumitNaiksatam> SridarK: which one?
19:05:56 <SridarK> and according to Rajesh - not sure if we can do anything on this (132399) Floating ip
19:07:34 <garyduan> typically, firewall should be applied before dnat
19:07:51 <garyduan> Did Rajesh say if it can be done or not?
19:08:05 <SridarK> garyduan: i think he mentioned cannot
19:08:34 <SumitNaiksatam> garyduan badveli: do you want to explore the feasibility of that one?
19:08:51 <SumitNaiksatam> actually this is working as designed
19:08:55 <SumitNaiksatam> we did not intend to support this
19:09:03 <SumitNaiksatam> at least in the first iteration
19:09:10 <SumitNaiksatam> now we need to explore if we can
19:09:12 <SridarK> From Rajesh: "The chain we install will only see private addresses. So, one needs to use internal IP address in that rule. "
19:09:41 <SumitNaiksatam> SridarK:  yes, because i believe the ip address is not dnated already when we apply the firewall
19:09:56 <SridarK> SumitNaiksatam: true
19:10:15 <SumitNaiksatam> SridarK: so we never see the floating up
19:10:17 <SumitNaiksatam> *ip
19:10:45 <SridarK> SumitNaiksatam: yes we are always on fixed ip
19:11:06 <SumitNaiksatam> okay so no one wants to look at this
19:11:14 <SridarK> garyduan: badveli - will add u to the email that Rajesh sent
19:11:46 <garyduan> SumitNaiksatam: we can look at it together with service group backend
19:11:52 <SumitNaiksatam> i suspect that some of the undecided bugs might turn out to be higher priority
19:11:58 <SumitNaiksatam> garyduan: ok
19:12:11 <SumitNaiksatam> so we need to triage them at the earliest
19:12:48 <SumitNaiksatam> #topic blueprint tracking
19:12:59 <SumitNaiksatam> so regarding service objects
19:13:22 <SumitNaiksatam> unforntunately i was not able to follow up with the team on this, and my apologies
19:13:32 <SumitNaiksatam> has any more discussion happened on this since the last meeting?
19:13:49 <beyounn> Sumit: thanks for the comments
19:13:50 <badveli> beyounn and myslef send an email clarifying
19:13:51 <SumitNaiksatam> badveli and beyounn: i know you guys had posted emails
19:13:59 <SumitNaiksatam> badveli: yes
19:14:28 <SumitNaiksatam> i will try and respond to that the earliest, again apologies
19:14:34 <beyounn> Sumit: for your comments, how about I add icmp support to rule as well?
19:15:04 <SumitNaiksatam> beyounn: yeah my point was that we might need to add icmp support regardless of service objects
19:15:17 <beyounn> Sumit:agree
19:15:39 <beyounn> Sumit: only one questions-- is it ok to overload source/dest ports for code/type?
19:16:01 <SumitNaiksatam> beyounn: you ask because security groups does it?
19:16:07 <beyounn> Sumit: right
19:16:17 <beyounn> I don't really want to do it that way
19:16:21 <SumitNaiksatam> beyounn: i did not quite understand why they did it that way
19:16:24 <SumitNaiksatam> beyounn: yeah
19:16:40 <SumitNaiksatam> beyounn: its not intuitive to me at all
19:16:43 <beyounn> Sumit, ok, I will propose the new attributes in firewall rule
19:16:57 <SumitNaiksatam> beyounn: ok sounds good, what do others think?
19:17:17 <SridarK> This is good - std ACL type definition ?
19:17:30 <SumitNaiksatam> SridarK: ok
19:17:38 <beyounn> --protocol icmp --icmp-type 1 -icmp-code 1
19:17:44 <beyounn> ok ?
19:17:47 <SridarK> eys
19:17:51 <SridarK> *yes
19:17:58 <SumitNaiksatam> beyounn: that sounds very intuitive to me
19:18:19 <beyounn> And it is consistent with service object as well
19:18:26 <SumitNaiksatam> beyounn: ok
19:18:38 <SridarK> SumitNaiksatam: should this go as a separate BP ?
19:18:48 <SumitNaiksatam> SridarK: ah good point
19:18:56 <SumitNaiksatam> SridarK: i was thinking when i was putting that comment
19:19:02 <SumitNaiksatam> ideally yes
19:19:03 <SridarK> sigh i hope the answer is No :-)
19:19:25 <SridarK> I  was afraid that u would say yes :-)
19:19:39 <SumitNaiksatam> well if i dont, someone else will
19:20:03 <beyounn> Is a separated BP really necessary?
19:20:05 <SumitNaiksatam> this should be a straighforward one though to review as a spec
19:20:08 <SridarK> True that is the right way as this has nothing to do with serv obj
19:20:14 <SumitNaiksatam> beyounn: ok lets think a little more
19:20:30 <SumitNaiksatam> beyounn: as SridarK said
19:20:52 <SumitNaiksatam> beyounn SridarK: i am definitely not in favor of creating more work than required
19:21:05 <SridarK> should i file a bug that icmp is broken on firewalls ? :-)
19:21:09 <SumitNaiksatam> and would hope to cut the process as much as possible
19:21:23 <beyounn> Sridark +1
19:21:41 <beyounn> And I can take the bug
19:21:49 <beyounn> :-)
19:22:02 <SumitNaiksatam> so while on that, have you seen this #link https://wiki.openstack.org/wiki/NeutronJunoProjectPlan
19:22:09 <SumitNaiksatam> neutron juno plan ^^^
19:22:14 <SumitNaiksatam> this does not have fwaas at all
19:22:19 <SumitNaiksatam> so i have reached out to the PTL
19:22:25 <SumitNaiksatam> i believe that is an oversight
19:22:40 <SumitNaiksatam> and i would be sending him the items which need to be listed
19:23:02 <SridarK> SumitNaiksatam: yes
19:23:04 <SumitNaiksatam> that said, you can see that the number of items mentioned for the other services are minimal
19:23:16 <SumitNaiksatam> and so we cannot give a laundry list either
19:23:54 <SumitNaiksatam> we have to decide what is it that is absolute top priority for us, and for which we would want to get a committment from the PTL to get on the roadmap for Juno
19:23:55 <garyduan> hopefully, we get flavor settled
19:24:07 <SumitNaiksatam> garyduan: just saying that
19:24:18 <SumitNaiksatam> garyduan: thanks, so thats a given
19:24:33 <SumitNaiksatam> is prad_ around?
19:24:33 <SridarK> SumitNaiksatam: perhaps we can do some discussions offline and try to come up with a list
19:24:42 <prad_> SumitNaiksatam, hi
19:24:43 <SumitNaiksatam> SridarK: i am fine with that
19:24:59 <SumitNaiksatam> SridarK: but realistically i think its going to be one more item that we can push for
19:25:13 <SridarK> SumitNaiksatam: ok
19:25:15 <beyounn> Do we need a F2F meeting?
19:25:18 <SumitNaiksatam> prad_: so you are tracking the fwaas requirements on the ceilometer side
19:25:28 <SumitNaiksatam> beyounn: sure, we can
19:25:58 <prad_> SumitNaiksatam, yea, we need clarity on Fwaas side what the plan is
19:26:16 <prad_> SumitNaiksatam, so based on SridarK's email, Rajesh might not be able to add the hit count support?
19:26:16 <SumitNaiksatam> prad_: i was expecting a blueprint spec on the fwaas side as well for the missing functionality
19:26:33 <SumitNaiksatam> prad_: are you okay if that cannot be added in Juno?
19:26:42 <prad_> SumitNaiksatam, i'm not familiar with fwaas side of the code to write a reasonable spec
19:26:44 <SumitNaiksatam> prad_: if not i was going to scout for more resources on this
19:27:20 <prad_> SumitNaiksatam, ideally if we can get it in for juno that would be helpful.. but if you're saying we don't have resources then I guess we have no choice but to punt?
19:27:21 <SumitNaiksatam> i was actually going to check with badveli if he was interested in taking this up (without knowing at all as to how full your plate is)
19:27:48 <SumitNaiksatam> badveli: this might be a good place to get your hands really dirty in fwaas
19:27:53 <SumitNaiksatam> assuming you have time
19:27:59 <beyounn> Sumit: Let me and Vashul work out on time first
19:28:08 <SumitNaiksatam> beyounn: sure
19:28:28 <SumitNaiksatam> if not, and no one else is willing to take this up, then we cannot do hit counts in Juno
19:28:44 <beyounn> Sumit, how about we get the list and then we can work out the resource?
19:28:50 <SumitNaiksatam> i would have really liked to have this since it satisfies the ceilometer requirements
19:29:03 <SumitNaiksatam> beyounn: we already have the list
19:29:20 <SumitNaiksatam> beyounn: #link https://wiki.openstack.org/wiki/Neutron/FWaaS/JunoPlan
19:29:36 <SumitNaiksatam> but not all of the above will make it to the list that we send to the PTL
19:29:51 <beyounn> Sumit, that is what I was talking about
19:29:51 <SumitNaiksatam> in fact my guess is that we can only have one more item in addition to flavors
19:30:00 <SumitNaiksatam> that means that everything else is best effort
19:30:26 <SumitNaiksatam> however, in my opinion satisfying ceilometer requriements is critical for the adoption of fwaas
19:30:27 <beyounn> Sumit, not even the service insertion?
19:30:33 <SridarK> SumitNaiksatam: and we will need to work out dependency on flavor, insertion
19:30:42 <SumitNaiksatam> beyounn: service insertion, yes
19:30:56 <SumitNaiksatam> beyounn: but i am thinking that as a part of the adv services work
19:31:02 <s3wong> SridarK: beyounn: I will work with you guys on service insertion framework migration
19:31:05 <SumitNaiksatam> beyounn: so i am not counting that here, its cross list there
19:31:16 <SumitNaiksatam> s3wong: awesome, thanks
19:31:25 <SumitNaiksatam> s3wong: dont leave me out :-P
19:31:34 <SridarK> s3wong: knight in shining armor ;-)
19:31:42 <SumitNaiksatam> SridarK: lol
19:31:54 <beyounn> Sumit, since we have the service group BP and Code out there already, I think it could be a shorter path
19:31:56 <SumitNaiksatam> guarding the alamo! :-P
19:31:57 <s3wong> SridarK: beyounn: SumitNaiksatam: in fact, FWaaS will be the first one we will do - since LBaaS new object model will be around J-2
19:32:02 <SridarK> while he is in a lbaas mtg :-)
19:32:55 <SumitNaiksatam> beyounn: sure, lets discuss as you guys suggested
19:33:12 <SumitNaiksatam> #action beyounn badveli to decide if they can look at hit counts
19:33:35 <SumitNaiksatam> in general we need to develop some expertize in the team on the iptables driver side
19:33:38 <beyounn> Sumit: also, if we can get the service group cleaned up, we may be able to get new resource on the next thing
19:33:42 <SumitNaiksatam> to complement Rajesh
19:34:10 <SridarK> Rajesh said he could be available a bit later on - timing now is critical
19:34:17 <SumitNaiksatam> hence i was looking for volunteers (and suggested badveli’s name)
19:34:30 <SumitNaiksatam> SridarK: yeah, juno 2 is critical
19:34:37 <SridarK> SumitNaiksatam: yes agreed
19:35:11 <SumitNaiksatam> garyduan beyounn: are you guys comfortable with the iptables driver?
19:35:37 <SumitNaiksatam> we need someone whenever Rajesh does not have time to look at it
19:35:58 <SumitNaiksatam> lets take this offline
19:36:10 <beyounn> Does everyone available next week?
19:36:16 <SumitNaiksatam> my question is for everyone in the team in fact
19:36:19 <SumitNaiksatam> beyounn: i am
19:36:30 <SridarK> yes me too
19:36:42 <SumitNaiksatam> #action SumitNaiksatam to start email thread for meeting
19:36:43 <garyduan> yes
19:36:55 <beyounn> How about we do a F2F next week to close it?
19:36:57 <SumitNaiksatam> but next week is too late
19:37:04 <beyounn> Friday?
19:37:09 <SumitNaiksatam> we need to send list to PTL at the earliest
19:37:18 <SumitNaiksatam> friday afternoon is good
19:37:27 <SumitNaiksatam> ok lets decide offline
19:37:31 <SumitNaiksatam> we are over time
19:37:32 <SridarK> ok
19:37:41 <beyounn> ok
19:37:53 <SumitNaiksatam> prad_: the first step for getting the hit counts is to have the bp spec
19:38:03 <SumitNaiksatam> prad_: if we cant find a resource to do that, we are stuch
19:38:06 <SumitNaiksatam> *stuck
19:38:18 <prad_> SumitNaiksatam, hmm understand
19:38:24 <SumitNaiksatam> i could have, but i cannot commit, so i dont want to put my hand up
19:38:44 <SumitNaiksatam> prad_: can you at least make some progress with what is already there?
19:38:52 <prad_> SumitNaiksatam, my plate is a bit too full for juno2, otherwise i would have volunteered
19:38:55 <SumitNaiksatam> prad_: otherwise we have a serious issue
19:39:02 <SumitNaiksatam> prad_: totally understand
19:39:28 <SridarK> prad_: other than hit counts u can do lifecyle metrics ?
19:39:30 <SumitNaiksatam> the fwaas team would really like to see the ceilometer integration, so thanks prad_ for taking this up
19:39:32 <prad_> SumitNaiksatam, yea i already started looking into fw/rules and policy tracking
19:39:40 <SumitNaiksatam> prad_: ok cool
19:39:51 <SumitNaiksatam> SridarK: yes, thats what i meant to ask
19:40:03 <SridarK> SumitNaiksatam: ok cool
19:40:04 <SumitNaiksatam> prad_: we can try and help you at least with that
19:40:20 <prad_> cool
19:40:25 <SumitNaiksatam> prad_: another way of saying, please bug SridarK :-P
19:40:35 <SridarK> prad_: we can discuss for sure no worries :-)
19:40:49 <SumitNaiksatam> i wont put that as an action item
19:40:58 <prad_> hehe ok
19:41:04 * SumitNaiksatam hides for cover before SridarK comes after me
19:41:16 <SumitNaiksatam> #topic open discussion
19:41:18 <SridarK> SumitNaiksatam: SridarK would never do that :-)
19:41:26 <SumitNaiksatam> SridarK: i know
19:41:29 <SumitNaiksatam> :-)
19:41:38 <SumitNaiksatam> did we miss anything important
19:41:44 <SumitNaiksatam> i know we did not cover vendor BPs
19:41:55 <SumitNaiksatam> beyounn: did you say you added one too?
19:42:07 <SridarK> SumitNaiksatam: we can discuss offline on our stuff
19:42:13 <beyounn> Sumit: no , i did not
19:42:15 <SumitNaiksatam> SridarK: ok
19:42:29 <SumitNaiksatam> beyounn:  ah ok, sorry got confused with some other comment
19:42:32 <SumitNaiksatam> ok what else?
19:42:53 <beyounn> Sumit: I will leave the icmp part of you comment as under discussion
19:43:01 <SumitNaiksatam> beyounn: ok
19:43:20 <SumitNaiksatam> i have an action item to respond to the email thread in general
19:43:35 <beyounn> Ok, I will follow up with you then
19:43:55 <SumitNaiksatam> alright thanks everyone for your patience and participation
19:44:02 <SumitNaiksatam> apologies again for starting late
19:44:10 <SumitNaiksatam> thanks for sticking around longer
19:44:13 <badveli> thanks
19:44:21 <SumitNaiksatam> #endmeeting