18:34:27 <SumitNaiksatam> #startmeeting Networking FWaaS
18:34:28 <openstack> Meeting started Wed Jul  9 18:34:27 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:34:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:34:32 <openstack> The meeting name has been set to 'networking_fwaas'
18:34:43 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/FWaaS
18:34:52 <SumitNaiksatam> #topic Action Item follow up
18:35:04 <SumitNaiksatam> i think most of the AIs have been addressed
18:35:10 <SumitNaiksatam> thanks to SridarK and yisun
18:35:33 <SumitNaiksatam> we had one to set up a meeting with the DVR folks
18:35:40 <SumitNaiksatam> and Swami is here
18:35:47 <SumitNaiksatam> so lets jump into that
18:35:49 <Swami> yes
18:35:53 <SumitNaiksatam> #topic DVR discussion
18:36:06 <SumitNaiksatam> firstly Swami welcome back, and thanks for joining! ;-)
18:36:08 <Swami> sorry I was on vacation and could not join the meetings
18:36:15 <SumitNaiksatam> Swami: you deserve it
18:36:25 <SumitNaiksatam> Swami: i mean the vacation
18:36:58 <SumitNaiksatam> Swami: as you can tell, we have been having quite a bit of discussion in the fwaas team on how to address the DVR integration
18:37:25 <SumitNaiksatam> yisun: has been leading the charge on that front
18:37:38 <Swami> Yes, can you update me on this, is there a proposal
18:37:41 <SumitNaiksatam> and most of the fwaas team members met in person as well yesterday
18:37:45 <SumitNaiksatam> Swami: yes
18:37:52 <SumitNaiksatam> yisun: do you want to summarize
18:37:57 <SumitNaiksatam> Swami: we have some questions for you as well
18:38:14 <Swami> sure, if I know the answer I can provide you the answer right away.
18:38:14 <beyounn> Sumit, I'm in another meeting, could you help?
18:38:24 <SumitNaiksatam> beyounn: sure
18:38:56 <SumitNaiksatam> Swami: we first need to fully understand the manifestation of the “service” node
18:39:12 <SumitNaiksatam> Swami: what is it, how will be deployed?
18:40:40 <SumitNaiksatam> Swami: there?
18:40:56 <Swami> Service node is something similar to the network node that we have today and only services that will be running in that node is the "default snat", "dhcp" and probably VPNaaS
18:41:09 <SumitNaiksatam> Swami: ok
18:41:39 <SumitNaiksatam> Swami: so will it be part of a DVR (as in an implementation detail) or will it be a separate resource?
18:41:46 <Swami> The way it is depolyed, is that, we have the same L3 agent working in service mode, but in the configuration file, you have to enable a flag for service node.
18:41:49 <SumitNaiksatam> Swami: pardon my ignorance on this
18:41:58 <SridarK> Swami: will all North - South traffic go thru this Service Node
18:41:59 <SumitNaiksatam> Swami: ah got it
18:42:39 <Swami> Not all North South traffic will go through the Service Node. The VM's that have floating IP, will forward traffic directly from the Compute Node.
18:42:49 <garyduan> Sridark: I guess your quesion is regarding DNAT/Floating IP
18:42:52 <SumitNaiksatam> Swami: ah
18:43:11 <Swami> For other VMs that does not have floating IP, and has the default SNAT will forward traffic to the External network ( N-S) through the Service Node.
18:43:15 <SridarK> Swami: thanks ok this was the issue that garyduan u brought up
18:43:48 <SumitNaiksatam> Swami: in that case how will VPNaaS does not need to see any floating IP traffic?
18:44:02 <SumitNaiksatam> rephrase - VPNaaS does not need to see any floating IP traffic?
18:44:36 <Swami> it depends on your implementation.
18:44:59 <SumitNaiksatam> Swami: what about the reference implementation?
18:45:00 <Swami> If the VPNaaS is running in a VM and if you have Floating IP associated to the VM, then your VPN traffic will not flow through the Service node.
18:45:37 <SumitNaiksatam> nati_ueno: there?
18:45:48 <Swami> But if you take our reference implementation for VPN, then this service will be running in the service node.
18:45:49 <nati_ueno> hi
18:46:00 <beyounn> Swami: the case we are talking about is an VM that has FIP but the NATed traffic needs to go throughout VPNaaS
18:46:21 <SumitNaiksatam> nati_ueno: so is it okay for VPNaaS to not see the floating ip traffic?
18:46:35 <beyounn> Swami, if that case, we still need to steering the FIP traffic to VPNaaS, do we?
18:46:43 <beyounn> s/if/in/
18:46:45 <nati_ueno> I don't think vpn is seeing floating ip traffic
18:46:55 <SumitNaiksatam> sorry, dont mean to distract from teh fwaas dsicussion, we are just trying to understand how it works for vpnaas
18:47:04 <SumitNaiksatam> nati_ueno: ok, so not a concern for you?
18:47:16 <Swami> Yes VPN does not need to see the FIP traffic. FIP is basically to get to the VM.
18:47:23 <nati_ueno> SumitNaiksatam: gotcha. yeah, I think VPN is for private ip
18:47:35 <SumitNaiksatam> nati_ueno: ok
18:48:02 <nati_ueno> I believe service node has one external ip. This will be vpn endpoint.
18:48:10 <nati_ueno> Swami: right?
18:48:11 <SumitNaiksatam> nati_ueno: ok
18:48:35 <SumitNaiksatam> so Swami what we were thinking is that, as a first iteration, we would support FWaaS only as a perimiter firewall to deal with the N-S traffic
18:48:47 <Swami> Yes, service node will the gateway to external network and that would be vpn endpoint.
18:49:50 <SumitNaiksatam> Swami: howeve for the above to work we would need to see all N-S traffic
18:50:05 <Swami> sumit: When you say North-South traffic it includes all FIP and other default Gateway traffic.
18:50:06 <garyduan> SumitNaiksatam: on service node, we can only deal with S - N traffic
18:50:07 <SumitNaiksatam> beyounn SridarK garyduan: correct?
18:50:16 <beyounn> Sumit:+1
18:50:18 <SridarK> Swami: Hmm! so both sides of the traffic will go thru the Service Node if that is the tunnel termination point for VPN ?
18:50:22 <SumitNaiksatam> Swami: yes
18:50:42 <SridarK> SumitNaiksatam: yes
18:50:50 <garyduan> I guess for VPN referense design, traffic has to go through service node
18:51:05 <Swami> garyduan: Yes I agree.
18:51:28 <garyduan> For FW, FIP traffic doesn't have to
18:51:30 <SridarK> Swami: even in the DNAT scenario ?
18:51:34 <SumitNaiksatam> yes, i think we can keep VPN aside for now, since it seems that for the reference implementation there is no issue, VPNaaS is dealing with onyl private IPs
18:51:50 <garyduan> not 'for FW', just in general
18:51:57 <yyywu> Hi, one question, all NAT operation will be done on Service Node?
18:52:15 <garyduan> yyywu: no, DNAT is on compute node
18:52:30 <garyduan> yyywu: I mean FIP
18:52:54 <SumitNaiksatam> Swami: ok let me take step back
18:52:54 <Swami> All NAT operation for VM's that have default gateway will be done in Service Node.
18:53:24 <SumitNaiksatam> Swami: in your mind, what solution had you thought of for integrating DVR with FWaaS?
18:54:02 <Swami> Sumit: This was based on previous discussion that myself and vivek had with yi.
18:54:21 <SumitNaiksatam> Swami: ok, and “this” being?
18:54:30 <Swami> For the east-west we only route traffic on one compute node and so on the other side the traffic is not routed.
18:54:55 <SumitNaiksatam> Swami: true, so we have a problem with FWaaS working as is for the E-W traffic
18:55:23 <SumitNaiksatam> Swami: but we were trying to see if we can could just limit to FWaaS to the N-S traffic in the first iteration of DVR support
18:55:30 <Swami> So I think the original proposal that we did was instead of applying the firewall rules in the router interfaces we can apply the rules on a bridge interface above the routers in each compute node, so that both sides of the traffic will hit the firewall rules.
18:55:56 <SumitNaiksatam> Swami: however, that seems to be a problem too now, since not all N-S traffic hits the service node
18:56:15 <Swami> But when we initially had the discussion we did not see any issues with North-South. That is my understanding. Correct me if I am wrong.
18:56:42 <beyounn> Swami: until we realized the FIP will not go to service node
18:56:50 <SumitNaiksatam> Swami: but then the service node does not see all the N-S traffic per your earlier explanation
18:58:07 <Swami> For the North-South scenario including the Service node and the compute node, the existing  reference implementation for FWaaS where the rules are applied to the router interface will work, provided the FWaaS rules are applied on all compute nodes where the routers are hosted.
18:58:30 <SumitNaiksatam> Swami: ah ok
18:59:07 <SumitNaiksatam> Swami: but how will we know which rules to apply on the compute nodes?
18:59:25 <SumitNaiksatam> Swami: or are suggesting that we just apply the same rules everywhere?
18:59:34 <SumitNaiksatam> *are you
19:00:04 <Swami> Probably applying the same rules everywhere will be the easy option, but it might have some performance implications.
19:00:21 <SridarK> Swami: but if response traffic does not hit the same point (service node) that will be a problem (in terms of connection tracking )
19:00:53 <SridarK> Swami: and this will the case if u have NAT happening on the compute node correct ?
19:00:55 <Swami> SridarK: For the North-South this will work, it will hit the same point.
19:01:10 <SridarK> Swami: even with the NAT scenario ?
19:01:35 <SumitNaiksatam> SridarK: i believe for the FIP case, both directions will hit the same compute node, Swami right?
19:01:47 <Swami> SridarK: Let me explain.
19:02:46 <Swami> I think we need a picture to explain.
19:02:54 <SridarK> Swami: :-)
19:03:16 <SridarK> i think i see what SumitNaiksatam is saying in that case yes
19:03:33 <SumitNaiksatam> Swami: good point
19:03:38 <SumitNaiksatam> Swami: how about a f2f meeting?
19:03:43 <yyywu> could we draw a diagram on good doc?
19:03:47 <SridarK> asciiflow for IRC product idea :-)
19:03:51 <yyywu> google
19:04:04 <Swami> The traffic will hit the router in both these cases, that is my understanding.
19:04:24 <SridarK> Swami: by router - u mean service node
19:04:44 <Swami> I think we already have some good pictures out there in the google. We can take up that for explaining to the team.
19:05:43 <natarajk> SridarK: there is a router running in each compute node for DVR
19:06:03 <Swami> Let me do one thing as sumit suggested we can have a virtual meeting room session to go over the scenario nextweek.
19:06:05 <SridarK> natarajk: yes i know - i wanted to understand which one
19:06:08 <Swami> If that is ok with everyone.
19:06:15 <SumitNaiksatam> Swami: good suggestion
19:06:25 <SumitNaiksatam> Swami: let me work out the logistics with you
19:06:57 <SumitNaiksatam> #action SumitNaiksatam Swami to plan virtual/f2f meeting to further follow up on DVR/FWaaS integration
19:07:06 <Swami> Couple of our folks are out this week. They will be in office next week.
19:07:15 <natarajk> can we do google hangout ?
19:07:17 <SumitNaiksatam> Swami: for now, what is the best DVR document to look at (in case there is more than one)
19:07:26 <Swami> So let us plan for either Tuesday or Wednesday next week.
19:07:29 <yyywu> webex possible?
19:07:30 <SumitNaiksatam> Swami: and again, apologies for the ignorance on this
19:07:42 <SridarK> yyywu: webex possible i can set that up
19:07:46 <Swami> The design doc should be the best one to lock for.
19:07:55 <yyywu> SridarK, thanks.
19:07:55 <SumitNaiksatam> Swami: tuesday is better, so that we are prepared for the wednesday meeting
19:08:02 <SumitNaiksatam> Swami: link?
19:08:05 <Swami> We do have multiple design docs, I will forward you the L3 Agent/SNAT design doc link
19:08:15 <SumitNaiksatam> Swami: thanks
19:08:26 <SumitNaiksatam> Swami: the one with teh pretty figures ;-)
19:08:49 <SumitNaiksatam> Swami: who else at your end are we missing this week?
19:08:51 <Swami> Otherwise, since the agenda is specific to North-South, I will put together a picture just to address the traffic flow.
19:08:55 <beyounn> https://docs.google.com/document/d/1iXMAyVMf42FTahExmGdYNGOBFyeA4e74sAO3pvr_RjA/edit
19:08:59 <beyounn> this is what I was reading
19:09:02 <SumitNaiksatam> Swami: sweet
19:09:09 <SumitNaiksatam> beyounn: thanks
19:09:15 <Swami> I don't have Rajeev and Mike in office this week. Vivek is in a different timezone.
19:10:07 <SumitNaiksatam> Swami: ok, i just wanted to understand what progress we can make this week
19:10:16 <Swami> This document has couple of pictures that you may be interested in .
19:10:44 <SumitNaiksatam> Swami: also, have you speced out the VPNaaS/FWaaS support to be part of the DVR spec, or you anticipate a new bp for this?
19:10:54 <Swami> Or else I will talk to vivek and let us put together a flow picture for North South traffic that uses the Service node and the one that uses the FIP on the compute Node.
19:11:02 <SumitNaiksatam> Swami: i am just trying to understand since we have limited time to submit bp specs
19:11:14 <SumitNaiksatam> Swami: that sounds great
19:11:16 <Swami> Will that work out, and if you have any questions we can take it up in the next week's meeting.
19:11:50 <SumitNaiksatam> Swami: ok we will wait for your diagram then, say by Friday?
19:12:02 <Swami> Sumit: I have not speced out Services bp along with DVR. It would be a follow on.
19:12:13 <Swami> #agreed.
19:12:54 <SumitNaiksatam> Swami: ok that makes it tricky, i am not sure we have resources right now, do add a new bp spec before tomorrow
19:13:30 <SumitNaiksatam> Swami: we will probably need to work it out with the PTL to ride on top of the DVR spec if we have to achieve this in Juno time frame
19:14:19 <Swami> Ok, do you want me to add the spec.
19:14:46 <SumitNaiksatam> Swami: lets check with the PTL on this
19:15:03 <Swami> sure
19:15:19 <SumitNaiksatam> in general, question to the FWaaS team, does anyone have to time to quickly write up a place holder FWaaS spec to support DVR?
19:15:28 <SumitNaiksatam> this will however have to land by tomorrow?
19:15:41 <SumitNaiksatam> SridarK_ beyounn garyduan badveli: ^^^ ?
19:15:54 <SumitNaiksatam> natarajk: ^^^ ?
19:15:57 <SridarK_> SumitNaiksatam: by placeholder what do we need in that ?
19:16:13 <SumitNaiksatam> SridarK_: i tried to hand wave there, you caught me! :-P
19:16:19 <SridarK_> SumitNaiksatam: :-)
19:16:19 <Swami> SridarK: probably everything that the spec guidlines mandates
19:16:30 <SumitNaiksatam> Swami: :-)
19:16:33 <Swami> Sridark: just kiding.
19:16:40 <badveli> is it very detail
19:16:44 <SumitNaiksatam> i mean i wanted to meet the deadline for submitting the blueprint spec by tomorrow
19:16:51 <SridarK_> SumitNaiksatam: Swami: i fear that with the spec we will have an issues
19:16:58 <SumitNaiksatam> i dont expect all the details to be filled out
19:16:58 <SridarK_> with review cycles etc
19:17:29 <SridarK_> can we target to get this done by associating with one of the existing BP
19:17:37 <SumitNaiksatam> i am just trying to understand if this is feasible
19:17:47 <SumitNaiksatam> if not, it is what it is
19:18:08 <SridarK_> SumitNaiksatam: i can add a spec quickly if u want
19:18:13 <SumitNaiksatam> and the fall back option could be that Swami could submit a rev for his DVR blueprint
19:18:20 <SridarK_> but need more discussion on what we want to put there
19:18:20 <SumitNaiksatam> SridarK_: ok
19:18:26 <SumitNaiksatam> SridarK_: agree
19:18:31 <beyounn> Sridark_+1
19:18:46 <badveli> yes
19:18:48 <SumitNaiksatam> Swami: how soon is it possible to get the diagram that you were planning?
19:19:29 <beyounn> Sumit and Sridar: badveli could help too
19:19:30 <Swami> Can I get it to you latest by tomorrow evening? Will it be acceptable.
19:19:32 <SumitNaiksatam> Swami: that is for the N-S and the FIP traffic
19:19:50 <badveli> beyounn: i will help
19:20:08 <SumitNaiksatam> Swami: hmm, suspect that might be a little late (i understand though that you might have a dependency on Vivek and he is not immediately available)
19:20:22 <SumitNaiksatam> SridarK_: tomorrow evening might be late, right?
19:20:32 <SridarK_> SumitNaiksatam: yes cutting it too fine
19:20:34 <SumitNaiksatam> beyounn: thanks, good to know that badveli can help
19:20:54 <Swami> Yes, other option is I can try by tomorrow morning. That is the fastest I could do.
19:21:06 <SridarK_> Swami: would it be possible to have a call with Vivek tonight or early am tomorrow if that is reqd
19:21:17 <SumitNaiksatam> Swami: okay lets shoot for tomorrow morning
19:21:34 <SumitNaiksatam> SridarK_ badveli: meanwhile we can work on the bp spec skeleton
19:21:45 <SridarK_> SumitNaiksatam: ok
19:21:49 <Swami> Yes, I will keep him in the loop, if you guys have any question you can shoot him an email.
19:22:01 <SumitNaiksatam> Swami: morning around 10 AM (sorry for being pushy!)
19:22:03 <badveli> ok sumit
19:22:47 <Swami> #agreed
19:22:57 <SumitNaiksatam> Swami: thanks much
19:24:06 <SumitNaiksatam> #action Swami to prepare N-S and FIP traffic diagram, send to FWaaS team by morning July 10th to aid submission of FWaaS support for DVR bp spec
19:24:30 <SumitNaiksatam> Swami: would you also be available for a quick call tomorrow morning after the diagram is ready?
19:24:35 <Swami> sumit: this will not be an ASCII diagram.
19:24:43 <SumitNaiksatam> Swami: yes sure :-)
19:24:44 <SridarK_> Swami: :-(
19:24:50 <SumitNaiksatam> SridarK_: that is fine
19:24:54 <Swami> sumit: yes, will be available.
19:24:57 <SridarK_> SumitNaiksatam: just kidding
19:25:11 <SumitNaiksatam> Swami: SridarK_: I am seeing this mainly as a tool for us to understand
19:25:29 <SumitNaiksatam> Swami: you can perhaps add the diagram to your spec itself and we can reference it
19:25:44 <SumitNaiksatam> Swami: so no ascii diagram required even when we submit the spec
19:25:55 <yyywu> Swami, can you forward to mailing list?
19:25:59 <SumitNaiksatam> Swami: whatever works for you, but at least get it to us
19:26:01 <Swami> sumit: got it!
19:26:22 <garyduan> Sorry, I am back. I will look at the diagram
19:26:48 <SumitNaiksatam> SridarK_ Swami: i might be busy with group policy meeting tomorrow morning, so can you guys sync up on the follow up call tomorrow morning?
19:27:00 <SridarK_> SumitNaiksatam: sure
19:27:11 <SumitNaiksatam> SridarK_: perhaps you can set up a webex for 11 or so and invite everyone involved here
19:27:17 <SumitNaiksatam> Swami: sound okay?
19:27:17 <Swami> sure
19:27:22 <SumitNaiksatam> Swami: thanks
19:27:23 <SridarK_> SumitNaiksatam: sure will do
19:27:32 <SridarK_> Swami: thanks - will send u an email too
19:27:48 <SumitNaiksatam> indeed, thanks much Swami for induling us!
19:27:57 <SumitNaiksatam> #topic Open Discussion
19:28:12 <SumitNaiksatam> i wanted to mainly focus on the DVR issue for today
19:28:17 <SumitNaiksatam> any other burning concerns
19:28:25 <SumitNaiksatam> beyounn: on the service objects
19:28:41 <badveli> spec review
19:28:47 <beyounn> Sumit: yes, did not hear anything yet
19:28:58 <SumitNaiksatam> beyounn: one question (and might be late to bring this up) - how did we arrive at the name “service objects”?
19:29:25 <beyounn> Sumit: it is a common term used by Juniper and Netscreen
19:29:32 <SumitNaiksatam> beyounn: i want to make sure we have consensus on this and dont get blocked on it in the future (i know its kind of silly concern)
19:29:36 <SumitNaiksatam> beyounn: ok
19:29:50 <SumitNaiksatam> beyounn: earlier we were talking in terms of “application” objects
19:30:03 <beyounn> Sumit: "naming" is the most complicate matter to discuss :-)
19:30:06 <SumitNaiksatam> beyounn:  this is when we had started the fwaas project
19:30:10 <SumitNaiksatam> beyounn: ha :-)
19:30:19 <beyounn> Sumit: I have no problem to change that
19:30:45 <garyduan> 'application' might indicate APP ID function
19:30:46 <SumitNaiksatam> beyounn: my concern is that people dont misinterpret with what we are trying to do, and hence progress gets blocked
19:30:51 <beyounn> Sumit: the app object can mean different things when the L7 feature started
19:31:08 <beyounn> Sumit: +1
19:31:34 <beyounn> Sumit: when we have applicate identification, the application object is really a L7 term
19:31:34 <SumitNaiksatam> beyounn garyduan: okay, i dont have problem with service objects, i just want to make sure that its what the community/industry understands and we are not blocked
19:31:43 <SumitNaiksatam> beyounn: agree
19:31:56 <SumitNaiksatam> SridarK_: whats your view on this?
19:32:13 <SumitNaiksatam> natarajk: you as well
19:32:21 <SridarK_> SumitNaiksatam: i am fine with service group terminology
19:32:32 <beyounn> Sumit: the simplest way to look at is if you go to anything unix device /etc/services, you will get all the protocol/port/service definitions
19:32:38 <SridarK_> i think this is common usage
19:32:43 <beyounn> s/anything/any/
19:32:52 <SumitNaiksatam> beyounn: ah nice, taht works for me
19:33:17 <SumitNaiksatam> beyounn: perhaps we can even add that justification/clarification to the spec
19:33:35 <SumitNaiksatam> sorry if i raised an inconsequential concern!
19:33:49 <SumitNaiksatam> for once, the fwaas meeting has been longer than the adv services meeting!
19:33:54 <SridarK_> :-)
19:33:54 <SumitNaiksatam> anything else?
19:33:58 <SridarK_> folks request to review spec: #link https://review.openstack.org/#/c/105373/ for our vendor implementation
19:33:59 <beyounn> Sumit: sure
19:34:16 <SridarK_> natarajk: thanks for getting it started
19:34:20 <SumitNaiksatam> SridarK_: thanks of adding us as reviewers, will look
19:34:26 <beyounn> Guys, please also help to put +1 to service objects
19:34:28 <SridarK_> SumitNaiksatam: thanks
19:34:33 <beyounn> I just want to get some activities
19:34:35 <SridarK_> beyounn: surely i will do that
19:34:43 <beyounn> Sridark_: thanks
19:34:49 <SumitNaiksatam> beyounn: yes
19:34:49 <SridarK_> my old +1 is gone now
19:35:01 <natarajk> SridarK: you are welcome. will give my +1
19:35:02 <SumitNaiksatam> beyounn: hence raised the topic here
19:35:07 <beyounn> Sridark_: all the +1 are gone
19:35:27 <SumitNaiksatam> beyounn badveli: we need to iterate and respond quickly
19:35:33 <SridarK_> beyounn: yes i have no issues thanks for addressing my earlier comments
19:35:35 <badveli> ok
19:35:42 <SumitNaiksatam> beyounn: did you hear back from nati_ueno or akihiro?
19:35:42 <SridarK_> beyounn: will do so today
19:35:53 <beyounn> Sumit: did not
19:36:04 <beyounn> Sumit: I normally update spec overnight
19:36:10 <nati_ueno> ooops  I'm missing something?
19:36:16 <SumitNaiksatam> beyounn: yes, keep up the good work
19:36:24 <SumitNaiksatam> nati_ueno: the service objects spec :-)
19:36:37 <nati_ueno> SumitNaiksatam: gotcha! I'll review it today.
19:36:42 <beyounn> nati_ueno: thank ahead
19:36:46 <SumitNaiksatam> nati_ueno: #link https://review.openstack.org/#/c/94133
19:37:24 <SumitNaiksatam> nati_ueno: thanks much!
19:37:31 <SumitNaiksatam> alrighty, thanks everyone
19:37:37 <beyounn> Thanks!!!!
19:37:37 <SumitNaiksatam> #endmeeting