18:32:56 <SumitNaiksatam> #startmeeting Networking FWaaS
18:32:56 <openstack> Meeting started Wed Jul 16 18:32:56 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:32:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:33:01 <openstack> The meeting name has been set to 'networking_fwaas'
18:33:04 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/FWaaS
18:33:15 <SumitNaiksatam> #topic Action Item follow up
18:33:38 <SumitNaiksatam> the pending action item was to set up a meeting with the DVR folks
18:34:06 <SumitNaiksatam> thanks SridarK  for leading on this, i believe we had two meetings with the DVR team, and we are making good progress
18:34:22 <beyounn> hi
18:34:24 <SumitNaiksatam> we will get to that specific topic in the DVR related update
18:34:33 <SridarK> SumitNaiksatam: no worries - spec is out - and thanks to Yi & badveli_ as well
18:34:38 <SumitNaiksatam> lets jump to that
18:34:47 <SumitNaiksatam> #topic DVR discussion
18:35:16 <SumitNaiksatam> #link https://review.openstack.org/106225
18:35:32 <SumitNaiksatam> thanks SridarK badveli_ and yisun for getting posted
18:35:46 <SridarK> SumitNaiksatam: will address ur comment and reflect the minor changes suggested by DVR team
18:35:56 <SumitNaiksatam> thanks to swami as well for his support and being the liason on the DVR side
18:36:02 <SumitNaiksatam> SridarK: great
18:36:22 <SumitNaiksatam> another procedural matter, we need to make sure that this gets discussed in the L3 team meeting as well
18:36:33 <SumitNaiksatam> the one that is tomorrow
18:36:38 <SumitNaiksatam> i will send out an email
18:36:54 <SumitNaiksatam> beyounn: you will be attending that meeting?
18:37:11 <beyounn> I have a conflict meeting
18:37:21 <SumitNaiksatam> ok, SridarK badveli_?
18:37:22 <beyounn> Wed morning 8:00 is not good for me
18:37:24 <SridarK> SumitNaiksatam: i can attend
18:37:28 <badveli_> yes
18:37:33 <SumitNaiksatam> SridarK badveli_: nice
18:37:35 <badveli_> i will attend
18:38:08 <SumitNaiksatam> #action SumitNaiksatam to inform Swami to bring up the FWaaS support proposal in the L3 team meeting
18:38:18 <beyounn> badveli_: you can also help on the implementation, right?
18:38:26 <badveli_> yes
18:38:39 <SumitNaiksatam> badveli_: nice
18:38:58 <SumitNaiksatam> SridarK: can you summarize today morning’s discussion for everyone’s benefit here?
18:39:06 <SumitNaiksatam> SridarK: sorry to put you on the spot
18:39:08 <SridarK> SumitNaiksatam: sure
18:39:22 <SridarK> We will cover N - S usecase
18:39:27 <SumitNaiksatam> i dont think yapeng is here
18:39:35 <SridarK> We will not break E -W usecases
18:39:54 <SridarK> Target FW rules on the SNAT namespace on network Node
18:40:11 <SridarK> Target FW rules on FIP/IR namespace on the Compute Nodes
18:40:58 <SridarK> We will not try to optimize FW rules for distribution
18:41:08 <SridarK> Focus on correctness
18:41:14 <SridarK> ok that is the rough summary
18:42:22 <SumitNaiksatam> SridarK: so for FIP, we decided to apply in the IR namespace, right?
18:42:53 <SridarK> SumitNaiksatam: i think Swami's suggestion was to keep that open but yes we will target IR namespace
18:44:04 <SridarK> SumitNaiksatam: mainly for the purposes of the spec but initial attempt is to get it on the IR NS with a tag for traffic on the interface associated with the FIP NS
18:44:14 <SumitNaiksatam> SridarK: wasnt the suggestion to keep the specifics of the interface names open?
18:44:28 <SridarK> SumitNaiksatam: that as well
18:44:32 <SumitNaiksatam> SridarK: but we agreed on the IR namespace
18:44:36 <SumitNaiksatam> SridarK: ah ok
18:44:47 <SumitNaiksatam> is garyduan here?
18:45:06 <SridarK> SumitNaiksatam: yes but just for now to name it as FIP/IR NS to give us some options just in case ...
18:45:56 <beyounn> Gary is in meeting until now
18:46:08 <SumitNaiksatam> SridarK: okay
18:46:18 <beyounn> Sorry, he is still in meeting
18:46:24 <SumitNaiksatam> beyounn: i wanted to check with garyduan if he is comfortable with the approach we are taking
18:46:48 <SumitNaiksatam> natarajk: have you looked at the proposal?
18:47:11 <natarajk> yes
18:47:17 <beyounn> Sumit: I had a quick chat with him, he is fine
18:47:27 <natarajk> I have been reviewing the DVR FWaas spec udpate
18:47:36 <SumitNaiksatam> beyounn natarajk: ok
18:48:27 <SumitNaiksatam> there was also a suggestion from swami for a f2f meeting
18:48:36 <SumitNaiksatam> i believe after july 25th
18:48:58 <SumitNaiksatam> lets discuss that offline and decide on date
18:49:12 <SridarK> SumitNaiksatam: +1 - i think that will be useful
18:49:59 <SumitNaiksatam> so on this topic, our first focus has to be get the spec approved
18:50:50 <SumitNaiksatam> SridarK badveli_: perhaps good to attempt a DVR installation with the links that were sent out earlier
18:51:12 <badveli_> fine sumit
18:51:18 <SridarK> SumitNaiksatam: Will get the updates in and reach out to FWaaS, DVR team and cores for review by late afternoon
18:51:41 <SridarK> SumitNaiksatam: will try that - badveli_ and i can sync up on this
18:52:07 <SumitNaiksatam> SridarK badveli_: thanks!
18:52:19 <SumitNaiksatam> is there anything else we need to discuss on this?
18:52:30 <SridarK> no worries, i think i am good
18:52:41 <SumitNaiksatam> SridarK: thanks
18:52:55 <SumitNaiksatam> #topic Service Objects
18:52:55 <badveli_> we need to figure out the fip interface
18:53:20 <badveli_> sorry, will send out a mail on fip interface after testing
18:53:25 <badveli_> please continue
18:54:04 <SumitNaiksatam> #link https://review.openstack.org/94133
18:54:21 <SumitNaiksatam> beyounn: there?
18:54:33 <badveli_> yes, he is in a meeting
18:54:45 <SumitNaiksatam> okay, i have +2’ed the patch
18:54:51 <badveli_> thanks sumit
18:55:02 <SumitNaiksatam> we need to reach out to nachi, kyle and akihiro
18:55:40 <beyounn> Sumit: Gary sent eamil to akihiro. I will reach out nachi and kyle after my current meeting
18:55:48 <SumitNaiksatam> beyounn: nice
18:55:53 <SumitNaiksatam> beyounn: any blockers for you?
18:56:23 <beyounn> hop, I'm real good now
18:56:39 <beyounn> And thanks everyone for the helps !!!!!!
18:57:16 <SumitNaiksatam> ok moving on
18:57:26 <SumitNaiksatam> #topic flavors support
18:57:36 <SumitNaiksatam> i wanted to garyduan’s opinion on this
18:58:19 <SumitNaiksatam> salvatore has asked a question on the flavor’s spec whether it is feasible for implementation in the juno time frame if the spec is approved
18:58:29 <SumitNaiksatam> of course this depends on what gets approved
18:58:32 <SridarK> SumitNaiksatam: by the looks of the discussion i wonder if we will be able to move to this
18:58:44 <SumitNaiksatam> SridarK: okay
18:59:02 <SumitNaiksatam> but i would like garyduan to respond to that question in the review
18:59:05 <SridarK> even if it gets approved - our time line will be quite tight i guess
19:00:26 <SumitNaiksatam> SridarK: however garyduan really wanted this to land to enable vendor driver support
19:00:31 <SridarK> SumitNaiksatam: but if it gets delayed we will be asking the same question in K
19:00:38 <SridarK> SumitNaiksatam: my fear
19:00:46 <SumitNaiksatam> beyounn badveli_: can you please convey to garyduan my earlier request?
19:01:07 <badveli_> yes i will talk to him
19:01:23 <SumitNaiksatam> badveli_: ok thanks this has to be done today
19:01:36 <badveli_> ok, will talk to him
19:02:24 <SumitNaiksatam> #action garyduan to respond to salvatore’s question on implementation feasiblity in #link https://review.openstack.org/#/c/102723/
19:02:40 <SumitNaiksatam> #topic Bugs
19:03:45 <garyduan> Hi, I am back. Sorry about that.
19:03:45 <SridarK> enikanorov_: has assigned one of the new bugs to himself
19:03:55 <SumitNaiksatam> SridarK: link?
19:04:15 <SumitNaiksatam> garyduan: hopefully you can scroll to the discussion earlier on flavors
19:04:28 <SridarK> #link https://bugs.launchpad.net/neutron/+bug/1340735
19:05:01 <SridarK> another issue on tempest: #link https://bugs.launchpad.net/tempest/+bug/1342516 - review is out
19:05:14 <SridarK> those i believe were the new bugs for this week
19:05:23 <SumitNaiksatam> i dont think we can do anything about #link https://bugs.launchpad.net/neutron/+bug/1340735
19:05:55 <SumitNaiksatam> since we are at the mercy of the l3 agent kicking in for the firewall deletion
19:06:00 <SridarK> yes
19:06:09 <SridarK> another old one:
19:06:15 <SridarK> #link https://bugs.launchpad.net/neutron/+bug/1310857
19:06:24 <SumitNaiksatam> SridarK: enikanorov_ might have assigned it to himself for triaging purposes
19:06:43 <SridarK> SumitNaiksatam: yes i think so too
19:06:44 <SumitNaiksatam> SridarK: he probably does not intend to implement it
19:06:55 <SumitNaiksatam> SridarK: i will comment on the bug report
19:07:01 <SridarK> ok cool
19:07:25 <SridarK> #link https://review.openstack.org/#/c/90575/ for #link https://bugs.launchpad.net/neutron/+bug/1310857
19:07:28 <badveli_> sridark info  how do you look at the bugs assigned in fwaas, is there any link that you have created
19:07:33 <SridarK> i think we are good
19:07:46 <SridarK> on that needs mark to chime in on his comment
19:08:01 <badveli_> sridark or are we search it
19:08:02 <SumitNaiksatam> badveli_: i have posted a link on the wiki
19:08:29 <badveli_> sumit:new bugs filed that are coming
19:08:35 <SumitNaiksatam> badveli_: the link is #link https://bugs.launchpad.net/openstack/+bugs?field.searchtext=fwaas&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package
19:08:53 <SumitNaiksatam> this gives everything related to FWaaS across all the projects
19:08:58 <badveli_> thanks sumit
19:09:01 <SumitNaiksatam> SridarK: on https://bugs.launchpad.net/tempest/+bug/1342516
19:09:48 <SumitNaiksatam> its probably not specific to fwaas right?
19:09:53 <SridarK> nothing really specific to us
19:09:53 <SridarK> yes
19:10:06 <SridarK> just lands up on our radar
19:10:11 <SridarK> because of fwaas string
19:10:25 <SumitNaiksatam> its probably just the case that in this example it shows up with the fwaas test
19:10:27 <SumitNaiksatam> yeah
19:12:28 <SumitNaiksatam> SridarK: so for #link https://review.openstack.org/#/c/90575/ mark’s comment has been responded to, right?
19:12:34 <SridarK> SumitNaiksatam: yes
19:12:48 <SumitNaiksatam> thankfully the -2 is not there any more!
19:12:49 <SridarK> the assignee has fixed it
19:12:58 <SridarK> and Mark took out his -2
19:13:05 <SridarK> and now there is a -1
19:13:11 <SumitNaiksatam> wow, i think that must be a first!
19:13:18 <SridarK> but this looks good
19:13:20 <SridarK> :-)
19:13:35 <SumitNaiksatam> we are blessed!
19:13:44 <SridarK> I will ping SridharG (the submitter) to reach out
19:13:55 <SumitNaiksatam> SridarK: thanks much
19:14:02 <SridarK> no worries
19:14:08 <SumitNaiksatam> anything else on the bugs radar?
19:14:26 <SridarK> SumitNaiksatam: nothing major to report
19:14:52 <SumitNaiksatam> SridarK: thanks
19:14:58 <SridarK> np at all
19:15:03 <SumitNaiksatam> #topic Vendor Blueprints
19:15:41 <SumitNaiksatam> SridarK natarajk: can you add your blueprint specs here: https://wiki.openstack.org/wiki/Meetings/FWaaS#Blueprint_Tracking
19:16:01 <natarajk> sure
19:16:04 <SridarK> SumitNaiksatam: will do
19:16:08 <SumitNaiksatam> natarajk SridarK: thanks
19:16:16 <SumitNaiksatam> SridarK: link to your bp?
19:16:25 <SridarK> SumitNaiksatam: #link #link https://review.openstack.org/#/c/105373/
19:16:31 <SumitNaiksatam> SridarK: thanks
19:16:50 <SumitNaiksatam> SridarK: so we have a dependency here on Bob’s patch?
19:16:51 <SridarK> SumitNaiksatam: also the dependency that i was waiting on just got approved 2 mins ago
19:17:15 <SumitNaiksatam> SridarK: oh good
19:17:21 <SumitNaiksatam> SridarK: i can look at it then
19:17:23 <SridarK> SumitNaiksatam:  so we are good on the dependency - i will respond to Kyle's -1 and hopefully we will get this moving
19:17:30 <SridarK> SumitNaiksatam: thanks much for ur help on this
19:17:44 <SumitNaiksatam> SridarK: actually kyle removed his -1
19:17:52 <SridarK> aah great
19:18:32 <SridarK> ok i just seer that too
19:18:36 <SridarK> *see
19:18:43 <SumitNaiksatam> natarajk: link to your blueprint spec?
19:18:49 <SridarK> we are on real time
19:19:11 <natarajk> Sumit, i am still going through l3 plugin review
19:19:18 <SumitNaiksatam> natarajk: ah ok
19:19:39 <natarajk> I'll submit the spec, but i am also waiting for flavors framework
19:19:58 <SumitNaiksatam> natarajk: ok
19:20:19 <SumitNaiksatam> natarajk: i believe its too late now to submit a new blueprint spec
19:20:31 <SumitNaiksatam> natarajk: that dealine was on july 10th
19:20:43 <natarajk> Sumit, my focus has been to get the l3 spec and code approved
19:20:46 <SumitNaiksatam> the spec approval deadline is July 20th
19:20:56 <SumitNaiksatam> natarajk: sure, sounds like the right priority
19:21:11 <SumitNaiksatam> i was earlier misreporting the SAD to be july 17th
19:21:41 <SumitNaiksatam> that means that we have a couple of more days than we expected
19:21:48 <SumitNaiksatam> so its a good thing
19:22:36 <SumitNaiksatam> anything else on the vendor blueprints
19:22:37 <SumitNaiksatam> ?
19:22:43 <natarajk> if l3 code get approved, i can work on firewall plugin (if vendor extensions or flavor is accepted by the community)
19:22:59 <SumitNaiksatam> natarajk: sure, that i believe will be for K release then
19:23:10 <natarajk> Sumit, yes
19:23:16 <SumitNaiksatam> natarajk: good
19:24:18 <SumitNaiksatam> #topic open discussion
19:24:39 <SridarK> SumitNaiksatam: will also reach out to s3wong on plans for service insertion
19:24:50 <SumitNaiksatam> SridarK: yeah sure, thanks
19:25:00 <SridarK> SumitNaiksatam: will be great if we can get that in
19:25:17 <SumitNaiksatam> SridarK: yeah! its very frustrating
19:25:56 <SridarK> SumitNaiksatam: the third time is a charm so lets hope that works :-(
19:26:19 <SumitNaiksatam> SridarK: yeah!
19:26:36 <SumitNaiksatam> garyduan: so you will respond on the flavors review?
19:27:27 <garyduan> yes
19:27:49 <garyduan> I will add my comment to the spec
19:28:11 <SumitNaiksatam> garyduan: thanks
19:28:27 <SumitNaiksatam> okay, if nothing else, lets call it a wrap
19:28:37 <SumitNaiksatam> thanks everynone for attending, bye!
19:28:45 <SridarK> thanks
19:28:47 <SridarK> bye
19:28:49 <natarajk> bye
19:28:50 <SumitNaiksatam> not to forget that we have immediate work to do on the DVR front
19:28:55 <SumitNaiksatam> #endmeeting