18:37:51 <SumitNaiksatam> #startmeeting Networking FWaaS
18:37:52 <openstack> Meeting started Wed Jul 23 18:37:51 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:37:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:37:56 <openstack> The meeting name has been set to 'networking_fwaas'
18:37:58 <SumitNaiksatam> pcm___: hi
18:38:07 <SumitNaiksatam> pcm___: thanks for joining as well
18:38:22 <pcm___> sure np. Someone has to keep an eye on you guys :)
18:39:03 <SumitNaiksatam> pcm___: thanks for carrying out that imp task! perhaps you will extend it to the reviews as well ;-)
18:39:13 <SumitNaiksatam> #info spec approval deadline has passed
18:39:14 <pcm___> yup
18:39:30 <SumitNaiksatam> i think we managed to get the specs approved that we had planned
18:39:34 <SumitNaiksatam> anything we missed
18:39:35 <SumitNaiksatam> ?
18:39:47 <badveli> thanks sumit
18:39:52 <SumitNaiksatam> badveli: sure
18:40:28 <SumitNaiksatam> if we missed something, and you want to petition for an exception, please send an email to the mailer
18:40:39 <SumitNaiksatam> although the chances of getting an exception are pretty slim
18:40:43 <SumitNaiksatam> ok moving on
18:40:52 <SumitNaiksatam> #topic action item review
18:41:25 <SumitNaiksatam> i was planning to set up a f2f with Swami
18:41:43 <Swami> Yes sumit.
18:41:53 <Swami> Are you guys on for the meet, I did not hear anything from you.
18:41:56 <SumitNaiksatam> badveli beyounn garyduan, what say, one day we drive to sacramento?
18:42:22 <SumitNaiksatam> Swami: still convincing people to make the trip :-)
18:42:26 <garyduan> ah
18:42:29 <SumitNaiksatam> Swami: we will get back to you on this
18:42:54 <Swami> SumitNaiksatam: Sure
18:43:02 <SumitNaiksatam> #action fwaas team to discuss f2f team with DVR team
18:43:45 <SumitNaiksatam> another action item was for Swami to bring up the FWaaS/DVR spec in the L3 meeting to pave the way for approval
18:43:51 <SumitNaiksatam> so we are good on this as well
18:44:11 <natarajk> cool
18:44:16 <SumitNaiksatam> Swami and team, thanks again for all the last minute interaction and for pushing this forward
18:44:56 <natarajk> yes the meetings really helped in finalizing the spec
18:45:06 <SumitNaiksatam> the third action was for garyduan to provide an estimate on supporting flavors for fwaas and provide an update (in response to salvatore’s comment) in the flavors bp spec
18:45:16 <SumitNaiksatam> natarajk: +1
18:45:57 <SumitNaiksatam> garyduan please follow up in case you havent
18:46:10 <SumitNaiksatam> #topic Bugs
18:46:53 <SumitNaiksatam> one pending bug was reduced in severity from high to medium
18:47:01 <SumitNaiksatam> we still need to review
18:47:26 <SumitNaiksatam> #link https://review.openstack.org/#/c/90575
18:48:01 <SumitNaiksatam> any other bugs that caught anyone’s attention?
18:48:16 <garyduan> I did comment on both falvor spec and patch
18:48:30 <natarajk> SumitNaiksatam: I'll review bug 90575
18:48:46 <SumitNaiksatam> garyduan: great
18:48:50 <SumitNaiksatam> natarajk: thanks
18:49:15 <SumitNaiksatam> BTW, our bug Czar - SridarK is out today
18:49:46 <SumitNaiksatam> but SridarK did a pass yesterday and reported that he did not find anything which was critical
18:49:53 <SumitNaiksatam> badveli: i believe you are also looking at this?
18:50:03 <badveli> yes i followed that link
18:50:04 <SumitNaiksatam> badveli: i mean scrubbing bugs?
18:50:26 <badveli> i looked at the link some days back
18:50:36 <SumitNaiksatam> badveli: ok great, good to have multiple keep an eye on this
18:50:53 <badveli> currently submitting a patch for the comments i have for service groups
18:50:59 <SumitNaiksatam> #topic blueprint tracking
18:51:01 <badveli> i will take a look at it again
18:51:09 <SumitNaiksatam> badveli: thanks
18:51:26 <SumitNaiksatam> FWaaS/DVR support
18:52:05 <SumitNaiksatam> badveli: SridarK mentioned you were trying to get an installation going
18:52:22 <SumitNaiksatam> badveli: i mean just the DVR installation
18:53:24 <Swami> Guys there was fix that went in for the FIP yesterday in the L3 agent, I recommend you to restack with the latest code for testing.
18:53:41 <SumitNaiksatam> Swami: thanks for the heads up
18:53:51 <badveli> sridar asked if  i have two servers, but we did not yet discussed on it
18:53:52 <SumitNaiksatam> Swami: so its merged, right?
18:54:02 <Swami> Yes will be merged anytime soon.
18:54:06 <Swami> It is ready to be merged.
18:54:11 <SumitNaiksatam> Swami: that said i believe we were earlier pointed to a private repo earlier
18:54:13 <Swami> But you can still pick up from Carl's repo
18:54:20 <SumitNaiksatam> Swami: ah my question
18:54:26 <Swami> All patches have not landed up in the upstream
18:54:37 <SumitNaiksatam> Swami: so we continue to go to Carl’s repo?
18:54:40 <SumitNaiksatam> for now
18:54:42 <Swami> That is the reason we recommend to pick up from Carl's repo, that is updated constantly.
18:54:50 <Swami> sumit: yes
18:54:51 <SumitNaiksatam> Swami: okay good
18:55:11 <SumitNaiksatam> Swami: so does Carl’s repo have the entire implementation, or that is also evolving?
18:55:12 <Swami> SumitNaiksatam: I need to step out, if you need any other information please let me know offline.
18:55:29 <SumitNaiksatam> Swami: ok we will ping you, thanks for joining
18:55:30 <Swami> SumitNaiksatam: Carl's repo has the entire code base.
18:55:37 <SumitNaiksatam> Swami: ok
18:55:57 <Swami> Thanks sumit
18:56:24 <SumitNaiksatam> badveli: sorry, did not notice your earlier response
18:56:46 <SumitNaiksatam> badveli: so you are planning to start installing the DVR in parallel?
18:57:02 <badveli> no problem, i am trying to study on the wiki on how to install
18:57:36 <SumitNaiksatam> badveli: great, i think that will be very helpful preparation until SridarK comes back, so that we can make some immediate progress after he is back
18:57:51 <SumitNaiksatam> ok anything more on FWaaS/DVR?
18:58:00 <badveli> sumit, i am actively working on the patches for the service groups
18:58:08 <SumitNaiksatam> yes, thats next
18:58:13 <SumitNaiksatam> Service Objects/Groups
18:58:23 <SumitNaiksatam> badveli: any blockers there?
18:58:58 <badveli> i will be submitting a patch for the db part addressing comments and also some of the spec's latest updates
18:59:34 <badveli> the reference implementation is another patch which is wip
19:00:16 <badveli> thanks for your help, if we can get the cli and the configs part reviewed
19:00:35 <badveli> the data modelling
19:00:55 <SumitNaiksatam> badveli: sure, but the CLI review will typically happen in earnest after the neutron pathces are in a good stage
19:01:13 <SumitNaiksatam> badveli: but yeah we need to keep working on them in parallel, so that people can test end to end
19:02:26 <badveli> sumit: can it happend that the cinfig and the db patches will be merged
19:02:29 <SumitNaiksatam> badveli: i am behind on the reviews for code patches
19:02:38 <SumitNaiksatam> badveli: links?
19:02:44 <badveli> before the cli patch
19:02:59 <badveli> i send the email,
19:03:03 <SumitNaiksatam> oh btw, can you all please update: #link https://wiki.openstack.org/wiki/Neutron/FWaaS/JunoPlan
19:03:27 <SumitNaiksatam> whenever you post a patch
19:03:40 <badveli> fine sumit
19:04:09 <SumitNaiksatam> badveli: i meant can you paste the links here for the benefit of those in this meeting
19:04:20 <badveli> yes sumit will do it
19:04:28 <SumitNaiksatam> badveli: in terms of review and merging, the expectation is as follows
19:04:42 <SumitNaiksatam> 1. the patches should be small
19:05:14 <SumitNaiksatam> 2. if the feature is large, the patches should be broken into relatively self-contained parts in the form of a series
19:05:37 <SumitNaiksatam> in this case, Resource model/API, and DB can be one patch
19:05:57 <SumitNaiksatam> plugin/agent/driver can be a second patch
19:06:13 <SumitNaiksatam> depending on the size, if they turn out to be too large, we wil have to break them further
19:06:20 <badveli> Sumit: We are doing exactly the same way
19:06:46 <SumitNaiksatam> 3. for a feature to merge, the refer implementation (that goes all the way to the datapath) should be available for review
19:06:48 <garyduan> There will be some overlap with the flavor support, as both touch fwaas plugin
19:06:51 <SumitNaiksatam> and testing
19:06:56 <badveli> theResource model/API, and DB is one patch and the plugin/agent/driver is another patch in wip
19:07:05 <SumitNaiksatam> badveli: great
19:07:10 <SumitNaiksatam> badveli: will take a look
19:07:47 <SumitNaiksatam> badveli: to your earlier question, the neutron patches will merge before the CLI patches
19:08:03 <SumitNaiksatam> badveli: i did not quite understand what you meant by the config patches
19:08:19 <SumitNaiksatam> garyduan: agreed, for now i would say lets not create dependencies
19:08:46 <SumitNaiksatam> garyduan: i think we can take the hit of resolving merge conflicts in the interest of letting these proceed in parallel
19:08:54 <garyduan> sure. should be easy to resolve
19:08:57 <badveli> sumit, the one for theResource model/API, and DB
19:09:00 <SumitNaiksatam> garyduan: good
19:09:14 <SumitNaiksatam> badveli: ah, yeah, we will get to that first
19:11:12 <SumitNaiksatam> badveli: as a reference, please pay careful attention to the reviews that went if for the initial fwaas patches
19:11:54 <SumitNaiksatam> badveli: if we avoid the issues present there, i think it will reduce the time we spend on these reviews
19:12:17 <SumitNaiksatam> ok moving on
19:12:27 <SumitNaiksatam> #topic vendor blueprints
19:12:51 <badveli> sumit, sure i am addressing
19:12:55 <SumitNaiksatam> SridarK is not here
19:12:57 <SumitNaiksatam> badveli: thanks
19:13:15 <natarajk> SumitNaiksatam: i'll file the design spec for brocade plugin once kilo spec repository opens
19:13:16 <SumitNaiksatam> natarajk: and you mentioned that your stuff is targeted for K?
19:13:28 <SumitNaiksatam> natarajk: nice, keep us posted
19:13:41 <SumitNaiksatam> #topic open discussion
19:13:54 <SumitNaiksatam> anything else we need to discuss today?
19:13:55 <natarajk> SumitNaiksatam: Focusing on getting the l3 plugin approved for Juno-3
19:14:12 <SumitNaiksatam> natarajk: yes sure, it was great that the spec was approved!
19:14:17 <natarajk> SumitNaiksatam: Thanks for your support
19:14:24 <SumitNaiksatam> natarajk: always!
19:14:50 <SumitNaiksatam> ok if no more issues to be discussed today, then we get 15 mins back :-)
19:15:15 <SumitNaiksatam> ok thanks all for joining
19:15:19 <SumitNaiksatam> bye!
19:15:21 <natarajk> bye
19:15:24 <SumitNaiksatam> #endmeeting