18:31:06 <SumitNaiksatam> #startmeeting Networking FWaaS
18:31:07 <openstack> Meeting started Wed Jul 30 18:31:06 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:31:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:31:10 <openstack> The meeting name has been set to 'networking_fwaas'
18:31:30 <badveli> yes
18:31:38 <badveli> sumit:hi
18:31:47 <SumitNaiksatam> badveli: hi
18:32:00 <SumitNaiksatam> #topic Action items review
18:32:02 <badveli> sorry was discussing some ting
18:32:33 <SumitNaiksatam> our pending action item is a logistical one, we had to set up a f2f with the DVR team
18:32:44 <SumitNaiksatam> SridarK: we were waiting for you to get back
18:33:00 <SridarK> SumitNaiksatam: yes i am good lets figure out a day
18:33:24 <badveli> i had got two servers for my installation
18:33:36 <SridarK> badveli: great
18:33:52 <SumitNaiksatam> #action SumitNaiksatam to start a thread in fwaas team to schedule f2f meeting with DVR team
18:33:55 <badveli> sridar we can try the installation, going through the wiki
18:33:59 <SumitNaiksatam> badveli: thats great
18:34:05 <badveli> thanks sumit
18:34:11 <SridarK> SumitNaiksatam: so maybe badveli and i will spend some time on this later this week
18:34:21 <SumitNaiksatam> badveli: can you hold to that discussion when we bring up that agenda item?
18:34:25 <SridarK> so we will have some more context b4 the mtg with DVR
18:34:29 <SumitNaiksatam> SridarK: ^^^?
18:34:33 <SridarK> oops sorry
18:35:05 <SumitNaiksatam> though we can definitely treat badveli’s activity as a pending action item ;-)
18:35:15 <SumitNaiksatam> SridarK: no worries
18:35:37 <SumitNaiksatam> SridarK: btw, belated, but welcome back! :-)
18:35:47 <SridarK> SumitNaiksatam: glad to be back :-)
18:35:59 <SumitNaiksatam> SridarK: the team definitely missed you last week
18:36:05 <SumitNaiksatam> #topic Bugs
18:36:07 <SridarK> SumitNaiksatam: thx
18:36:21 <SumitNaiksatam> i did not find anything critical or high that is pending
18:36:24 <SridarK> SumitNaiksatam: quick scan on bugs nothing new
18:36:34 <SumitNaiksatam> SridarK badveli: did you get a chance to bug scrub?
18:36:36 <SridarK> SumitNaiksatam: yes
18:36:39 <SumitNaiksatam> SridarK: ah ok
18:36:55 <badveli> looked at the link,
18:37:03 <SumitNaiksatam> badveli: ok good
18:37:34 <SumitNaiksatam> at some point we have to make a push towards get a grasp on how the pending bugs are going to be closed
18:37:54 <SumitNaiksatam> i am saying in the context of juno-3
18:38:22 <SridarK> SumitNaiksatam: yes once we get our patches moving - we will try to wrap up on some of these bugs
18:38:28 <SumitNaiksatam> we will have time to get big fixes in even after juno-3 but they will have to only critical fixes
18:38:37 <SumitNaiksatam> SridarK: that sounds like a good plan
18:39:03 <SridarK> SumitNaiksatam: mostly we have some low priority issues now
18:39:13 <SumitNaiksatam> SridarK: i was suggesting that we need to track down the folks who are not in this meeting but are owning the patches for those bugs
18:39:16 <badveli> yes sumit, after the patches we can wrap the bugs
18:39:21 <SumitNaiksatam> SridarK: yes, thankfully
18:39:30 <SridarK> SumitNaiksatam: let me take a stab at that
18:39:39 <SumitNaiksatam> SridarK: great
18:39:41 <badveli> did we get any feed back from sridargaddam
18:39:57 <SumitNaiksatam> we can essentially split the bugs between us, and follow up with the relevant folks
18:40:04 <SumitNaiksatam> SridarK: i know you are already doing that
18:40:07 <SridarK> SumitNaiksatam: sounds good
18:40:12 <SumitNaiksatam> badveli: we did, and he posted a new patch as well
18:40:20 <badveli> ok, thanks sumit
18:40:37 <badveli> yes we can split up the bugs and go after the relevant bugs
18:40:59 <SumitNaiksatam> i believe Sridargaddam needs to post a new rev
18:41:07 <SumitNaiksatam> to respond to carl_baldwin’s -1
18:41:18 <SumitNaiksatam> ok anything else on bugs?
18:41:37 <SridarK> SumitNaiksatam: nothing from me - i am not caught up on last week yet either
18:41:41 <SumitNaiksatam> we were discussing #link https://review.openstack.org/#/c/90575/7
18:41:47 <SumitNaiksatam> SridarK: ok sure
18:41:59 <SumitNaiksatam> #topic FWaaS support for DVR
18:42:09 <SumitNaiksatam> SridarK: badveli yisun: ?
18:42:28 <SumitNaiksatam> badveli: you already mentioned that you set up the servers, thats great
18:42:28 <badveli> yes sumit
18:42:36 <SumitNaiksatam> badveli: so you have a working DVR setup?
18:42:52 <SridarK> SumitNaiksatam: i believe the plan was badveli and i will get together to go over the changes once we have a DVR setup
18:43:36 <badveli> sumit:i have the two servers , initially it was tough to have the servers i think we needed atleast two. so got it and trying to set up
18:43:36 <SumitNaiksatam> badveli: so you have a DVR installation?
18:44:05 <badveli> sumit: i did not had enough servers, just got two servers
18:44:07 <SumitNaiksatam> badveli: nice, completely appreciate the difficulty in getting the two servers, its not easy with resource constraints and what not
18:44:20 <SumitNaiksatam> badveli: i am guessing two should be enough?
18:44:26 <badveli> yes sumit
18:44:35 <SumitNaiksatam> badveli: SridarK we should check with Swami on this
18:44:52 <SridarK> SumitNaiksatam: yes 2 was recommended by Rajeev
18:45:00 <SumitNaiksatam> also regarding the f2f meeting, i think its better if we do some amount of home work before we schedule the meeting
18:45:11 <SridarK> SumitNaiksatam: i think once we this moving we can reach out to Swami
18:45:16 <SumitNaiksatam> that way we can have more informed conversation
18:45:20 <SridarK> SumitNaiksatam: yes that will be beneficial
18:45:21 <SumitNaiksatam> SridarK: great
18:45:51 <badveli> sridar: i think once we set up the things and start playing with it we might get more idea
18:46:06 <SridarK> SumitNaiksatam: badveli ideally once we have DVR we can look at the FWaaS failure cases
18:46:13 <SridarK> as a first step
18:46:17 <SumitNaiksatam> badveli: SridarK so you plan to sync up this week?
18:46:25 <SridarK> yes we will
18:46:27 <badveli> yes sumit
18:46:32 <SumitNaiksatam> ok great, thanks
18:46:43 <SumitNaiksatam> also do we have any dependencies on the DVR team?
18:46:56 <SumitNaiksatam> if so, we can start tracking them here
18:47:18 <SridarK> SumitNaiksatam: good question - while doing the spec 2 or 3 patches were yet to merge
18:47:29 <SridarK> SumitNaiksatam: will follow thru on that
18:47:30 <SumitNaiksatam> SridarK: ah ok
18:47:43 <SumitNaiksatam> i believe the suggestion was that we used the private repo
18:47:48 <SumitNaiksatam> for that reason
18:47:55 <badveli> Sumit:  patches from dvr, should we go through them to understand more, there were some couple of changes we might need to understand more
18:47:56 <SridarK> SumitNaiksatam: yes that is correct
18:48:20 <SridarK> SumitNaiksatam: particularly the L3 agent was still in review but i need to check now
18:48:40 <SumitNaiksatam> ok
18:49:03 <SridarK> SumitNaiksatam: my sense is that our changes are going to be in the Agent and the driver - we will try to scope this out to get a sense of the scope
18:49:18 <SumitNaiksatam> SridarK badveli can we create a new wiki page for FWaaS DVR support and link it from the FWaaS wiki page?
18:49:32 <SridarK> SumitNaiksatam: sure will do
18:49:52 <badveli> yes sumit, sridark we can add details independently
18:49:52 <SridarK> badveli: and i can discuss this
18:50:02 <SumitNaiksatam> on that wiki page, lets list provide links to our patches and to all the dependencies
18:50:05 <badveli> fine sridark
18:50:21 <SridarK> SumitNaiksatam: sounds good
18:50:33 <SumitNaiksatam> once this is done, lets send an email to the mailer, so that its known to all what we are working on, and what are dependencies
18:50:55 <SridarK> SumitNaiksatam: ok
18:51:19 <SumitNaiksatam> #action SridarK badveli to setup FWaaS DVR support wiki page, provide spec/impl/dependency links, send email to -dev with pointer to this wiki page
18:51:22 <badveli> sridark is already on top of it, we can add it
18:51:30 <SumitNaiksatam> badveli: great
18:51:41 <SumitNaiksatam> anything else to discuss on this topic?
18:51:44 <SumitNaiksatam> any blockers here?
18:51:45 <badveli> thanks sridark and sumit
18:52:01 <SridarK> SumitNaiksatam: no blockers seen as of now
18:52:11 <badveli> the scope of the code changes
18:52:16 <SridarK> SumitNaiksatam: i am sure something will come up
18:52:32 <SumitNaiksatam> SridarK: badveli thanks for the update
18:52:39 <SumitNaiksatam> #topic Service Objects
18:52:55 <badveli> i am working on the reference implementation
18:53:08 <SumitNaiksatam> #link https://review.openstack.org/#/c/67784/
18:53:25 <SumitNaiksatam> ah seems like i have the wrong link
18:53:26 <badveli> sumit
18:53:34 <SumitNaiksatam> badveli: can you post the link to your patch here
18:53:38 <badveli> i am tryiing to update the link in the wiki
18:53:47 <badveli> not able to update it
18:53:58 <SumitNaiksatam> badveli: was just going to say
18:54:09 <SumitNaiksatam> everyone please keep: #link https://wiki.openstack.org/wiki/Neutron/FWaaS/JunoPlan updated
18:54:23 <SumitNaiksatam> badveli: you might have not logged in before you tried to update
18:54:36 <SumitNaiksatam> badveli: else i dont see any reason why you would not be able to update
18:55:00 <badveli> https://review.openstack.org/#/c/105873/
18:55:15 <badveli> not sure i tried some time back
18:55:19 <badveli> i will update again
18:55:51 <badveli> https://review.openstack.org/#/c/106274/
18:56:25 <badveli> https://review.openstack.org/#/c/106918/
18:56:29 <badveli> three patches
18:56:41 <badveli> the reference implementation is not yet done
18:56:55 <badveli> i am working on it and would be finishing sooner
18:57:04 <SumitNaiksatam> badveli: good
18:57:05 <SridarK> badveli: i have not looked yet either - will do so
18:57:16 <badveli> thanks sridark and sumit
18:57:21 <SumitNaiksatam> badveli: sorry for having to take the drastic step of -2ing the patch
18:57:30 <badveli> no problem
18:57:38 <badveli> i was a bit confused
18:57:52 <SumitNaiksatam> badveli: if i did not, someone else would have done it for that reason
18:57:52 <badveli> on the process, for some reason
18:58:03 <badveli> ok, no problem sumit
18:58:07 <SumitNaiksatam> badveli: also your second patch needs to be dependent of the first one
18:58:20 <SumitNaiksatam> badveli: the process is documented in the gerrit workflow
18:58:21 <badveli> there was some last minute updates that happened
18:58:37 <badveli> thanks sumit
18:58:51 <SumitNaiksatam> badveli: you shoud have been able to search this on google, but here is a ready reference: #link https://wiki.openstack.org/wiki/Gerrit_Workflow
18:59:02 <badveli> yes sumit the second is dependent on first
18:59:07 <SumitNaiksatam> badveli: also, i had earlier sent you a link on how the commit messages need to be formatted
18:59:25 <SumitNaiksatam> badveli: please follow those guidelines, as i still see some descrepancies
18:59:35 <badveli> sumit, i followed it for the second patch
18:59:40 <SumitNaiksatam> badveli: i know this is not as much technical, but it does turn off reviewers
18:59:58 <badveli> yes sumit, the first and last patch were uploaded before
19:00:07 <badveli> i will also correct them
19:00:10 <SumitNaiksatam> badveli: for one, “Implements: blueprint fwaas-customized-service for customized service” is not a suggested a commit message title
19:00:36 <SumitNaiksatam> badveli: ah i see, you updated https://review.openstack.org/#/c/106274/
19:00:39 <SumitNaiksatam> badveli: good
19:00:49 <badveli> yes sumit
19:00:53 <badveli> Add service group as a firewall customized service
19:00:57 <SridarK> badveli: i can also help offline if u need - SumitNaiksatam has explained a lot of this to me earlier on the dependencies etc
19:01:09 <badveli> the second one was updated after you send the link
19:01:27 <badveli> i am adding the reference implementation so will update the rest of the two
19:01:44 <badveli> but i am a bit not sure how does all this patches work
19:01:46 <SumitNaiksatam> badveli: great, i also notice you added the UTs in the first patch
19:01:56 <SumitNaiksatam> badveli: i have removed my -2
19:02:07 <badveli> thanks sumit
19:02:13 <badveli> initially at the last minute
19:02:17 <SumitNaiksatam> badveli: please go ahead, why do you say - “i am a bit not sure how does all this patches work"
19:02:33 <badveli> yes, you mentioned the first patch
19:02:43 <badveli> is cli and it will go in after the patches in
19:02:49 <badveli> neutron
19:03:10 <badveli> sumit: you had mentioned it will be reviewed after the patches in neutron
19:03:29 <SumitNaiksatam> badveli: you mean the client patch?
19:03:32 <badveli> for example i will try to get the reviewers in second patch
19:03:46 <badveli> yes, the cli part
19:03:57 <badveli> if some reviewers approve second patch
19:04:04 <SumitNaiksatam> badveli: yeah, there is no way that the CLI will be approved and merged before the neutron patches
19:04:21 <SumitNaiksatam> badveli: because it does not make sense to have CLI for a feature that does not exist
19:04:36 <SumitNaiksatam> badveli: typically the rewiew happens in parallel
19:04:57 <SumitNaiksatam> badveli: but you will recieve more attention on the CLI patches once its clear that the neutron patches are almost ready
19:05:28 <badveli> fine sumit: how does this dependency is explicit
19:05:29 <SumitNaiksatam> badveli: but you do have to keep the CLI patch ready, since people wil ltry to install devstack and test the neutron patches using your CLI patches
19:05:44 <SumitNaiksatam> badveli: you cannot setup a dependency across projects
19:06:03 <badveli> i meant to say if i get some approvals for the second and third patch
19:06:05 <SumitNaiksatam> badveli: which means, in this case, you cannot setup a dependency from your CLI patch on your neutron patch
19:06:18 <badveli> oh..thanks sumit
19:06:25 <SumitNaiksatam> badveli: i am a little cofused as to which are your second and third patches
19:06:33 <SumitNaiksatam> badveli: lets not refer to them that way
19:06:44 <badveli> does this mean we cannot ask the reviewers for reviewing the cli
19:06:47 <SumitNaiksatam> badveli: i believe you have one CLI patch and two neutron patches
19:06:51 <badveli> ok
19:06:52 <badveli> yes
19:06:55 <SumitNaiksatam> badveli: i already answered that
19:07:13 <SumitNaiksatam> badveli: you can ask, and you should, but realistically you will not get much attention
19:07:38 <badveli> fine sumit, i will actively work on the neutron patches
19:07:46 <badveli> for the reviews
19:07:57 <badveli> to happen
19:07:59 <SumitNaiksatam> badveli: the way you want to go about is by saying - here are the neutron patches, please review them; and here is the CLI patch which will help you to review those
19:08:23 <badveli> got it sumit
19:08:30 <SumitNaiksatam> badveli: that way you point to both these sets of patches, with due priority given to the neutron patch
19:09:05 <badveli> fine sumit
19:09:25 <badveli> also the wiki link has some tempest and horizon
19:09:30 <SumitNaiksatam> another suggestion, and pretty for everyone here - we can assign some identifier names to our patches
19:10:03 <SumitNaiksatam> for example in the group policy work, i go GP-API-1, GP-DB-1,…, GP-API-2, GP-DB-2, etc
19:10:18 <SumitNaiksatam> that way it becomes easier to refer to patches when we are talking
19:10:28 <badveli> fine sumit
19:10:29 <SumitNaiksatam> these can be mentioned in the commit message
19:10:49 <SumitNaiksatam> you can see the group policy patch: #link https://review.openstack.org/#/c/95900/20
19:11:04 <SumitNaiksatam> this is just a personal preference, there is no precedence in neutron for this
19:11:13 <SumitNaiksatam> so feel free to ignore
19:12:21 <badveli> fine sumit
19:12:39 <SumitNaiksatam> anything else to discuss on service objects?
19:12:52 <SumitNaiksatam> my fingers are aching now! :-(
19:12:54 <badveli> the wiki link is also capturing about the heat
19:13:15 <badveli> sumit, i think we are done but last one
19:13:24 <badveli> the wiki link has tempest horizon
19:13:25 <SumitNaiksatam> badveli: yeah sure
19:13:27 <SridarK> SumitNaiksatam: :-) we need voice to text convertors for IRC
19:13:29 <SumitNaiksatam> badveli: yes
19:13:36 <SumitNaiksatam> SridarK: :-)
19:13:42 <SumitNaiksatam> badveli: very good point to bring up
19:13:57 <badveli> wikik has horizon,tempest,heat
19:13:59 <SumitNaiksatam> badveli: we need the tempest API patch to be in review as well
19:14:09 <badveli> ok, this is what i need
19:14:15 <SumitNaiksatam> badveli: the neutron patch will not merge without the tempest API patch
19:14:25 <SumitNaiksatam> badveli: let me hook you up with miguel
19:14:32 <badveli> thanks sumit
19:14:40 <badveli> appreciate your help
19:14:44 <SumitNaiksatam> badveli: and ideally we should have a tempest scenario patch as well
19:15:22 <badveli> i will go through it, but the scenario patch is compulsary
19:15:23 <SumitNaiksatam> #action SumitNaiksatam to reach out to mlavalle regarding tempest patches for upcoming fwaas features, cc rest of the fwaas team
19:15:24 <badveli> ?
19:15:37 <SumitNaiksatam> badveli: lets check with mlavalle
19:15:44 <badveli> thanks sumit
19:15:55 <SumitNaiksatam> badveli: but even if its not, its better to have it, since it wil strengthen our case
19:16:24 <SumitNaiksatam> badveli: lets do all we can (assuming we have the time) so that our reviews get smoother
19:16:24 <badveli> fine sumit, let me go through it
19:16:39 <badveli> yes sumit
19:16:45 <SumitNaiksatam> #topic FWaaS metering
19:16:51 <SumitNaiksatam> is prad here?
19:17:10 <SumitNaiksatam> SridarK: i believe prad got his spec approved in ceilometer
19:17:12 <SumitNaiksatam> SridarK: thats great
19:17:23 <SridarK> SumitNaiksatam: oh great
19:17:33 <SridarK> SumitNaiksatam: i will sync with prad
19:17:36 <SumitNaiksatam> if prad, needs any help we are here to help
19:17:46 <SumitNaiksatam> #topic open discussion
19:17:51 <SridarK> SumitNaiksatam:  to make sure on any requirements on neutron side
19:17:53 <SumitNaiksatam> #undo
19:17:54 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x2d0c350>
19:18:01 <SumitNaiksatam> SridarK: yes
19:18:11 <SumitNaiksatam> #topic Vendor blueprints
19:18:22 <SumitNaiksatam> natarajk: SridarK: anything you want to bring up?
19:18:24 <SridarK> SumitNaiksatam: sorry done with what i had to say on the pref topic
19:18:33 <SridarK> *prev
19:18:59 <natarajk> SumitNaiksatam:Nothing much. We are fixing our CI server to l3 plugin.
19:19:12 <natarajk> to -> for
19:19:21 <SumitNaiksatam> natarajk: ah ok, sorry i havent been able to get to it
19:19:35 <SumitNaiksatam> natarajk: review i mean, i have a big stack
19:19:42 <SumitNaiksatam> SridarK: anything at your end?
19:19:45 <SridarK> SumitNaiksatam: not much to report on our side - we need the vendor dependent patch to merge
19:20:05 <SridarK> SumitNaiksatam: we will have the FWaaS piece ready
19:20:54 <SumitNaiksatam> SridarK: sweet
19:21:01 <SumitNaiksatam> #topic open discussion
19:21:21 <SridarK> SumitNaiksatam: will reach out to u and s3wong to discuss service insertion
19:21:31 <SumitNaiksatam> gduan: are you tracking the flavor impleemenation from enikanorov__?
19:21:41 <SumitNaiksatam> SridarK: sure, we are a bit behind on that
19:21:59 <SridarK> SumitNaiksatam: will discuss over email
19:22:26 <SumitNaiksatam> badveli: can you check with gduan?
19:22:34 <badveli> fine sumit
19:23:24 <SumitNaiksatam> badveli gduan: we need to keep track since we might not get a whole lot of time to react once the spec is approved
19:24:53 <gduan> Hi
19:25:07 <SumitNaiksatam> gduan: ^^^
19:25:09 <gduan> I am actually fine with the patch
19:25:14 <SumitNaiksatam> ok good
19:25:16 <gduan> but spec is not approved yet
19:25:21 <SumitNaiksatam> gduan: yeah
19:25:38 <SumitNaiksatam> gduan: we have to be ready on the fwaas side to jump in when the spec is approved
19:25:48 <SumitNaiksatam> gduan: probably this weekend
19:25:53 <SumitNaiksatam> anything else to discuss?
19:25:55 <gduan> sure
19:26:04 <gduan> the patch is the data model patch
19:26:23 <SumitNaiksatam> gduan: okay
19:26:40 <gduan> the implementation is not submitted yet,
19:27:05 <gduan> I mean enikanorov's patch
19:27:06 <SumitNaiksatam> gduan: for what?
19:27:31 <gduan> enikanorov's current patch is for data model only
19:28:03 <gduan> I guess dispatching part will be another one
19:28:23 <SumitNaiksatam> gduan: ah ok, lets check with him, on provide comment on the patch
19:28:36 <SumitNaiksatam> gduan: glad that you have been tracking ;-)
19:28:44 <SumitNaiksatam> okay if nothing else, lets wrap up
19:28:50 <gduan> ok. I will discuss with him.
19:28:57 <SumitNaiksatam> gduan: thanks
19:28:59 <SumitNaiksatam> thanks all!
19:29:00 <SumitNaiksatam> bye
19:29:02 <badveli> bye
19:29:04 <SridarK> thanks all
19:29:04 <SumitNaiksatam> #endmeeting