18:32:46 <SumitNaiksatam> #startmeeting Networking FWaaS
18:32:47 <openstack> Meeting started Wed Aug  6 18:32:46 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:32:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:32:50 <openstack> The meeting name has been set to 'networking_fwaas'
18:32:58 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/FWaaS
18:33:08 <SumitNaiksatam> SridarK: thanks for update the meeting wiki page
18:33:15 <regXboi> SumitNaiksatam: so try it - you can chair and unchair me :)
18:33:22 <SridarK> SumitNaiksatam: no worries
18:33:37 <SumitNaiksatam> regXboi: in think unchair might work
18:33:45 <SumitNaiksatam> regXboi: we probably need the chairs option
18:33:59 <SumitNaiksatam> #chair SumitNaiksatam SridarK regXboi
18:34:00 <openstack> Current chairs: SridarK SumitNaiksatam regXboi
18:34:04 <regXboi> and there you go
18:34:16 <SumitNaiksatam> regXboi: awesome, we are good now! :-)
18:34:22 <regXboi> and now you can unchair me and I'll go away :)
18:34:26 <regXboi> or actually
18:34:29 <regXboi> #unchair regXboi
18:34:30 <openstack> Current chairs: SridarK SumitNaiksatam
18:34:34 <SumitNaiksatam> regXboi: you are welcome to hang in there
18:34:36 <regXboi> I'll unchair myself :)
18:34:44 <regXboi> no - have to go fight another battle :/
18:34:46 <regXboi> later all
18:35:05 <SumitNaiksatam> #topic Action item follow up
18:35:22 <SumitNaiksatam> meeting with the DVR folks - do we need one?
18:35:39 <SridarK> SumitNaiksatam: i think it will be good to do that nevertheless
18:35:52 <SumitNaiksatam> SridarK: sure, f2f or virtual is good?
18:36:01 <SridarK> SumitNaiksatam: hopefully by next week we will be in a decent shape
18:36:04 <SumitNaiksatam> SridarK: perhaps we can start with webex to begin with
18:36:17 <SridarK> SumitNaiksatam: yes exactly and we can make the trip if needed
18:36:21 <SumitNaiksatam> SridarK: okay sure, should we put something on the calendar for next tuesday?
18:36:28 <SumitNaiksatam> SridarK: i mean WebEx
18:36:31 <SridarK> SumitNaiksatam: sounds good
18:36:38 <SridarK> i can set that up
18:36:39 <badveli> i am able to configure the dvr as a centralized
18:36:52 <badveli> on a single node
18:37:00 <badveli> applied the firewall rules
18:37:11 <badveli> as we expected they do not applpy on snat name space
18:37:18 <SumitNaiksatam> badveli: hang on
18:37:28 <SumitNaiksatam> badveli: lets do the update in the dvr topic
18:37:36 <badveli> ok
18:38:15 <SumitNaiksatam> #topic WebEx meeting with DVR team for Aug 12
18:38:19 <SumitNaiksatam> #undo
18:38:20 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x2e43250>
18:38:30 <SumitNaiksatam> #action WebEx meeting with DVR team for Aug 12
18:39:18 <SumitNaiksatam> we had another action item “SridarK badveli to setup FWaaS DVR support wiki page, provide spec/impl/dependency links, send email to -dev with pointer to this wiki page”
18:39:33 <SridarK> SumitNaiksatam: still lagging on that
18:39:36 <badveli> sumit as part of it i had got some info
18:39:47 <SumitNaiksatam> SridarK badveli: np
18:39:53 <badveli> will sync up with sridar and update
18:39:57 <SumitNaiksatam> #action SridarK badveli to setup FWaaS DVR support wiki page, provide spec/impl/dependency links, send email to -dev with pointer to this wiki page
18:39:59 <SumitNaiksatam> badveli: thanks
18:40:00 <SridarK> SumitNaiksatam: i think would like to get some basic setup going and then update with some meaningful info
18:40:13 <badveli> yes
18:40:14 <SumitNaiksatam> SridarK: even placeholder for now is good
18:40:30 <SumitNaiksatam> i had action item to follow up with mlavalle
18:40:34 <SridarK> SumitNaiksatam: ok sounds good then we will do that
18:40:35 <SumitNaiksatam> on tempest, which i did
18:40:49 <SumitNaiksatam> so, i think we are good on that
18:41:07 <SumitNaiksatam> we will discuss tempests test for service objects in that corresponding topic
18:41:18 <badveli> yes
18:41:33 <badveli> sumit:we will discuss there i have some update
18:41:55 <SumitNaiksatam> #topic FWaaS support for DVR
18:42:08 <SumitNaiksatam> badveli: please go ahead with what you were stating earlier
18:42:36 <badveli> sumit: I was able to configure dvr in a single node
18:43:16 <badveli> dvr_snat option
18:43:33 <badveli> i saw that snat name space
18:43:39 <SumitNaiksatam> badveli: thats great
18:43:53 <badveli> does not get the firewall rules applied as we expected
18:44:15 <badveli> sumit: we were planning to change that
18:44:42 <badveli> the firewall gets applied on the internal router
18:45:43 <SridarK> SumitNaiksatam: badveli and i discussed and i am trying to set up on a server to eventually get to a multinode so we can also validate on the distributed router - running into some tangential issues
18:45:45 <badveli> sumit: since the compute, network everything exists in the same node
18:46:09 <SumitNaiksatam> SridarK badveli: ah ok
18:46:45 <SumitNaiksatam> badveli: i believe you mentioned earlier that you were going to try a two node set up?
18:47:11 <badveli> yes sumit, i have another server but it needs a update
18:47:38 <badveli> we were having an esxi older version i need to update
18:47:56 <badveli> so i cannot use it
18:48:07 <SumitNaiksatam> badveli: ok good, perhaps worth spending time doing that first then on the single node
18:48:27 <SumitNaiksatam> that said, is DVR a misconfiguration on a single node?
18:48:36 <badveli> fine sumit looks good
18:48:50 <badveli> the dvr wiki says we can configure like that
18:48:56 <SridarK> SumitNaiksatam: the single node enables one to "kick the tires" on DVR
18:49:08 <SridarK> SumitNaiksatam: as stated on the DVR wiki
18:49:45 <SridarK> SumitNaiksatam: makes sense as a single node which could compute nodes
18:51:08 <SumitNaiksatam> SridarK badveli: so FWaaS should still work on that right?
18:51:17 <SumitNaiksatam> or are we not going to allow that?
18:51:27 <SridarK> SumitNaiksatam: we should allow
18:51:39 <SridarK> by putting it on the correct NS
18:52:12 <badveli> yes
18:52:17 <SridarK> SumitNaiksatam: i think we should view this as a DVR with a single node
18:52:28 <SridarK> as opposed to the non DVR mode
18:52:37 <SumitNaiksatam> SridarK: yes agree
18:52:44 <SridarK> where we will go to todays implemenation
18:52:51 <badveli> yes we should put it in teh correct name space
18:53:03 <SumitNaiksatam> SridarK: but i was asking in the context of badveli stating that it does not work
18:53:27 <SumitNaiksatam> SridarK badveli: so our solution is going to be different for single node DVR versus multi-node DVR?
18:53:40 <SridarK> SumitNaiksatam: i think it will be same
18:53:56 <SridarK> SumitNaiksatam: with single node - we will be on the service node
18:54:04 <SridarK> i believe
18:54:14 <badveli> sumit: on a single node since the compute,network are in the same
18:54:14 <SridarK> good point for clarification with the DVR team
18:54:39 <badveli> node i was trying to think which name space we should apply the firewall
18:55:21 <badveli> sridark: agreed we need more clarification
18:55:47 <SridarK> SumitNaiksatam: i think once we have the setup we will prototype on that quickly - badveli and i will close on this
18:56:15 <SumitNaiksatam> SridarK: great
18:56:21 <SridarK> SumitNaiksatam: we would like to do this before we discuss with the DVR team
18:56:34 <SridarK> so we can have a meaningful conversation
18:56:51 <SumitNaiksatam> i am just trying to make sure that we have not hit a technical roadblock in terms of getting this to work on a single node
18:56:57 <SumitNaiksatam> SridarK: absolutely
18:57:21 <SridarK> SumitNaiksatam: agreed - we may be able to get this validated on a single node faster
18:57:48 <SridarK> on the multimode - i worry about the basic setup and some other tangential issues we could run into
18:57:58 <SridarK> *multinode
18:58:15 <SumitNaiksatam> SridarK: completely agree
18:58:35 <SumitNaiksatam> SridarK: however it might make sense to get to that sooner that later
18:58:55 <SridarK> SumitNaiksatam: yes agreed we will spin that in parallel
18:59:08 <badveli> fine sridark and sumit
19:00:10 <badveli> since the wiki is saying there is an option to configure on a single node, i started with that
19:00:22 <badveli> since it is a service,network and compute node
19:00:29 <SridarK> badveli: makes sense to start simple
19:00:58 <badveli> thanks sridar we can get a feel of it
19:01:03 <SumitNaiksatam> badveli: i agree as well
19:01:09 <SridarK> badveli: SumitNaiksatam 's point is since the multinode is the final solution we should not lose sight of that
19:01:14 <SumitNaiksatam> SridarK: do you have access to a couple of servers?
19:01:34 <SridarK> SumitNaiksatam: sigh - i have one - i am trying to get another one
19:02:24 <SridarK> SumitNaiksatam: will figure something out
19:02:53 <SumitNaiksatam> SridarK: ah great
19:03:17 <SumitNaiksatam> the reason why i asked was i wanted to check if we could start the multi-node setup in parallel at your end
19:03:26 <SridarK> SumitNaiksatam: agreed
19:04:04 <badveli> Sridar and Sumit, I will also try that by bringing the second server
19:04:19 <badveli> after updating it
19:04:45 <SumitNaiksatam> badveli: great
19:05:03 <SumitNaiksatam> badveli SridarK: so we know what the solution is for getting this to work on a single node?
19:05:23 <SridarK> SumitNaiksatam: yes we have a fair idea of what needs to be done
19:06:04 <SridarK> SumitNaiksatam:  will feel more comfortable on trying some stuff out - we will target that by end of the week
19:06:34 <badveli> Sridar looks like the same solution should be fine
19:06:50 <badveli> for either the multi node or single node, right?
19:07:12 <SridarK> badveli: slight changes for the multi node
19:07:18 <badveli> depending on the node
19:07:26 <SridarK> badveli: for diff NS
19:07:34 <SridarK> but change will be minor
19:08:12 <SridarK> badveli: we can work thru this to have good confidence level once we try out some simple tests
19:09:16 <badveli> yaeh i meant the same, we understand what we need to do, will try
19:09:51 <SumitNaiksatam> SridarK: can we document this in the wiki?
19:09:59 <SridarK> SumitNaiksatam: ok will do
19:10:17 <SumitNaiksatam> SridarK: i mean, something very short, at least as a starting point - in terms of the differences between the two approaches
19:10:45 <SumitNaiksatam> SridarK: since you seem to have thought through at least a little bit of this
19:10:48 <SridarK> SumitNaiksatam: sounds good - we allude to this in the spec but will good to capture the salient points
19:11:17 <SumitNaiksatam> SridarK: ah good - i meant in the context of the single node deployment versus multi-node
19:11:30 <SridarK> in  a more crisp manner - yes will do
19:11:46 <SridarK> ok got it
19:11:48 <SumitNaiksatam> SridarK badveli: so what is our target in the coming week?
19:11:52 <SumitNaiksatam> SridarK: thanks
19:12:06 <SumitNaiksatam> can we have a bare bones WIP patch posted?
19:12:17 <SridarK> SumitNaiksatam: we will get some basic prototyping done and try to have a 2 node setup up
19:12:39 <badveli> Sridark: agreed, I think we need some prototype
19:12:46 <SridarK> SumitNaiksatam: we can shoot for that but i think we may get to next week on posting a WIP
19:13:22 <SridarK> SumitNaiksatam: but we will see if we can get some success with a proto we will try to get a WIP out earlier
19:13:45 <badveli> Yes Sridark i think that makes more sense
19:14:35 <SumitNaiksatam> SridarK: at this point i am thinking that we dont necessarily have to tested out the patch
19:15:01 <SridarK> SumitNaiksatam: ok
19:15:04 <SumitNaiksatam> SridarK: as long as we can put an initial version which is along the lines of what is stated in the bp
19:15:11 <SumitNaiksatam> this will of couse be WIP
19:15:19 <SridarK> SumitNaiksatam: ok we will look at that in those terms
19:15:19 <SumitNaiksatam> but will open it up to whoever wants to review
19:17:08 <badveli> Sumit,Sridar i am able to get some thing about the driver side and the agent side
19:17:16 <SumitNaiksatam> badveli: sweet
19:17:40 <SumitNaiksatam> badveli SridarK: hate to push this, but can we target those WIP patches for the coming monday?
19:17:51 <SumitNaiksatam> that way we can provide an update in the neutron team meeting
19:17:59 <SridarK> SumitNaiksatam: no worries we will defn shoot for that
19:18:49 <badveli> Sumitt as you had mentioned we can try to code as specified in the spec, also we have some info from the dvr team
19:20:19 <badveli> but functionality we are not tested
19:20:49 <badveli> sumit: functionality testing we are not doing is it fine?
19:21:17 <SumitNaiksatam> badveli: we have to do that, but i am saying does not have to be finished by monday
19:21:28 <SumitNaiksatam> badveli: that is an ongoing effort
19:22:17 <badveli> sumit: so our goal should be code as per the spec and improve on it based on our testing
19:23:29 <badveli> i am asking this because we are not yet finished having the set ups
19:23:31 <SumitNaiksatam> badveli: yes
19:23:43 <SumitNaiksatam> would like to make sure that people get a chance to review a lot ahead of time
19:24:04 <badveli> sumit: fine with me
19:24:09 <SumitNaiksatam> #action SridarK badveli to attempt WIP patches by Aug 11th
19:24:22 <SumitNaiksatam> SridarK badveli thanks much! and sorry for pushing!
19:24:36 <SumitNaiksatam> this will also help for our tuesday meeting i guess
19:24:39 <SridarK> SumitNaiksatam: no worries - we are fast nearing end of the release
19:24:53 <SumitNaiksatam> ok anything more to discuss on this front?
19:25:03 <SridarK> SumitNaiksatam: nothing from me
19:25:17 <SumitNaiksatam> badveli: ?
19:25:18 <badveli> nothing from my side too
19:25:37 <SumitNaiksatam> SridarK badveli: great, thanks!
19:25:48 <SridarK> SumitNaiksatam: no worries
19:26:00 <SumitNaiksatam> #topic Service Objects
19:26:06 <SumitNaiksatam> badveli: again :-)
19:26:17 <SumitNaiksatam> badveli: how is it coming along? any progress with tempest?
19:26:27 <badveli> Sumit: Yes added tempest test
19:26:35 <badveli> but need one small help
19:26:43 <SumitNaiksatam> badveli: thats cool, yes sure
19:26:55 <badveli> is there any way we can do a break while running tempest
19:27:00 <badveli> the tests are done
19:27:23 <badveli> but needed to find some failure issues
19:27:49 <badveli> as we can do a debugging with the usual unit test suites
19:28:00 <badveli> can we do the same with the tempest?
19:28:39 <SridarK> badveli: are u talking of something like a pdb.set_trace()
19:28:49 <SumitNaiksatam> yeah i was just going to ask
19:28:52 <badveli> yes sridark, i meant it
19:29:15 <badveli> nothing mentioned in wiki
19:29:51 <SumitNaiksatam> badveli: so which part of the code do you need to put the breakpoint in?
19:30:12 <SridarK> badveli: somehow my experience with this on tests is a bit mixed - i think i don't understand this as well as it is running in a venv and have not been very successful
19:30:20 <SridarK> it works great on the actual code
19:31:01 <SridarK> badveli: as a workaround - i have resorted to adding logs into files - not the best way
19:31:48 <SridarK> SumitNaiksatam: oops looks like we are at time
19:32:06 <SridarK> not sure if there is another mtg
19:32:09 <SumitNaiksatam> SridarK: yeah
19:32:15 <SumitNaiksatam> i dont think there is one
19:32:20 <SumitNaiksatam> but we should wrap up
19:32:23 <SridarK> oh ok
19:32:25 <badveli> Sumit: looks like this works in regular unit tests i wanted to break in the point where i am posting the command
19:32:40 <SumitNaiksatam> badveli: on the tempest side on the neutron side?
19:32:45 <badveli> tempest side
19:32:59 <badveli> it does not work
19:33:00 <SumitNaiksatam> badveli: if its on the tempest side, you can send a quick email to mlavalle and check it as well
19:33:10 <badveli> fine sumit i will do
19:33:17 <badveli> another issue is
19:33:42 <badveli> i completed the driver side patch also
19:34:02 <badveli> so i have almost all the patches
19:34:16 <badveli> when running the db migration for the config,api
19:34:23 <badveli> oslo.config.cfg.NoSuchOptError: no such option: mysql_engine
19:34:37 <badveli> i enter into this problem
19:35:01 <badveli> sumit.sirdar: do you have any idea
19:35:05 <badveli> its holding me
19:35:23 <badveli> it started recently
19:35:57 <SumitNaiksatam> badveli: i think its an issue with the new oslo packages
19:35:59 <SridarK> badveli: there have been some changes in the db migration - perhaps u have something there
19:36:08 <SumitNaiksatam> badveli: perhaps refreshign might help
19:36:21 <SumitNaiksatam> badveli: also i think HenryG is a great person to check with on this
19:36:25 <badveli> varmour@ubuntu-1-104:/opt/stack/neutron/neutron$  neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini revision -m "service_group_ext" --autogenerate
19:36:48 <SridarK> badveli: i can help u get in touch with HenryG - if u are not able to track him down
19:37:03 <HenryG> I am easy to track down :)
19:37:12 <SridarK> HenryG: :-)
19:37:53 <SridarK> badveli: there u have HenryG - u can send him an email too - i will send u his email off line if needed
19:38:04 <HenryG> Didn't I just +1 a review to fix that?
19:38:08 <badveli> thanks HenryG,Sumit
19:38:40 <SumitNaiksatam> HenryG: thanks, whats the link?
19:38:48 <HenryG> looking ...
19:39:37 <HenryG> https://review.openstack.org/112171  ?
19:40:55 <badveli> thanks HenryG, I will change that file
19:41:17 <SumitNaiksatam> HenryG: awesome thanks!
19:41:23 <HenryG> badveli: Let me know if that does not work for you
19:42:03 <badveli> thanks HenryG, you saved my research. thanks for your help
19:42:40 <SridarK> HenryG: u have set the bar for response times now - wish all would even get to a fraction of this. :-)
19:43:19 <SumitNaiksatam> SridarK: lol
19:43:23 <badveli> +1
19:43:27 <SumitNaiksatam> ok anything else on service objects?
19:43:35 <SumitNaiksatam> since we are running short on time
19:43:39 <badveli> Sumit> I will try to target to post all the patches
19:43:44 <badveli> including the tempest
19:44:23 <badveli> thanks for your helps
19:44:39 <SumitNaiksatam> badveli: awesome effort in making progress
19:44:44 <SumitNaiksatam> #topic open discussion
19:44:50 <SumitNaiksatam> anything more today?
19:45:22 <SridarK> SumitNaiksatam: sent out bug scrub mail (i need to send one to myself too) - nothing much more to add
19:45:40 <SumitNaiksatam> SridarK: that was great
19:45:48 <SumitNaiksatam> SridarK: i did not see anything critical in taht
19:46:02 <SridarK> SumitNaiksatam: no worries - yes nothing critical
19:46:02 <SumitNaiksatam> SridarK: i mean marked as critical
19:46:12 <SridarK> SumitNaiksatam: yes
19:46:20 <SumitNaiksatam> SridarK: great thanks for going through the list!
19:46:32 <SridarK> SumitNaiksatam: no worries at all
19:46:34 <SumitNaiksatam> SridarK: i think SridharG’s patch was merged?
19:46:41 <SumitNaiksatam> i had +2’ed it earlier
19:46:43 <SridarK> SumitNaiksatam: yes that was great
19:46:54 <SridarK> SumitNaiksatam: yes
19:47:39 <SumitNaiksatam> garyduan: anything you wanted to chime in on?
19:48:09 <garyduan> regarding flavor?
19:48:15 <SumitNaiksatam> garyduan: yes
19:48:27 <garyduan> I talked to enikanorov
19:48:58 <garyduan> there is a neutronclient patch
19:49:02 <garyduan> beside neutron patch
19:49:22 <SridarK> oops looks like we lost SumitNaiksatam
19:49:22 <garyduan> but, first of all, we need get spec approved
19:49:36 <garyduan> :-)
19:50:05 <SumitNaiksatam> i think my network connection if flaky again
19:50:05 <garyduan> Sumit is back.
19:50:23 <SridarK> ok
19:50:26 <SumitNaiksatam> SridarK: please feel free to end the meeting if i am bounced out again
19:50:32 <SridarK> ok
19:50:37 <SridarK> will do
19:50:45 <garyduan> so, for flvar, waiting for spec to be approved
19:50:55 <SumitNaiksatam> garyduan: yeah
19:51:15 <SumitNaiksatam> garyduan: ok, you feel comfortable jumping on it for fwaas support, once its approved?
19:51:47 <garyduan> yes
19:52:00 <SumitNaiksatam> garyduan: sweet
19:52:06 <SumitNaiksatam> on that positive note
19:52:12 <SumitNaiksatam> lets call it a wrap!
19:52:18 <SumitNaiksatam> thanks all for joining
19:52:21 <badveli> bye all
19:52:22 <SumitNaiksatam> lots of work to do!
19:52:27 <SridarK> ok bye all
19:52:28 <SumitNaiksatam> bye all
19:52:31 <SumitNaiksatam> #endmeeting