18:31:43 <SumitNaiksatam> #startmeeting Networking FWaaS
18:31:44 <openstack> Meeting started Wed Oct 22 18:31:43 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:31:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:31:49 <openstack> The meeting name has been set to 'networking_fwaas'
18:32:07 <SumitNaiksatam> seems like everyone is busy preparing for the summit ;-)
18:32:35 <SumitNaiksatam> #info kilo design summit etherpad: https://etherpad.openstack.org/p/neutron-fwaas
18:33:20 <SumitNaiksatam> #info neurtron kilo design summit topics: #link https://etherpad.openstack.org/p/kilo-neutron-summit-topics-distilled
18:33:32 <SumitNaiksatam> lets get started with the standing items on the agenda
18:33:36 <SumitNaiksatam> #topic Bugs
18:33:45 <SumitNaiksatam> I dont see anything new popping up
18:33:47 <SumitNaiksatam> SridarK: ?
18:33:58 <SridarK> SumitNaiksatam: not much to report
18:34:08 <SumitNaiksatam> i know badveli was going to do some additional testing
18:34:12 <SumitNaiksatam> but he doesnt seem to be here
18:34:18 <SumitNaiksatam> lets check back with him offline
18:34:27 <SridarK> SumitNaiksatam: will do
18:35:50 <SumitNaiksatam> i dont think any of the untriaged bugs are critical
18:36:19 <SridarK> SumitNaiksatam: i will also take  a look
18:36:25 <SumitNaiksatam> SridarK: thanks
18:36:28 <SumitNaiksatam> #topic Docs
18:36:35 <SumitNaiksatam> SridarK: any updates?
18:36:42 <SridarK> SumitNaiksatam: not much on this
18:37:25 <SumitNaiksatam> SridarK: let me know if you need anything from me, happy to jump in…
18:37:35 <SridarK> SumitNaiksatam: will do
18:37:45 <SumitNaiksatam> ok moving on
18:38:01 <SumitNaiksatam> #topic Kilo blueprints
18:38:22 <SumitNaiksatam> SridarK: i noticed that you added a vendor blueprint for the CSR
18:38:26 <SumitNaiksatam> glebo: hi there!
18:39:18 <SridarK> SumitNaiksatam: yes resubmitted what we had for Juno
18:39:23 <SumitNaiksatam> SridarK: thats a good thing
18:39:33 <SumitNaiksatam> SridarK: we need to start refocussing on getting the process going
18:39:40 <glebo> SumitNaiksatam: lo!
18:39:46 <SridarK> SumitNaiksatam: now our dependencies are in
18:39:54 <SridarK> glebo: hi
18:39:57 <SumitNaiksatam> SridarK: agreed
18:40:09 <SumitNaiksatam> glebo: is vishnu planning to repost the service groups blueprint?
18:40:22 <SumitNaiksatam> natarajk: what about your vendor spec?
18:40:37 <natarajk> i was planning to submit it after the design summit
18:40:40 <glebo> SumitNaiksatam: absolutely
18:40:45 <SumitNaiksatam> natarajk: ok sure
18:40:46 <glebo> I'll ping him on it
18:40:55 <glebo> suprised he didn't do it already
18:40:58 <SumitNaiksatam> glebo: yes, i think better to put it in at earliest
18:41:09 <SumitNaiksatam> glebo: he might have had, and i might have missed it
18:41:10 <glebo> SumitNaiksatam: ack
18:41:18 <SumitNaiksatam> glebo: apologies in advance if i missed it
18:41:54 <glebo> #action: glebo to encourage vishnu to submit service groups BP asap
18:42:20 * glebo surprised vishnu not on the chat here himself
18:42:40 <SumitNaiksatam> glebo: thanks for adding the AI
18:42:48 <SumitNaiksatam> #action: glebo to encourage vishnu to submit service groups BP asap
18:43:15 <SumitNaiksatam> #chairs SridarK natarajk glebo
18:43:32 <SumitNaiksatam> #chair SridarK natarajk glebo
18:43:33 <openstack> Current chairs: SridarK SumitNaiksatam glebo natarajk
18:43:43 <SumitNaiksatam> glebo: i checked, i dont think its in
18:44:08 <SumitNaiksatam> glebo: but its perfectly understandable if badveli is a bit confused and frustrated here
18:44:13 <glebo> SumitNaiksatam: ya, me too. Already pinged him on it
18:44:30 <glebo> SumitNaiksatam:  LOL!!
18:44:39 <glebo> SumitNaiksatam:  honestly, if he wasn't, I wouldn't be here
18:44:46 <SumitNaiksatam> glebo: :-)
18:44:57 <SumitNaiksatam> i think we all are!
18:45:04 <SumitNaiksatam> anyway
18:45:11 <glebo> SumitNaiksatam:  moving on
18:45:30 <SumitNaiksatam> so in terms any additional blueprints to be posted
18:45:42 <SumitNaiksatam> i think we need the design summit discussion to go through
18:45:45 <glebo> badveli joining any second now
18:45:54 <badveli> thanks glebo
18:45:56 <badveli> sorry
18:45:58 <SumitNaiksatam> ah badveli just joined
18:46:01 <SumitNaiksatam> badveli: not worries
18:46:12 <SumitNaiksatam> *no
18:46:13 <glebo> badveli: good to see someone is still able to get emersed in coding
18:46:30 <glebo> badveli:  ah… the good ol days…
18:46:41 <badveli> thanks glebo, sorry today being diwali
18:46:46 <SumitNaiksatam> badveli: we handed you an AI while you were busy actually working! ;-)
18:47:02 <badveli> sorry sumit, did not see it
18:47:06 <glebo> badveli:  let's go ahead and have u resubmit the BP for service groups
18:47:14 <glebo> badveli: ack?
18:47:24 <badveli> the blue print?
18:47:37 <SumitNaiksatam> badveli: yeah, the service groups
18:47:39 <badveli> the blue print is already approved
18:47:49 <glebo> badveli: and do so asap, yeah, BP, spec and code, all in kilo
18:48:04 <glebo> SumitNaiksatam: that's the proper process?
18:48:32 <SumitNaiksatam> glebo: yeah, we have to go by that, until we decide or are told to do something else
18:49:03 <badveli> sumit, do we submit the bp and code by branch names?
18:49:05 <SridarK> badveli: u need to resubmit spec
18:49:27 <badveli> thanks sridark, i will try to do that
18:49:32 <SumitNaiksatam> badveli: resubmit the blueprint (you will have to make minor modifications since the template has changed slightly)
18:49:43 <SumitNaiksatam> badveli: code can just be rebased
18:49:44 <badveli> should we get the approvals again?
18:50:00 <SumitNaiksatam> badveli: yes, we need the approvals again on the spec
18:50:02 <badveli> for the blue print?
18:50:05 * glebo here it comes, ducking
18:50:08 <SumitNaiksatam> badveli: yes
18:50:22 <SumitNaiksatam> glebo: :-)
18:50:42 * glebo feels deja vu for badveli, and for all here, really
18:50:44 <SumitNaiksatam> badveli: so things are clear on the process?
18:50:53 * glebo lavers, rinses, repeats
18:50:58 <SumitNaiksatam> glebo: deja vu for the nth time!
18:51:15 <glebo> SumitNaiksatam:  so, is that deja vu vu vu vu vu vu vu
18:51:23 <SumitNaiksatam> glebo: :-)
18:51:29 <glebo> SumitNaiksatam:  or just more simply deja vu^9
18:51:36 <SumitNaiksatam> badveli: is the process clear?
18:52:06 <glebo> maybe we ought to get shirts printed up for sumit, just for FWaaS team to wear, "deja vu^9"
18:52:07 <badveli> yes, but this will still delay and not able to get why we are doing this again
18:52:26 <glebo> and maybe we'll bring enough for the LBaaS and VPNaaS teams too
18:52:29 <badveli> and getting the approvals
18:52:37 <badveli> again???
18:52:40 <SumitNaiksatam> glebo: :-)
18:52:53 <glebo> since u know they are having the exact same tongue n cheek exchange in their mtgs this week too
18:52:55 <SumitNaiksatam> badveli: i share your frustration, and we are trying to find a solution
18:53:19 <glebo> SumitNaiksatam:  badveli: +1000
18:53:37 <SumitNaiksatam> badveli: but until then we have to stay the course
18:53:49 <glebo> badveli: Let's u and I take it offline. I can coach u thru it tomorrow, k?
18:54:03 <badveli> fine with me, thanks glebo
18:54:05 <SumitNaiksatam> badveli: open to your suggestions as well, if you think a different approach might be helpful
18:54:44 <badveli> Sumit, as you know how hard it is getting the approvals
18:54:51 <badveli> and going through it again
18:54:53 <glebo> *badveli pictures blow torches*
18:55:29 <glebo> badveli:  time check. Let's take it offline
18:55:34 <SumitNaiksatam> badveli: agree, and hence we had team discussions to explore options
18:55:41 <SumitNaiksatam> ok moving on
18:56:00 <SumitNaiksatam> #topic Kilo design summit discussion
18:56:01 <s3wong> badveli: it is probably going to be worse this time. only five selected cores can give your spec a +A in Kilo cycle :-)
18:56:20 <SumitNaiksatam> s3wong: now you are really rubbing it in!
18:56:31 <s3wong> SumitNaiksatam: :-)
18:56:47 <glebo> s3wong:  at least now we know which core's reviews really matter
18:56:53 <SumitNaiksatam> s3wong: yeah sad but (absolutely) true
18:57:00 <badveli> thanks s3wong
18:57:03 <glebo> s3wong: that's a step in the right direction, or bright side
18:57:10 <SumitNaiksatam> s3wong: btw, welcome to fwaas!
18:57:34 <s3wong> glebo: well, you still need the 2 +2's , but you need an extra step to get the +A in case the two cores that gave you +2's aren't one of the five
18:57:39 * glebo snaps for s3wong
18:58:04 <glebo> s3wong: ack. Exactly
18:58:13 <s3wong> SumitNaiksatam: just happened to be on #openstack-meeting-3; sorry for the interruption, please move on
18:58:17 <glebo> s3wong:  but at least now we KNOW that
18:58:24 <SumitNaiksatam> ok Kilo design summit discussion
18:58:28 <glebo> s3wong:  Which, you know, is nice
18:58:55 <s3wong> glebo: :-)
18:59:05 <SumitNaiksatam> i provided link to the etherpad earlier #link https://etherpad.openstack.org/p/neutron-fwaas
18:59:06 <glebo> s3wong: actually, very helpful "interruption". Everyone needs to be clear on that process step
18:59:13 <SumitNaiksatam> please enter your input
18:59:45 <SumitNaiksatam> s3wong: right, you are welcome to stick around
18:59:47 * glebo scanning epad
19:00:22 <SridarK> SumitNaiksatam: the entries in the kilo epad have been preserved here
19:00:36 <glebo> brb
19:00:40 <s3wong> BTW, guys, in this morning's neutron-drivers meeting, a new "lighting talks" session is suggested and probably will replace the "retrospective" session
19:00:52 <SumitNaiksatam> so as we had discussed within the team earlier, the following seem to be community priorities for FWaaS:
19:00:53 <SridarK> i think that does reflect our priorities for kilo
19:01:08 <SumitNaiksatam> 1. Get FWaaS out of experimental status (address router insertion)
19:01:09 <SumitNaiksatam> 2. Support FWaaS for E-W scenario in DVR.
19:01:10 <SumitNaiksatam> 3. Service Groups (since this code is posted and in review)
19:01:11 <SumitNaiksatam> 4. Metering capabilities (Ceilometer dependency)
19:01:12 <SumitNaiksatam> 5. Flavors - we might need to support if this gets implemented
19:01:19 <s3wong> so don't be discouraged if your proposal didn't make the initial cut of design summit, you may still get to do a 5 minutes lighting talk
19:01:50 <SridarK> SumitNaiksatam: +1
19:02:17 <SumitNaiksatam> i would propose that we keep our focus on the above during the discussions
19:02:25 <SridarK> SumitNaiksatam: +1
19:02:56 <SumitNaiksatam> on point 1, i myself am not clear as to why FWaaS is qailified as “experimental”
19:03:30 <SumitNaiksatam> i was consulted on this point in the first release of fwaas, and my feedback was based on the insertion issue
19:03:56 <SridarK> SumitNaiksatam: i think this is probab only open issue
19:04:05 <SumitNaiksatam> SridarK: yeah
19:04:30 * glebo back
19:04:34 <SumitNaiksatam> are there any disagreements within the team on the above priorities?
19:05:16 <SumitNaiksatam> the above obviously does not include vendor specific stuff
19:05:22 <SridarK> SumitNaiksatam: agree, i guess we also have to see how this "services coming out of neutron" story plays out
19:05:27 <SumitNaiksatam> the above also in the context of Kilo
19:05:33 <SumitNaiksatam> SridarK: agreed
19:05:35 <SridarK> and how that impacts our list
19:06:08 <glebo> on the above priorites,
19:06:24 <glebo> I think we will gain a lot of cred in the community at large if
19:06:31 <SumitNaiksatam> the key to any “coming out” discussion is who are the cores
19:06:42 <glebo> we are shown to be talking about pulling out vendor plugins from main
19:07:06 <glebo> and creating an interface for them to easily be loaded as plugg-able modules
19:07:21 <SumitNaiksatam> glebo: as i mentioned before pulling out vendor plugins is not a discussion just in the context of FWaaS
19:07:30 <glebo> as I've mentioned before, it's a huge sticking point for several of the TC,
19:07:37 <glebo> SumitNaiksatam:  understood
19:07:38 <glebo> but
19:07:52 <SumitNaiksatam> glebo: this has been on the table for a long time, and i believe it will happen in Kilo
19:07:53 <glebo> each service element will need to address it for themselves,
19:08:07 <glebo> so, if we show we are doing our part, it will earn us some cred
19:08:26 <glebo> SumitNaiksatam: exactly why we need to have it on our list,
19:08:43 <glebo> so that we are being good citizens to the deeper architectural direction
19:08:50 <SumitNaiksatam> glebo: yeah, sure we can put it on the list, but we will just be following what the rest of neutron is doing
19:08:53 <glebo> SumitNaiksatam: make sense?
19:09:05 <glebo> SumitNaiksatam:  sure, and
19:09:16 <glebo> it indicates are are "cheefully complying" and
19:09:30 <glebo> if we can add some value there, the community will like that too, and
19:10:07 <glebo> we need to ensure that the hooks, plugs, interfaces, structures, etc. that we need in order to succeed in such an extraction are present
19:10:12 <SumitNaiksatam> glebo: yes we will definitely comply, i dont think we will have a choice, and we definitely prefer that option
19:10:43 <glebo> SumitNaiksatam: so, it becomes a pretty big work item for us in kilo,
19:10:48 <glebo> I'll add it to the epad
19:11:13 <SumitNaiksatam> glebo: “interfaces” for plugging into neutron is not a FWaaS-specific topic
19:11:29 <SumitNaiksatam> glebo: that becomes a general services’ discussion
19:11:43 <glebo> SumitNaiksatam:  agreed, and
19:11:48 <SumitNaiksatam> glebo: feel free to add to the etherpad, since it reinforces the discussion
19:11:51 <glebo> FWaaS has it's side of it
19:12:15 <glebo> it's our part of the service insertion model, our domain-specific elements
19:12:26 <SumitNaiksatam> glebo: but i wanted to make sure that we dont get lost in that disucssion and hence stall on the features for FWaaS that are sort of independent of that aspect
19:13:20 <SumitNaiksatam> by “that” i mean the “service insertion” related conversation
19:13:30 <glebo> SumitNaiksatam:  not to be sarcastic, but to then go ahead and be sarcastic… those features aren't really "getting in" right now anyway
19:13:31 <SumitNaiksatam> since this has happened in the past two cycles
19:14:07 <glebo> SumitNaiksatam: job 1: unstick the system, whatever it takes. Job 2: make FWaaS feature rich
19:14:23 <glebo> SumitNaiksatam: doing 1 w/o 2 is wheel spinning, no?
19:14:56 <SumitNaiksatam> also, in the past we have tried justify the value/need of the service insertion framework using FWaaS as an exmaple/case study
19:15:40 <SumitNaiksatam> however the net result of that was that we could neither get the service framework in, and we couldn’t solve the problem for fwaas either (and thus continue to be branded experimental)
19:16:12 <SumitNaiksatam> glebo: so most of what you are saying is deja vu to me ;-) (and not trying to be sarcy there)
19:16:40 <glebo> SumitNaiksatam: totally empathetic
19:16:41 <SumitNaiksatam> okay so the meta point was, please put your comments on the etherpad :-)
19:16:55 <glebo> SumitNaiksatam: right. Will do
19:17:01 <glebo> ;-)
19:17:04 <SumitNaiksatam> glebo: ;-) but could be :-( just as well!
19:17:22 <glebo> (some of my points are already there, prepended with [glebo])
19:17:28 <SumitNaiksatam> glebo: nice
19:17:48 <SumitNaiksatam> so what the above list means is that we miss out very critical features like zones and address groups
19:18:32 <SumitNaiksatam> and logging and hit counts
19:19:12 <SumitNaiksatam> the fact that none of features were allowed to go through in the last two cycles has created a huge backlog of items
19:19:40 <SumitNaiksatam> and that will take a long time to clear up in the current process/system  (if at all)
19:19:58 <glebo> (hit counts is a very cool feature. We have them in our product, and customers LOVE them)
19:20:12 <SumitNaiksatam> glebo: absolutely agree
19:20:29 <SumitNaiksatam> glebo: its critical for firewalls
19:20:43 <SumitNaiksatam> so any way the point i wanted to make is that we havent lost track of these features
19:21:16 <SumitNaiksatam> but we will unlikely have time for them with the current constraints
19:21:38 <SumitNaiksatam> since we are veering more into open discussion territory
19:21:43 <SumitNaiksatam> #topic Open Discussion
19:21:53 <glebo> SumitNaiksatam:  re: backlog, that's sort of ok, for the short term, because we aren't trying to build an open source FW here, just trying to define policy blobs. In reality, all the products can define their own policy blobs in their config / mgmt systems, so there is a work around in the short run, for operators, automatable through vendor API
19:22:41 <SumitNaiksatam> glebo: people prefer a single pane of glass
19:23:28 <glebo> SumitNaiksatam: any update from the service teams strategy session last week. As you know I left early. Saw the write up. Commented. But not sure if any response came back after that. ?
19:23:40 <SumitNaiksatam> glebo: i responded to your emails
19:23:54 <SumitNaiksatam> glebo: i did not notice your emails until yesterday
19:23:55 <glebo> SumitNaiksatam:  ok, must have missed it
19:24:02 <glebo> SumitNaiksatam:  will check
19:24:18 <SumitNaiksatam> glebo: for some reason the thread got buried and popped only because of s3wong’s email yesterday
19:24:24 <glebo> SumitNaiksatam:  re: 1 glass: for sure. Wouldn't be here otherwise.
19:24:30 <SumitNaiksatam> glebo: :-)
19:24:53 <SumitNaiksatam> ok if nothing else to discuss we can get 5 mins of our time back
19:25:20 <SridarK> SumitNaiksatam: perhaps we can all start thinking about the priority list
19:25:32 <SumitNaiksatam> SridarK: sure
19:25:53 <SridarK> SumitNaiksatam: so in terms of spec etc we can get some early discussion at the summit
19:26:09 <SumitNaiksatam> i would also propose that we popularize this etherpad and make sure that we get a good critical mass of folks for the F2F discussions in the summit
19:27:21 <SumitNaiksatam> ok thanks folks for attending today
19:27:26 <SumitNaiksatam> bye!
19:27:27 <SridarK> bye all
19:27:41 <SumitNaiksatam> #endmeeting