18:32:51 <SumitNaiksatam> #startmeeting Networking FWaaS
18:32:52 <openstack> Meeting started Wed Nov 19 18:32:51 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:32:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:32:57 <openstack> The meeting name has been set to 'networking_fwaas'
18:34:13 <SumitNaiksatam> #announce SPD: Monday 12-8-2014 SAD: Monday 12-15-2014
18:34:24 <SumitNaiksatam> pc_m: vishwanathj: hi
18:34:35 <vishwanathj> vi
18:34:38 <vishwanathj> hi
18:35:21 <SumitNaiksatam> hope the SPD and SAD dates are not too intimidating ;-)
18:35:34 <SridarK> SumitNaiksatam: SPD, SAD are fast upon us
18:35:46 <SridarK> did not realize the timeline earlier either
18:36:09 <SumitNaiksatam> yes, so lets focus on what we want to get in by that, we will pick that up in just a bit
18:36:46 <SumitNaiksatam> #topic Bugs
18:36:49 <badveli> december 15th
18:36:53 <SumitNaiksatam> glebo: hi
18:36:56 <SumitNaiksatam> #undo
18:36:57 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x1fe1950>
18:37:20 <SumitNaiksatam> okay since we have some more critical mass here
18:37:36 * glebo is here, but tied up on another call, so not really paying much attention. If needed, ping me unicast, and I'll pay attention to group
18:37:44 <badveli> just wanted to clarify if the spec approval is by december 15tt
18:37:46 <SumitNaiksatam> i wanted bring up the question that we had discussed in the adv services’ meeting as well yesterday
18:38:05 <SumitNaiksatam> do we need this sub-team and this meeting?
18:38:10 <SridarK> badveli: yes
18:38:28 <badveli> thanks sridar
18:38:43 * pc_m hi. I'm multitasking meetings.
18:38:57 <SumitNaiksatam> badveli: ?
18:39:17 <badveli> sumit, i was confirming the spec approval date
18:39:23 <SridarK> SumitNaiksatam: my vote is that it helps us discuss details as we get more into the specs and code especially
18:39:38 <SridarK> SumitNaiksatam: i don't think we can discuss this in the neutron mtg
18:39:51 <SumitNaiksatam> SridarK: okay, what do other folks present here think? glebo vishwanathj badveli pc_m?
18:40:12 <badveli> previously when we wanted to discuss
18:40:20 <glebo> i think we need this meeting because we are still really FAR behind the feature set required to be genuinely useful to operators, and once we get split done, we need to run like bats of out hell getting caught up, and the rest of the community doesn't need to be a part of that
18:40:23 <badveli> in late juno cycle
18:40:32 * glebo goes back to other mtg
18:40:41 <pc_m> SumitNaiksatam: I'm just monitoring to keep a pulse on FWaaS (and make sure you're keeping things in line :)
18:40:48 <badveli> we used to join the meeting when we want
18:40:48 <SridarK> glebo:  +1
18:40:49 <SumitNaiksatam> pc_m: :-)
18:41:05 <pc_m> SumitNaiksatam: Not sure if need this meeting or can include in Adv Svcs meeting as a topic.
18:41:06 <SridarK> pc_m: with his baseball bat :-)
18:41:08 <badveli> my question is when we need info can we
18:41:15 <badveli> join the meeting
18:41:31 <badveli> ?
18:41:40 <badveli> i am fine wither way
18:41:45 <badveli> either way
18:41:55 <SumitNaiksatam> pc_m: its proposed that this will be a standing item on the adv services meeting
18:42:26 <SumitNaiksatam> pc_m: however our past experience is that we have used up the one hour of the FWaaS meetings prety regularly
18:42:41 <SumitNaiksatam> pc_m: and i am sure LBaaS tends to use theirs as well (in their meeting)
18:43:11 <SumitNaiksatam> pc_m: so i would tend to think that the adv services’ meeting would be more of an update from each of the services’ teams to the rest of the group
18:43:16 <pc_m> SumitNaiksatam: That may make for the argument to keep it sep.
18:43:32 <SumitNaiksatam> pc_m: rather than deeper technical discussions (which we tend to have here)
18:43:34 <SumitNaiksatam> pc_m: yeah
18:43:48 <pc_m> SumitNaiksatam: makes sense
18:43:50 <SridarK> SumitNaiksatam: i feel that this is a time that is blocked in our calendars  and an opportunity for a quick sync up to discuss issues on hand
18:43:56 * pc_m putting bat back in drawer
18:44:02 <SumitNaiksatam> SridarK: okay
18:44:03 <SridarK> SumitNaiksatam: else we may land up doing this adhoc
18:44:05 * pc_m :)
18:44:09 <vishwanathj> SridarK +1
18:44:17 <SridarK> pc_m: Whew!  :-)
18:44:20 <SumitNaiksatam> vishwanathj: okay
18:44:25 <SumitNaiksatam> pc_m: :-)
18:44:49 <SumitNaiksatam> okay so it seems that this team wants to continue this collaboration as a sub-team, and continue the meetings as well
18:44:51 <badveli> sumit, having the item in the adv service meeting will also give an opportuniy in asking qurestions which we are not sure
18:45:19 <SumitNaiksatam> badveli: yes, i explained earlier what we will be doing in each of the meetings
18:45:35 <SumitNaiksatam> ok moving on
18:45:38 <SumitNaiksatam> #topic Bugs
18:46:36 <SumitNaiksatam> so we dont seem to have any new high priority bugs on reported
18:46:45 <SridarK> SumitNaiksatam: yes nothing new
18:46:49 <SumitNaiksatam> the highest priority one is this on the client side:
18:47:14 <SumitNaiksatam> #link https://bugs.launchpad.net/python-neutronclient/+bug/1318617
18:47:48 <SumitNaiksatam> the priority for this was bumped up, not sure why
18:48:32 <SumitNaiksatam> lets review the patch: #link https://review.openstack.org/#/c/104132/
18:48:52 <SumitNaiksatam> badveli: anything else on your bug triaging radar?
18:49:09 <badveli> nothing much i am checking the other one
18:49:31 <SumitNaiksatam> badveli: which other one?
18:49:32 <badveli> tear down existing session
18:49:42 <badveli> when there is an update
18:49:45 <SumitNaiksatam> badveli: ah okay
18:49:49 <SridarK> badveli: the iptables issue ?
18:49:52 <badveli> yes
18:50:00 <SumitNaiksatam> yeah we discussed last week
18:50:04 <SumitNaiksatam> badveli: can you post the link?
18:51:31 <badveli> https://bugs.launchpad.net/neutron/+bug/1386543
18:51:58 <SridarK> may be not much may need to be done on this
18:52:04 <badveli> yes
18:52:08 <SridarK> from the fw side
18:52:39 <SumitNaiksatam> ok good
18:52:52 <SumitNaiksatam> badveli: please keep tracking since its assigned to you
18:52:59 <SumitNaiksatam> #topic Docs
18:53:23 <SumitNaiksatam> SridarK: and I had an AI last week to follow up on the FWaaS/DVR documentation
18:53:28 <SridarK> SumitNaiksatam: yes
18:53:32 <SumitNaiksatam> just heard back from swami
18:53:50 <SridarK> yes we looks like it is WIP
18:53:53 <SumitNaiksatam> SridarK: from what i understood, he will be making the doc changes?
18:54:01 <SridarK> I will be in sync with Swami
18:54:36 <SridarK> I could provide a description of the fw side of the world
18:54:45 <SumitNaiksatam> SridarK: ok cool, perhaps we can pass the link to the rest of the team as well (should help to get more eyes on the review)
18:54:46 <SridarK> anyways will sync with Swami
18:55:01 <SridarK> ok will do when i get it
18:55:05 <SumitNaiksatam> SridarK: thanks
18:55:24 <SumitNaiksatam> SridarK: any other docs activity showing up your radar?
18:55:37 <SridarK> the other is one is:
18:55:42 <SridarK> #link https://bugs.launchpad.net/openstack-manuals/+bug/1346986
18:56:05 <SridarK> this seems to be an update on a section for the Security Guide
18:56:27 <SridarK> and it is quite dated - so am confused by what is actually reqd
18:56:38 <SridarK> as the general docs cover FWaaS
18:57:06 <SridarK> I should reach out to the submitter for some clarification - should have done that earlier - apologies
18:57:07 <SumitNaiksatam> yeah this is the one which rudrajit was assigned to
18:57:11 <SridarK> will take care of this
18:57:16 <SumitNaiksatam> seems to be sitting there for a long time
18:57:21 <SridarK> if it is not relevant we can close it
18:57:23 <SumitNaiksatam> not sure if its even relevant any more
18:57:28 <SumitNaiksatam> yeah exactly
18:57:35 <SridarK> yes and it involves a lot of other things not just fwaas
18:57:45 <SumitNaiksatam> there are a bunch of doc bugs mentioned in the neutron meeting:
18:57:52 <SumitNaiksatam> #link https://wiki.openstack.org/wiki/Network/Meetings
18:58:44 <SumitNaiksatam> we need to scrub this list to see if there is anything that we need to contribute to
18:59:11 <SumitNaiksatam> #link https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=neutron
18:59:11 <SridarK> SumitNaiksatam: i will do this and reach out to Edgar if more clarification is needed
18:59:19 <SumitNaiksatam> SridarK: great, thanks@
18:59:47 <SumitNaiksatam> its interesting there are references to quantum in that list ;-)
18:59:53 <SridarK> :-)
19:00:18 <SridarK> i would like to see positron or quark or whatever in the next cycle :-)
19:00:40 <SumitNaiksatam> i think we need to pay attention to this: #lik https://bugs.launchpad.net/openstack-manuals/+bug/1373674
19:00:44 <SumitNaiksatam> #link https://bugs.launchpad.net/openstack-manuals/+bug/1373674
19:01:22 <SumitNaiksatam> perhaps follow up with anne gentle on this
19:01:31 <SumitNaiksatam> SridarK: you want to take that AI?
19:01:42 <SridarK> SumitNaiksatam: yes pls
19:02:05 <SumitNaiksatam> #action SridarK to follow up with ann gentle on #link https://bugs.launchpad.net/openstack-manuals/+bug/1373674
19:02:33 <SumitNaiksatam> SridarK: please cc me (and anyone else interested) as well, so that we can jump in if required
19:02:40 <SridarK> SumitNaiksatam: will do
19:03:05 <SumitNaiksatam> SridarK: thanks
19:03:07 <SumitNaiksatam> moving on
19:03:10 <badveli> yes
19:03:14 <SumitNaiksatam> #topic Kilo Blueprints
19:03:45 <SumitNaiksatam> badveli’s security objects and groups:
19:03:52 <badveli> yes sumit
19:04:29 <SridarK> badveli: thanks for addressing my review comments
19:04:35 <SumitNaiksatam> #link https://review.openstack.org/#/c/131596/
19:04:38 <badveli> thanks sridar, for review
19:04:58 <badveli> i think sumit wants to rephrase some of them
19:05:06 <SridarK> badveli: i think once u have addressed the latest round from SumitNaiksatam - i think i am good
19:05:12 <SumitNaiksatam> i added some review comments
19:05:23 <SumitNaiksatam> badveli: thanks
19:05:27 <badveli> yes i am in the process, but one thing in the work items
19:05:41 <badveli> how can we explain more
19:06:00 <SumitNaiksatam> i had mentioned this process, we need to tighten up the content otherwise it creates unnecessary misunderstanding
19:06:10 <badveli> my problem is if i do not put them after *
19:06:15 <SumitNaiksatam> and we should not have to waste cycles on grammar and typos
19:06:30 <SumitNaiksatam> this should be run through spell checkers upfront
19:07:02 <SumitNaiksatam> having reviewers tell you to correct grammar, and then having to spend the back and forth cycles on doing it, is just a big waste of time
19:07:05 <badveli> do we have some kind of tool
19:07:27 <SumitNaiksatam> badveli: be creative :-)
19:07:30 <badveli> i am just editing in the vi,
19:07:53 <SumitNaiksatam> easy to copy paste in a word-like editor :-)
19:08:20 <SumitNaiksatam> okay, any other objections or blockers on the techincal front with respect to this blueprint?
19:08:31 <SumitNaiksatam> or any suggestions for badveli?
19:08:47 <SridarK> SumitNaiksatam: none from me - i think the model resembles Sec Grps
19:09:12 <SumitNaiksatam> SridarK: okay
19:09:16 <SridarK> SumitNaiksatam: badveli confirmed this in terms of object to group association
19:09:27 <badveli> thanks sridar
19:09:32 <SumitNaiksatam> SridarK: that we cannot resuse objects across groups?
19:09:38 <SridarK> SumitNaiksatam: yes
19:09:46 <SumitNaiksatam> okay
19:10:01 <SridarK> SumitNaiksatam: we can take a call on the approach
19:10:02 <SumitNaiksatam> the reuse is at the group level
19:10:23 <SridarK> SumitNaiksatam: yes
19:10:41 <badveli> yes
19:11:31 <SumitNaiksatam> so this is consistent with the FWaaS rule and policy association as well, right?
19:11:36 <SridarK> SumitNaiksatam: i think this is fine but this should not become a roadblock on Dec 14 - i think this kind of adopts the Sec grp way of doing things
19:11:56 <badveli> yes this is similar to sec grp way
19:11:57 <SumitNaiksatam> we cant reuse rules across firewall policies
19:12:06 <SumitNaiksatam> *firewall rules
19:12:23 <SridarK> SumitNaiksatam: yes so this is consistent
19:12:34 <badveli> yes
19:13:52 <SridarK> as long as we are clear there is no issue here
19:14:04 <SumitNaiksatam> so once badveli puts out the new rev, lets try to push forward
19:14:26 <SumitNaiksatam> glebo: did you get a response to the email you had sent regarding the service groups blueprint?
19:14:42 <SridarK> badveli: after ur next rev - i will go thru one other scan and i can +1
19:15:04 <glebo> SumitNaiksatam: I don't think so
19:15:10 * glebo double checking now
19:15:15 <badveli> thanks sridar, sumit
19:15:17 <SumitNaiksatam> glebo: okay, yeah just checking, since i did not see anything
19:18:02 <SumitNaiksatam> the next one we are tracking is the router-specific firewall insertion
19:18:08 <SumitNaiksatam> SridarK: any progress?
19:18:18 <SridarK> SumitNaiksatam: few options
19:18:28 <SridarK> Option 1: Revive Service Insertion - i am not sure about how this will fly.
19:18:44 <SridarK> Option 2: Insert FW on a specific Router. (what Mark wanted)
19:18:53 <SridarK> Option 3: Insert FW on neutron port(s) (we can validate to ensure that if it is a list they are all associated with a single router)
19:19:04 <SridarK> My personal opinion is that if we are not doing Option 1, Option 3 is reasonable - it can achieve the requirement from Mark and yet is more flexible.
19:19:29 <SridarK> the Spec deadlines got me boltibg
19:19:33 <SridarK> *bolting
19:19:34 <bobmel> I agree, why essentially waste effort on a something halfbacked as option 2
19:19:35 <SumitNaiksatam> SridarK: yeah i dont think we are doing option 1
19:19:55 <SridarK> i have started putting things down for a spec
19:20:03 <SumitNaiksatam> bobmel: i agree, though that comes with the risk of a -2
19:20:11 <SridarK> will get a first cut out by end of week
19:20:25 <SumitNaiksatam> and i am willing to vote in favor of that option if everyone in the team here feels likewise
19:20:26 <SridarK> bobmel: yes
19:20:39 <SumitNaiksatam> bobmel: btw, welcome to the fwaas meeting ;-)
19:21:04 <bobmel> SumitNaiksatam: Yes but it is a bit insane to -2 something that is more useful in practice
19:21:37 <SumitNaiksatam> bobmel: i will let history speak for itself! ;-)
19:21:45 <bobmel> SumitNaiksatam: Like pc_m I monitor every step... :-) Hope I can actively contribute going forward though.
19:21:45 <s3wong> SridarK: option 1 is already rejected by markmcclain --- during Friday's meeting in Paris, markmcclain talked about FW able to run on selected routers without a new service insertion framework
19:21:56 <SridarK> bobmel: yes agree i think we can find a reasonable ground
19:22:17 <SumitNaiksatam> ah s3wong, we have lots of people watching over our shoulders today! :-)
19:22:23 <SridarK> s3wong: yes i think we can work with option 3 that will satisfy the requirement
19:22:29 <SumitNaiksatam> and i thought we were lacking critical mass
19:23:08 <SridarK> hopefully no one came with weapons
19:23:10 <SridarK> :-)
19:23:15 <SumitNaiksatam> SridarK: lol
19:23:42 <SumitNaiksatam> SridarK: sorry to push, any ETA on posting the spec?
19:23:44 <SridarK> SumitNaiksatam: ok i will put things down in a spec
19:23:49 <s3wong> SridarK: keep in mind that markmcclain wants to have the ability to backport to stable branches, so a new framework would be out of question, too much to port
19:23:53 <SridarK> will try for end of week
19:24:31 <SridarK> s3wong: hmm we will need to add an extension
19:24:37 <s3wong> SumitNaiksatam: just got out of my day job meeting -- and was attracted by the term "service insertion" :-)
19:25:06 <SridarK> s3wong: u are a riot (meant as a compliment) :-)
19:25:17 <SumitNaiksatam> SridarK: not sure why an extension is required
19:25:27 <SumitNaiksatam> SridarK: but lets take it offline
19:25:37 <SridarK> SumitNaiksatam: u are saying add it as an attribute to the resource
19:25:50 <SridarK> SumitNaiksatam: yes we can discuss more
19:25:59 <SumitNaiksatam> SridarK: i am also curious as to what the default would be with ports
19:26:21 <SumitNaiksatam> SridarK: i am sure you have given this thought, so lets see it in the spec
19:26:37 <SumitNaiksatam> SridarK: as far as the spec is concerned, you can keep it simple and cut to the chase
19:26:44 <SumitNaiksatam> SridarK: easier to read that way :-)
19:26:46 <SridarK> SumitNaiksatam: more thought is needed here - will ping u offline
19:26:49 <badveli> please let me know also when you are discussing this
19:26:50 <SridarK> SumitNaiksatam: yes will do
19:26:59 <SumitNaiksatam> SridarK: extra details can be added per request
19:27:02 * glebo just resent that email to mestery & markmcclain trying to nail down required reviewers for Service Object & Groups spec
19:27:10 <SridarK> badveli: sure
19:27:16 <SridarK> SumitNaiksatam: ok sounds good
19:27:22 <SumitNaiksatam> anything else to discuss on this topic?
19:27:30 <SridarK> SumitNaiksatam: nothing from me
19:27:44 <SumitNaiksatam> #topic Open Discussion
19:27:51 <SumitNaiksatam> anything more to cover for today?
19:27:57 <SridarK> SumitNaiksatam: we wil also be pushing a vendor bp
19:28:03 <SumitNaiksatam> SridarK: sure
19:28:19 <SridarK> it is out already ( i have resubmitted from Juno)
19:28:20 <SumitNaiksatam> anyone else planning to push a vendor bp, so that we can track it?
19:28:27 <SumitNaiksatam> fwass-related that is
19:28:28 <SridarK> vishwanathj: ?
19:28:32 <vishwanathj> Brocade will soon
19:28:51 <SridarK> vishwanathj: if u have intent for Kilo u should do that soon
19:29:06 <vishwanathj> SridarK, understood
19:29:18 <pc_m> FYI: I'm starting on some L3 agent refactoring. Starting with extracting out device driver logic. Please look at https://review.openstack.org/#/c/135392/ if you get a chance.
19:29:35 <SridarK> vishwanathj: karhik will need to get his router stuff out too
19:29:39 <SumitNaiksatam> vishwanathj: yeah, you might have missed earlier, SPD: Monday 12-8-2014 SAD: Monday 12-15-2014
19:29:40 <pc_m> Teasing out FW, VPN, LB device driver loading.
19:29:42 <SridarK> *karthik
19:29:55 <vishwanathj> SridarK, I think Karthik already did that for the router last week
19:30:00 <SridarK> ok
19:30:02 <SumitNaiksatam> pc_m: sweet, great that you could get started on this
19:30:31 <pc_m> would love and FW centric feedback on what's happening there.
19:30:43 <SumitNaiksatam> pc_m: is such situations it will help proactively add us reviewers so that it readily shows up on our radars
19:30:46 <vishwanathj> SumitNaiksatam: What is SPD and what is SAD
19:30:47 <pc_m> (and LB too)
19:31:01 <SumitNaiksatam> vishwanathj: spec proposal deadline, spec approval deadline
19:31:06 <SridarK> pc_m: u have my feedback
19:31:08 <vishwanathj> Thanks
19:31:15 <pc_m> SridarK: Thanks!
19:31:23 <SumitNaiksatam> vishwanathj: propose the spec latest by the first deadline and get it approved by the second
19:31:32 <SumitNaiksatam> ok thanks all
19:31:33 <SumitNaiksatam> we are minute over
19:31:37 <SridarK> bye
19:31:37 <SumitNaiksatam> thanks for joining
19:31:38 <vishwanathj> Ok
19:31:39 <SumitNaiksatam> bye!
19:31:41 <vishwanathj> bye
19:31:43 <SridarK> vishwanathj: ping me offline
19:31:44 <SumitNaiksatam> #endmeeting