00:01:12 <SridarK> #startmeeting Networking FWaaS
00:01:13 <openstack> Meeting started Thu May 12 00:01:12 2016 UTC and is due to finish in 60 minutes.  The chair is SridarK. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:01:17 <openstack> The meeting name has been set to 'networking_fwaas'
00:01:20 <SridarK> #chair xgerman
00:01:21 <openstack> Current chairs: SridarK xgerman
00:01:27 <xgerman> o/
00:01:58 <SridarK> thx all for joining and lets get started.
00:02:03 <SridarK> #topic FWaaS current state
00:02:19 <SridarK> Some updates from the last few days
00:02:58 <SridarK> With the merge of #link https://review.openstack.org/#/c/223343/ in neutron - FWaaS is broken. What initially seemed like something that could be fixed within the scope of FWaaS - does not seem so.
00:03:14 <njohnsto_> sadly
00:03:51 <SridarK> njohnsto_: , mfranc213 , padkrish and i have been triaging this to get an understanding of what is needed
00:04:21 <SridarK> Essentially the FWaaS Agent which resided in L3Agent - now is out. There were plans to have the ability for L3Agent to load Service Agents in a clean manner and some work is needed on this.
00:04:48 <SridarK> We have raised this with the L3 team and thanks Nate for capturing the issue in:
00:05:02 <SridarK> #link https://bugs.launchpad.net/neutron/+bug/1580239
00:05:04 <openstack> Launchpad bug 1580239 in neutron "[RFE] Add agent extension framework for L3 agent" [Wishlist,New]
00:05:36 <SridarK> We hope to have a discussion in the L3 team meeting tomorrow
00:05:49 <SridarK> njohnsto_: thx again for getting this filed
00:06:09 <xgerman> +1
00:06:09 <njohnsto_> I have started on a draft spec (unpublished) but I don't feel like enough of the details are known to intelligently describe a proposed solution.
00:06:55 <SridarK> njohnsto_: that is fair - hopefully some discussion with the L3 folks will help get the details flushed out
00:07:16 <njohnsto_> SridarK: that is my hope
00:08:57 <SridarK> Unfortunately, until we have some resolution - we really cannot have anything merge in FWaaS
00:09:14 <xgerman> :-(
00:09:23 <njohnsto_> Completely stuck.
00:09:51 <SridarK> and we dont see some easy way to solve this in FWaaS
00:10:32 <njohnsto_> For my part, I have the L3 extension as top priority, but if that is blocked I will work on doing any fleshing out of the DB model.
00:10:47 <SridarK> njohnsto_: +1
00:11:36 <SridarK> that is kind of where things stand - we hope to get some resolution and a way fwd soon
00:12:06 <SridarK> any other thoughts or suggestions ?
00:12:27 <s3wong> SridarK: oh well... nothing much else we can actually do
00:12:36 <SridarK> s3wong: yes
00:13:42 <njohnsto_> Does this mean we will be in a separate process like Octavia or code loaded into L3 like QoS is in L2?
00:13:42 <SridarK> njohnsto_: i will join u in the L3 mtg and will certainly help in any way possible
00:14:03 <njohnsto_> SridarK: very much appreciated
00:14:20 <SridarK> njohnsto_: if we are a separate process then we may need the appropriate hooks
00:14:43 <SridarK> clearly the inheritance model that was present was not desirable
00:14:59 <njohnsto_> indeed
00:15:04 <xgerman> njohnsto_ I assume we will be a plugin. dougwig has said that this should work for projects not in the neutron repo
00:15:19 <njohnsto_> I can see why they wanted to get that inheritance model deleted
00:15:25 <SridarK> but either an option to load service agents or something else along those lines should be the model
00:15:55 <s3wong> njo
00:16:06 <SridarK> xgerman: +1 that will enable other projects to let their agents reside in the context of L3Agent
00:16:28 <s3wong> njohnsto_: I agreed. Sucks for us, but I do think it is cleaner on l3agent perspective
00:17:01 <SridarK> the inheritance model existed as there was no other option
00:17:26 <SridarK> and oddly fwaas and vpnaas went in slightly different directions too
00:17:42 <SridarK> definitely a cleaner model is needed
00:17:46 <njohnsto_> After the L3 meeting we can confer with the LBaaS team and the VPNaaS team (if there is such a thing) to get their buy-in/help.
00:18:10 <xgerman> yeah, LBaaS doesn’t use L3
00:18:13 <SridarK> njohnsto_: if i am not mistaken LBaaS has no such dependency
00:18:18 <xgerman> they do everything over the API
00:18:23 <SridarK> xgerman: +1
00:18:41 <njohnsto_> OK
00:18:57 <SridarK> Lets hope for a good discussion tomorrow
00:19:39 <SridarK> I am not sure if reverting the patch will even be considered
00:19:54 <mickeys> It won't be considered
00:19:59 <s3wong> I doubt it
00:19:59 <njohnsto_> I agree, I think we are past the point of no return
00:20:10 <SridarK> so if there is a quick solution that will get us going that is our only hope
00:20:21 <SridarK> i feel so too
00:21:05 <njohnsto_> At least we can demonstrate momentum, commitment, and contribution to the greater Neutron community.
00:21:13 <SridarK> njohnsto_: +1
00:21:19 <xgerman> +1
00:21:24 <SridarK> and this is an enabler
00:21:35 <SridarK> for such service models
00:22:17 <njohnsto_> Yes
00:22:30 <SridarK> Ok lets quickly hit other topics
00:22:39 <SridarK> #topic FWaaS v2
00:23:49 <SridarK> so while this issue gets sorted - we can try to get some momentum on our patchsets - we may need to get creative on how we test things out
00:24:01 <mickeys> L2!
00:24:19 <SridarK> at least with the EXT - Db - Plugin can move fwd
00:24:28 <SridarK> and mickeys: yes L2 for sure
00:24:29 <s3wong> SridarK: wouldn't our CI reject all the patches (or we don't have func-test)?
00:24:39 <SridarK> s3wong: yes that is the problem
00:24:59 <SridarK> we can keep working them
00:25:32 <SridarK> in an ideal situation - if the situation with L3 gets resoloved - we will atleast have some work done to get merges to happen
00:25:49 <SridarK> at a later point
00:25:56 <njohnsto_> We can also prep a patch to fix all the neutron_lib deprecation notices
00:26:08 <SridarK> njohnsto_: true
00:26:26 <SridarK> but i think we need to have some basic functionality w.r.t v2 done as well
00:27:35 <njohnsto_> yes
00:29:46 <njohnsto_> So since we know we will not be inheriting from L3NATAgent can we set up a new ancestor stub to inherit from, and unwed get unit tests?
00:30:05 <njohnsto_> s/unwed/unwedge/
00:31:02 <xgerman> makes sense
00:31:59 <SridarK> njohnsto_: for UT yes we could do some thing not sure on functional tests - i have not looked at that recently - i know madhu_ak and others were moving things there
00:32:31 <SridarK> so we may still have an issue on merge, but njohnsto_: good thought
00:32:50 <xgerman> madhu_ak is likely off the project
00:33:03 <SridarK> xgerman: ok
00:33:50 <SridarK> mickeys: u were talking abt a patch needed in neutron to clean up things around iptables for multiple features
00:34:00 <mickeys> Yes. I have not started that yet.
00:34:09 <SridarK> mickeys: ok
00:34:57 <mickeys> I think if you run with security groups disabled you could do something without it. Otherwise the change will be needed
00:35:57 <xgerman> that might be a good way to start
00:36:19 <SridarK> mickeys: ok and we should be targetting this anyways for the v2 effort
00:36:24 <njohnsto_> So did madhu_ak have changes that were in-progress that someone needs to pick up?
00:37:11 <mickeys> SridarK: Yes it is necessary for the v2 effort
00:37:11 <SridarK> njohnsto_: he was cleaning up things around the functional tests - will need to double check
00:38:41 <SridarK> njohnsto_: i will reach out to him
00:39:07 <njohnsto_> SridarK: thanks
00:39:12 <SridarK> We can atleast get things lined up on areas that need attention
00:39:33 <SridarK> that will be goodness anyways
00:39:40 <SridarK> even if merging is an issue
00:39:48 <SridarK> now
00:39:50 <xgerman> SridarK let me know if you can’t get through to him - I have a more direct channel :-)
00:40:10 <SridarK> xgerman: ok thx will appreciate ur help
00:40:53 <SridarK> Anything else to discuss on v2  ?
00:41:32 <SridarK> For the new contributors feel free to reach out to folks for any help needed
00:42:00 <padkrish> SridarK: sure, will be reaching out to xgerman soon
00:42:17 <SridarK> padkrish: great
00:42:34 <chandanc> Sure will do
00:42:49 <SridarK> chandanc: ok
00:42:56 <SridarK> #topic Meeting time
00:43:25 <SridarK> I think we have had some inputs on the meeting time that is favorable to all
00:44:09 <SridarK> chandanc: Sarath: What would be the earliest time that would be reasonable to u guys
00:44:36 <SridarK> so we can make it easy on njohnsto_ and mfranc213 on the US Eastern
00:44:51 <SridarK> we can also continue the discussion on the email thread
00:44:54 <chandanc> 9:30 India is good time for me
00:45:10 <Sarath> yes
00:45:14 <chandanc> but is it Ok for other people too
00:45:40 <SridarK> That would be 11pm Eastern
00:46:06 <njohnsto_> 9:30am New Delhi time?  That is fine with me
00:46:19 <s3wong> SridarK: no problem with me
00:47:14 <njohnsto_> So am I right, that would be 0400 UTC?
00:47:16 <xgerman> +1
00:47:27 <xgerman> it say 9 pm pacific for me
00:48:08 <chandanc> njohnsto: yes
00:48:31 <njohnsto_> Excellent
00:48:34 <SridarK> ok we can close out on the email and we can update
00:48:58 <SridarK> #topic Open Discussion
00:49:01 <chandanc> Thanks everyone
00:49:31 <yushiro> chandanc, NP
00:49:40 <njohnsto_> I can be backup meeting chair for SridarK, to provide a second so you don't have to xgerman
00:49:58 <xgerman> thanks, appreciated
00:50:07 <SridarK> njohnsto_: sounds good thx
00:50:19 <chandanc> njohnsto_: Can you send us your draft spec ? or may be after the meeting with L3 team
00:51:07 <njohnsto_> After the L3 meeting, I will get it into a better form and send it.
00:51:18 <chandanc> sure
00:51:38 <njohnsto_> And then we can hopefully get more feedback in the neutron-drivers meeting.
00:52:05 <SridarK> njohnsto_: +1
00:52:14 <njohnsto_> #action njohnston to send spec after L3 meeting
00:52:39 <yushiro> padkrish, hi. I'd like to share about current status for FWaaS v2 l2-agent.
00:52:58 <padkrish> yushiro# sure
00:54:04 <yushiro> padkrish, OK, thanks.  I've just come back from holidays.  I'll send e-mail to you.
00:54:25 <padkrish> yushiro# sure, pls do..will sync up
00:54:43 <SridarK> padkrish: yushiro: thx
00:55:02 <SridarK> Anything else anyone would like to bring up ?
00:55:45 <njohnsto_> I am good
00:55:50 <xgerman> +1
00:56:12 <s3wong> all good
00:56:17 <SridarK> ok then folks have a good rest of the week. Thx for joining
00:56:17 <chandanc> +1
00:56:25 <Sarath> Thanks
00:56:30 <s3wong> Thanks
00:56:31 <SridarK> #endmeeting