16:00:52 <emagana> #startmeeting networking-guide
16:00:53 <openstack> Meeting started Thu Jan 14 16:00:52 2016 UTC and is due to finish in 60 minutes.  The chair is emagana. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:56 <openstack> The meeting name has been set to 'networking_guide'
16:01:11 <emagana> I am sure Sam-I-Am is around!
16:01:23 <Sam-I-Am> howdy
16:01:37 <Sam-I-Am> emagana: whats up with the calendar confusion?
16:01:41 <emagana> it is just you and me
16:01:56 <navinrio> Hi
16:01:59 <emagana> Am I wrong?
16:02:05 <emagana> hi navinrio
16:02:11 <lwilliams> o/
16:02:13 <Sam-I-Am> emagana: did you see the post on the -dev list?
16:02:25 <emagana> Sam-I-Am: I though we were fine
16:03:13 <Sam-I-Am> emagana: dunno, i reloaded the ical and the meeting is next week, but i dont think it hurts to talk now anyway since we're here
16:03:19 <Sam-I-Am> and the networking guide needs work, as usual
16:03:37 <emagana> indeed!
16:03:56 <emagana> action# review the calendar and make ajustment based on the ical
16:04:17 <Sam-I-Am> i dont see you around much these days
16:04:35 <emagana> let's make this one focus on the guide assignments
16:05:06 <navinrio> I am thinking to work on Legacy to DVR - TBD ( H )
16:05:11 <navinrio> Is it ok with team
16:05:19 <emagana> we were hoping to get more people self-assignments from the etherpad #link https://etherpad.openstack.org/p/networking-guide
16:05:22 <Sam-I-Am> navinrio: sure, if you're up for that task
16:05:23 <navinrio> what is the timeline and
16:05:29 <Sam-I-Am> navinrio: asap :)
16:05:44 <Sam-I-Am> navinrio: or... 2 releases ago?
16:05:47 <emagana> navinrio: thanks, yes we need to add content asap
16:06:14 <Sam-I-Am> migration to dvr rather than reinstalling increases adoption of dvr
16:06:23 <Sam-I-Am> people don't want to greenfield if they can avoid it
16:06:27 <emagana> navinrio: I just added your name to the etherpad
16:06:54 <emagana> I am taking Debugging
16:07:10 <emagana> Sam-I-Am: you have already configuration.
16:07:18 <Sam-I-Am> emagana: yeah, and i need to update the scenarios
16:07:24 <emagana> with that we will have covered some of the ( H ) areas
16:07:27 <Sam-I-Am> the prep/cleanup patch merged which is nice
16:07:36 <navinrio> You you want me to do testing
16:07:44 <emagana> Sam-I-Am: where we are on the versioning?
16:07:46 <navinrio> of legacy DVR
16:07:48 <Sam-I-Am> emagana: done
16:07:57 <navinrio> stuff next gen DVR fixed
16:08:07 <Sam-I-Am> navinrio: yeah, any procedures/instructions need to be validated
16:08:34 <Sam-I-Am> emagana: if you want to patch liberty now (which we have to do for the scenarios), you hit master then backport
16:08:40 <emagana> For some reason i saw the sc68cal patch for versioning abandoned
16:08:51 <Sam-I-Am> emagana: it was an errant backport
16:08:57 <emagana> Sam-I-Am: my bad!
16:08:58 <sc68cal> ^this
16:09:03 <emagana> sc68cal: hi there!
16:09:05 <Sam-I-Am> which turned out to be a front-port because it came before when we cut stable/liberty
16:09:23 <Sam-I-Am> so instead we just backported about a dozen patches to the already-cut stable/liberty
16:09:48 <Sam-I-Am> so we're good to go now... and the web site is rendering properly
16:10:00 <Sam-I-Am> only issue is that the juno net guide points to kilo, but nothing we can (or should) do about that
16:10:01 <navinrio> Ok Thanks for adding my name to Legacy to DVR - TBD ( H )
16:10:15 <Sam-I-Am> unless you want to backport things to a dead release
16:10:24 <emagana> Sam-I-Am: excelent!  OK, time to look for the future  ;-)
16:11:24 <emagana> Other important section is VPNaaS
16:11:39 <Sam-I-Am> yeah
16:11:42 <Sam-I-Am> well, all the *aas
16:11:44 <emagana> I wil try to talk to Paul M. from Cisco
16:12:07 <emagana> Indeed!
16:12:19 <emagana> I will take LBaaS
16:12:19 <Sam-I-Am> it supposedly works multi-node now (mostly) so we need to test that... and then figure out how we document deployment
16:12:30 <Sam-I-Am> in other words, can we say "take scenario X, and do these things"
16:12:37 <Sam-I-Am> or do we need a completely new scenario
16:12:52 <emagana> I go for the first option
16:13:02 <emagana> creating more scenarios feels like we will repeat a lot of conenct
16:13:06 <emagana> content*
16:13:09 <Sam-I-Am> the question here is can vpnaas work between 2 routers in the same cloud, or does it require more than 1 cloud
16:13:20 <Sam-I-Am> if its between two routers, we can probably augment an existing scenario
16:13:43 <emagana> Sam-I-Am: I haven't not use it.. let's find out sone neutrinos to give us advice
16:14:01 <Sam-I-Am> the annoying thing about vpnaas is it replaces the l3 agent, so we'll have to replace the conventional l3 agent in the scenario we use
16:14:16 <Sam-I-Am> rather than building up from scratch assuming the operator wants to deploy vpnaas
16:14:24 <emagana> #action ask armax if vpnaas will work between 2 routers in the same cloud, or does it require more than 1 cloud
16:15:15 <Sam-I-Am> i can also find people to ask
16:16:01 <Sam-I-Am> its a simple question that lets us get started
16:16:04 <emagana> ok
16:17:06 <Sam-I-Am> lbaas and fwaas also need some use cases
16:17:12 <emagana> Sam-I-Am: you have this one merged: https://review.openstack.org/#/c/267245/
16:17:14 <Sam-I-Am> they're a little less involved, imo
16:17:23 <emagana> I was wondering if we still need a spec for Mitaka changes?
16:17:26 <Sam-I-Am> emagana: yes, cleaned up a lot of stuff. changed legacy to classic.
16:17:30 <Sam-I-Am> we do need a spec for mitaka changes
16:17:36 <Sam-I-Am> i wrote a BP yesterday
16:17:42 <Sam-I-Am> of course we're still doing liberty work :/
16:17:47 <Sam-I-Am> but a lot of it will apply to mitaka too
16:17:55 <Sam-I-Am> like separation of agent config into new files
16:18:07 <emagana> please, include the link for the BP
16:18:44 <emagana> Sam-I-Am: could you also include the work needed for mitaka in the etherpad to keep track of it
16:18:49 <Sam-I-Am> #link https://blueprints.launchpad.net/openstack-manuals/+spec/networkguide-mitaka
16:19:12 <Sam-I-Am> yeah, i'm going to write a spec for the basics... update scenarios, etc.
16:19:22 <emagana> #link https://blueprints.launchpad.net/openstack-manuals/+spec/networkguide-mitaka
16:19:28 <Sam-I-Am> i hope we can get more done, but there's just not a lot of contributions
16:19:33 <Sam-I-Am> i can only work 24 hours a dat
16:19:34 <Sam-I-Am> day
16:19:43 <emagana> Sam-I-Am: Thanks for the assignation of that BP  :-)
16:20:03 <emagana> So, the specs is needed then?
16:20:08 <emagana> I guess it is!
16:20:12 <Sam-I-Am> we need something to track updates for mitaka
16:20:17 <Sam-I-Am> however thats going to work
16:20:26 <emagana> ok..
16:20:34 <Sam-I-Am> ideally someday we'll have a lot of the static content done, and then our changes are like the install guide "whats changed in X?"
16:20:48 <Sam-I-Am> the install guide has a spec for each release
16:21:50 <emagana> sc68cal: anything that you want to cover?
16:22:18 <navinrio> For Legacy DVR what shall be Contents
16:22:22 <navinrio> is how to do
16:22:38 <navinrio> is it how to configure Legacy DVR and USed case
16:22:59 <emagana> navinrio: I would suggest to follow the same format that we have for the other legacy scenarios
16:23:10 <navinrio> some inputs from team what are they looking to see in that Topic
16:23:25 <navinrio> I mean to say Legacy DVR
16:23:30 <Sam-I-Am> navinrio: you deploy conventional multi-node OVS with at least 2 net nodes and 2 compute nodes... deploy conventional routers on it with some VMs... then convert the deployment to DVR.
16:23:39 <sc68cal> emagana: sorry no
16:23:43 <Sam-I-Am> navinrio: and you document how you did all of it
16:23:49 <navinrio> Got It
16:23:51 <navinrio> thank U
16:24:09 <navinrio> Thank U
16:24:14 <navinrio> Appreciated
16:24:19 <Sam-I-Am> navinrio: you can extend the classic-with-ovs scenario with more nodes
16:24:37 <Sam-I-Am> right now 3 nodes doesn't get you much with dvr
16:24:45 <Sam-I-Am> so you need several more to see if dvr even works
16:24:56 <navinrio> Ok
16:25:02 <Sam-I-Am> come to think of it, you can probably use the DVR scenario, just dont deploy DVR on it
16:25:03 <navinrio> when do u want to complete this
16:25:13 <Sam-I-Am> sooner the better
16:25:16 <navinrio> Ok
16:25:17 <navinrio> got it
16:25:19 <navinrio> thank U
16:25:23 <navinrio> will focus on it
16:25:30 <emagana> navinrio: Thanks!
16:25:42 <emagana> Please, include us in the review once you have initial pacthes.
16:26:03 <navinrio> Understood will do
16:26:15 <emagana> navinrio: even if the patch is not ready, we could start providing guidence before you have spent a lot of time is probably wrong direction
16:26:29 <navinrio> Ok
16:26:33 <navinrio> so shall send email
16:26:46 <navinrio> to you and touch base offline
16:27:00 <emagana> navinrio: as long as you include us in the gerrit review, you will get the emails
16:27:08 <navinrio> Ok
16:27:11 <navinrio> Got it
16:28:08 <emagana> we are having this meeting next week, in order to adjust to the calendar changes for the new year.
16:28:18 <emagana> Is there something else to discuss today?
16:28:30 <Sam-I-Am> emagana: is that the conclusion on the calendar problem?
16:28:34 <navinrio> I am fine and thank You for providing me inputs
16:28:36 <Sam-I-Am> all of my meetings were messed up the last 2 weeks
16:29:17 <emagana> Sam-I-Am: not sure what else we can do!
16:30:05 <Sam-I-Am> yep, just want to make sure i'm not crazy
16:30:11 <Sam-I-Am> well i am, just not crazy in that instance
16:30:17 <Sam-I-Am> you have to be crazy to openstack
16:30:58 <emagana> LOL
16:31:15 <emagana> Sam-I-Am: indeed.. take a break..
16:31:34 <Sam-I-Am> then things dont get done
16:31:44 <emagana> #action emagana will send a reminder for next week meeting
16:31:45 <Sam-I-Am> anyway, i think we're good here
16:31:53 <emagana> Sam-I-Am: we have a lot of work..
16:31:53 <Sam-I-Am> expect to see some liberty-mitaka scenario updates from me soon
16:32:00 <Sam-I-Am> emagana: i'm also working on ovn docs
16:32:18 <emagana> Sam-I-Am: Thanks.. you and sc68cal are the masters!
16:32:29 <emagana> ok.. take care!
16:32:30 <emagana> ciao all
16:32:34 <sc68cal> ya
16:32:39 <sc68cal> more Sam-I-Am then me
16:32:45 <sc68cal> *than
16:32:52 <navinrio> Thank You .. Bye everyone
16:32:53 <Sam-I-Am> lol, see y'all later
16:33:10 <emagana> #endmeeting