16:02:33 <emagana> #startmeeting networking-guide
16:02:33 <openstack> Meeting started Thu Feb  4 16:02:33 2016 UTC and is due to finish in 60 minutes.  The chair is emagana. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:38 <openstack> The meeting name has been set to 'networking_guide'
16:02:44 <njohnston> o/
16:02:48 <Sam-I-Am> hello
16:03:02 <emagana> we have so far njohnston Sam-I-Am
16:03:08 <emagana> anyone else?
16:03:18 <julen> hey Sam-I-Am: you are also with the general documentation, right?
16:03:32 <emagana> julen: Sam-I-Am is a core
16:03:35 * haleyb is lurking
16:03:42 <julen> I am Julen, by the way, from Hamburg (Germany)
16:03:56 <emagana> julen: not Spain?
16:04:25 <lwilliams_> o/
16:04:30 <Sam-I-Am> yeah, i do a lot of core docs
16:04:42 <julen> well... I am living in Germany now...
16:05:51 <julen> good! I have many ideas, maybe we can talk about some of them after the important stuff...
16:06:10 <emagana> #topic announcements
16:06:23 <emagana> any announcement?
16:07:09 <emagana> ok.. moving on
16:07:19 <Sam-I-Am> nothing here...
16:07:30 <emagana> #topic action items
16:07:56 <emagana> Do we have networking guide reviews out there that need our attention?
16:08:27 <Sam-I-Am> nope
16:08:30 <Sam-I-Am> its been pretty quiet
16:08:38 <Sam-I-Am> i need to do another round of updates to the scenarios
16:08:55 <emagana> same here.. I started the debugging section but I haven't pushed anything
16:09:04 <Sam-I-Am> we also never really came to a conclusion about how to handle provider networks in the classic scenarios
16:09:46 <emagana> did we decided to extend the scenarios... it's fuzzy right now
16:09:54 <emagana> in my mind I meant
16:10:06 <Sam-I-Am> yeah i think we did
16:10:15 <Sam-I-Am> its a lot of work, so i want to make sure we're all thinking the same thing before i work on it
16:10:21 <lwilliams_> that's what i recall as well...
16:10:31 <julen> are we talking about the network section on the install guide or about the networking guide?
16:10:37 <Sam-I-Am> networking guide
16:10:43 <Sam-I-Am> the install guide is another team
16:10:48 <emagana> julen: This meeting is focus on the networking guide
16:11:13 <emagana> Let's take a look to the etherpad. #link https://etherpad.openstack.org/p/networking-guide
16:11:53 <emagana> I found this work: https://gist.github.com/ssrikant20/c9c9044a1b57844a227d
16:11:55 <julen> aha.. I thought the networking section of the install guide and the networking guide were somehow linked. As an extension
16:11:59 <emagana> but seems to be in the wrong format
16:12:22 <Sam-I-Am> julen: they are somewhat linked - i work on both
16:12:55 <Sam-I-Am> emagana: what is this thing?
16:13:14 <emagana> I just got it from the etherpad
16:13:34 <lwilliams_> hmm, not sure either
16:13:37 <Sam-I-Am> oh, thats really weird
16:13:42 <Sam-I-Am> we dont do things that way
16:13:56 <emagana> Sam-I-Am: this is what I am calling it out
16:14:08 <Sam-I-Am> ssrikant: hello?
16:14:13 <Sam-I-Am> same username resides in here
16:14:16 <emagana> we should NOT do that.. I  will contact Sangeetha Srikanth directly
16:14:37 <Sam-I-Am> yeah, we need to use the regular workflow
16:14:47 <emagana> #action emagana to contact ssrikant
16:14:53 <Sam-I-Am> then we can also compare it with existing content
16:14:55 <emagana> is navinrio around?
16:15:49 <Sam-I-Am> guess not
16:16:26 <emagana> ok.. for the new members.. could you help on any of the topics in the etherpad?
16:16:36 <emagana> looking at julen and lwilliams_  :-)
16:17:14 <lwilliams_> :) i will take a closer look at some of the overview sections and see where i can help.
16:17:21 <julen> which ones?
16:17:31 <Sam-I-Am> most of the work needs to be done in the intro/config sections
16:17:31 <emagana> we would like to complete section marked as (H) High and (M) at least
16:17:39 <Sam-I-Am> the scenarios are pretty good right now
16:17:43 <lwilliams_> ok
16:18:18 <emagana> I have to admit that I am way late on my sections but will deliver no matter what
16:18:37 <Sam-I-Am> emagana: join the club
16:18:47 <emagana> so many things going on..
16:18:57 <Sam-I-Am> emagana: running 'sorted' on my list of to-dos returns the same list
16:19:03 <emagana> not sure if you got the email but I was invited to join the User Committee
16:19:03 <Sam-I-Am> sorted by priority, that is
16:19:07 <Sam-I-Am> its always fires
16:19:12 <Sam-I-Am> i didnt see that
16:19:37 <emagana> ok. let's move on..
16:20:14 <emagana> Sam-I-Am: Do you want to discuss?
16:20:27 <emagana> sorry...  hit enter before time..
16:20:39 <emagana> I meant if you have something to discuss with the team?
16:20:52 <Sam-I-Am> not really. just always looking for more contributors.
16:21:03 <Sam-I-Am> maintaining the guide is not easy
16:21:06 <julen> emagana: I might not be able to take care of any of the points completely by myself, but I can help on adding stuff, or some useful picture...
16:21:11 <Sam-I-Am> and it still lacks a lot of stuff
16:21:34 <emagana> julen: That is great, please add you name to the sections in the etherpad
16:21:47 <Sam-I-Am> and more than one person can be on a topic in the etherpad
16:21:54 <emagana> we have fews weeks before M-3
16:22:00 <emagana> which is first week of March
16:22:01 <julen> can I just write some draft or comments?
16:22:09 <julen> that's good
16:22:17 <emagana> let's target draft of those section at least
16:22:34 <emagana> julen: yes, feel free to push things directly to gerrit and we will review
16:22:41 <emagana> you can add us as reviewers
16:23:39 <julen> just to clarify: so, the install guide provides instructions on how to set up each and every component of openstack, and the networking guide is meant to provide a deeper understanding of all the involved concepts. Right?
16:23:54 <julen> so, sort of "the neutron manual"
16:24:32 <emagana> correct
16:24:33 <Sam-I-Am> julen: yeah
16:24:38 <julen> good
16:24:43 <Sam-I-Am> the install guide is the "easy path"
16:24:59 <Sam-I-Am> its the quickest way to deploy a working stack while learning how all the things work
16:25:02 <Sam-I-Am> its just one way
16:25:16 <Sam-I-Am> the networking guide is aimed more toward operators who want to deploy more complex networking
16:25:32 <Sam-I-Am> but also provides intro material to cover the gap between physical and virtual networks
16:25:39 <Sam-I-Am> networking is probably the hardest thing for most people to understand
16:26:27 <Sam-I-Am> eventually we may integrate the networking guide with the admin guide, but right now its independent
16:27:11 <emagana> let's move on
16:27:16 <Sam-I-Am> yep
16:27:18 <emagana> #topic open discussion
16:27:20 <julen> hmm... so, if I want to bring up a topic about the networking section of the install guide, this wouldn't be the right place... right?
16:27:26 <Sam-I-Am> nope
16:27:42 <emagana> julen go ahead
16:28:14 <julen> ok, I'll try, and if it is not the right place, I'll explain again in somewhere else
16:29:33 <emagana> the floor is yours
16:29:58 <julen> so...  long story short: I have an BASH version of the install guide but although I follow everything step by step, it still has some little issue
16:30:20 <julen> this is called BOMSI, and I already introduced it very shortly on the last summit in tokyo
16:30:53 <Sam-I-Am> ok...
16:31:09 <Sam-I-Am> the training guide folks also maintain shell scripts for the install guide
16:31:14 <Sam-I-Am> they call it osbash
16:31:21 <julen> the thing is: BOMSI might be a good way to test the install guide, as the code includes exactly, line by line the commands in the documentation
16:31:29 <julen> really?
16:31:32 <Sam-I-Am> yep
16:31:36 <julen> never heard about it..
16:31:49 <julen> but this one is based on ISO...
16:32:14 <julen> and it is multinode...
16:32:21 <Sam-I-Am> so is theirs
16:32:26 <julen> hmm.. I have to check that code
16:32:46 <Sam-I-Am> but anyway, we've discussed testing via script... the problem is making sure the script and docs align for each release
16:32:58 <Sam-I-Am> part of the install guide is doing every step manually
16:33:02 <Sam-I-Am> and there's a reason for it
16:33:27 <emagana> in my opinion as a operator, I will NEVER deploy anything that I want in production using bash scripts
16:33:45 <Sam-I-Am> emagana: well, no, however...
16:33:57 <emagana> they are hard to maintain and they do not provide a repeatable way to deploy a cluster consistently
16:34:10 <Sam-I-Am> the next steps after a manual install are learning how to automate deployment
16:34:12 <julen> hmm.. but what is the reason not to force to do some steps manually?
16:34:24 <Sam-I-Am> julen: the install guide is a learning experience
16:34:41 <Sam-I-Am> there are much better ways to automate installs - like puppet
16:34:51 <emagana> Sam-I-Am: We have Salt, Ansible, Puppet and Chef project for that
16:35:05 <Sam-I-Am> point is, too many people dive into automation first and then assume "things work" ... without really learning how openstacks works
16:35:06 <julen> sure.. but you don't follow the guide step by step...
16:35:08 <emagana> yeap, that is my point
16:35:18 <Sam-I-Am> then they go deploy in production, stuff breaks, and they're crying for help
16:35:42 <Sam-I-Am> so the point of the install guide is a step-by-step manual procedure to learn how services talk, what they do, ports they use, etc.
16:35:52 <Sam-I-Am> sooooo.....
16:36:09 <Sam-I-Am> i think automation is important, and the next step for people is automating something simple like the install guide
16:36:23 <julen> aha... I see. So the point on providing more "manual" steps on the guides, is to help people understand what they wrote, right?
16:36:26 <Sam-I-Am> in other words, provide a starting people so people don't have to start all over
16:36:29 <Sam-I-Am> yeah
16:36:38 <emagana> indeed!
16:36:42 <Sam-I-Am> i know chef is working on an automated version of the install guide
16:36:54 <Sam-I-Am> so having a bash one isnt the worst thing in the world - but we already have osbash
16:37:05 <Sam-I-Am> i would like to see one using ansible and puppet too
16:37:30 <emagana> but that is not our goal  :-)
16:37:42 <Sam-I-Am> not this teams goal, the install guide team's goal
16:37:47 <emagana> julen: do you have something else to discuss?
16:38:11 <julen> nope, everything is clear
16:38:19 <emagana> anyone else?
16:38:31 <Sam-I-Am> julen: feel free to join the install guide team
16:38:33 <Sam-I-Am> we need more people
16:39:13 <emagana> not sure what to do more
16:39:45 <emagana> we reached the neutron team and we sent emails to all ML lists... I had a list of people but they are not attending the meeting nor contributing
16:40:09 <Sam-I-Am> yeah, so goes the story with docs
16:40:21 <Sam-I-Am> none of the other meetings are getting attendance, so you're not alone
16:40:29 <emagana> Sam-I-Am: :-(
16:40:52 <emagana> well, let's keep trying
16:41:02 <emagana> I will talk to PTLs to get more ideas..
16:41:06 <emagana> anything else?
16:41:09 <lwilliams_> good idea
16:41:15 <Sam-I-Am> nothing from me
16:41:22 <lwilliams_> no
16:41:24 <Sam-I-Am> just putting out more fires :)
16:41:28 <emagana> #action emagana to talk with PTLs to get more contributors in networking guide
16:41:38 <emagana> Thank you all!
16:41:51 <njohnston> emagana: Shall I just grab some sections from the etherpad?
16:41:51 <Sam-I-Am> yep, thanks
16:41:52 <lwilliams_> thanks emagana
16:41:54 <emagana> Pelase, work on the etherpad to be sure we cover more section
16:41:55 <Sam-I-Am> njohnston: yes
16:42:01 <emagana> njohnston: Yes!
16:42:17 <njohnston> OK, I will take one and get to work :-)
16:42:25 <emagana> just add your name and write the docs and we will help on reviews and improvements
16:42:34 <emagana> njohnston: awesome!
16:42:47 <njohnston> Are the ones listed as TBD open for the taking?
16:43:01 <ssrikant> @Sam-I-Am I sent some content for networking guide few days back.
16:43:12 <emagana> ssrikant: good to see you around
16:43:14 <Sam-I-Am> yeah, and ones with people assigned already
16:43:24 <ssrikant> This is my first attempt so took an easy one
16:43:31 <emagana> ssrikant: We want you to push your documentation in gerrit and not private github accounts
16:43:36 <ssrikant> i sent an email to the group as well
16:43:45 <Sam-I-Am> ssrikant: i didnt see an e-mail
16:43:58 <emagana> ssrikant: me neither
16:44:19 <ssrikant> hmm.. it was to  networking@openstacknow.com
16:44:24 * njohnston takes "Advanced configuration -> Operational"
16:44:38 <emagana> I dont know that address
16:44:42 <ssrikant> I just followed the instructions in Instructions for Contributors
16:44:50 <ssrikant> in https://wiki.openstack.org/wiki/NetworkingGuide/TOC
16:45:00 <ssrikant> if there is another email or steps please let me know
16:45:07 <ssrikant> i will resubmit.
16:45:27 <Sam-I-Am> ssrikant: oh, that email hasnt worked in a while
16:45:31 <Sam-I-Am> use the docs mailing list
16:45:32 <ssrikant> :(
16:45:32 <emagana> use these ones: openstack-docs@lists.openstack.org &  openstack-dev@lists.openstack.org
16:45:36 <ssrikant> ok.. sorry did not know
16:45:39 <emagana> n.p.
16:45:52 <ssrikant> ok..
16:46:02 <Sam-I-Am> ssrikant: also that wiki page is outdated
16:46:04 <ssrikant> and I need to put it in a different repo
16:46:16 <ssrikant> and not gist
16:46:20 <Sam-I-Am> for a while we were allowing people to contribute in any format or location to get content
16:46:22 <emagana> yes, please
16:46:24 <Sam-I-Am> but that didnt work out well
16:46:30 <Sam-I-Am> so now you have to use the regular gerrit workflow
16:46:41 <Sam-I-Am> guess we need to fix that wiki page
16:46:43 <ssrikant> ok.. if u have some basic steps for that kindly let me know
16:46:51 <ssrikant> i will follow that procedure.
16:46:56 <emagana> ssrikant: take a look: http://docs.openstack.org/infra/manual/developers.html
16:46:59 <ssrikant> ok
16:47:11 <Sam-I-Am> emagana: btw i submitted a patch to remove the apac meeting, and also changed the agenda to use an etherpad for this meeting
16:47:13 <emagana> you need to use the openstack-manuals repo
16:47:27 <emagana> Sam-I-Am: I saw it.. make sense
16:48:19 <ssrikant> ok.. let me read thro this and will submit the content and will also email the mailing list once done
16:48:31 <emagana> great
16:48:32 <ssrikant> @emagana @Sam-I-Am Thank you
16:48:34 <Sam-I-Am> ssrikant: you dont have to mail the list about contributions
16:48:38 <Sam-I-Am> we'll see them in the review queue
16:48:41 <ssrikant> ok
16:48:42 <emagana> yeap..
16:48:46 <Sam-I-Am> just e-mail the list with questions
16:48:52 <Sam-I-Am> like... you cant get something to work
16:48:57 <ssrikant> ok..got it
16:49:47 <Sam-I-Am> anything else?
16:50:02 <njohnston> What content do you think should be in the Operational section other than logging?  http://docs.openstack.org/liberty/networking-guide/adv-config-operational.html
16:50:51 <Sam-I-Am> njohnston: maybe db management?
16:50:57 <Sam-I-Am> i think there's a patch somewhere for it...
16:51:21 <Sam-I-Am> https://review.openstack.org/#/c/276335/
16:51:30 <njohnston> Thanks!
16:51:30 <Sam-I-Am> havent looked at it yet, but seems along those lines
16:51:50 <Sam-I-Am> maybe document the "cleaner" scripts
16:51:57 <Sam-I-Am> like ovs-cleanup or whatever its called
16:52:01 <Sam-I-Am> there's one for linux bridge too
16:52:19 <Sam-I-Am> stuff operators would need to do from more of an administrative standpoint
16:52:34 <Sam-I-Am> upgrades would probably go into operational bits
16:53:15 <Sam-I-Am> emagana: anything else?
16:53:23 <emagana> no, we are good
16:53:27 <emagana> Thank you all!
16:53:41 <emagana> #endmeeting