18:03:15 <Sukhdev> #startmeeting networking_l2gw
18:03:16 <openstack> Meeting started Mon Mar  2 18:03:15 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:19 <openstack> The meeting name has been set to 'networking_l2gw'
18:03:27 <Sukhdev> #topic: Agenda
18:03:39 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
18:03:59 <Sukhdev> #topic: Announcements
18:04:40 <Sukhdev> I do not have any specific announcement - except that feature freeze for Kilo is this week
18:04:52 <Sukhdev> this does not impact us
18:05:00 <maruti> agreed
18:05:39 <Sukhdev> anybody has any announcement - before we dive into status
18:06:13 <Sukhdev> We have tons of merged patches - see here https://review.openstack.org/#/q/status:merged+project:stackforge/networking-l2gw,n,z
18:06:49 <Sukhdev> Only handful are left which are also very close to completion - see here https://review.openstack.org/#/q/status:open+project:stackforge/networking-l2gw,n,z
18:07:21 <maruti> Armando reviewed some patches pretty fast and gave comments on which people are working currently. l2gw client is in good shape. REST APIs are in good shape. devstack scripts are committed.  Pending work items:  batch scripts and test automation - alok and ashish  packaging - koteswara and vikas  documentation - maruti and selva
18:07:22 <Sukhdev> #topic: Project Status
18:07:45 <Sukhdev> ah ha you beat me to it - maruti, I was going to ask you to provide status :-)
18:07:48 <maruti> Armando reviewed some patches pretty fast and gave comments on which people are working currently. l2gw client is in good shape. REST APIs are in good shape. devstack scripts are committed.
18:08:21 <maruti> Pending work items: batch scripts and test automation - alok and ashish
18:08:24 <maruti> packaging - koteswara and vikas
18:08:33 <maruti> documentation - maruti and selva
18:09:03 <Sukhdev> Hats off to the team this is tremendous progress
18:09:24 <maruti> agreed.
18:09:59 <Sukhdev> maruti - I wanted to dive into some of the details so that others can start to test this feature
18:10:05 <maruti> I am going to submit a patch which will bridge l2gw plugin and the ML2 plugin
18:10:29 <maruti> sure Sukhdev
18:10:55 <Sukhdev> you mean when a network is added to L2-GW, generating create_port requests to ML2?
18:11:32 <maruti> yes
18:12:14 <Sukhdev> This will be similar to adding network interface to router - similar port_create request is generated
18:13:01 <maruti> Reference: https://review.openstack.org/#/c/153774/
18:13:59 <Sukhdev> Thanks for the link
18:14:08 <maruti> When an event occurs in ML2, l2gw service plugin should  get notified so that the service plugin can write into OVSDB tables.
18:14:39 <Sukhdev> and, vice-a-versa, right?
18:14:55 <maruti> vice-versa not required
18:15:07 <Sukhdev> can you elaborate why not?
18:15:28 <maruti> if there are any changes in OVSDB tables, l2gw service plugin writes into OVSDB tales and also sends RPCs to the L2 agents
18:15:42 <maruti> if there are any changes in OVSDB tables, l2gw service plugin writes into neutron tables and also sends RPCs to the L2 agents
18:16:13 <maruti> so that L2 agents can create tunnels to the gateways
18:16:29 <Sukhdev> then you are saying, it will bypass the ML2 plugin
18:17:06 <maruti> yes
18:18:02 <maruti> that patch set is under review.  https://review.openstack.org/#/c/158655/
18:18:46 <Sukhdev> makes sense - thanks for clarification
18:19:08 <Sukhdev> Anybody on the channel have any question on this before we move to next topic?
18:20:06 <Sukhdev> maruti: you mentioned devstack scripts are done
18:20:34 <Sukhdev> can one enable L2-GW service by using devstack?
18:20:38 <maruti> yes
18:20:53 <Sukhdev> do you have link handy to the patch?
18:21:07 <maruti> https://review.openstack.org/#/c/158395/
18:21:20 <Sukhdev> #link: https://review.openstack.org/#/c/158395/
18:21:40 <selvakumar> there is readme.rst under repo
18:21:41 <selvakumar> https://github.com/stackforge/networking-l2gw/blob/master/devstack/README.rst
18:22:16 <Sukhdev> selvakumar: Thanks
18:22:58 <Sukhdev> #topic: Verification of the existing code
18:23:32 <Sukhdev> I had an off-line chat with Armado and asked when can folks pull the code on their platforms and start to test
18:24:04 <Sukhdev> He indicated we are very close - I see the patches are almost ready
18:24:40 <Sukhdev> I have asked couple of people in Arista to look into this code and test on Arista HW
18:25:04 <Sukhdev> We are in a wait state for a green signal to go ahead - as soon as the code is ready to go
18:25:24 <Sukhdev> Having said that, I want to ask you guys a question
18:25:32 <maruti> Once these patches are merged: https://review.openstack.org/#/c/158655/   https://review.openstack.org/#/c/156494/ and the ML2 plugin patching with L2gw service plugin, then it should work.
18:25:55 <Sukhdev> yup - understood
18:26:08 <Sukhdev> the question I want to ask you is as follows:
18:26:49 <Sukhdev> For a new person, who wants to play with L2 Gateway service (and has not been involved in these meetings) -
18:27:14 <Sukhdev> Shall we write up something for a quick ramp up steps?
18:27:55 <Sukhdev> For example, selvakumar you mentioned about the README for the devstack
18:28:20 <maruti> That is the plan. However, we have some reviews in progress on which we are working daily and want to get them merged so that end-to-end will work.
18:29:01 <maruti> The next would be the documentation.
18:29:09 <Sukhdev> understood - that is what I meant by "green light"
18:29:23 <Sukhdev> we have a project wiki https://wiki.openstack.org/wiki/Neutron/L2-GW
18:29:30 <maruti> Yes
18:29:39 <Sukhdev> we can add a section to it for quick ramp up
18:29:50 <maruti> agreed
18:30:11 <Sukhdev> Cool - let me know if I can help in this regards
18:30:34 <maruti> sure Sukhdev
18:30:41 <Sukhdev> As soon as the code is ready, we would want more and more folks to start testing on various platforms
18:30:56 <maruti> That will be great
18:31:03 <Sukhdev> This will authenticate the implementation and help improve the quality
18:32:44 <Sukhdev> Anything else you want to add to give the rest of team update?>
18:33:34 * Sukhdev waiting
18:33:40 <maruti> After the pending reviews are merged, the third party CI on which alok and ashish are working on will also start functioning.
18:33:41 <selvakumar> Sukhdev - you can take an action item for document on me and Maruti.
18:34:57 <Sukhdev> #action: selvakumar and maruti to document the users guide to deploy the L2-Gateway service
18:35:14 <Sukhdev> selvakumar: Thanks
18:35:29 <Sukhdev> #topic: Open Discussion
18:36:14 <Sukhdev> I think we have a excellent status update of the project - want to see if there is anything in general anybody wants to bring up
18:36:30 * Sukhdev waiting
18:37:18 <Sukhdev> selvakumar, maruti: I did not check the votes on our presentation
18:37:30 <Sukhdev> please forward the link to others to vote on it
18:38:29 <Sukhdev> Folks we are done.
18:38:40 <Sukhdev> Thanks for joining.
18:38:40 <selvakumar> Sukhdev , we have already  forwarded to our entire HP Networking section for requesting vote
18:38:59 <Sukhdev> selvakumar: cool - likewise, I did the same
18:39:16 <selvakumar> thanks Sukhdev
18:39:21 <Sukhdev> We will meet in two weeks - hopefully, we will have documentation
18:39:34 <selvakumar> yes sure
18:39:52 <maruti> I am not sure where can we check the votes
18:39:59 <Sukhdev> selvakumar, maruti : as soon as you get to the documentaion, please ping me - we do not have to wait, if we can move on it sooner
18:40:13 <maruti> sure Sukhdev
18:40:51 <Sukhdev> Folks, will see you here in two weeks.
18:41:01 <Sukhdev> bye
18:41:10 <Sukhdev> #endmeeting