18:01:47 <Sukhdev> #startmeeting networking_l2gw
18:01:47 <openstack> Meeting started Mon Mar 30 18:01:47 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:50 <openstack> The meeting name has been set to 'networking_l2gw'
18:02:08 <Sukhdev> #topic: Agenda
18:02:13 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
18:02:25 <Sukhdev> #topic: Announcements
18:02:35 <Sukhdev> I have an announcement
18:03:04 <Sukhdev> I updated our L2 GW wiki to include the documentation -
18:03:16 <Sukhdev> Do not know if you guys had any chance to look at it yet
18:03:59 <Sukhdev> http://docs-draft.openstack.org/39/164639/3/check/gate-networking-l2gw-docs/b111c4c//doc/build/html/
18:04:18 <koteswar> yea. i have seen it. u linked l2gateway documentation in the wikipage
18:04:52 <Sukhdev> Also, in last week's Neutron core meeting I announced about the availability of our API
18:05:20 <Sukhdev> I wanted to make sure wider audience is aware of this and start to use it
18:05:29 <Sukhdev> koteswar: good
18:05:31 <koteswar> ok.
18:05:56 <Sukhdev> Any body has any announcement that you want to share with the team?
18:06:08 * Sukhdev waiting
18:06:43 <Sukhdev> #topic: Project Status
18:06:52 <koteswar> @sukhdev: as you know l2gw packaging is under review. vikas is waiting for +2 from armando\
18:07:01 <Manjunath> @Vikas can you go ahead and talk about packaging stuff
18:07:05 <vikas> yes..
18:07:21 <armax> vikas: I’ll be picking up on l2gw related reviews this week
18:07:34 <armax> I was swamped with Neutron’s RC reviews last week
18:07:59 <armax> that said, I am not the only one with +2 rights
18:08:00 <vikas> ok fine
18:08:13 <vikas> https://review.openstack.org/#/c/163827/
18:08:21 <Sukhdev> Now armax is making me feel guilty:-)
18:08:38 <armax> Sukhdev: I wasn’t blaming anyone :)
18:08:48 <Sukhdev> I looked at the reviews over the weekend
18:09:30 <Sukhdev> vikas: I reviewed this earlier and posted comment - I will look at it today
18:10:03 <vikas> ok fine
18:10:23 <Manjunath> Myself and Phani reported some bugs and we are working on it.
18:10:38 <koteswar> all the major code is merged in stackforge. only some defect fixes are pending
18:11:24 <Sukhdev> This has been amazing progress - hats off to you guys
18:11:35 <koteswar> we started testing end to end with HP switch
18:11:52 <Sukhdev> koteswar: how is it coming?
18:12:20 <Sukhdev> koteswar: VM to BM ping back-n-forth?
18:12:37 <koteswar> sukhdev: you guys can start testing with arista switches and let us know the status
18:12:56 <Sukhdev> koteswar: I have two people looking at it
18:13:49 <koteswar> yes sukhdev. VM to BM ping is working fine.
18:14:26 <Sukhdev> koteswar: that is great
18:14:42 <koteswar> ok. please let us know if you guys face any issues
18:15:12 <Sukhdev> koteswar: I will - I am trying to get the testing scheduled -
18:16:07 <koteswar> sukhdev: ok. thanks.
18:16:10 <Sukhdev> I have commitment from two people to jump on it soon - they have already pulled the code and reviewed it. It is looking all good
18:16:52 <Sukhdev> I have a bit of update as well - will provide in a bit - want to have you guys cover first
18:17:04 <koteswar> ok
18:17:36 <Sukhdev> #topic: Patches under review:
18:18:04 <Sukhdev> We discussed about one patch - anything else on any of other patches?
18:18:09 <koteswar> from now onwards armando asked to raise defects and then raise code review against it
18:18:30 <Sukhdev> koteswar: that is the right way....
18:19:14 <Sukhdev> I saw few bugs - which is a good thing - that means things are working
18:19:16 <vikas> https://review.openstack.org/#/c/167556/
18:19:26 <koteswar> sukhdev: what ever the issues found, please raise defects in launchpad
18:19:39 <Sukhdev> koteswar: will do
18:20:41 <Sukhdev> armax: when ever you become overwhelmed, feel free to ping me, I would be happy to step in
18:21:24 <armax> Sukhdev: ok,
18:21:38 <koteswar> few patch sets are waiting for +2 from armando https://review.openstack.org/#/q/status:open+project:stackforge/networking-l2gw,n,z
18:21:41 <armax> I am always overwhelmed
18:21:42 <armax> :)
18:22:10 <Sukhdev> OK - I will review these patches later this evening
18:22:29 <Sukhdev> koteswar: feel free to ping me - I am mostly on the neutron channel
18:23:00 <Sukhdev> Anything else on the patches?
18:23:07 * Sukhdev waiting
18:23:46 <Sukhdev> #topic: Discussion about missing pieces
18:23:51 <koteswar> sukhdev: ok
18:24:44 <Sukhdev> armax: for Kilo, is there anything additional that is missing?
18:25:14 <armax> we’d need to pusblish this stuff to pypi, but other than that we should be good
18:25:39 <armax> Sukhdev: I am thinking of adding an AFFILIATED file to Neutron that captures all the neutron-related project, just for reference
18:25:43 <armax> but that would be it
18:26:05 <Sukhdev> armax: I can help with pypi stuff
18:26:21 <armax> Sukhdev: you got yourself an #action
18:26:47 <Sukhdev> #action: Sukhdev to look at adding L2-GW to pypi
18:27:39 <Sukhdev> armax: for versioning - 2015.1.1 is good, right?
18:28:22 <armax> Sukhdev: not sure if going with the 0.x.y scheme is better
18:28:30 <armax> Sukhdev: this is a sort of library after all
18:29:42 <Sukhdev> armax: I was thinking we can align it with neutron release by using similar numbering - i.e. 2015.1.X with kilo/stable and 2015.2..x with Liberty/stable, etc..
18:30:16 <Sukhdev> this way we can add bug fixes, etc on different versions to keep it aligned with Neutron releases
18:30:38 <armax> Sukhdev: that works too, but the nice thing about the different versioning scheme is that we don’t have to align
18:30:45 <armax> and go at our pace
18:32:20 <Sukhdev> armax: I guess you have a point - I was thinking down the road, when many people are using this with different releases of Neutron (fast forward 2 years) and want to submit fixes to only sub branches
18:32:56 <armax> 2 years from now, I dunno if I am alive
18:33:01 <armax> :)
18:33:31 <Sukhdev> armax: Well, when thinking versioning, etc.. it is good to think that way
18:33:45 <armax> jokes aside, yes
18:33:58 <Sukhdev> armax: I can place a bet that I will be bugging you two years down the road as well (God willing :-))
18:34:03 <armax> do we see ourselves iterate faster than Neutron?
18:34:06 <armax> I would think so
18:34:18 <Sukhdev> armax: Yes,
18:34:30 <Sukhdev> armax: actually may be -
18:34:41 <armax> how do other projects’ versioning scheme is like? I see that most choose x.y.z where x,y,z=0,1,2,3,…
18:34:55 <armax> so I figured that it’s prolly more appropriate
18:35:06 <Sukhdev> considering we are in early stage - I have a feeling many will jump in and would want to make changes, enhancements, etc
18:35:49 <Sukhdev> armax: I just went through the discussion about networking_arista, and decided it that way
18:36:07 <Sukhdev> this gives tremendous flexibility to vendors, users, developers -
18:36:48 <armax> Sukhdev: sure, overall they are pretty much the same, it’s a matter of perception
18:36:59 <armax> Sukhdev: I leave the choice to you
18:37:06 <armax> or the larger consensus
18:37:16 <armax> of the folks sitting in this room
18:37:37 <Sukhdev> what do others think?
18:37:46 <Sukhdev> Here is how I was thinking:
18:38:21 <Manjunath> we can align it with neutron release
18:38:25 <Sukhdev> When kilo is close, we will create a branch on this project called kilo/stable, create a tag, version it, and publish it to pypi
18:39:21 <armax> Sukhdev: ok
18:39:52 <Manjunath> ok
18:40:00 <Sukhdev> And, going forward, the version for the master branch for this project will become 2015.2.0
18:40:28 <Sukhdev> this way now one can fix bug against only Kilo, if they want or against both master and kilo
18:41:22 <Sukhdev> the users who do not care about the release (e.g. if they pick neutron master branch) they will simply use "pip install networking_l2gw" and get the latest code
18:42:12 <Manjunath> Agreed
18:42:31 <Sukhdev> for those who worry about using a specific code branch they can use "sudo pip install networking_l2gw>=2015.1.0, <2015.2.0" - this gives them latest on the kilo/stable
18:42:49 <koteswar> if nuetron changes its version amd l2gw has no changes, do we still change l2gw version to align with neutron?
18:43:32 <Sukhdev> koteswar: we do not have to - but, if we make any fix which will go into liberty, then we do
18:44:28 <Sukhdev> For instance (as an example) - kilo/stable will support vxlan<->VLAN mapping. If we add VLAN<->VLAN mapping in liberty - we can change the version
18:44:53 <Sukhdev> Hope this is making sense
18:45:20 <koteswar> sukhdev: ok
18:45:28 <Sukhdev> We can discuss further in our next meeting - once you have had a chance to digest it and think about it
18:45:47 <Sukhdev> armax: does this make sense?
18:46:05 <koteswar> sukhdev:sure
18:46:06 <Sukhdev> We still have some time to do this - Kilo does not go our until 4/29
18:46:11 <armax> Sukhdev: sure
18:46:27 <Sukhdev> Sounds good
18:46:34 <Sukhdev> Anything else on this?
18:46:50 * Sukhdev waiting
18:47:10 <Sukhdev> #topic: Open Discussion
18:47:26 <Sukhdev> I want to give you guys an update
18:47:49 <Sukhdev> I have been socializing this project with wider audiaence
18:47:59 <Sukhdev> many people are not aware of this project
18:48:19 <Sukhdev> When I give them high level overview - everybody likes it
18:48:43 <Sukhdev> I have been sending the link to our wiki to many vendors/customers
18:49:34 <Sukhdev> We need to make sure that we make larger population aware of this
18:50:19 <Sukhdev> that is it from me
18:50:27 <Sukhdev> anybody wants to add anything?
18:51:03 <Sukhdev> armax: any final departing thoughts?
18:51:25 <armax> Sukhdev: nope
18:51:52 <Sukhdev> OK - folks, in that case we are done - thanks for joining and providing update
18:51:58 <Sukhdev> #endmeeting