17:03:25 <Sukhdev> #startmeeting networking_l2gw
17:03:26 <armax> hi
17:03:26 <openstack> Meeting started Mon Apr 13 17:03:25 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:29 <openstack> The meeting name has been set to 'networking_l2gw'
17:03:44 <Sukhdev> #topic: Agenda:
17:04:13 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
17:04:36 <Sukhdev> #topic: Announcements:
17:04:57 <Sukhdev> Before we start, anybody has any announcement to make?
17:05:37 <Sukhdev> #topic: Discussion on Plan for Vancouver summit presentation
17:06:04 <Sukhdev> I thought we start with some kind of plan as to how to organize our presentation
17:06:11 <Sukhdev> for Vancouver summit
17:06:30 <Sukhdev> who wants to go first?
17:06:38 <maruti_> What points should we cover in the presentation?
17:07:02 <Sukhdev> maruti_: I think we should highlight the following points:
17:07:17 <Sukhdev> 1) Background/motivation and any prior attempts
17:07:33 <Sukhdev> 2) High level architecture
17:07:42 <Sukhdev> 3) Participants
17:07:57 <Sukhdev> 4) a bit about the details (not too glory details)
17:08:10 <Sukhdev> 5) a demo
17:08:12 <maruti_> Use cases?
17:08:17 <selvakumar> L2GW RESTful API design, L2GW agent design , L2GW Service Plugin architecture (includes Ml2 interactions), SB implementation (OVSDB )
17:08:44 <Sukhdev> selvakumar: should we cover that under 3 & 4
17:08:57 <yamahata> future plan?
17:08:58 <Sukhdev> maruti_: use cases is good -
17:09:23 <Sukhdev> maruti_: I think use cases can go between 1 and 2
17:09:29 <selvakumar> Sukhdev: I agree
17:09:35 <Sukhdev> yamahata: yes - definately
17:10:12 <Sukhdev> armax: thoughts?
17:10:16 <maruti_> armax what do you think?
17:10:30 <armax> can someone elaborate point 3?
17:10:36 <armax> I am not sure I understand what it is
17:11:06 <Sukhdev> armax: I thought we introduce the team, the wiki, the meetings (this one), etc...
17:11:15 <Sukhdev> armax: as part of 3
17:11:36 <armax> Sukhdev: I am not sure the audience could care about the wiki and pointers
17:11:42 <armax> those should go at the end
17:11:46 <armax> for people’s reference
17:12:01 <armax> when we’re doing the Q&A
17:12:04 <armax> if there’s any
17:12:06 <Sukhdev> armax: sounds reasonable -
17:12:22 <armax> after all we the rest of the points look good
17:12:23 <Sukhdev> I threw all those bullets (not necessarily in the order)
17:12:47 <armax> in the simplest of forms we could really just take the lightening talk that Maruti gave during the last summit
17:12:53 <maruti_> Should it be a live demo or recorded?
17:12:55 <armax> and explode the points in the actual stuff that was done
17:13:20 <armax> maruti_: I think that a canned demo is probably better, but I honestly don’t think that a demo brings any value
17:13:28 <Sukhdev> maruti_: do you still have that presentation? can you share?
17:13:37 <armax> in the end is a bunch of commands typed in the cli
17:13:44 <maruti_> Yes I will send an email with the preso
17:13:52 <armax> and a ping to a baremetal host that people must believe is indeed bare matal
17:13:55 <armax> I don’t think it'
17:13:59 <armax> it’s that sexy
17:14:16 <maruti_> :)
17:14:32 <armax> so if we were to expand other points, or save time for Q&A I’d totally vote for banning the demo altogether
17:14:41 <Sukhdev> armax: I am OK either way - demo gives feeling that the API is ready
17:14:49 <armax> Sukhdev: no it doesn't
17:15:11 <Sukhdev> armax: but, if couple of vendors say they are using it, it will do the same
17:15:57 <armax> Sukhdev: and that has nothing to do with showing a demo
17:16:12 <armax> as the name says, a demo shows how the product works
17:16:17 <armax> not that people are using it
17:16:18 <Sukhdev> only issue I see with demo is that it could chew a lot of time - which could be spent on Q&A
17:16:34 <armax> Sukhdev: right…in the end it’s like
17:16:42 <maruti_> We can keep the demo in the backup slides
17:16:59 <Sukhdev> armax, maruti_ : I have an idea
17:17:08 <armax> the other idea is that we could record the demo and give the pointer
17:17:19 <maruti_> yes, that is good
17:17:37 <armax> the other possibility is that while we explain the API we could should the demo side by side
17:17:44 <armax> but that requires quite a bit of training
17:17:47 <Sukhdev> usually, there are open time slots available - we could possibly schedule demo there - and in the main presentation can tell people, if anybody is interested in playing with it, they can go to this session
17:17:52 <armax> to make sure that everything goes smoothly
17:18:04 <armax> that too
17:19:51 <Sukhdev> So, we have few ideas: a) no demo, b) recorded demo with a pointer c) separate demo session (live) d) ??
17:21:00 <Sukhdev> I have did c) for Arista demo in the past - it worked well - i.e. in the main session, just mentioned and gave the timing of the demo and who ever is interested shows up there
17:21:07 <maruti_> I liked option b
17:21:15 <armax> I guess a recorded demo would be good as educational material available n the wiki
17:21:24 <armax> if we have time we could do b and c
17:21:29 <armax> they are not mutually exclusive
17:22:15 <Sukhdev> armax: if you choose to do c) we could use recorded or live (depending upon the level of confidience :-))
17:22:57 <Sukhdev> recorded demo takes the pressure off :-)
17:23:19 <Sukhdev> we could record it and play/pause and explain
17:24:12 <maruti_> We will see how much time it takes to cover all the slides. If we are good with respect to time during practice, then we can bring in the recorded demo.
17:25:04 <maruti_> We can decide on this later.
17:25:18 <Sukhdev> I have a feeling we will get lots of questions - as I am anticipating there will be lots of interest in this topic
17:25:58 <Sukhdev> That leads to the question on number of slides -
17:26:42 <armax> well the question is really who talks what
17:27:36 <Sukhdev> armax: we can divide the sub-topics and decide who covers which sub-topic
17:27:38 <armax> typically one should spend one or one minute an half per slide
17:27:53 <armax> if we have a 40 min slots
17:28:05 <armax> prolly 15 slides is the most we could afford
17:28:06 <maruti_> According to me, let's put the slides together and then decide who can take up which slide(s).
17:28:52 <Sukhdev> maruti_: sounds reasonable
17:29:36 <maruti_> Let me and Selva prepare a draft copy and send to you people and then let us review over the emails and modify accordingly.
17:30:15 <Sukhdev> maruti_: sounds good - so, you will take your existing deck and build around it, right?
17:30:24 <maruti_> Yes
17:30:34 <selvakumar> Maruti: I agree that sounds good, we can workout the slides
17:30:41 <maruti_> And I will send the copy of the lightning talk to you anyways
17:31:23 <Sukhdev> We can iterate over the slides via email and then we can use next meeting (4/27) as well to cover the loose ends
17:31:42 <maruti_> Agreed
17:32:34 <Sukhdev> maruti_: In the mean time, I have kicked off testing on Arista HW - If you want, I can record a demo as well (only if I am able to make it work :-))
17:32:49 <maruti_> :)
17:33:21 <Sukhdev> #action: maruti_ and selvakumar to prepare a rough draft of the presentation and share with the team
17:33:26 <maruti_> Thanks Sukhdev. You may hit some issues. I am also testing the latest code and fixing issues as they are discovered.
17:33:42 <armax> one thing that might be looking to add
17:34:03 <armax> is a roadmap, assumed we can work out one ahead of the summit ;)
17:34:20 <armax> where do we go from here?
17:34:37 <maruti_> Our earlier plan was the s/w l2 gateway.
17:34:44 <Sukhdev> armax: correct - i think that is what yamahata was eluding to as well
17:34:57 <armax> also, another suggestion would be to add a slide with FAQ
17:35:09 <armax> Sukhdev: yes, I think we can elaborate a roadmap offline
17:35:16 <armax> but it’s good to bear that in mind
17:35:48 <yamahata> FAQ would be uploaded to wiki or somewhere. This is a bit off topic.
17:35:57 <armax> as for FAQ, for instance I am thinking about the most obvious question people may ask, like ‘how do I get my hands on L2GW'?
17:36:16 <armax> yamahata: I don’t think it is
17:36:18 <Sukhdev> armax: FAQ, wiki, team, meetings, participants, etc…we can all dump it on one slide
17:36:31 <armax> Sukhdev: right, that’s what I am saying a slide with pointers
17:36:38 <armax> but highlighting the most obvious ones
17:36:58 <Sukhdev> armax: I see your point - I think it makes sense
17:37:03 <armax> after the presentations people would want to know how to get it to work
17:37:21 <armax> and since l2gw is not technically part of neutron, people would wonder how we integrate etc
17:37:48 <armax> these are details we can iron out offline
17:37:55 <Sukhdev> when maruti_ sends the initial draft, we can look at adding a slide or two cover this and iterate over it
17:37:59 <armax> I am just making the suggestion here
17:39:00 <Sukhdev> So, we have a plan for the slides, and we are converging on recorded demo
17:39:08 <Sukhdev> Are we good with this?
17:39:42 <Sukhdev> Hopefully within next week or two, we should polish up the slides and then we can cover them in the next meeting (here)
17:39:51 <maruti_> Yes. Let us review further over emails
17:40:15 <Sukhdev> Any other thought on this? I have one more item to cover :-)
17:40:36 * Sukhdev waiting
17:40:58 <Sukhdev> #topic: versioning and release management of L2 Gateway
17:41:09 <Sukhdev> I pushed a patch yesterday -
17:41:15 <Sukhdev> #link: https://review.openstack.org/#/c/172742/
17:41:41 <Sukhdev> In this patch, I tried to explain my thought process - do not know if you guys had a chance to review
17:41:43 <maruti_> Sukhdev you posted a review for pip install. I am not sure whether it will work currently.
17:42:13 <Sukhdev> maruti_: did not understand, can you elaborate?
17:42:35 <armax> Sukhdev: now that Kilo RC is out, I am gonna resume efforts on this project, so I’ll review it later
17:42:45 <Sukhdev> maruti_: if you mean pip install will not work because we have not pushed it yet - then yes
17:43:00 <maruti_> correct
17:43:38 <Sukhdev> armax maruti_: correct - once we agree to the versioning, etc.. I will create a branch, tag the version and push it to pypi
17:43:50 <armax> Sukhdev: cool
17:43:53 <maruti_> That will be great
17:44:05 <armax> Sukhdev: I shall have a pass by the end of my day
17:44:16 <Sukhdev> To push the package to pypi, it needs to be tagged and versioned - hence, we need to reach to an agreement
17:45:03 <Sukhdev> armax: cool - I will be on IRC, feel free to ping me with questions/clarifications
17:45:22 <Sukhdev> Others, please do review and see if you agree to the overall thought process
17:45:52 <Sukhdev> #topic: Project Status
17:46:13 <Sukhdev> armax, maruti_ , selvakumar : want to give status of the project (overall)?
17:47:00 * Sukhdev waiting
17:47:16 <armax> I have none
17:47:57 <armax> but I have noticed that HP has plugged a 3rd pary CI system to the project
17:48:15 <maruti_> Most of the code is landed into the stackforge
17:48:19 <selvakumar> Sukhdev: Alok and team will start testing end to end from this wednesday . right now dev team  have resolved the critical defects. we yet to continue end to end testing
17:48:41 <armax> the CI should expand the test coverage
17:48:43 <maruti_> We are also filing defects as we come across and fixing them.
17:48:49 <armax> and I know some folks are working on it
17:49:08 <maruti_> right now, I am able to execute REST APIs and able to make changes to the OVSDB tables.
17:49:14 <alokmaurya> we are working on to add more tests
17:49:37 <Sukhdev> I approved three patches over the weekend - hopefully, that will make things more stable
17:49:46 <alokmaurya> currently  CI  is  running with basic  CURD operations of l2gateway  and l2gateway connection
17:50:42 <Sukhdev> alokmaurya: interesting, when I tried to run on Arista HW, I was seeing issues -
17:50:42 <alokmaurya> we are trying  to  convert  existing tempest test cases in a similar format as neutron api tests
17:51:21 <maruti_> Sukhdev, the same issues were seen by the CI and I got a chance to fix them.
17:51:43 <maruti_> Please take the latest code and you should be good to test with Arista switches.
17:52:02 <alokmaurya> Sukhdev :  are you trying to run  tests  which  are available in repo ?
17:52:19 <Sukhdev> maruti_: I have already pulled the latest code, will test later today and report via email
17:52:19 <ashishg> submitted the patch for the same https://review.openstack.org/#/c/172855/
17:52:23 <selvakumar> Sukhdev: please create a defect in launchpad or do let us know in case if you facing issue during Arista switch testing
17:52:56 <Sukhdev> selvakumar: I have been sending emils - I will start to file bugs as well
17:53:08 <Sukhdev> Want to bring up another issue
17:53:15 <Sukhdev> #topic: Documentation
17:53:30 <selvakumar> sure Sukhdev:
17:53:32 <Sukhdev> Our documentation link is broken - are you aware of it?
17:53:49 <Sukhdev> check out - http://docs-draft.openstack.org/39/164639/3/check/gate-networking-l2gw-docs/b111c4c//doc/build/html/
17:53:55 <Sukhdev> what caused it?
17:54:10 <Sukhdev> anybody is aware of this?
17:55:01 * Sukhdev waiting
17:55:19 <Sukhdev> armax: you are good at this kind of stuff :-):-) any idea?
17:55:38 <armax> it works here
17:55:39 <armax> http://docs-draft.openstack.org/35/172935/1/check/gate-networking-l2gw-docs/b924e06//doc/build/html/
17:55:46 <armax> so I suspect it’s an outlier
17:56:24 <Sukhdev> wow!! strange - does this mean the link is fluid and subject to change?
17:57:00 <armax> of course it does
17:57:13 <armax> do you see that the URL contains the refspec?
17:57:32 <Sukhdev> armax: now that you pointed, I do see it -
17:58:16 <Sukhdev> armax: how do we nail it to the wiki and make it stable link?
17:58:50 <Sukhdev> armax: I hope there is a way to do it
17:59:04 <armax> Sukhdev: that I am not sure, I am not sure there is, we’d need to ask the docs folks
17:59:23 <armax> Sukhdev: perhaps there’s a doc job just as a pip one
17:59:57 <armax> look here:
17:59:58 <armax> http://docs.openstack.org/infra/manual/creators.html#add-link-to-your-developer-documentation
18:00:02 <Sukhdev> armax: if you can give me few pointers/contacts offline, I will follow up and get this fixed
18:00:03 <armax> it looks like perhaps it can’t be done
18:00:29 <Sukhdev> armax: oh - that is not good :-)
18:00:34 <armax> but perhaps it can be published here
18:00:35 <armax> https://readthedocs.org/
18:00:56 <armax> I am pretty sure that’a viable alternative for now
18:01:18 <armax> like there used to be ceilomter
18:01:19 <Sukhdev> Folks, we are up against the time - want to ask final question - Shall we change the meeting time for future meetings or keep it at original time
18:01:19 <armax> http://ceilometer.readthedocs.org/en/latest/
18:01:46 <Sukhdev> armax: let me ping you off line to cover this
18:01:54 <armax> I need to dash
18:01:57 <armax> Sukhdev: ping me later
18:02:05 <Sukhdev> So, what is the answer to my question? about time?
18:02:11 <maruti_> This time is good for us unless it's a problem for other time zones.
18:02:14 <selvakumar> Sukhdev: today time sounds good for India folks
18:02:17 <armax> I am happy to keep the existing slot
18:02:33 <armax> but 10am PST works for me too, but I might not be able to attend all the time
18:02:57 <Sukhdev> armax: you have to make it hard :-)
18:03:26 <Sukhdev> I will change it to earlier slot and on a need basis we can push it out, if needed
18:03:38 <armax> Sukhdev: I know, that’s me
18:03:40 <armax> :)
18:03:48 <Sukhdev> I will send out ML with updated time - also, check the wiki to be sure of the time
18:03:58 <maruti_> ok
18:04:17 <Sukhdev> thanks folks - it was a very productive meeting.
18:04:22 <Sukhdev> #endmeeting