17:05:32 <Sukhdev> #startmeeting networking_l2gw
17:05:33 <openstack> Meeting started Mon Apr 27 17:05:32 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:37 <openstack> The meeting name has been set to 'networking_l2gw'
17:05:54 <Sukhdev> #topic: Agenda
17:05:59 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway#Agenda
17:06:12 <Sukhdev> Hope everybody had a chance to look at the agenda
17:06:24 <Sukhdev> Does anybody want to add anything to Agenda?
17:06:37 <Sukhdev> #Announcements:
17:06:47 <ashishg> yes can we include the https://review.openstack.org/#/c/172855/ for review
17:06:48 <marutikamat> Ashish wants to add review https://review.openstack.org/#/c/172855/ <https://review.openstack.org/#/c/172855/>
17:07:22 <Sukhdev> marutikamat: Lets discuss these in the Bugs section
17:07:31 <marutikamat> sure
17:07:53 <Sukhdev> Kilo is out and the Liberty Summit is in 3 weeks -
17:08:07 <Sukhdev> anybody wants to announce anything for the team?
17:09:07 <Sukhdev> marutikamat, ashishg: You are free to add things to the agenda beforehand - just update the wiki directly
17:09:28 <Sukhdev> #topic: Action Items from previous week
17:09:40 <Sukhdev> I saw the presentation for the summit
17:10:00 <Sukhdev> I have not had time to review it yet - just did a quick glance at it
17:10:02 <marutikamat> More things to be fleshed out in the slides
17:10:10 <Sukhdev> marutikamat: correct
17:10:14 <marutikamat> they are just a draft version
17:10:24 <marutikamat> Anyone is free to edit them
17:10:32 <Sukhdev> marutikamat: Understood
17:11:02 <Sukhdev> marutikamat: the version you sent, I could not edit - can you send it either google or powerpoint slides form?
17:11:28 <marutikamat> sure
17:12:08 <Sukhdev> yamahata: did you have an opportunity to look at them?
17:12:30 <yamahata> Sukhdev: Not yet. I'll do this week.
17:12:58 <Sukhdev> marutikamat: Also, one more observation - these say HP Helium - Do you want them to be HP specific?
17:13:39 <Sukhdev> marutikamat: my suggestion will be remove this - thoughts?
17:13:50 <marutikamat> We received an e-mail from management to use that template
17:14:02 <marutikamat> I will check and let you know tomorrow.
17:14:20 <yamahata> Helion?
17:14:26 <Sukhdev> marutikamat: Please do -
17:14:38 <Sukhdev> yamahata: Yes
17:14:38 <marutikamat> Yes
17:15:31 <Sukhdev> marutikamat: My suggestion would be to keep the deck generic and then mention at some point about HP solution
17:15:54 <marutikamat> Yes makes sense
17:16:12 <Sukhdev> marutikamat: When you talk about the solution and demo - use HP switches and specific products
17:16:31 <marutikamat> agreed
17:16:53 <Sukhdev> marutikamat: I will do the same - BTW, it is working on Arista TORs as well - I tested in multi-switch topology
17:17:57 <Sukhdev> marutikamat: Once you send the editable version, I will make the updates and send it back to the team for review/discussion
17:18:11 <Sukhdev> Our next meeting will be the last before Summit -
17:18:17 <marutikamat> Great news! :)
17:18:24 <Sukhdev> We should iron out everything by them
17:18:33 <marutikamat> Great news that the solution is working with Arista as well
17:18:49 <Sukhdev> Anything else on this?
17:19:01 <marutikamat> I sent you the editable version just now
17:19:25 <Sukhdev> marutikamat: Cool - thanks - is it in the powerpoint or Google ?
17:19:39 <marutikamat> power point
17:19:56 <Sukhdev> I am an Apple guy - have to make sure have appropriate packages to edit :-):-)
17:20:15 <Sukhdev> Anything on the Summit session planning?
17:20:39 <marutikamat> First let's get the slides in shape
17:20:48 <marutikamat> What do you say?
17:21:00 <Sukhdev> Actually, I have couple of question - will ask later in the meeting
17:21:08 <Sukhdev> marutikamat: Yes - agree
17:21:27 <Sukhdev> marutikamat: lets iterate over email
17:21:32 <marutikamat> Only then we will come to know how much time it will take for us to go through the slides
17:21:53 <Sukhdev> Sounds good
17:22:03 <marutikamat> We will also meet in person before the session and will finalize.
17:22:20 <Sukhdev> marutikamat: good idea
17:22:35 <Sukhdev> #topic: Versioning and Release Management
17:22:50 <marutikamat> I will check if Alok/Ashish can record a demo too
17:23:24 <marutikamat> Armando has to approve the review posted by Sukhdev
17:23:54 <marutikamat> Sukhdev can you check with him?
17:24:00 <Sukhdev> marutikamat: Yes, I was looking for him.
17:24:25 <Sukhdev> Are we in a position to cut the release - there are some critical bugs still open
17:24:36 <Sukhdev> I do not know if you saw this https://review.openstack.org/#/c/177637/
17:24:41 <Sukhdev> #link: https://review.openstack.org/#/c/177637/
17:24:49 <marutikamat> We will fix them in a few more days
17:25:27 <Sukhdev> Our project was not setup with correct ACLs, hence, I could not tag the release - now that this patch is approved, I can tag our project with branches
17:25:47 <Sukhdev> I will create a kilo/stable release branch - within this week.
17:26:11 <Sukhdev> As soon as armax approves my patch, this will be ready to go
17:26:16 <marutikamat> This is good
17:26:31 <Sukhdev> Then I will release networing-l2gw package on pypi
17:26:47 <Sukhdev> I have been purposely dragging my feel to get things stablize
17:27:05 <Sukhdev> I opened a bug late last week - which is very annoying as well -
17:27:28 <Sukhdev> require unstack/stack to move forward - those kinds of bugs are annoying :-)
17:27:40 <marutikamat> A few developers need some clarifications from you on some bugs
17:27:53 <marutikamat> :)
17:28:12 <Sukhdev> marutikamat: That is why I added Bugs as a topic to the agenda - lets cover all of that in there
17:28:26 <Sukhdev> I have one more topic before we jump into Bugs
17:28:32 <marutikamat> ok
17:28:54 <Sukhdev> #topic: OVSDB Sever <-> Neutron Controller connection initiation
17:29:09 <Sukhdev> I wanted to have brief discussion on this -
17:29:35 <marutikamat> Per the blueprint spec, only l2gw agent opens a connection with the OVSDB server unlike NSX
17:29:40 <Sukhdev> Our present solution requires Neutron to open a connection with OVSDB server
17:29:57 <marutikamat> We can include it in the next release
17:30:26 <Sukhdev> marutikamat: correct - I noticed it leaves a security hole (during my testing) - hence, thought if we can discuss and fix
17:30:38 <marutikamat> ok
17:30:43 <Sukhdev> next release is fine - as long as we understand the issue.
17:31:04 <Sukhdev> marutikamat: Perhaps we can add to our future work items.
17:31:08 <marutikamat> You may SSL between the l2gw agent and the OVSDB server to fill this security hole. Any thoughts?
17:31:33 <marutikamat> L2 gw agent already supports SSL
17:32:41 <Sukhdev> There are multiple ways to address the security - but, I was accidently attaching to the wrong switches, and it will let me do it
17:33:21 <Sukhdev> I was launching devstack (forgot to update the IP of the devices) and it will gladly connect to the switches, it was not suppose to connect
17:33:33 <selvakumar_s> Sukhdev: in that case SSL do the trick right ?
17:34:38 <Sukhdev> selvakumar_s: Probably (and will also admit that it was an operator fault) - nonetheless, if we allowed the connection initiation in the reverse direction, this will make it safe
17:35:28 <Sukhdev> selvakumar_s: Also, for those who are used to NSX type of deployments, this will come more natural for them
17:35:32 <marutikamat> We will implement it in the next release.
17:35:39 <Sukhdev> selvakumar_s: for new comers this will not matter
17:36:01 <Sukhdev> marutikamat: Cool - we will add to our future items
17:36:04 <Sukhdev> lets move on
17:36:10 <marutikamat> Ok
17:36:15 <Sukhdev> #Bugs:
17:36:24 <Sukhdev> Let me start with one -
17:36:34 <Sukhdev> the one I added to the agenda
17:36:48 <Sukhdev> #link: https://bugs.launchpad.net/networking-l2gw/+bug/1444188
17:36:48 <openstack> Launchpad bug 1444188 in networking-l2gw "can not create l2 gateway connection without specifying segmentation ID" [Undecided,New]
17:37:07 <Sukhdev> I tried to explain the limitation in the bug explanation - did it make sense?
17:37:43 <marutikamat> Alok/Selva, your observation/analysis on this one.
17:37:44 <Sukhdev> If we allowed segmentation-ID = 0 (to mean untagged packets) that will do the trick
17:38:00 <selvakumar_s> Sukhdev: we need the OVSDB Dump how it should look like in case of no segmentation id
17:38:29 <Sukhdev> selvakumar_s: When I get on the system next, I will capture and paste it to the bug
17:38:44 <selvakumar_s> Sukhdev: we discussed with Alok and HP switch will not work for emtpy vlan_binding for the port table
17:38:44 <marutikamat> Sukhdev, when you do this with NSX, what is the VNI to VLAN binding on the physical port on the OVSDB server table?
17:39:17 <Sukhdev> in general, I want to make sure we are on the same page in terms of tagged vs untagged packets
17:39:17 <marutikamat> Selva, we can try with 0 as Sukhdev mentioned
17:39:47 <selvakumar_s> Sukhdev: For This bug  : Making changes in Front end is easy and we need to understand deeper how it works in OVSDB side if we dont allow segmentation id .
17:39:54 <marutikamat> It will be clear after Sukhdev supplies the OVSDB table dump
17:40:14 <selvakumar_s> Yes Maruti:
17:40:40 <Sukhdev> selvakumar_s: I am not expert on NSX (hence I am working with Artista internal people who are expert in that area) - But, I think NSX allows segmentation ID = 0 for untagged packets
17:41:17 <marutikamat> AI on Sukhdev: Supply the OVSDB dump when you configure with 0 seg ID.
17:41:24 <Sukhdev> selvakumar_s: I will collect more information and how it works on NSX and add to the bug description
17:41:32 <marutikamat> Please paste in the bug report.
17:41:49 <selvakumar_s> Sukhdev: Sure meanwhil we will discuss internally tomorrow
17:41:52 <Sukhdev> #action: Sukhdev to provide the dump of OVSDB server for untagged configuration
17:41:58 <selvakumar_s> Sure
17:42:11 <Sukhdev> Next bug:
17:42:30 <Sukhdev> #link: https://review.openstack.org/#/c/172855/
17:43:34 <Sukhdev> ashishg: you are looking for approval on this, right?
17:43:40 <marutikamat> Sukhdev: Please review it if time permits.
17:43:47 <selvakumar_s> Sukhdev: we have reviewed this patchset internally and we are waiting for armax and you for further  reviewing
17:43:58 <Sukhdev> ashishg: or do you want to discuss anything about it?
17:44:21 <ashishg> yes i want this to be reviewed
17:44:34 <Sukhdev> selvakumar_s: my bad - I actually looked at it twice, but, could not complete the review (because the patch is big) :-)
17:44:55 <Sukhdev> ashishg: I will get to it this week - unless armax beats me to it :-)
17:45:03 <Sukhdev> next bug
17:45:06 <ashishg> ok thanks
17:45:10 <Sukhdev> #link: https://review.openstack.org/#/c/172855/
17:45:43 <Sukhdev> Opps - sorry it the same one
17:45:50 <marutikamat> :)
17:45:56 <Sukhdev> marutikamat: you had two - what is the other one?
17:46:26 <marutikamat> Other one was yours
17:46:37 <marutikamat> https://review.openstack.org/#/c/172742/
17:47:05 <Sukhdev> Oh OK - we are waiting for armax to approve this - unless marutikamat you want to approve it?
17:47:37 <marutikamat> Just wanted armax to check whether his review comments are addressed.
17:48:18 <Sukhdev> marutikamat: sounds good - I will look for him on IRC later
17:48:29 <marutikamat> ok thanks.
17:48:38 <Sukhdev> armax: I see you are online now -
17:48:55 <Sukhdev> There is one more bug - I wanted to bring up -
17:49:01 <Sukhdev> #link: https://bugs.launchpad.net/networking-l2gw/+bug/1447910
17:49:01 <openstack> Launchpad bug 1447910 in networking-l2gw "L2 Gateway creates multiple entries for logical switch" [Undecided,New] - Assigned to MANJUNATH PATIL (mpatil)
17:49:09 <Sukhdev> Did you have a chance to look at this one?
17:49:21 <Sukhdev> This was the latest one I discovered -
17:49:38 <Sukhdev> The worst part is it hard to clear the condition.
17:49:42 <marutikamat> We will figure out the root cause tomorrow.
17:50:26 <Sukhdev> I remved duplicate entry from mysql - as well as reset the OVSDB server (removed from it as well), but will reappear - :-)
17:50:50 <Sukhdev> the only way to clear it was by unstacking/stacking - which is kinda annoying :-)
17:51:12 <marutikamat> If you could described how you ran into this situation (reproducible steps), it will help us to understand it quickly.
17:51:14 <Sukhdev> Anything else on the Bugs?
17:51:58 <Sukhdev> marutikamat: I could not figure out how I got into this mess - All I know is it was working fine with one TOR. I was trying to another TOR to the topology
17:52:48 <marutikamat> OK. We will look into this tomorrow.
17:52:50 <Sukhdev> Once I had all the underlay worked out for the second TOR and went to create a GW and connection and it started rejecting - that is how I discovered this condition
17:53:30 <Sukhdev> Anything else?
17:53:39 <Sukhdev> #Open Discussion:
17:53:51 <Sukhdev> I had couple of question - that I mentioned I will ask later
17:53:57 <Sukhdev> Let me ask them now
17:54:18 <Sukhdev> First question is neutron-l2gw vs, just neutron
17:54:42 <Sukhdev> why did we choose to start our api's with -l2gw option?
17:54:47 <marutikamat> Selva, do you know this info from Preeti?
17:55:20 <Sukhdev> It almost gives the feeling that we are orphan children :-):-)
17:55:21 <selvakumar_s> No idea Maruti . I think armax might be knowing this
17:55:22 <marutikamat> It is because the CLIs code is not part of python neutron client
17:55:49 <Sukhdev> marutikamat: do we intend to align evantually?
17:56:17 <Sukhdev> perhaps I will ask armax when I run into him
17:56:27 <Sukhdev> Second question -
17:56:30 <marutikamat> ok
17:56:36 <Sukhdev> it is related to future work -
17:56:55 <Sukhdev> Shall we plug these APIs into Horizon?
17:56:57 <selvakumar_s> Sukhdev:https://review.openstack.org/#/c/164114/
17:57:17 <selvakumar_s> this review is for l2gateway cli using neutronclient extension.
17:57:19 <marutikamat> Options I can think of: 1. Using manager table of OVSDB to initiate connections from the OVSDB server.
17:57:26 <marutikamat> 2. S/W l2 gateway
17:57:32 <marutikamat> 3. Supporting DVR with l2gw.
17:58:48 <Sukhdev> selvakumar_s: Thanks for the link - I will look at this
17:59:07 <marutikamat> Having l2gw APIs in Horizon looks good too.
18:00:01 <Sukhdev> marutikamat: Yes, all of those are good to add
18:00:24 <Sukhdev> marutikamat: perhaps we should add those to slide deck
18:00:42 <marutikamat> true
18:00:54 <Sukhdev> marutikamat: I can think of another one - VLAN<->VLAN gateway support
18:01:17 <selvakumar_s> Sukhdev: Good point
18:01:32 <marutikamat> Racha wanted to support other types like FLAT or GRE (I don't remember)
18:02:10 <Sukhdev> marutikamat: yes, that is true - we should list these all and then we can prioritize based upon the interest
18:02:19 <Sukhdev> We are out of time - anything else?
18:02:44 <Sukhdev> This is excellent discussion - wish armax was here too :-(
18:02:54 <Sukhdev> Thanks folks
18:03:04 <Sukhdev> #endmeeting