17:04:29 <Sukhdev> #startmeeting networking_l2gw
17:04:30 <openstack> Meeting started Mon Jun  8 17:04:29 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:34 <openstack> The meeting name has been set to 'networking_l2gw'
17:04:54 <Sukhdev> #topic: Agenda
17:04:59 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
17:05:19 <Sukhdev> sorry folks jumping from one meeting to another
17:05:43 <Sukhdev> armax marutikamat : did you have a chance to look at the agenda?
17:05:55 <armax> yes
17:06:09 <marutikamat> Yes I did
17:06:16 <Sukhdev> Are we good with it - or want to cover anything else?
17:06:31 <Sukhdev> #topic: Announcements
17:06:33 <marutikamat> I will add something in the end
17:06:52 <Sukhdev> marutikamat: cool
17:07:05 <Sukhdev> The presentation at summit went very well - I got lots of queries -
17:07:14 <Sukhdev> I am sure you got many as well
17:07:29 <marutikamat> Yes
17:07:29 <Sukhdev> #link: https://www.openstack.org/summit/vancouver-2015/summit-videos/presentation/bringing-provider-networks-into-openstack-using-l2-gateway
17:07:51 <Sukhdev> I was hoping that we will have many additional people joining us today
17:08:13 <Sukhdev> anybody in this meeting who has not introduced themselves yet? Please do so…now...
17:08:57 <Sukhdev> #topic: L2 GW Wiki updated
17:09:10 <Sukhdev> I took some time to update the wiki yesterday
17:09:45 <Sukhdev> #link: https://wiki.openstack.org/wiki/Neutron/L2-GW
17:10:14 <Sukhdev> Please have a look and feel free to update as needed - I also added links to the demos
17:10:33 <Sukhdev> #topic: Requested features in Liberty
17:10:40 <marutikamat> Thanks Sukhdev
17:10:44 <armax> thanks Sukhdev, it looks good
17:10:56 <Sukhdev> I have listed one new feture
17:11:13 <Sukhdev> OVSDB server connection initiation -
17:11:32 <Sukhdev> I briefly chatted with you about it in Vancouver
17:11:49 <armax> Sukhdev: I wonder if we should have a ‘roadmap’ section that shows what we do/did each release
17:11:53 <Sukhdev> We need ability to be able to initiate connection from either side
17:12:09 <Sukhdev> armax: excellent idea
17:12:26 <marutikamat> +1 with armax
17:12:41 <Sukhdev> armax: you want to add, or you want me to do the honors?
17:13:06 <Sukhdev> marutikamat: that goes for you too - I did not mean to exclude you
17:13:09 <marutikamat> I got the idea Sukhdev what you are asking. However, we will need a BP for this.
17:13:31 <armax> Sukhdev: I can sketch something out?
17:13:48 <Sukhdev> armax: cool thanks - let me know if you need any help from me
17:13:49 <armax> marutikamat: either a bp or a bug fix
17:13:57 <armax> marutikamat: I mean bug report
17:14:29 <Sukhdev> I would think a bug should be sufficient - unless you want to go through the hassle of BP
17:14:31 <marutikamat> Per the original spec, all the connections are opened by the gw agents. But in this  change, the connections will be opened by the OVSDB server itself.
17:14:40 <Sukhdev> I could open a bug, if you like
17:15:30 <marutikamat> ok
17:15:52 <Sukhdev> marutikamat: OK - as in OK to open a bug? :-)
17:16:05 <marutikamat> Are we giving an option to the use in ini file?
17:16:20 <marutikamat> s/use/user
17:16:31 <Sukhdev> marutikamat: yes, it will better - but, I am OK either way
17:16:38 <marutikamat> please file a bug
17:16:49 <Sukhdev> marutikamat: will do
17:17:07 <marutikamat> ok, we will figure out after investigation
17:17:25 <Sukhdev> armax marutikamat : any other feature you are considering for Liberty?
17:17:51 <armax> We’ve been saying we wanted a softweare l2gw
17:18:00 <armax> but no-one is stepping up and volunteer
17:18:11 <armax> they all want the cake but not pay for it :)
17:18:20 <Sukhdev> armax: correct :-)
17:18:33 <marutikamat> Yes. Just to inform you, myself and selva have been pulled out and put into some other projects. I was also thinking of support for service node and supporting l2gw through ODL
17:18:49 <Sukhdev> armax: I am a bit disappointed - I was hoping to see lot more new people here asking for all kinds of features
17:19:09 <marutikamat> armax i will send out a separate e-mail on the l2gw-ODL integration
17:19:15 <armax> marutikamat: ok, let’s sync up offline
17:19:40 <armax> Sukhdev: perhaps we need more advertising, during the neutron irc meeting?
17:20:07 <Sukhdev> armax: I did few times in the past - I'll put it on next week's meeting
17:20:27 <marutikamat> nsx supports service node for unknown traffic. we should also support it.
17:21:25 <Sukhdev> marutikamat: you mean punt all BUM traffic to service node?
17:21:49 <marutikamat> one more item s DVR with l2gw
17:22:02 <armax> we should start building a backlog of items, via bug list and whatnot
17:22:04 <marutikamat> yes Sukhdev
17:22:49 <Sukhdev> armax: Actually, we can list them on the wiki - when you list roadmap, perhaps we can add a section for future (long term) items -
17:23:02 <Sukhdev> armax: that may generate interest among others
17:23:12 <armax> Sukhdev: I was thinking that the roadmap should capture big ticket items
17:23:23 <armax> and duplicating the list is a bit of a pain to keep in sync
17:23:57 <Sukhdev> armax: we can create a bug and put the pointer under roadmap - that will keep things easy
17:24:21 <Sukhdev> marutikamat: can you open bugs for each of the items you mentioned?
17:24:31 <marutikamat> ok sure Sukhdev.
17:24:42 <marutikamat> please put action item on me
17:24:43 <armax> Sukhdev: ok, let me see what we put together
17:25:20 <marutikamat> Is Isaku there in the meeting?
17:25:21 <Sukhdev> #action: marutikamat to create bugs for each of the new feature enhancements for L2 Gateway
17:25:38 <Sukhdev> marutikamat: I do not see him here
17:25:52 <marutikamat> He was keen in software l2gw.
17:26:24 <Sukhdev> yes, he expressed interest, but, never came forward with anything concrete
17:27:22 <Sukhdev> #action: Sukhdev to open a bug for OVSDB connection initiation from OVSDB server
17:27:32 <Sukhdev> #topic: Bugs
17:27:58 <Sukhdev> marutikamat: I had discussed with you about the flood list issue
17:27:59 <marutikamat> Sukhdev, people are facing problems while backporting the fixes
17:28:16 <Sukhdev> marutikamat: what is the issue?
17:28:37 <Sukhdev> armax: is expert in this kinds of issues - I usually bug him when I get stuck :-):-)
17:28:38 <marutikamat> Our test enginners (Ashish and Alok) are able to ping from bare metal server to the VM first.
17:28:40 <Sukhdev> but, I can help
17:29:19 <marutikamat> vikas sent you an email on that. the branch shows as master even if he is trying to commit on kilo/stable.
17:29:23 <Sukhdev> marutikamat: after the first ping from VM or adding arp entry solves it
17:29:57 <marutikamat> they do not ping from VM first. The first ping itself from BM to VM works for them.
17:30:03 <armax> marutikamat: are you saying that this is a regression?
17:30:17 <armax> marutikamat: or in other works did the test case ever pass?
17:30:21 <marutikamat> I was expecting their email reply to you but they missed it out today,
17:30:26 <Sukhdev> marutikamat: the best way to do is to go on the review board - open the patch which merged in master - and click on a tab called cherry pick - click on it and rest is easy
17:30:27 <marutikamat> I will check with them again tomorrow.
17:30:48 <armax> if so, a good tool to use would be git bisect
17:31:36 <marutikamat> thanks to both of you for the suggestion
17:31:48 <Sukhdev> marutikamat: I think the best way to go about is to dump the OVSDB contents and paste it - I sent you the paste from my side
17:31:59 <armax> marutikamat: that’s a handy and quick tutorial http://webchick.net/node/99
17:32:06 <marutikamat> Sukhdev: I will request Alok/Ashish to get in touch with you for the ping problem
17:32:10 <Sukhdev> marutikamat: I see that HS VTEP publishes the flood list and SW VTEP does not
17:32:21 <armax> marutikamat: basically ‘bisect’ will help you identify what commit broke the feature
17:32:23 <Sukhdev> marutikamat: cool -
17:32:39 <armax> and then it’s easier to understand what’s going, that assumed that it is a regression
17:32:46 <marutikamat> armax: thanks
17:33:47 <Sukhdev> armax: thanks for sharing this tool - I did not know about it
17:34:07 <armax> Sukhdev: sure thing
17:34:23 <Sukhdev> As to the bugs - I approved few
17:34:42 <Sukhdev> I will review more and approve them this week
17:34:52 <marutikamat> thanks Sukhdev
17:35:05 <Sukhdev> we are looking good from the bugs point of view
17:35:22 <Sukhdev> marutikamat: I have exhausted my agenda items
17:35:32 <Sukhdev> you mentioned you wanted to bring something ?
17:35:41 <Sukhdev> #topic OpenDiscussion
17:35:51 <Sukhdev> Lets hear it
17:36:33 <marutikamat> I already mentioned above. Additional backlog items
17:36:48 <Sukhdev> Oh I see - cool
17:36:48 <marutikamat> I will submit bugs for those
17:36:55 <Sukhdev> good
17:36:59 <Sukhdev> anything else?
17:37:13 <marutikamat> nothing from me
17:37:23 <Sukhdev> Looks like we are done -
17:37:32 <Sukhdev> thanks folks
17:37:46 <marutikamat> thanks both of you
17:38:02 <Sukhdev> #endmeeting