17:07:37 <Sukhdev> #startmeeting networking_l2gw
17:07:38 <openstack> Meeting started Mon Jun 22 17:07:37 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:41 <openstack> The meeting name has been set to 'networking_l2gw'
17:07:50 <Sukhdev> #topic: Agenda
17:08:02 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
17:08:20 <Sukhdev> #topic: Annoncements
17:08:39 <Sukhdev> Looks like Maruti has moved on to a different project
17:08:50 <Sukhdev> phanipawan: can you please fill us in
17:08:59 <phanipawan> yeah
17:09:13 <phanipawan> currently there are couple of patchsets in review
17:09:22 <vik_> yes
17:09:37 <phanipawan> and there are couple of bug fixes which require the posted patchset to be merged
17:09:45 <Sukhdev> phanipawan: we can get into the patchs later in the meeting -
17:09:57 <phanipawan> ok sukhdev
17:10:08 <Sukhdev> can you explain the roles of the people so that I can reach out to the right people regarding issues
17:10:45 <phanipawan> at the point of time we were busy in our internal projects
17:10:57 <phanipawan> so only few of them are working on the bug fixes
17:11:39 <Sukhdev> phanipawan: who has moved on (in addition to Maruti) and who is working on L2 GW?
17:11:52 <phanipawan> sukhdev : how do u want us to move further with the l2 gateway project?
17:12:25 <phanipawan> currently myself, manjunath and vikas are working on l2gateway, Maruti and selvakumar has moved on
17:12:46 <Sukhdev> phanipawan: oh I see - thanks for sharing this information
17:13:13 <Sukhdev> phanipawan: This is still a good time for all of you to attend this meeting?
17:13:33 <phanipawan> It is 10.30 pm in the night
17:13:41 <Sukhdev> :-)
17:13:47 <phanipawan> if we can move this meeting early then it would be helpful
17:14:04 <amotoki> phanipawan: you seem to be in india.
17:14:05 <phanipawan> :-)
17:14:23 <Sukhdev> Let me discuss this with armax and see what can we do
17:14:25 <phanipawan> amotoki: yeah
17:15:09 <Sukhdev> #action: Sukhdev to work with armax to come up with an earlier slot for this meeting
17:15:21 <Sukhdev> #topic: Action Items
17:15:46 <Sukhdev> phanipawan: Maruti had an action to create bugs for new features - did he discuss it with you?
17:17:05 <vik_> i think he has created
17:17:08 <Sukhdev> vik_: feel free to jump in - if you have information on this to share
17:17:31 <Sukhdev> I had an action to create one as well
17:17:35 <phanipawan> sukhdev : yes, he has created the bugs
17:17:43 <Sukhdev> vik_: Do you have the links?
17:17:47 <phanipawan> but we are not sure abt the implementation part
17:17:56 <Sukhdev> #link: https://bugs.launchpad.net/networking-l2gw/+bug/1466302
17:17:58 <openstack> Launchpad bug 1466302 in networking-l2gw "OVSDB Server connection initiation to be configurable" [Undecided,New]
17:18:15 <Sukhdev> This is the one I created - for a new feature
17:18:34 <Sukhdev> we discussed this one in the last meeting as well as in Vancouver
17:18:39 <phanipawan> https://bugs.launchpad.net/networking-l2gw/+bug/1463783
17:18:39 <openstack> Launchpad bug 1463783 in networking-l2gw "Networking L2 Gateway does not support software L2 gateway" [Undecided,New]
17:18:52 <vik_> i will confirm ..pls give me a minute
17:19:16 <Sukhdev> #link: https://bugs.launchpad.net/networking-l2gw/+bug/1463783
17:19:41 <koteswar> Bug 1463784, Bug 1463788, Bug 1463783, Bug 1463666 - these are the defects raised by maruti
17:19:43 <openstack> bug 1463784 in networking-l2gw "Networking L2 Gateway does not work with DVR" [Undecided,New] https://launchpad.net/bugs/1463784
17:19:45 <openstack> bug 1463788 in networking-l2gw "Networking L2 gateway REST APIs cannot be invoked by Horizon dashboard" [Undecided,New] https://launchpad.net/bugs/1463788
17:19:46 <openstack> bug 1463783 in networking-l2gw "Networking L2 Gateway does not support software L2 gateway" [Undecided,New] https://launchpad.net/bugs/1463783
17:19:48 <openstack> bug 1463666 in networking-l2gw "Networking L2 Gateway does not support service node to handle unknown BUM traffic" [Undecided,New] https://launchpad.net/bugs/1463666
17:20:09 <vik_> https://bugs.launchpad.net/networking-l2gw/+bug/1463788
17:20:20 <Sukhdev> koteswar: got it - thanks
17:20:24 <vik_> https://bugs.launchpad.net/networking-l2gw/+bug/1463784
17:20:53 <Sukhdev> This leads me into the next topic:
17:21:06 <Sukhdev> #topic Bugs:
17:21:34 <Sukhdev> phanipawan: you had started with discussing about the bugs - now is a good time to discuss it
17:21:48 <vik_> https://review.openstack.org/#/c/185357/
17:22:04 <vik_> https://review.openstack.org/#/c/180403/
17:22:11 <phanipawan> sukhdev : there are couple of important patchsets which are waiting to be reviewed
17:22:42 <vik_> these are the patch sets which address some three to four issues
17:22:53 <phanipawan> we need your help in reviewing those patchsets
17:22:59 <Sukhdev> phanipawan: vik_ posted two - are there any more?
17:23:01 <vik_> yes
17:23:14 <Sukhdev> I will review these today
17:23:52 <Sukhdev> Any other patch other than these two?
17:24:07 <vik_> i think only these two are remaining
17:24:23 <phanipawan> only these two are the major patchsets remaining
17:24:39 <Sukhdev> phanipawan vik_ : will get to it today
17:24:40 <phanipawan> these two patchsets will fix 3 critical bugs
17:25:06 <Sukhdev> phanipawan: got it - also, be sure to back port to stable/kilo as well
17:25:20 <vik_> sure
17:25:21 <phanipawan> sukhdev: there are 2 more bug fixes, for which i will raise a review tomo or day after
17:25:55 <Sukhdev> as soon as they are approved and merged, you can simply click on "cherry pick" button to submit to the stable/kilo
17:26:09 <Sukhdev> phanipawan: sure no problem - I will look for those as well
17:26:23 <phanipawan> thanks
17:26:42 <Sukhdev> phanipawan: I wanted to discuss about this - https://bugs.launchpad.net/networking-l2gw/+bug/1466302
17:26:43 <openstack> Launchpad bug 1466302 in networking-l2gw "OVSDB Server connection initiation to be configurable" [Undecided,New]
17:27:05 <Sukhdev> phanipawan: what would it take to get this one done?
17:27:45 <Sukhdev> Maruti, Selva, and I discussed about this - they felt it could be done very easily -
17:28:11 <phanipawan> sukhdev: i think there are some more investigations need to be done on how we can achieve this
17:28:21 <phanipawan> do u have any pointers?
17:28:47 <Sukhdev> phanipawan: is it possible for you to speak with Maruti?
17:29:07 <Sukhdev> phanipawan: is he available for you to talk to or has he moved physically?
17:29:19 <vik_> he is available
17:29:34 <vik_> we will discuss this with him
17:29:35 <phanipawan> sukhdev: we will talk with him on this subject
17:30:03 <Sukhdev> vik_: he should be able to give you full details (selva) as well - as three of discussed the details of its implementation
17:30:20 <vik_> ok
17:30:38 <Sukhdev> anything else on your mind?
17:31:17 <Sukhdev> phanipawan, vik_ koteswar: if you need to get hold of me, feel free to send me an email at sukhdev@arista.com
17:31:33 <vik_> yes sure
17:31:49 <phanipawan> sukhdev: yeah sure
17:32:32 <phanipawan> sukhdev: is that the most priority item currently in l2 gateway?
17:32:46 <Sukhdev> there was another bug (which I have not filed) but, has been discussed in the email - regarding flooding the remote macs
17:32:50 <Sukhdev> phanipawan: yes
17:34:45 <Sukhdev> phanipawan: this is the email where Ashish Gupta, you, and others are copied
17:35:00 <Sukhdev> I do not see vik_ or koteswar copied on that email
17:35:30 <phanipawan> sukhdev: yes i know abt that issue
17:35:46 <phanipawan> but we could not find that issue in our setup
17:35:48 <vik_> ya i don't know about this..can you please forward that?
17:35:52 <Sukhdev> phanipawan: I have been waiting for reply to that email :-):-)
17:36:09 <Sukhdev> vik_: email?
17:36:36 <Sukhdev> vik_: I mean what is your email?
17:36:40 <vik_> vikas.d-m@hp.com
17:36:42 <phanipawan> sukhdev: can you please find out the scenario where the MCAST_MACS_REMOTES table in OVSDB is entered
17:37:09 <phanipawan> because that entry is not getting populated in our setup
17:37:22 <Sukhdev> phanipawan: I sent out the dump of the OVSDB - this had it
17:37:23 <phanipawan> we tried to debug that issue
17:38:05 <Sukhdev> phanipawan: I sent the dump which showed that the Arista HW vtep was publishing that information, but, the OVS vtep was not
17:38:32 <phanipawan> ohh
17:38:35 <Sukhdev> phanipawan: I can try to locate that dump and re-sent it
17:39:13 <Sukhdev> vik_: I just forwarded you the email
17:39:17 <phanipawan> sukhdev: in which case the ARISTA HW vtep populates that information?
17:39:27 <phanipawan> can you please let us know
17:40:07 <vik_> ya got it
17:40:14 <Sukhdev> phanipawan: Anything it see behind it (i.e. BMs connected behind it), it will publish their macs
17:41:30 <phanipawan> sukhdev: But the BMs connected behind it are entered into the Mcast_Mac_Local in our case
17:41:51 <phanipawan> the Mcast Mac Remote are not at all populated
17:42:16 <phanipawan> we need to figure out why it is behaving differently
17:44:06 <Sukhdev> sorry got disconneced
17:44:36 <Sukhdev> phanipawan: I do not know my last two messages made it or not - did not realized I was disconnected :-)
17:45:01 <phanipawan> sukhdev: can u repost your messages
17:45:18 <Sukhdev> i mean publish to the remove vtep as the remote macs - so that the remote vtep knows that those macs are behind HW vtep - this is needed only for the first ping
17:45:28 <Sukhdev> If SW vtep published the same thing in the reverse, then HW vtep will know that a VM is behind remote (SW) vtep, hence, the BM to VM, and hence the first ping from BM to VM will work
17:45:35 <Sukhdev> phanipawan: just did
17:47:54 <Sukhdev> phanipawan: does it make sense?
17:48:18 <phanipawan> sukhdev: i am still confused
17:48:32 <Sukhdev> phanipawan: :-)
17:49:27 <Sukhdev> phanipawan: if you see the HW VTEP schema and see the purpose of remote mac table - that might help explain
17:50:09 <Sukhdev> L2 GW does not populate it at all - under no circumstances
17:50:28 <phanipawan> sukhdev: i think we will do some investigation on this and then come to you
17:50:47 <phanipawan> if we find anything then we will drop u an email
17:50:56 <phanipawan> if that's ok with you?
17:51:17 <Sukhdev> phanipawan: even I am not expert on this - hence, I had included our local expert on the email - please feel free to reply to that email, he will help explain better than I can :-)
17:52:14 <phanipawan> sukhdev: sure, we will verify and try to reproduce this on our setup
17:52:18 <Sukhdev> phanipawan: yup that will be good - but, the best thing will be reply to that email, and ask Ashwin to explain it to you better - he will be happy to do it
17:52:38 <Sukhdev> phanipawan: Thanks
17:52:51 <phanipawan> sukhdev : sure :-)
17:52:56 <Sukhdev> With this I am done with the agenda
17:53:07 <Sukhdev> Do you guys have anything you want to discuss?
17:53:34 <phanipawan> nothing at the moment
17:53:47 <vik_> same here
17:53:54 <Sukhdev> cool - in that case we are done
17:54:05 <Sukhdev> Thanks guys
17:54:14 <Sukhdev> #endmeeting