17:01:21 <Sukhdev> #startmeeting networking_l2gw
17:01:21 <openstack> Meeting started Mon Aug 17 17:01:21 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:24 <openstack> The meeting name has been set to 'networking_l2gw'
17:01:44 <Sukhdev> #topic: Agenda
17:01:50 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
17:01:56 <Sukhdev> vikas: hello
17:02:27 <Sukhdev> Anybody would like to add anything to the agenda
17:02:58 <vikas> i think only we two are there?
17:03:27 <Sukhdev> vikas: anybody else from india team here?
17:03:33 <marutikamat> I am here
17:03:41 <marutikamat> Hi everyone
17:04:08 <Sukhdev> marutikamat: hello
17:04:38 <marutikamat> Sukhdev: Hello
17:04:41 <Sukhdev> I do not see armax here yet
17:05:04 <Sukhdev> #topic: Announcements
17:05:20 <Sukhdev> The FF is approaching really fast
17:05:57 <Sukhdev> anybody has any announcement to share with us?
17:06:16 <marutikamat> FF is by the month-end isn't it?
17:06:25 <Sukhdev> yes -
17:06:50 <Sukhdev> marutikamat: by the time we meet next, we will be hitting the FF
17:07:06 <marutikamat> I agree with you
17:07:15 <marutikamat> We have to submit everything by that time
17:07:21 <marutikamat> whatever pending items
17:07:25 <marutikamat> we have
17:07:33 <Sukhdev> few issues to cover -
17:07:41 <Sukhdev> #topic CI breakage
17:07:55 <Sukhdev> marutikamat: what is up with the hp CI breakage?
17:08:05 <Sukhdev> this is blocking all the merges
17:08:56 <Sukhdev> I was hoping armax will have an update for us. He is not here marutikamat, do you have any update on this?
17:09:02 <marutikamat> Did Vikas or Preeti get a chance to look at the hp CI?
17:09:04 <vikas> i think its get cleared..phani patches were merged
17:09:50 <Sukhdev> vikas: oh - that is a great news - this must have happened while I was sleeping - I checked it last night and it was still failing
17:10:29 <Sukhdev> vikas: so, are you saying we are unblocked now?
17:10:41 <vikas> yes in kilo branch may be..but in master ,his patches were merged
17:10:48 <marutikamat> I saw the last email on 8/17 at 9.30pm shows the hp CI for l2gw is still failing
17:11:34 <Sukhdev> vikas; look at this - https://review.openstack.org/#/c/194919/
17:11:37 <marutikamat> Traceback (most recent call last):
17:11:38 <marutikamat> File "networking_l2gw/tests/api/test_l2gw_negative.py", line 127, in test_delete_l2gw_associated_l2gw_connection
17:11:38 <marutikamat> l2_gateway_id=l2_gateway['id'], network_id=net_id)
17:11:38 <marutikamat> File "/opt/stack/networking-l2gw/.tox/api/src/neutron/neutron/tests/tempest/services/network/json/network_client.py", line 140, in _create
17:11:38 <marutikamat> resp, body = self.post(uri, post_data)
17:11:38 <marutikamat> File "/opt/stack/networking-l2gw/.tox/api/local/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 256, in post
17:11:38 <marutikamat> return self.request('POST', url, extra_headers, headers, body)
17:11:39 <marutikamat> File "/opt/stack/networking-l2gw/.tox/api/local/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 643, in request
17:11:39 <marutikamat> resp, resp_body)
17:11:40 <marutikamat> File "/opt/stack/networking-l2gw/.tox/api/local/lib/python2.7/site-packages/tempest_lib/common/rest_client.py", line 705, in _error_checker
17:11:40 <marutikamat> raise exceptions.Conflict(resp_body)
17:11:41 <marutikamat> tempest_lib.exceptions.Conflict: An object with that identifier already exists
17:11:41 <marutikamat> Details: {u'message': u'Duplicate segmentation ID for the interface name=FortyGigE1/0/1 uuid=226f22e3-841c-48d2-82ee-aad0daa559d3', u'detail': u'', u'type': u'L2GatewayDuplicateSegmentationID'}
17:11:42 <marutikamat> Ran 21 tests in 309.913s
17:12:47 <Sukhdev> vikas: the previous one was for kilo - here is the one from master - https://review.openstack.org/#/c/205866/
17:13:44 <Sukhdev> marutikamat: that traceback seems to imply actual failure/bug
17:15:25 <Sukhdev> vikas: any thoughts on this?
17:15:39 <marutikamat> I will request vikas to work with ashish to get it resolvd
17:15:42 <marutikamat> resolved*
17:16:08 <marutikamat> hi armax
17:16:23 <Sukhdev> we are down to the wire from the timing prospective
17:17:01 <marutikamat> I  think let's continue with the current timings
17:17:23 <vikas> ok maruti..i will work with ashish on this issue
17:17:30 <marutikamat> Sukhdev: can you please put an action item on vikas?
17:18:07 <Sukhdev> #action: vikas to work with ashish to resolve the CI blockage issue
17:18:28 <Sukhdev> #topic: Bugs
17:18:53 <Sukhdev> #link: https://review.openstack.org/#/q/status:open+project:openstack/networking-l2gw,n,z
17:19:20 <Sukhdev> Some of these patches are sitting there for a while because of CI issue
17:19:29 <Sukhdev> I wanted to cover few of these -
17:19:52 <Sukhdev> vikas: any update on this - https://review.openstack.org/#/c/208524/
17:20:14 <Sukhdev> vikas: We would like to get this done ASAP so that it can go into Liberty -
17:20:15 <vikas> yes sukdev..i am working on it
17:20:44 <Sukhdev> It is still in WIP since last time - can we help in any way to get this moving along?
17:21:19 <vikas> i have some technical issues to be resolved .. i am working with maruti to resolve those
17:21:38 <marutikamat> https://review.openstack.org/#/c/202495/ - I have implemented remaining use cases. However, one part is not working (creating a port after l2-gateway-connection is created). I have to sync the latest upstream code and retry.
17:21:38 <Sukhdev> vikas: cool - thanks
17:22:13 <vikas> yes i will send a mail incase i need your guidance
17:22:32 <Sukhdev> marutikamat: ah cool this was the next one on my list :-)
17:22:40 <marutikamat> :-)
17:22:59 <marutikamat> I will post the next complete patch within this week
17:23:00 <Sukhdev> marutikamat: looks like you are on top of this -
17:23:06 <marutikamat> yes
17:23:17 <Sukhdev> marutikamat: once you have an updated version, let me know, we can test it for you
17:23:36 <marutikamat> Sukhdev: sure
17:23:52 <Sukhdev> vikas: that goes for your patch as well - as soon as you able to move forward, let me know the updated version of the patch and we can test it for you
17:24:17 <vikas> yes sure
17:24:37 <Sukhdev> marutikamat: this is the next one - https://review.openstack.org/#/c/206638/
17:26:02 <marutikamat> Sukhdev: I have tested the patch with more changes. It works well. Only thing is that I have to update the unit test cases and post the next patch set
17:26:40 <Sukhdev> marutikamat: cool - so, looks like some logistical issues - not too bad -
17:26:48 <marutikamat> corret
17:26:51 <marutikamat> correct*
17:27:05 <Sukhdev> here is the one which has been sitting there for a while without any review - https://review.openstack.org/#/c/189708/
17:27:18 <Sukhdev> marutikamat: what is up with this one?
17:28:58 <marutikamat> Sukhdev: I will have to check with Jatin to analyze the problem.
17:29:07 <marutikamat> I will do it tomorrow.
17:29:18 <Sukhdev> marutikamat: cool - thanks
17:29:33 <Sukhdev> one last thing -
17:30:11 <Sukhdev> preeti was having some issues with her patch - any word on that?
17:31:43 <marutikamat> Sukhdev: She was able to complete it, and posted a new patch set if I am not wrong.
17:31:57 <marutikamat> She has to address review comments
17:32:59 <Sukhdev> marutikamat: is this the one - https://review.openstack.org/#/c/212430/
17:33:40 <marutikamat> Sukhdev: Yes
17:34:05 <Sukhdev> marutikamat: I looked at it yesterday and posted a comment - I will keep an eye on it
17:34:31 <Sukhdev> she is not here - she needs to upload the newer version so that it can be reviewed and moved forward
17:35:00 <marutikamat> Sukhdev: I will check with her again tomorrow
17:35:14 <Sukhdev> marutikamat: cool - thanks
17:35:24 <Sukhdev> With this I am done with my list of bugs
17:35:43 <Sukhdev> marutikamat vikas: do you have a patch/bug that you want to bring up?
17:36:08 <vikas> no i dont have..
17:36:31 <marutikamat> Sukhdev: Not from me
17:36:41 <Sukhdev> cool -
17:36:49 <Sukhdev> #topic: Open Discussion
17:37:04 <Sukhdev> Well, that brings us to the last topic on the agenda
17:37:17 <Sukhdev> Anything in general to discuss?
17:37:38 <Sukhdev> Please keep in mind that we have only 2 weeks left to get everything merged in -
17:37:53 <marutikamat> Sukhdev: I agree
17:38:03 <vikas> yes
17:38:12 <Sukhdev> vikas: so, this puts pressure on you to get the CI fixed and the patch  - :-):-)
17:38:26 <vikas> :-)
17:38:33 <marutikamat> I heard that backporting to Kilo is now stopped?
17:38:43 <marutikamat> Sukhdev: Is that true?
17:39:16 <Sukhdev> marutikamat: I think it is because the window to cut the next stable release is passed -
17:39:31 <Sukhdev> marutikamat: but, we can still continue to merge into our repo for kilo
17:40:18 <marutikamat> Sukhdev: Thanks for the info
17:40:40 <Sukhdev> we can request a special release - this is my understanding
17:40:44 <marutikamat> Sukhdev: Thanks for the info
17:41:23 <Sukhdev> marutikamat, vikas: Do you believe we need to meet again next week - considering the FF deadline? or we are OK without it
17:42:14 <Sukhdev> we can continue to communicate over email as well - but. I am getting a bit concerned that we may miss the deadline
17:42:17 <marutikamat> We are OK without it. We can communicate via email
17:42:37 <marutikamat> Otherwise is also OK. We can meet as usual
17:42:38 <Sukhdev> marutikamat: sounds good - just wanted to throw it out there
17:42:59 <Sukhdev> cool then
17:43:03 <Sukhdev> anything else?
17:43:46 <vikas> nothing from myside
17:43:50 <Sukhdev> looks like we are done
17:44:10 <marutikamat> Yes
17:44:13 <Sukhdev> Thanks folks - looking forward to seeing those patches merged
17:44:21 <marutikamat> Bye Sukhdev and vikas
17:44:25 <Sukhdev> bye
17:44:30 <vikas> thanks sukdev..
17:44:31 <Sukhdev> #endmeeting