17:02:13 <Sukhdev_> #startmeeting networking_l2gw
17:02:13 <openstack> Meeting started Mon Oct 12 17:02:13 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:17 <openstack> The meeting name has been set to 'networking_l2gw'
17:03:07 <Sukhdev_> #topic: Agenda
17:03:13 <Sukhdev_> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway#Meeting_October_12.2C_2015
17:03:21 <Sukhdev_> armax: are you here?
17:03:30 <armax> yes
17:03:37 <armax> fighting a gate breakage though
17:03:52 <Sukhdev_> I do not see anybody from India team here
17:04:43 * eshedg slaps gampel around a bit with a large fishbot
17:05:20 <Sukhdev_> Ofer - are you here? I do not know your IRC handle
17:05:24 <eshedg> hi sukhdev, i would like to add an item to the agenda
17:05:36 <eshedg> eran gampel & myself are attending, instead of Ofer
17:05:57 <Sukhdev_> eshedg: welcome
17:06:15 <Sukhdev_> Waiting for India team to join us
17:06:21 <eshedg> tnx.  sure.
17:07:05 <Sukhdev_> #topic: Release planning
17:07:35 <Sukhdev_> We are down to three patches that need to be merged before we can release L2GW package
17:08:13 <Sukhdev_> armax: we need your blessing on the three patches so that I can approve them for merge so that we can release it
17:08:30 <armax> Sukhdev_: which are they?
17:08:49 <Sukhdev_> armax: https://review.openstack.org/#/c/202495/
17:09:03 <Sukhdev_> https://review.openstack.org/#/c/222841/
17:09:22 <Sukhdev_> and, https://review.openstack.org/#/c/206638/
17:09:32 <armax> Sukhdev_: you’re not going to get my blessing on 202495
17:09:41 <armax> Sukhdev_: I think it is wrong
17:10:04 <armax> and so is 222841
17:10:09 <armax> as for 206638
17:10:24 <armax> I see no follow up
17:10:27 <armax> on my -1
17:11:24 <Sukhdev_> I wonder if maruti is on PTO
17:11:37 <armax> russell’s point on switching to ovslib must be addressed if we want the l2gw project to be other to other contributions
17:11:43 <armax> we can’t ignore people’s feedback
17:11:49 <armax> especially if it’s valid one
17:12:13 <Sukhdev_> I saw his email last week stating that he has addressed your comments - perhaps it was on a different patch
17:13:04 <Sukhdev_> I think his email was about 202495 - sorry about confusion
17:13:30 <Sukhdev_> His email seems to suggest he addressed your concerns -
17:14:35 <Sukhdev_> armax: can you please respond to maruti's email and give him your feedback as to what he needs to address the concerns - so, that we can get this merged?
17:15:17 <armax> Sukhdev_: why? he said ‘done’ and ‘done'
17:15:23 <armax> Sukhdev_: maybe he forgot to push?
17:15:49 <armax> Sukhdev_: besides, without CI passing, do you really want to merge?
17:16:30 <Sukhdev_> armax: I am confused - I see +1 from jenkins
17:16:43 <armax> not jenkins the 3rd party ci
17:17:40 <Sukhdev_> Oh I see - since maruti is not here, it is bit hard...let me follow up with his email and lets see if we can get to some resolution on this
17:18:14 <Sukhdev_> other than that I do not have anything additional on this..
17:18:24 <Sukhdev_> we can move on to the next topic -
17:19:04 <Sukhdev_> #topic: L2GW as cloud-interconnect
17:19:14 <Sukhdev_> eshedg: you are up
17:19:26 <eshedg> yep.  gampel and me are here.
17:19:32 <gampel> We think that with adding additional optional API to the L2 GW and small modification to the HW vtep schema this is possible
17:19:46 <Sukhdev_> eshedg: in the last meeting we had asked for some kind of writeup on this
17:19:58 <gampel> to use the L2 Gw API to connect Openstack cloud
17:20:14 <gampel> yes i uploaded slide https://drive.google.com/file/d/0B6xagq1_AACadE40WVBXS196b2M/view?pli=1
17:20:31 * Sukhdev_ looking
17:20:53 <Sukhdev_> #link: https://drive.google.com/a/arista.com/file/d/0B6xagq1_AACadE40WVBXS196b2M/view?pli=1
17:21:01 <Sukhdev_> armax: you may want to look at this
17:21:12 * armax looking
17:22:40 <armax> I think what concerns me the most about this use case is the fact that there are too many ‘caveats'
17:23:01 <eshedg> like what?
17:23:12 <armax> if I udnerstand it correctly you have two totatlly independent openstack deployments
17:23:14 <armax> correct?
17:23:23 <gampel> yes
17:23:25 <armax> and you want to take 2 neutron logical networks
17:23:43 <armax> and connect the data plane
17:23:53 <armax> so that it looks like a single broadcast doamin
17:23:55 <armax> domain
17:23:57 <armax> is that so?
17:24:30 <gampel> yes but it could be discovery driven or DB (SDN) driven
17:24:38 <armax> ok
17:25:13 <Sukhdev_> so, it could be openstack on both side or hybrid model
17:25:33 <gampel> we think that if we add to the Vtep HW to the locater a tunnel id
17:25:43 <armax> the problem I envision is that these logical networks must be crafted in a way that they can actually work together
17:25:53 <armax> like IP spaces, gateways, etc
17:26:00 <armax> to not mention routing
17:26:22 <eshedg> okay, the use case we have in mind is the "tricircle"
17:26:34 <eshedg> where we have an orchestration "over cloud" that handles it
17:27:00 <armax> ok, without something on ‘top’ that abstract everything
17:27:22 <armax> this feature alone is too error-prone
17:27:23 <gampel> The cascading project that create a shared network resource
17:27:48 <gampel> we need validation process
17:27:53 <gampel> i agree
17:28:10 <armax> so I’d rather see that take shape first
17:28:34 <armax> I wouldn’t personally want to expose such a capability with some overarching solution that ensure usability
17:28:47 <armax> *without
17:29:30 <eshedg> we agree that this functionality without a "top" is cumbersome
17:29:50 <gampel> we could think on a authentication of the two sides that agree to connect the two networks
17:29:52 <eshedg> but there still is merit in it, if some user wants to connect manually multiple clouds, without a top management
17:30:32 <armax> eshedg: without proper safeguards, I bet that could be really hard to achieve successfully
17:30:38 <armax> there are way to many ‘gotchas'
17:30:43 <eshedg> i agree that this is a far-fetch
17:30:49 <Sukhdev_> eshedg: I see the use case - but, as armax pointed out - the routing and IP management needs to be addressed
17:30:51 <eshedg> however, we wanted to re-use as much as we could with tricircle
17:31:33 <eshedg> if we could extend l2gw APIs for the tricircle "top cloud" use case, it would be better
17:32:11 <eshedg> otherwise, we will need to create the "border gateway" within tricircle project
17:32:19 <Sukhdev_> eshedg: I am not familiar with tricircle - any pointers?
17:32:35 <eshedg> gampel will send it
17:32:46 <armax> how to do handle the default gateway on the network’s subnet?
17:32:55 <armax> host routes etc?
17:33:29 <eshedg> good question. we differentiate between "l2" cross-cloud connectivity
17:33:33 <eshedg> and "l3" connectivity
17:33:34 <gampel> design doc of https://docs.google.com/document/d/19BXf0RhkH8wEEymE2eHHqoDZ67gnzgvpr3atk4qwdGs/edit?usp=sharing
17:34:01 <eshedg> if it's "l2", then it's a single broadcast domain
17:34:07 <Sukhdev_> #link: https://docs.google.com/document/d/19BXf0RhkH8wEEymE2eHHqoDZ67gnzgvpr3atk4qwdGs/edit#heading=h.5r6zgqbiehsh
17:34:21 <eshedg> if it's "l3" then the subnets are different on each physical site
17:35:10 <armax> I would have to read through and digest these docs
17:35:25 <eshedg> okay, excellent
17:35:39 <Sukhdev_> me too - I must agree that this is an interesting use case
17:35:48 <Sukhdev_> I will review these documents as well
17:36:21 <Sukhdev_> eshedg gampel: are you going to be in Tokyo?
17:36:24 <eshedg> yes
17:36:27 <gampel> Yes
17:36:43 <Sukhdev_> Can we set up some time to discuss this in person?
17:36:46 <armax> I can see the use case, my only concern is the usability
17:36:47 <gampel> we have a talk about the multi site
17:37:14 <gampel> sure yes
17:37:46 <gampel> we try to address the usability so it will be seamless to the user
17:37:47 <eshedg> i suggest we discuss this in-person in tokyo, pick the time & place
17:37:59 <Sukhdev_> armax, myself and other L2GW team will be there - it may be prudent to do a quick whiteboard discussion in Tokyo
17:38:04 <armax> before we rely on some f2f time
17:38:12 <armax> let’s put this on the next meeting agenda
17:38:21 <armax> so that we make sure people are reviewed the docs etc
17:38:43 <Sukhdev_> armax: unfortunately, our next meeting will be after summit
17:38:44 <eshedg> okay, that'll be excellent
17:38:48 <eshedg> oh...
17:39:05 <gampel> Can we discuss this over the mailing list
17:39:17 <Sukhdev_> armax: I will forward these documents via email to all the L2GW team so that they can review off-line
17:39:22 <armax> Sukhdev_: ok
17:39:32 <gampel> Ok thx
17:39:36 <eshedg> thanks
17:40:03 <Sukhdev_> gampel eshedg: I will follow up with our internal email to L2GW team so that everybody reviews these documents
17:40:29 <eshedg> okay, we will add some more data about how the packet flows side-to-side
17:40:30 <Sukhdev_> then we can pick a time to get together during summit to go over it and discuss in person
17:40:33 <eshedg> on both l2 and l3 use case
17:40:55 <eshedg> please add us both to the mailing list
17:41:13 <Sukhdev_> eshedg: How soon can you update these - so that I send the updated documents
17:41:36 <eshedg> we'll do it tomorrow on the AM (our time)
17:41:38 <Sukhdev_> eshedg gampel : please send me your emails at sukhdev@arista.com
17:42:13 <Sukhdev_> once you have updated version, shoot me an email - and I can follow up with the rest of the team
17:43:33 <Sukhdev_> #action: Sukhdev to follow up with the L2GW team about the L2GW cloud-interconnect use case
17:43:50 <Sukhdev_> anything else?
17:44:03 <eshedg> from us, no, thanks
17:44:58 <Sukhdev_> armax: anything from your side?
17:45:06 <armax> Sukhdev_: nop
17:45:14 <Sukhdev_> cool - I guess we are done
17:45:19 <gampel> thank you
17:45:20 <Sukhdev_> thanks folks
17:45:28 <Sukhdev_> bye
17:45:33 <eshedg> bye
17:45:34 <Sukhdev_> #endmeeting