17:34:21 <dougwig> #startmeeting networking_lib
17:34:21 <openstack> Meeting started Wed Jan 13 17:34:21 2016 UTC and is due to finish in 60 minutes.  The chair is dougwig. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:34:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:34:25 <openstack> The meeting name has been set to 'networking_lib'
17:34:26 <dougwig> #topic Open discussion
17:34:39 <dougwig> "Would like to discuss how we can mark the status of modules in the library for users."
17:34:47 <dougwig> can you explain what you mean here?
17:35:20 <pc_m> How we can let developers know that some functionality is available for use.
17:35:32 <pc_m> For example, callbacks, we named the dir _callbacks.
17:35:54 <dougwig> i'd like master to remain publishable to pypi at any time, so i don't want stuff in progress to not have an _.  IMO.
17:36:04 <pc_m> Wondering what the process is to transition something from work in progress to ready.
17:36:24 <dougwig> a review to do a git rename on a function or module should be all that's needed to make it ready to export.
17:36:58 <pc_m> ok. So for validators/convertors, add in a _ for the directory.
17:37:04 <pc_m> converters
17:37:20 <dougwig> if you need to iterate on it, yes.
17:38:01 <pc_m> dougwig: OK. I don't think that needs to be iterated on. Thought, with Neutron activity, we need to update it soon.
17:38:24 <dougwig> we'll have some lag and catch-up, just the nature of the beast during the transition.
17:38:39 <pc_m> yup.
17:38:50 <pc_m> Second item is upstreamed. Thanks for reviewing.
17:39:08 <pc_m> Third is the validators. Needs review.
17:39:21 <dougwig> ok, i'll add it to my list for today.
17:39:27 <pc_m> Wondering how we want to apply that to neutron.
17:40:02 <pc_m> Do we want to push a commit on top of 242219 that uses this capability in neutron?
17:40:20 <pc_m> ditto with others, like the callback mechanism?
17:40:39 <dougwig> pc_m: yes, exactly that.
17:41:05 <pc_m> OK will do that for the validators/converters.
17:41:12 <dougwig> ok
17:41:30 <pc_m> #action pc_m to apply validators/converters to 242219 in neutron
17:41:46 <dougwig> on the arg question, i'd suggest pinging kevin/henry directly, as they have opinions.
17:42:04 <pc_m> For the callbacks, I did the following - https://review.openstack.org/#/c/265997/
17:42:51 <pc_m> OK. I'll ask him to look at ^^^
17:43:20 <dougwig> saw that; let's get henry and kevin to comment.
17:43:28 <pc_m> Roger that
17:43:29 <dougwig> next item?
17:43:48 <dougwig> (folks here are about to head to lunch, so i'm in sprint mode.)  :)
17:44:03 <pc_m> On 242219, it's failing a few tests, do you know what is up there? I think you expected it?
17:44:18 <pc_m> understood.
17:44:41 <dougwig> no, i'm not sure why. i'm guessing i'm missing a helper hook to pull in the lib properly. do you want to take a peek?  or i'll look soon.
17:45:07 <pc_m> I'll try to look.
17:45:08 <dougwig> in terms of what needs looking at, i'd suggest taking a peek at the aas unit tests, and how they currently rely on some neutron stuff.  which parts should be dup'ed into the repos, which parts are useful parts of the lib?
17:45:46 <pc_m> If there are additional neutron-lib items that I can look at, let me know. I have time this week, and some next week (On PTO a few days).
17:46:16 <pc_m> #action pc_m to try to see what is causing 242219 test failures.
17:46:32 <dougwig> ok, did you see the note about the unit test dependencies?
17:46:43 <dougwig> first step is an analysis of what to move or dup.
17:46:43 <pc_m> #action pc_m to ping kevinbenton and HenryG on my commit for callbacks
17:46:51 <dougwig> then move/change/dup/whatnot.
17:47:00 <pc_m> no I didn't see that note.
17:47:21 <pc_m> Where is this note at?
17:47:55 <dougwig> 11:45am: "in terms of what needs looking at, i'd suggest taking a peek at the aas unit tests, and how they currently rely on some neutron stuff.  which parts should be dup'ed into the repos, which parts are useful parts of the lib?"
17:48:41 <dougwig> any other items?
17:48:56 <pc_m> no that's it.
17:49:04 <pc_m> Thanks!
17:49:08 <dougwig> cool.  i'm apparently about to be escorted to a crappy burrito. i can't wait.
17:49:08 <pc_m> Enjoy lunch!
17:49:16 <dougwig> i'll be on irc this afternoon.  cool, later!
17:49:16 <pc_m> :)
17:49:18 <dougwig> #endmeeting