07:05:24 <yamamoto> #startmeeting networking_midonet
07:05:25 <openstack> Meeting started Tue Dec  8 07:05:24 2015 UTC and is due to finish in 60 minutes.  The chair is yamamoto. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:05:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:05:28 <openstack> The meeting name has been set to 'networking_midonet'
07:05:44 <yamamoto> #link https://wiki.openstack.org/wiki/Meetings/NetworkingMidoNet agenda
07:06:07 <yamamoto> not many items on agenda.  this will be a short meeting i guess.
07:06:21 <yamamoto> #topic Announcements
07:06:33 <yamamoto> do anyone have announcements?
07:07:20 <yamamoto> we are past mitaka-1.  we are not doing milestones though.
07:07:35 <ryu25> I wonder if we should
07:07:38 <red_trela> not sure it qualifies as an announcement, but: we now have gerritbot in #midonet for networking-midonet :)
07:07:58 <yamamoto> red_trela: thank you for setting it up!
07:08:18 <ryu25> red_trela: thanks!
07:08:28 <yamamoto> #info we have gerritbot in #midonet for networking-midonet
07:09:20 <yamamoto> move on
07:09:22 <ryu25> no accouncement from me
07:09:23 <yamamoto> #topic Bugs
07:09:36 <yamamoto> #link https://bugs.launchpad.net/networking-midonet/
07:10:11 <yamamoto> the number of NEW bugs seems growing but still small
07:10:34 <yamamoto> no urgent bugs afaik
07:10:46 <ryu25> looks completely manageable
07:11:45 <yamamoto> ryu25: i think you are going to set up bug deputy
07:12:30 <ryu25> yamamoto: I set it up for midonet but I think it should be different for networking-midonet due to difficulty of doing both
07:12:39 <ryu25> so let's set one up for networking-midonet
07:12:52 <yamamoto> i see
07:12:53 <ryu25> I would be more than happy to volunteer for the first week
07:13:31 <yamamoto> thank you!
07:13:32 <ryu25> yamamoto: currently there are not too many developers that are familiar with both projects, and they are tracked rather differently
07:13:55 <ryu25> though now that we are inching towards adopting more openstack-ways for midonet, this problem may go away
07:14:08 <yamamoto> i agree
07:14:15 <irenab> yamahata: is this meeting for neutron midonet only or for midonet as well?
07:14:21 <yamamoto> let's start from this week.
07:14:27 <yamamoto> irenab: plugin only
07:14:27 <ryu25> irenab: networking-midonet only
07:14:39 <irenab> ok
07:14:41 <ryu25> there will be a separate one for midonet later today
07:15:39 <ryu25> yamamoto: I'm not sure what the best way to track the deputies.  I suppose we can just update the meetings page like in Neutron
07:15:43 <ryu25> what do you think?
07:16:23 <yamamoto> ryu25: i think it's fine.
07:16:31 <irenab> ryu25: +1
07:17:09 <yamamoto> #action yamamoto will create a bug deputy schedule on the meetings wiki
07:17:32 <red_trela> btw, did anyone follow the current neutron deputy discussion on the openstack-dev list?
07:17:36 <yamamoto> #info bug deputy for the first week will be ryu25
07:18:08 <yamamoto> red_trela: how current?  url?
07:18:35 <red_trela> last week: http://lists.openstack.org/pipermail/openstack-dev/2015-December/081132.html
07:19:27 <yamamoto> the summary of the thread is "the process is working well" afaik.
07:19:37 <red_trela> alright then :)
07:20:37 <ryu25> yeah i think generally people seem to be happy with the bug deputy process
07:20:38 <yamamoto> anyone has a specific bug to discuss here?
07:21:10 <ryu25> no i have no comment on the bugs
07:22:07 <yamamoto> lets move on
07:22:11 <yamamoto> #topic Open Discussion
07:22:22 <yamamoto> i have a question
07:22:36 <yamamoto> do we want rfe bug process similar neutron?
07:23:17 <irenab> yamamoto: I am not sure. I think having blueprint is enough
07:23:55 <red_trela> since networking-midonet is part of Neutron, do we have a choice?
07:24:18 <irenab> red_trela: what do you mean by part of neutron?
07:24:21 <yamamoto> blueprints are not convenient for discussion.  it's ok as far as a single company just decides the direction, though.
07:24:25 <red_trela> in terms of governance
07:25:16 <irenab> I think we do have a choice
07:25:27 <ryu25> in both processes, we still need drivers to agree on whether we accept them or not right?
07:25:59 <ryu25> irenab: you prefer blueprint because it's less heavy?
07:26:10 <irenab> ryu25: yes
07:26:17 <irenab> less steps in the process
07:27:06 <irenab> neutron proccesses still evolve
07:27:07 <yamamoto> probably "drivers" thing is more appropriate for midonet meeting, not this meeting.
07:27:20 <irenab> lets keep with waht works well for networking-midonet
07:28:36 <red_trela> isn't the purpose of the new RFE approach, that the discussion can happen very early in the process, while the blueprint approach requires quite some upfront work that might be lost if it's not accepted or needs considerable change?
07:29:39 <red_trela> Also, can't they co-exist? if you want an early opinion or look for more helping hands, go with an RFE. Otherwise, with a blueprint.
07:29:43 <irenab> red_trela: spec will require more work, blueprint at launchpad is short desctiption
07:30:30 <ryu25> so the extra step in the RFE process is the evaluation of the initial request?
07:30:31 <red_trela> ah, I thought it was the other way around...sorry for the noise :)
07:30:47 <irenab> I think we should have policies defined, so contributors will be aware of the procedures. Any process can be adopted.
07:31:31 <irenab> lets be agile and improve the process if it does not work well
07:32:19 <yamamoto> irenab: do you mean to document the current procedure?
07:32:42 <ryu25> i can go either way.  Why not just adopt what neutron is doing then? (RFE)
07:32:47 <irenab> yamamoto: yes, something like neutron having policies defined in the source tree
07:32:56 <yamamoto> irenab: do you volunteer?
07:33:19 <irenab> yamamoto: I do not mind.
07:33:59 <irenab> please add action for me to do so
07:34:27 <yamamoto> i tend to think it's simpler to adapt neutron policies but i'm fine with either ways as far as someone volunteer to document.
07:35:12 <yamamoto> #action irenab document the current procedure/policy for new features
07:35:17 <yamamoto> irenab: thank you!
07:35:48 <irenab> yamamoto: :-). I want to check similar projects, so be aligned with other vendor plugins
07:37:01 <red_trela> we should probably revisit this in 6 months or so, see how the new process is working for Neutron
07:37:04 <yamamoto> irenab: good idea.  i've heard odl has some procedure.
07:37:29 <irenab> red_trela: I would even do it earlier
07:37:47 <irenab> red_trela: by the end of Mitaka
07:37:52 <yamamoto> +1 earlier, 6 months sound too long
07:38:24 <irenab> yamamoto: thanks, will check with odl
07:38:52 <yamamoto> it seems we finished agenda items.  does anyone has anything more to discuss?
07:39:08 <red_trela> "6 months" was more of a random term anyway...I was just thinking that they might do a retrospect after Mitaka which we could use as a base
07:39:57 <red_trela> yes, one thing - once MidoNet is part of OpenStack (i.e. an accepted project), should we move networking-midonet from Neutron to MidoNet, governance wise?
07:40:38 <red_trela> we'll probably also have to see what the Neutron folks think about this, if we want to move
07:40:53 <yamamoto> red_trela: i'm not sure.  can't we belong to the both?
07:41:31 <red_trela> no
07:41:31 <ryu25> red_trela: I'm not sure if that will make sense since it's more tightly coupled with neutron for things like release cycles
07:41:44 <apuimedo> \o/
07:41:57 <ryu25> apuimedo: hello
07:41:59 <apuimedo> sorry that I'm late
07:42:13 <apuimedo> where are we on getting the plugin packages on distros?
07:42:24 <apuimedo> rdo and Ubuntu cloud archives
07:42:38 <red_trela> ryu25: yea, that's what I thought - just been wondering whether people maybe think that it's the same people, so it should be governed together
07:42:49 <red_trela> but I'm fine with leaving it as-is :)
07:43:00 <ryu25> i definitely wouldn't mind consolidating if it makes sense
07:43:17 <ryu25> but i don't think it makes sense at this moment
07:43:30 <yamamoto> ryu25: +1
07:43:54 <red_trela> got it
07:44:33 <ryu25> red_trela: let's see how it goes running two separate projects.  We may feel differently later
07:44:39 <red_trela> sure
07:45:59 <ryu25> nothing more from me
07:46:07 <yamamoto> apuimedo: i have no idea about packaging
07:46:15 <apuimedo> ryu25: ^^
07:46:48 <ryu25> i thought apuimedo answered his own question
07:50:00 <red_trela> maybe apuimedo needs to clarify the question
07:51:05 <apuimedo> I'll send to ml
07:51:08 <apuimedo> sorry ;P
07:51:31 <yamamoto> np
07:51:56 <yamamoto> see you later on the midonet meeting
07:51:56 <apuimedo> 3
07:52:09 <yamamoto> #endmeeting