#openstack-meeting: networking_ml2

Meeting started by mestery at 14:00:26 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/ML2 Agenda (mestery, 14:00:44)

  1. MechanismDriver (mestery, 14:01:11)
    1. https://review.openstack.org/33201 MechanismDriver review (mestery, 14:01:30)
    2. ACTION: rcurran to send email or review notes for details on common code (mestery, 14:10:12)

  2. ml2-portbinding (mestery, 14:11:22)
    1. https://blueprints.launchpad.net/quantum/+spec/ml2-portbinding ml2-portbinding blueprint (mestery, 14:11:30)
    2. ACTION: ML2 subteam to try to get MechanismDriver blueprint merged before Monday 7-1-2013. (mestery, 14:13:56)
    3. ACTION: mestery to file bug to get instance_name passed in from nova following the host_id patch (mestery, 14:21:49)
    4. ACTION: If nova patch to add instance_name is rejected, have ml2 context object use the nova API instead. (mestery, 14:22:40)

  3. ml2-gre (mestery, 14:22:50)
    1. https://review.openstack.org/33297 ml2-gre review (mestery, 14:22:57)

  4. ml2-vxlan (mestery, 14:26:40)
    1. https://blueprints.launchpad.net/quantum/+spec/ml2-vxlan ml2-vxlan blueprint (mestery, 14:26:46)

  5. Bugs and other blueprints (mestery, 14:33:03)
    1. https://review.openstack.org/#/c/33107/ tunnel_types review (mestery, 14:33:22)
    2. ACTION: mestery to file new bug to address matrohon's concerns on the tunnel_type fix (mestery, 14:34:53)
    3. https://blueprints.launchpad.net/quantum/+spec/l2-population L2 population blueprint (mestery, 14:36:56)

  6. Ported Mechanism Drivers (mestery, 14:41:26)
    1. https://bugs.launchpad.net/quantum/+bug/1177973 (feleouet, 14:42:14)
    2. https://review.openstack.org/#/c/33736/ seems to be related to our eventual multi-segment network API (rkukura, 14:45:46)
    3. ACTION: rkukura to provide ML2 related feedback on review https://review.openstack.org/#/c/33736/ (mestery, 14:48:23)
    4. https://blueprints.launchpad.net/quantum/+spec/sukhdev-8 Arista Mechanism Driver Blueprint (mestery, 14:50:17)
    5. https://blueprints.launchpad.net/quantum/+spec/ml2-md-cisco-nexus Cisco Nexus Mechanism Driver (mestery, 14:52:08)
    6. https://blueprints.launchpad.net/quantum/+spec/ml2-opendaylight-mechanism-driver OpenDaylight Mechanism Driver (mestery, 14:53:42)
    7. https://blueprints.launchpad.net/quantum/+spec/tailf-ncs Tail-f NCS Mechanism Driver (mestery, 14:58:20)

  7. Questions? (mestery, 14:59:05)


Meeting ended at 14:59:55 UTC (full logs).

Action items

  1. rcurran to send email or review notes for details on common code
  2. ML2 subteam to try to get MechanismDriver blueprint merged before Monday 7-1-2013.
  3. mestery to file bug to get instance_name passed in from nova following the host_id patch
  4. If nova patch to add instance_name is rejected, have ml2 context object use the nova API instead.
  5. mestery to file new bug to address matrohon's concerns on the tunnel_type fix
  6. rkukura to provide ML2 related feedback on review https://review.openstack.org/#/c/33736/


Action items, by person

  1. matrohon
    1. mestery to file new bug to address matrohon's concerns on the tunnel_type fix
  2. mestery
    1. mestery to file bug to get instance_name passed in from nova following the host_id patch
    2. mestery to file new bug to address matrohon's concerns on the tunnel_type fix
  3. openstack
    1. rkukura to provide ML2 related feedback on review https://review.openstack.org/#/c/33736/
  4. rcurran
    1. rcurran to send email or review notes for details on common code
  5. rkukura
    1. rkukura to provide ML2 related feedback on review https://review.openstack.org/#/c/33736/
  6. UNASSIGNED
    1. ML2 subteam to try to get MechanismDriver blueprint merged before Monday 7-1-2013.
    2. If nova patch to add instance_name is rejected, have ml2 context object use the nova API instead.


People present (lines said)

  1. mestery (120)
  2. rkukura (53)
  3. apech (27)
  4. matrohon (19)
  5. feleouet (14)
  6. rcurran (13)
  7. Sukhdev_ (7)
  8. openstack (3)
  9. doude_ (1)
  10. HenryG (1)


Generated by MeetBot 0.1.4.