14:00:21 <mestery> #startmeeting networking_ml2
14:00:22 <openstack> Meeting started Wed Jul 10 14:00:21 2013 UTC. The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'networking_ml2'
14:00:37 <mestery> #topic Action Items
14:00:45 <mestery> #link https://wiki.openstack.org/wiki/Neutron/ML2 ML2 Wiki
14:00:58 <mestery> We should try to start filling up the ML2 wiki page.
14:01:20 <rkukura> I have not made any progress on this, but will. Others should contribute as well.
14:01:38 <mestery> rkukura: Yes, agreed! I plan to add some devstack setup info this week.
14:01:56 <rkukura> I'm planning to add an intro and links to slides, etc.
14:02:12 <mestery> That would be most helpful for folks new to ML2.
14:02:34 <rkukura> Then we should link it into the main neutron wiki page's list of plugins
14:02:38 <mestery> #action ML2 Team to update ML2 wiki page.
14:03:13 <mestery> rkukura: Is arosen on the same page as ML2 multi-segment networks with this review: https://review.openstack.org/#/c/33736/
14:03:31 <mestery> That was the next action item on the list.
14:03:34 <mestery> from last week
14:03:37 <rkukura> i haven't heard any objections to that approach - will do a detailed review
14:03:46 <mestery> rkukura: Great, thanks!
14:03:47 <rkukura> and will look into exposing that extension
14:04:17 <rkukura> arosen did ping me about it last week
14:04:27 <mestery> rkukura: There is also this one from the Cisco side: https://blueprints.launchpad.net/neutron/+spec/multi-segment-and-trunk-support-cisco-nexus1000v
14:04:51 <mestery> rkukura: That one will be implemented in the context of Nexus 1000V, just throwing it out there for now.
14:05:07 <rkukura> same extension API?
14:05:26 <mestery> I need to validate that and get back to you, but I believe it's very similar yes.
14:05:53 <rkukura> I'm thinking this approach could give more flexibility for type drivers to define sensible attributes
14:06:22 <mestery> OK, great!
14:06:48 <mestery> OK, moving on to the next agenda item.
14:06:54 <mestery> #topic Blueprint Updates
14:07:07 <mestery> #link https://review.openstack.org/33201 MechanismDriver Review
14:07:14 <mestery> apech can't make it today
14:07:26 <mestery> But I think the MechanismDriver review is in good shape now.
14:07:33 <rkukura> that one is looking good to me - could get in today
14:07:40 <mestery> rkukura: My thoughts exactly!
14:07:55 <rkukura> I will test it in devstack today and +2 if no issues
14:08:12 <mestery> Great! I hope we can get that one and the GRE and VXLAN type drivers in today if possible.
14:08:23 <mestery> Any questions on MechanismDriver review?
14:08:29 <rkukura> is apech available if updates are needed today?
14:08:42 <mestery> Yes, he said he would be online most of the day, just not for hte meeting.
14:09:12 <sukhdev> rkukura: I can fill in for apech, if needed
14:09:27 <mestery> sukhdev: Thanks!
14:09:41 <mestery> OK, next blueprint.
14:09:48 <mestery> #link https://blueprints.launchpad.net/quantum/+spec/ml2-portbinding ML2 PortBinding
14:10:06 <rkukura> no progress - tied up with release work - should free up today to work on this
14:10:07 <mestery> rkukura: How goes PortBinding?
14:10:17 <mestery> So this one is likely H3 then right?
14:10:25 <rkukura> right
14:10:30 <rkukura> but early H3
14:10:30 <mestery> OK
14:10:50 <mestery> OK, any questions on PortBinding?
14:11:00 <rkukura> anyone know if the nova side got in ?
14:11:14 <mestery> I don't think it quite made it yet.
14:11:16 <sukhdev> Yes, Nova side is in
14:12:22 <mestery> #link https://review.openstack.org/33297 ML2 GRE
14:12:41 <mestery> matrohon: Hi
14:12:56 <matrohon> hi : I will push a new version with alembic script
14:13:22 <mestery> Great! I did the same for VXLAN. If that's your only change, I won't have to rebase the VXLAN review against yours.
14:13:38 <mestery> I think we can get ML2 GRE in today, what do you think matrohon?>
14:13:51 <rkukura> Are Zhang Hua's comments all addressed?
14:14:15 <matrohon> mestery I hope so, maybe tomorrow because it's the end of the day for me
14:14:22 <mestery> I think matrohon was waiting for Zhang Hua to respond to a few of his comments.
14:14:36 <rkukura> I think he wanted the range numbers stripped
14:14:46 <matrohon> rkukura: zhang hua complains about lockmode('update')
14:15:03 <matrohon> which is used everywhere else
14:15:11 <rkukura> let just be consistent with the rest of neutron on this for now
14:15:16 <mestery> Agreed
14:15:47 <mestery> rkukura: Does the freeze for H2 mean that if we don't get this in today it won't make H2?
14:16:11 <rkukura> I think so
14:16:23 <rkukura> end of day today
14:16:35 <mestery> OK, it's likely then this and VXLAN will land early in H3.
14:16:50 <rkukura> seems we could get gre in today
14:17:13 <matrohon> ok, i will propose something before the end of the day
14:17:24 <mestery> matrohon: thanks!
14:17:29 <mestery> Anything else on ML2 GRE?
14:17:59 <mestery> #link https://review.openstack.org/#/c/35384/2 ML2 VXLAN
14:18:13 <amotoki__> mestery: from yesterday neutron: mark said "All blueprints for H2 need to be proposed by Thursday,"
14:18:17 <mestery> I addressed all remaining comments with the review I pushed out this morning.
14:18:25 <mestery> amotoki__: Thanks!
14:18:36 <mestery> So I'm hopeful to get some +1s on the ML2 VXLAN review today.
14:19:23 <mestery> However, ML2 VXLAN is dependent on ML2 GRE to upstream, so I need GRE to go up first.
14:19:42 <mestery> Any ML2 VXLAN questions?
14:19:57 <rkukura> looks like multicast address is move to conf now, right?
14:20:02 <matrohon> mestery : do you keep multicast group in base?
14:20:42 <mestery> It's in the VXLANAllocation, if that's what you mean.
14:20:46 <matrohon> i'm not against this but i though that we decided to leave it only in the conf file
14:21:23 <mestery> matrohon: I think I missed that. I can spin a new version with that change, though.
14:21:30 <rkukura> that was my understanding as well
14:21:42 <mestery> OK, I will respin after the meeting with this change.
14:21:51 <matrohon> mestery : if we don't mind, thanks
14:22:06 <mestery> matrohon: No worries, it's a simple change, thanks for reminding me!
14:22:54 <mestery> #action mestery to respin the ML2 VXLAN review with muilticast group configuration via config file
14:23:01 <mestery> Anything else on ML2 VXLAN before we move on?
14:23:58 <mestery> #topic ML2 Related Bugs and Blueprints
14:24:11 <mestery> #link https://review.openstack.org/#/c/33107/ tunnel_types review
14:24:18 <mestery> I hope to push a new version of this patch out later today
14:24:30 <mestery> Hit some issues doing some testing with devstack (not related to my change) yesterday
14:24:44 <mestery> But I believe the version I will push goes the full way and will address gongysh's concerns.
14:25:12 <mestery> Would be great to see if this can make H2 today! rkukura, any chance you can review this later today?
14:25:31 <rkukura> I will
14:25:34 <mestery> The incremental change is minimal
14:25:37 <mestery> rkukura: Thanks!
14:26:00 <mestery> OK, moving on
14:26:05 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/campus-network Campus Networks
14:26:08 <mestery> Is Filipe here?
14:26:18 <fmanco> Hi
14:26:32 <mestery> fmanco: Hey!
14:26:53 <mestery> Not sure if people have looked at fmanco's blueprint, but there is some overlap with ML2, and some ideas on extending ML2 as well.
14:27:25 <fmanco> mestery: thanks for bringing this
14:27:51 <mestery> I think this makes sense for the ML2 team to review and provide feedback to fmanco. What do people think?
14:28:10 <rkukura> had not seen it, but will definitely need to read it
14:28:18 <fmanco> From my point of view I think I will have to extend the MechanismDriver
14:28:28 <mestery> rkukura: Thanks! I encourage other ML2 team members to review as well.
14:28:50 <mestery> fmanco: I think so too. My only concern is if this is something we can do in H3 or not.
14:29:07 <mestery> I think once rkukura and I have reviewed in detail we can provide more guidance.
14:29:17 <fmanco> mestery: I'm not sure
14:29:33 <sukhdev> I had not seen it either - I will look at it - sounds intersting
14:29:33 <fmanco> If I can divide it somehow I think maybe it can hit H3
14:29:47 <fmanco> but not all the blueprint almost for sure
14:29:55 <mestery> fmanco: That's a good plan, can you see how you might do that and propose that in your blueprint?
14:30:06 <fmanco> mestery: sure
14:30:37 <mestery> #action fmanco Split out the campus network blueprint into something which can maybe make H3
14:31:00 <rkukura> sounds like a good Icehouse summit topic to me!
14:31:39 <mestery> OK, moving on.
14:31:47 <mestery> #link https://blueprints.launchpad.net/quantum/+spec/l2-population L2 Population blueprint
14:31:52 <mestery> Is Francois here?
14:32:06 <mestery> Wait: I see this is now assigned to matrohon
14:32:13 <mestery> matrohon: Are you doing the L2 population work now?
14:32:31 <matrohon> it's not begin yet
14:32:40 <mestery> matrohon: OK
14:32:52 <matrohon> we still targeting it for H3
14:33:06 <mestery> #info L2 Population Blueprint now targeted for H3
14:33:35 <matrohon> but I have to take care about multi-tunnel support bug first
14:33:49 <mestery> You mean bug 1196963
14:33:51 <uvirtbot> Launchpad bug 1196963 in neutron "Update the OVS agent code to program tunnels using ports instead of tunnel IDs" [Wishlist,Triaged] https://launchpad.net/bugs/1196963
14:33:58 <matrohon> yes
14:34:07 <mestery> OK, cool!
14:34:25 <mestery> Can you target that one to H3? I see markmcclain moved it to wishlist and no milestone.
14:34:44 <matrohon> ok
14:34:52 <mestery> #action matrohon to target 1196963 to H3
14:35:15 <mestery> OK, any other bugs or blueprints the ML2 team should be tracking?
14:35:55 <rcurran> i take it you're purposefully leaving off the arista/cisco mech drivers for now
14:35:58 <rkukura> is event-based polling still important?
14:36:08 <mestery> rcurran: Yes, we'll talk about those in the next section
14:36:25 <mestery> rkukura: Is that an opened bug or blueprint?
14:36:32 <mestery> OR something that we may want to implement in ML2?
14:36:47 <rkukura> https://bugs.launchpad.net/neutron/+bug/1177973
14:36:51 <uvirtbot> Launchpad bug 1177973 in neutron "OVS L2 agent polling is too cpu intensive (dup-of: 1194438)" [Medium,In progress]
14:36:52 <uvirtbot> Launchpad bug 1194438 in neutron/grizzly "compute node's OVS agent takes long time to scan sync all port's stat and update port security rules" [High,In progress]
14:37:18 <mestery> rkukura: I missed that one, it is being tracked on the ML2 meeting page.
14:37:27 <rkukura> A separate improvement in polling went in, but event-based may still be worth doing
14:37:38 <mestery> rkukura: That particular bug is unassigned now.
14:37:43 <sukhdev> mestery: Arista driver is pretty much ready - just waiting on portbinding to make through, and test it
14:38:07 <rkukura> looks like it was marked as a duplicate
14:38:50 <mestery> rkukura: I see that now
14:39:19 <rkukura> Lets think about whether event-based is still worth doing
14:39:38 <mestery> rkukura: Seems like a large change, do we have someone with cycles to fully implement and test this out?
14:40:23 <rkukura> not sure, but long term is probably worthwhile
14:40:38 <rkukura> I'll talk to maru who originally filed it
14:40:43 <mestery> rkukura: Thanks!
14:40:55 <mestery> #action rkukura To discuss event-based polling bug with maru.
14:41:01 <mestery> OK lets move on now.
14:41:11 <mestery> #topic Ported Mechanism Drivers
14:41:22 <mestery> sukhdev: Arista driver updates?
14:42:02 <sukhdev> mestry: it is on track - as soon portbinding support makes it in, I am ready to go with this
14:42:16 <mestery> sukhdev: Great!
14:42:21 <mestery> rcurran: Cisco driver updates?
14:42:29 <sukhdev> Other than create_port (which needs binding info) all is a go
14:42:48 <rcurran> need to change how we access the external device info (existing cisco subplugin bug)
14:42:53 <rcurran> need to add UTs
14:43:04 <rcurran> but overall progress is fine
14:43:09 <mestery> rcurran: Are you also dependent on portbinding?
14:43:40 <rcurran> yes
14:43:49 <mestery> OK
14:43:55 <rkukura> OK, this is my highest priority for the rest of this week
14:44:10 <sukhdev> rkukura: thanks
14:45:01 <mestery> With respect to the OpenDaylight driver, we were waiting for OVSDB support on the OpenDaylight side, and someone has stepped up to implement that work there.
14:45:15 <mestery> So I'm still hopeful we can get an ODL MechanismDriver done for H3.
14:45:37 <mestery> Is Like Gorrie here for an update on the Tail-f NCS MechanismDriver?
14:45:52 <mestery> *Luke
14:47:10 <mestery> #topic Question?
14:47:16 <mestery> OK, anything else we need to discuss today?
14:47:31 <rkukura> Is anyone else seeing unit test failures with ml2 on trunk:
14:47:41 <rkukura> FAIL: neutron.tests.unit.ml2.test_agent_scheduler.Ml2AgentSchedulerTestCase.test_network_add_to_dhcp_agent
14:47:46 <mestery> rkukura: I just ran them all (including GRE and VXLAN) and they all worked fine for me.
14:47:50 <mestery> This was with Fedora19.
14:48:08 <mestery> rkukura: Have you tried blowing away your .tox directory and letting it recreate?
14:48:19 <mestery> That has helped me before (though I don't know why).
14:48:23 <rkukura> yes, many times
14:49:22 <mestery> rkukura: I'll reverify after the meeting and ping you on IRC with my results.
14:49:40 <rkukura> mestery: thanks - this is really baffling me
14:49:56 <mestery> OK, lets see if we can get the MechanismDriver review merged today if we can!
14:50:06 <mestery> And as a stretch goal, the GRE and VXLAN TypeDrivers as well.
14:50:11 <mestery> Thanks for everyone's hard work on ML2 items!
14:50:19 <mestery> #endmeeting