#openstack-meeting: networking_ml2

Meeting started by mestery at 14:00:03 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/ML2 Agenda (mestery, 14:00:16)
    2. MechanismDriver, tunnel_types, and GRE and VXLAN TypeDriver patches all merged for H2 (mestery, 14:01:30)
    3. ACTION: mestery to work on devstack support for new ML2 functionality (mestery, 14:05:47)
    4. ACTION: ML2 team to work on documenting new ML2 functionality (mestery, 14:05:59)

  1. Action Items (mestery, 14:06:34)
    1. https://wiki.openstack.org/wiki/Neutron/ML2 ML2 Wiki Page (mestery, 14:07:02)
    2. ACTION: mestery to make sure devstack defaults to ML2 instead of OVS (mestery, 14:07:19)
    3. ACTION: mestery to file bug to update ML2 README to take into account tunnel types changes (mestery, 14:08:08)
    4. Issues with VLAN ranges when running ML2 with devstack. (mestery, 14:14:29)
    5. https://blueprints.launchpad.net/neutron/+spec/campus-network Campus Network BP (mestery, 14:15:35)
    6. ACTION: rkukura to review Campus Network BP and provide feedback (mestery, 14:17:07)
    7. https://blueprints.launchpad.net/neutron/+spec/ml2-external-port (fmanco, 14:17:11)

  2. Blueprint Updates (mestery, 14:19:00)
    1. https://blueprints.launchpad.net/quantum/+spec/ml2-portbinding ML2 Port Binding (mestery, 14:19:14)
    2. ACTION: ML2 team to respond to port binding thread on openstack-dev (mestery, 14:24:12)
    3. https://blueprints.launchpad.net/neutron/+spec/ml2-multi-segment-api ML2 Multi-Segment API (mestery, 14:25:10)

  3. ML2 Related Bugs and BPs (mestery, 14:31:43)
    1. https://bugs.launchpad.net/devstack/+bug/1200767 ML2 devstack updates (mestery, 14:31:52)
    2. ACTION: mestery to talk to dean and gary about importance of ML2 devstack bug (mestery, 14:34:43)
    3. ACTION: matrohon to investigate possible provider extension bug with ML2 tunnel TypeDrivers (mestery, 14:40:16)
    4. https://blueprints.launchpad.net/quantum/+spec/l2-population OVS L2 Population BP (mestery, 14:40:30)

  4. Ported Mechanism Driver Updates (mestery, 14:44:51)
  5. Open Discussion (mestery, 14:48:31)
    1. ACTION: rkukura to file a BP to track migration from OVS/LB to ML2 (mestery, 14:56:46)


Meeting ended at 14:57:44 UTC (full logs).

Action items

  1. mestery to work on devstack support for new ML2 functionality
  2. ML2 team to work on documenting new ML2 functionality
  3. mestery to make sure devstack defaults to ML2 instead of OVS
  4. mestery to file bug to update ML2 README to take into account tunnel types changes
  5. rkukura to review Campus Network BP and provide feedback
  6. ML2 team to respond to port binding thread on openstack-dev
  7. mestery to talk to dean and gary about importance of ML2 devstack bug
  8. matrohon to investigate possible provider extension bug with ML2 tunnel TypeDrivers
  9. rkukura to file a BP to track migration from OVS/LB to ML2


Action items, by person

  1. matrohon
    1. matrohon to investigate possible provider extension bug with ML2 tunnel TypeDrivers
  2. mestery
    1. mestery to work on devstack support for new ML2 functionality
    2. mestery to make sure devstack defaults to ML2 instead of OVS
    3. mestery to file bug to update ML2 README to take into account tunnel types changes
    4. mestery to talk to dean and gary about importance of ML2 devstack bug
  3. openstack
    1. ML2 team to respond to port binding thread on openstack-dev
  4. rkukura
    1. rkukura to review Campus Network BP and provide feedback
    2. rkukura to file a BP to track migration from OVS/LB to ML2


People present (lines said)

  1. mestery (99)
  2. rkukura (50)
  3. matrohon (19)
  4. Sukhdev (13)
  5. fmanco (5)
  6. openstack (3)
  7. apech (2)
  8. uvirtbot (2)
  9. HenryG (1)


Generated by MeetBot 0.1.4.