#openstack-meeting: networking_ml2

Meeting started by mestery at 14:00:24 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/ML2 Agenda (mestery, 14:00:45)

  1. Discussion ITems (mestery, 14:01:55)
    1. Single file mech drivers are in drivers/mech_*.py. Single mech drivers with multiple files are in drivers/mech_*/. And multiple mech drivers from one vendor are in drivers/[vendor]/ (mestery, 14:10:14)
    2. Defer API extensibility for ML2 to Icehouse (mestery, 14:21:12)
    3. ACTION: asomya to try out MechanismDriver specific RPC calls with a new topic and report back on how that works (mestery, 14:32:30)

  2. Blueprint Updates (mestery, 14:36:54)
    1. https://blueprints.launchpad.net/quantum/+spec/ml2-portbinding ML2 Port Binding (mestery, 14:37:03)
    2. https://blueprints.launchpad.net/neutron/+spec/ml2-multi-segment-api ML2 Multi Segment API (mestery, 14:39:45)
    3. ACTION: mestery to monitor NVP extension for multiple provider networks in relation to ML2 multi-segment API (mestery, 14:42:43)
    4. https://blueprints.launchpad.net/neutron/+spec/ml2-typedriver-extra-port-info ML2 TypeDriver Extra Port Info (mestery, 14:43:51)
    5. https://review.openstack.org/#/c/37893/ ExtraPort Info Review (mestery, 14:44:10)

  3. Bugs (mestery, 14:49:15)
    1. https://review.openstack.org/#/c/37963/ ML2 devstack (mestery, 14:49:22)
    2. ACTION: mestery to send email to openstack-dev encouraging people to try ML2 out (mestery, 14:51:39)
    3. ACTION: mestery to update the wiki with ML2 devstack instructions (mestery, 14:51:47)
    4. https://review.openstack.org/#/c/38662/ Enable gre and vxlan with the same ID (mestery, 14:52:19)

  4. Questions and wrap up (mestery, 14:54:03)
    1. ACTION: apech to add some notes to the wiki about how the pre- and post- calls work (mestery, 14:55:17)


Meeting ended at 14:57:45 UTC (full logs).

Action items

  1. asomya to try out MechanismDriver specific RPC calls with a new topic and report back on how that works
  2. mestery to monitor NVP extension for multiple provider networks in relation to ML2 multi-segment API
  3. mestery to send email to openstack-dev encouraging people to try ML2 out
  4. mestery to update the wiki with ML2 devstack instructions
  5. apech to add some notes to the wiki about how the pre- and post- calls work


Action items, by person

  1. apech
    1. apech to add some notes to the wiki about how the pre- and post- calls work
  2. asomya
    1. asomya to try out MechanismDriver specific RPC calls with a new topic and report back on how that works
  3. mestery
    1. mestery to monitor NVP extension for multiple provider networks in relation to ML2 multi-segment API
    2. mestery to send email to openstack-dev encouraging people to try ML2 out
    3. mestery to update the wiki with ML2 devstack instructions
  4. openstack
    1. mestery to send email to openstack-dev encouraging people to try ML2 out


People present (lines said)

  1. mestery (84)
  2. rkukura (34)
  3. asomya (21)
  4. rcurran (15)
  5. apech (9)
  6. sukhdev (7)
  7. ZangMingJie (4)
  8. openstack (3)
  9. uvirtbot (1)


Generated by MeetBot 0.1.4.