14:00:48 <mestery> #startmeeting networking_ml2
14:00:49 <openstack> Meeting started Wed Aug 14 14:00:48 2013 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <rkukura> hi
14:00:52 <openstack> The meeting name has been set to 'networking_ml2'
14:01:05 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2 Agenda
14:01:27 <mestery> Wanted to highlight the ML2 wiki page again for everyone.
14:01:31 <mestery> #link https://wiki.openstack.org/wiki/Neutron/ML2 ML2 Wiki Page
14:02:15 <mestery> Keep adding content there as new ML2 items appear, we should use the wiki as the main ML2 contact point for new people looking into using or working on ML2.
14:02:36 <mestery> #topic Discussion Items
14:02:53 <mestery> rkukura suggested we talk about BPs which will make the H3 cutoff next week first.
14:03:20 <rkukura> other than ml2-portbinding and ml2-mult-segment, are there any others not yet in review?
14:03:34 <rcurran> ml2 cisco mech driver
14:03:42 <mestery> None that were deemed as ML2 infrastructure, no. Only MechDrivers left.
14:04:02 <apech> we posted the Arista mechanism driver for review last Friday, appreciate people's review
14:04:26 <mestery> I am not sure multi-segment will make H3.
14:04:38 <rkukura> will ODL mech driver make H3?
14:04:39 <mestery> It's likely not to, in fact. I'll see what I can do in the next week.
14:04:45 <mestery> ODL is out for H3.
14:04:54 <mestery> IT was dependent on too many upstream ODL changes which are not complete yet.
14:05:24 <mestery> #info OpenDaylight MechanismDriver moved into Icehouse
14:05:59 <rkukura> I should be able to get ml2-portbinding ready for review by Friday
14:06:15 <mestery> #info ML2 Port Binding should be out for review by Friday
14:06:19 <apech> great, thanks rkukura
14:06:29 <rkukura> I'll be on PTO next week, but plan to spend some time on updates and other ml2 reviews
14:06:37 <mestery> rkukura: Do we still agree that it's ok for multi-segment to slip to Icehouse? How hard should I push on that one in the next week?
14:06:39 <sukhdev> rkukura, thanks
14:07:00 <rkukura> PTO should at least prevent most other work distractions;-)
14:07:43 <rkukura> I don't think its a huge deal if multi-segment slips, but it might be very simple
14:08:01 <mestery> I'll try my best to get a review out by next week to make the cutoff.
14:08:23 <mestery> So, the other BP of note: ML2 TypeDriver Extra Port Info
14:08:29 <mestery> rkukura: Do we want that in for H3?
14:08:48 <rkukura> I just started looking at the current patch set
14:09:16 <mestery> rkukura: It's a fairly small patch, seems as if it should be ok once reviewed.
14:09:22 <ZangMingJie> I think it is almost ready to ship now
14:09:27 <rkukura> I've got some small concerns with the type driver API changes, but I'm sure they can be worked through
14:10:01 <mestery> rkukura: Can you provide some quick feedback on that on on gerrit today?
14:10:31 <rkukura> I'll try my best
14:10:44 <mestery> rkukura: Thanks, and I'll do the same.
14:10:52 <mestery> Did I miss any other BPs?
14:10:54 <rkukura> Is everyone else comfortable with the direction of this patch?
14:11:54 <rkukura> I'm wondering if multi-segment API should be the main way extra port info is supplied/accessed?
14:12:13 <mestery> Interesting idea there.
14:13:40 <mestery> rkukura: I'll look into that when working on multi-segment.
14:14:05 <mestery> Lets move onto the next topic on the agenda now.
14:14:30 <mestery> #topic Documentation
14:15:18 <mestery> I'm going to start the ML2 documentation soon as well.
14:15:40 <mestery> We need this to ensure anyone who wants to deploy Havana with ML2 has some direction. :)
14:15:49 <mestery> Anyone who wants to join me in writing this is more than welcome!
14:16:24 <mestery> #action mestery to start on ML2 documentation patches.
14:16:28 <mestery> Any questions on documentation?
14:16:32 <apech> mestery: happy to help
14:16:43 <mestery> apech: My first willing victim, excellent. :)
14:16:47 <rcurran> i take it at some point each mech vendor will add in there specific info
14:16:58 <mestery> #action apech to assist with ML2 documentation
14:17:22 <mestery> rcurran: We won't put vendor specific stuff into the general OpenStack documentation, same as with existing plugins.
14:17:34 <mestery> rcurrna: Vendor specific ML2 config will likely be on a wiki page, again, same as existing plugins.
14:17:41 <mestery> rkukura: Do you concur here?
14:17:44 <rcurran> ok, got it
14:18:05 <sukhdev> I think that makes sense
14:18:26 <rkukura> Sure, but I think the ml2 documentation should cover configuring drivers in general, with reference to the wikis for details
14:18:37 <mestery> Agreed, that makes sense.
14:19:43 <mestery> #topic ML2 devstack
14:20:04 <mestery> #link https://review.openstack.org/#/c/40882/1 ML2 Per MechanismDriver config
14:20:09 <mestery> Has anyone tried to use this yet?
14:20:24 <mestery> I've tried it with ODL, and it works great for adding ODL MD config.
14:20:29 <mestery> Would appreciate comments.
14:20:34 <mestery> I plan to rebase it later today.
14:20:38 <apech> mestery: have not, we'll try it out
14:20:44 <mestery> apech: Thanks!
14:21:29 <rcurran> i'll work w/ you also kyle on testing this w/ cisco_nexus
14:21:40 <mestery> rcurran: Thanks! Appreciate it!
14:22:15 <mestery> Any other devstack ML2 questions/concerns?
14:22:24 <rkukura> what about gating?
14:22:43 <rcurran> i have been using the initial devstack changes for ml2 and that works greate
14:22:50 <rkukura> do we want to get ml2+ovs gating going before switching devstack default?
14:22:54 <mestery> Good point. The gate and Neutron were in a tenuous relationship for the past few weeks, so I decided against bringing ML2 into that.
14:22:57 <mestery> Perhaps now is a good time.
14:23:33 <mestery> I think we need to get ovs+ml2 gating before we switch.
14:23:51 <mestery> #action mestery and rkukura to figure out ml2+ovs gating and switching devstack to default to ml2
14:23:54 <rkukura> seems we need someone to work with the CI folks on that, right?
14:24:02 <mestery> Yes
14:24:23 <rkukura> progress from non-voting to voting to default?
14:24:43 <mestery> Agreed, that should be good.
14:25:35 <mestery> #topic  ML2 Bugs and BPs
14:25:53 <mestery> There were a few bugs/BPs I forgot to mention at the top of the meeting.
14:26:01 <mestery> #link https://review.openstack.org/#/c/41136/ OVS L2 Population BP
14:26:32 <mestery> This looks to be revived now, and would be nice to get into H3 if possible.
14:27:14 <feleouet> taht would be great
14:27:22 <mestery> rkukura: This may affect port binding, wanted to bring this to your attention.
14:27:45 <rkukura> I noticed that
14:28:10 <mestery> It's on my plate to review later today. feleouet: Do you plan to submit a new patch which passes Jenkins soon?
14:28:50 <feleouet> safchain is actually in charge of this part
14:29:01 <feleouet> but I think he will soon
14:29:07 <mestery> feleouet: Ah, ok, thanks! I'll review this one soon as well.
14:29:08 <rkukura> I need to look at this in more detail - Ideally portbinding would go in first
14:29:18 <safchain> Sorry, I'll try to submit a new one by the end of the week
14:29:24 <feleouet> alongside with linuxbridge agent implementation
14:29:28 <mestery> safchain: Thanks.
14:29:35 <mestery> feleouet: Cool!
14:29:56 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1196963 VXLAN and GRE with the same ID
14:29:57 <uvirtbot> Launchpad bug 1196963 in neutron "Update the OVS agent code to program tunnels using ports instead of tunnel IDs" [Wishlist,In progress]
14:30:07 <mestery> This is another one it would be great to get in for H3.
14:30:32 <mestery> #link https://review.openstack.org/#/c/41239/ GRE and VXLAN review
14:30:33 <rkukura> feleouet: We may want to talk offline since ml2-portbinding is removing use of portbindings_db
14:31:16 <feleouet> rkukura: ok, for sure, I have to look at the proposal
14:32:10 <feleouet> the patch for bug/1196963 has important impacts on the flow logic
14:32:44 <feleouet> it will be required to implement l2-population on OVS agent
14:32:47 <mestery> feleouet: I'd like to get that one in, it will improve things I believe.
14:33:11 <mestery> feleouet: I think we can get this one in relatively easily.
14:33:16 <feleouet> well, for now, not that much (appart from fixing the bug)
14:33:31 <mestery> It's the gateway to L2 population as you say
14:33:37 <feleouet> yes, It'd be great
14:33:53 <mestery> OK, lets move on to the last agenda item now.
14:34:07 <mestery> #topic MechanismDriver Updates
14:34:08 <feleouet> I'm doing some perf benchs to make sure it doesn't has side effects
14:34:28 <mestery> Sukhdev, apech: Arista update?
14:34:43 <sukhdev> I posted the patch for review last friday
14:34:50 <rkukura> feleouet: diagram is very helpful!
14:35:16 <sukhdev> will appreciate the review
14:35:18 <mestery> sukhdev: I saw that, very good!
14:35:27 <sukhdev> thanks
14:35:28 <mestery> #action ML2 team to review Arista MechanismDriver
14:35:38 <mestery> rcurran: Cisco MD updates?
14:36:06 <rcurran> should go up end of week or beginning of next ... beefing up UT and some odds and ends
14:36:14 <sukhdev> mestery, rkukura: can you please review the patch and provide feedback?
14:36:23 <rcurran> question of arista ... since everyone is here
14:36:28 <mestery> sukhdev: Yes, will review it this week.
14:36:37 <rcurran> location of mech_vendor.ini files
14:36:41 <sukhdev> great, thanks
14:36:45 <rkukura> sukhdev: will do
14:36:56 <rcurran> under etc/neutron or neutron/plugin ..../drivers
14:37:04 <sukhdev> rcurran, thanks for bringing this up -
14:37:32 <rcurran> i put cisco's under etc/../ml2/ml2_mech_cisco.ini
14:37:51 <sukhdev> I did not know where to put .ini file
14:37:54 <rcurran> along w/ existing ml2_conf.ini
14:38:41 <mestery> rcurran: I think that makes sense to me.
14:38:54 <sukhdev> when i run openstack, I put the .ini file there as well - but, for the submission purposes, where do you put it?
14:39:32 <rcurran> not /etc ... file belongs under etc/plugins/ml2/
14:39:43 <rcurran> it gets moved to /etc
14:40:05 <sukhdev> Ah OK
14:40:56 <sukhdev> I can move it there in my next submission
14:41:55 <mestery> One more MD BP to note here (though I don't think Luke Gorrie is here):
14:42:03 <mestery> #link https://review.openstack.org/#/c/37647/ Tail-F NCS MechanismDriver Review
14:42:21 <mestery> This one is on patchset 11, looks to be progressing nicely./
14:43:04 <mestery> Any other MechanismDriver updates?
14:43:24 <sukhdev> while on the subject, can I ask a general question?
14:43:32 <mestery> sukhdev: yes!
14:44:29 <sukhdev> somebody posted a comment on the patch that if I introduce new DB models, I have to provide migration, where can I get info on that?
14:45:12 <mestery> sukhdev: https://wiki.openstack.org/wiki/Neutron/DatabaseMigration
14:45:26 <mestery> It's fairly simple, but please reach out with questions if you have any.
14:45:30 <sukhdev> thanks a ton
14:45:49 <mestery> #topic Questions?
14:45:57 <mestery> So, anything else for ML2 this week?
14:46:01 <rcurran> so you need changes for a new db
14:46:10 <rcurran> migration changes
14:46:18 <mestery> rcurran: I think only for changing existing DBs.
14:46:29 <rcurran> ok, which we don't have
14:46:52 <sukhdev> Ah I see -
14:46:55 <mestery> Yes, that makes it easier.
14:47:08 <rkukura> Are the mechanism driver's adding tables to ml2's DB, or adding their own DBs?
14:47:12 <rcurran> easier or no changes :-)
14:47:15 <sukhdev> I am not changing any DB models, so, I do not need to concer with this yet
14:47:32 <rkukura> If you are adding new models, I think migrations are needed
14:48:03 <sukhdev> rkukura, yes, I am adding our own DB tables in driver
14:48:27 <rkukura> sukhdev: so I think migrations are needed for those new tables
14:49:02 <sukhdev> rkukura, thanks for clarification. I will read the wiki and reach out if I have a question
14:49:22 <rkukura> sukhdev: Look at the existing migrations for the gre and vxlan type drivers
14:49:44 <sukhdev> rkukura, thanks I will look at them
14:50:45 <mestery> OK, wanted to remind everyone, H3 Feature Proposal Freeze (FPF) is the end of day the 22nd.
14:50:49 <mestery> #link https://wiki.openstack.org/wiki/FeatureProposalFreeze FPF
14:50:59 <apech> mestery: clarification on feature freeze
14:51:05 <mestery> Please propose your patches before then if you want them in H3.
14:51:08 <apech> do we need our blueprints reviewed and finalized by that?
14:51:09 <rkukura> on more topic: for now I guess any ml2 deployment does migtrations for all drivers
14:51:13 <apech> or just have the blueprints with diffs
14:51:20 <mestery> apech: THey need to be proposed by then, not merged.
14:51:26 <apech> mestery: thanks!
14:51:33 <rkukura> would be nice if we could make the migration script base this on what drivers are configured or something
14:51:39 <mestery> apech: Sure! You guys are good, since your's is proposed already. ;)
14:52:00 <mestery> rkukura: I thought we wanted the migration to run for all MDs initially, and we would optimize in Icehouse?
14:52:21 <apech> haha :)
14:52:24 <rkukura> mestery: That should be OK
14:52:55 <mestery> OK, thanks for everyone's continued support and efforts around ML2!
14:53:05 <apech> thanks
14:53:09 <mestery> We're heading into the final stretch for Havana now, lets keep the momentum going!
14:53:10 <rkukura> thanks everyone!
14:53:14 <mestery> #endmeeting