14:00:10 <mestery> #startmeeting networking_ml2
14:00:11 <openstack> Meeting started Wed Aug 21 14:00:10 2013 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'networking_ml2'
14:00:18 <Sukhdev> good morning
14:00:31 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2 Agenda
14:00:39 <mestery> Sukhdev: good morning!
14:00:57 <mestery> I wanted to again highlight the ML2 wiki page.
14:01:02 <rkukura> hi
14:01:02 <mestery> #link https://wiki.openstack.org/wiki/Neutron/ML2 ML2 Wiki page
14:01:21 <mestery> But I wanted to focus the meeting on blueprints and bugs today.
14:01:35 <mestery> #topic Blueprints and Bugs
14:02:02 <mestery> The H3 feature proposal freeze is within sight now.
14:02:18 <mestery> #link https://blueprints.launchpad.net/openstack-manuals/+spec/neutron-ml2-docs ML2 Documentation Blueprint
14:02:34 <mestery> I'm hoping to get started on this this week, and apech has volunteered to help.
14:03:00 <apech> mestery: yup, happy to help, just need to be pointed in the right direction :)
14:03:18 <mestery> apech: Agreed, I will syncup with you before the end of the week.
14:03:28 <apech> great
14:03:59 <mestery> Documentation for ML2 will be important given it's a new plugin and exposes new capabilities to users.
14:04:27 <mestery> #link https://blueprints.launchpad.net/quantum/+spec/ml2-portbinding ML2 Port Binding
14:04:36 <mestery> rkukura: Hi!
14:04:43 <rkukura> trying to push a WIP patch set right now
14:05:03 <rkukura> the plugin changes are about 90% implemented
14:05:07 <mestery> rkukura: Great! I know you're technically on vacation, so whatever you can do is great!
14:05:11 <rkukura> need to implement mech driver for agents
14:05:20 <mestery> rkukura: OK, makes sense.
14:05:33 <rkukura> I'll post updated WIPs until its ready to review
14:05:34 <mestery> rkukura: So this will essentially remove the OVS/LB code from the core plugin and move it to a mech driver?
14:05:44 <rkukura> should make Friday's deadline
14:05:49 <mestery> awesome
14:05:58 <rkukura> maybe not completely
14:06:07 <mestery> ok
14:06:13 <rkukura> this will deal with picking which segment and vif_driver are used
14:06:20 <mestery> Got it
14:06:27 <rkukura> followon work could move more of the RPC details to the drivers
14:06:59 <mestery> That sounds like a good icehouse blueprint. :)
14:07:05 <rkukura> right
14:07:18 <mestery> Great! Any questions on port binding?
14:07:33 <rkukura> https://review.openstack.org/43129
14:07:43 <mestery> rkukura: Not found.
14:07:45 <mestery> Permissions issue?
14:08:13 <Sukhdev> cant open either
14:08:34 <rkukura> looks like draft != WIP
14:08:53 <mestery> If you mark it WIP then we can see it I assume.
14:09:21 <rkukura> should be fixed now
14:09:28 <HenryG> Or add specific people to the draft
14:09:35 <mestery> Works now, thanks rkukura.
14:09:38 <rcurran> fixed
14:09:43 <Sukhdev> yuo - now it is working
14:10:00 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/ml2-multi-segment-api ML2 Multi-Segment API
14:10:31 <mestery> Now that arosen's multi provider net patch has merged (https://review.openstack.org/#/c/33736/), I plan to base the ML2 multi-segment work on that API.
14:10:33 <rkukura> noticed arosen's extension just got merged
14:10:37 <mestery> So I'm hoping to get a WIP patch out by Friday.
14:10:41 <rkukura> cool
14:10:48 <mestery> rkukura: Yes, and that will help because I plan to use that as the basis. :)
14:11:08 <mestery> So ideally by Friday I'll have a WIP patch sent out.
14:11:37 <mestery> Any questions for multi-segment?
14:11:50 <rkukura> probably need to get WIP removed to make H deadline
14:12:19 <rkukura> but not sure about that
14:12:21 <mestery> Before Friday?
14:12:29 <mestery> I'll ping markmcclain about that to verify, thanks rkukura.
14:12:34 <apech> mestery: do you think multi-segment will require existing mech drivers to have to change, even if they don't support multi-segment?
14:12:39 <apech> or will it be fairly transparent
14:12:53 <rkukura> each mech driver should only deal with a single segment
14:13:03 <mestery> It should be transparant
14:13:18 <rkukura> portbinding should pick the segment/driver combo to use
14:13:39 <apech> thanks
14:13:49 <mestery> OK, moving on to the next agenda item
14:13:56 <rkukura> of course multiple segments could use the same driver, but drivers shouldn't worry about that, except during binding
14:14:06 <mestery> rkukura: Yes, makes sense.
14:14:22 <mestery> #link https://review.openstack.org/#/c/33736/ Enable GRE and VXLAN with the same ID
14:14:33 <feleouet> hi
14:14:42 <mestery> This one is ready to merge, in fact, rkukura, if you could review it you may even approve it if it looks ok.
14:14:53 <mestery> feleouet has been very responsive to comments and this will be a nice addition
14:15:01 <feleouet> I'm about to submit a patch to adress the last review comments
14:15:08 <rkukura> wrong link?
14:15:12 <mestery> I think markmcclain had comments around creating a constant for table identifiers.
14:15:26 <mestery> Sorry: https://review.openstack.org/#/c/41239/
14:15:39 <mestery> #link https://review.openstack.org/#/c/41239/ Enable GRE and VXLAN with the same ID
14:16:11 <rkukura> I will review ASAP, although that might be early next week
14:16:11 <feleouet> yes, I've adressed these comments, as well as some tipos
14:16:13 <mestery> feleouet: I'll review again once you push a new version with fixes for latest comments
14:16:26 <rkukura> will be offline Sat and Sun
14:16:31 <feleouet> mestery: ok, thanks
14:16:32 <mestery> feleouet: Awesome. rkukura, I'll work with another core since you're on vacation, don't worry.
14:17:02 <mestery> Moving on to the next item.
14:17:08 <feleouet> maybe one comment about this patch
14:17:16 <mestery> feleouet: OK
14:17:32 <feleouet> there may be a bug in test_ovs_lib which is quite weak now
14:17:46 <feleouet> (I was trying to add some tests)
14:18:09 <feleouet> but they may should be adressed in another bug right?
14:18:20 <mestery> feleouet: Yes, I would file a different bug.
14:18:39 <feleouet> Ok, great
14:19:03 <mestery> feleouet: Anything else?
14:19:40 <feleouet> not more about this bug, we may discuss about testing offline
14:19:46 <mestery> OK
14:19:52 <mestery> #link https://review.openstack.org/#/c/41213/ Arista ML2 MechanismDriver
14:20:03 <mestery> This one looks very close to merging I believe.
14:20:09 <mestery> Nice work Sukhdev on addressing comments!
14:20:16 <Sukhdev> Thanks
14:20:37 <mestery> Sukhdev: I replied in gerritt to the setup.cfg item we had talked about yesterday.
14:20:42 <Sukhdev> I will push an updated patch today
14:20:49 <mestery> Sukhdev: Great!
14:20:56 <mestery> Any questions on the Arista driver?
14:21:07 <rkukura> yes
14:21:56 <rkukura> Am I correct that this driver works in conjunction with one of the existing agent's drivers, and thus should not need to implement the portbinding?
14:22:40 <Sukhdev> rkukura: not sure I understood the question
14:22:59 <apech> it would work in conjunction with a virtual switch driver (OVS, LinuxBridge, etc)
14:23:08 <apech> I'm not sure if that means we wouldn't need to implement portbinding
14:23:18 <apech> I must admit that I don't know the details of what portbinding does well enough
14:23:22 <rkukura> With the ml2-portbinding code, there will be a mech driver for one of the L2 agents that will do the binding
14:23:46 <rkukura> It seems the arista driver will need to use the segment details that get selected during portbinding
14:23:55 <apech> yes, that's right
14:24:01 <Sukhdev> yes that is right
14:24:11 <Sukhdev> we have everything except for the port name
14:24:28 <Sukhdev> we hope to get it when the port binding gets implemented
14:24:30 <rkukura> The arista driver will need to use PortContext.bound_segment()
14:24:56 <rkukura> just a heads up that we'll need to orchestrate merging these BPs
14:25:07 <Sukhdev> yes, and I am assuming this will give us the host ID and port name, etc.
14:25:33 <mestery> rkukura: If Arista goes in first, they can submit a bug to hook into port binding afterwards I believe, right?
14:25:34 <rkukura> all the attributes of the port, including binding:host_id and name should be available
14:25:43 <rkukura> mestery: correct
14:25:59 <rkukura> The arista driver has made the deadline, as far as I'm concerned
14:26:06 <mestery> Sukhdev apech: Since your patch is likely to merge first, you guys should open a bug to track integration with port binding.
14:26:25 <rkukura> good plan
14:26:26 <Sukhdev> sure, we can open the bug
14:26:48 <mestery> #action Sukhdev to file bug to track Arista MechanismDriver integration with port binding blueprint.
14:26:59 <rkukura> please let me know if the driver_api updates in ml2-portbinding look like they will suffice
14:27:30 <apech> will do
14:27:34 <rkukura> thx
14:27:58 <mestery> And this segways nicely into the next agenda item: the Cisco Nexus ML2 MechanismDriver
14:28:05 <mestery> #link https://blueprints.launchpad.net/quantum/+spec/ml2-md-cisco-nexus Cisco Nexus MechanismDriver
14:28:08 <mestery> rcurran: here?
14:28:10 <rcurran> hi
14:28:33 <rcurran> slowed down a tad by the cisco subplugin UT port
14:28:39 <rcurran> mech driver done
14:28:42 <rcurran> db mig done
14:29:01 <mestery> rcurran: Possible to post a review today?
14:29:01 <rcurran> will work throught the UT and get something out by H3 deadline for sure
14:29:14 <mestery> Even WIP for today, updated to review in progress tomorrow?
14:29:27 <rcurran> ok, i can do that
14:29:37 <mestery> cool
14:29:56 <mestery> Anything else on the Cisco Mech driver?
14:30:03 <rcurran> nope
14:30:09 <rcurran> from me that is :-)
14:30:14 <mestery> :)
14:30:15 <rkukura> so my understanding is that this driver will need to implement the port binding functions
14:30:31 <rcurran> pb will make things cleaner
14:30:33 <rkukura> we should be able to work that out next week
14:30:40 <rcurran> we get hostname from keystone today
14:30:49 <rcurran> same as plugins/cisco
14:31:00 <mestery> I'll be on PTO next week, so rkukura, if you could work closely with rcurran on that, it would be great!
14:31:18 <rkukura> sure
14:31:46 <mestery> OK next agenda item
14:31:54 <mestery> #link https://review.openstack.org/#/c/37647/ Tail-f NCS MechanismDriver
14:32:05 <mestery> This review has seen some good progress as well.
14:32:43 <mestery> I don't know if Luke Gorrie is here to answer questions, but I wanted to bring this review to the attention of hte larger ML2 team.
14:33:17 <rkukura> I'd like to see a README on this one
14:33:26 <mestery> Yes, and also an example .ini file.
14:33:31 <mestery> I'll file comments in the review for both of those.
14:34:23 <mestery> So, the last item on the BP agenda was devstack discussion
14:34:38 <mestery> #link https://review.openstack.org/#/c/40882/ ML2 devstack MechanismDriver integration
14:34:43 <mestery> I moved this patch to WIP for now
14:34:52 <mestery> As it failed to address the case of a MD having multiple .ini sections.
14:35:05 <mestery> rcurran and I discussed this, and I have a way forward, but have not had time to implement this yet.
14:36:04 <mestery> Any questions, suggestions, ideas on ML2 devstack?
14:36:06 <Sukhdev> I sent out the email earlier - I tested it for Arista Driver - worked just fine
14:36:06 <rkukura> one ml2-portbinding is merged, devstack will need to configure the L2 agents' mech drivers by default
14:36:24 <mestery> rkukura: Yes, we should file a bug to track that work.
14:36:32 <mestery> Sukhdev: Thanks for testing this out.
14:37:22 <mestery> #topic Icehouse ML2 Work
14:37:28 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2#Icehouse_ML2_work_for_reference Icehouse ML2 Items
14:37:40 <mestery> I moved some items we had been discussing to the Icehouse section, see the link above.
14:37:51 <mestery> I don't want to discuss them now, just highlight them here.
14:38:10 <mestery> I imagine we'll want to start thinking about Ml2 Icehouse design sessions soon as well.
14:38:58 <mestery> #topic Open Discussion
14:39:18 <mestery> Just a note, I'll be on PTO next week, and likely won't have access to computers for at least half the week.
14:39:24 <feleouet> one question anyway: we made good progress on l2-population implentation, don't you think it could get in for Havana?
14:39:29 <mestery> rkukura: Can you run the meeting next week on IRC?
14:39:42 <rkukura> I'd be happy to
14:39:48 <mestery> rkukura: Thanks!
14:39:59 <mestery> feleouet: If you think it can make Havana, then I'd be happy to review it and help make it so!
14:40:17 <mestery> feleouet: It was marked WIP, so I put it under Icehouse, I'll move it back into the Havana bucket.
14:40:32 <mestery> L2 population would be a great optimization to get into H3!
14:40:38 <feleouet> mestery: great! we should soon push agent implementations
14:40:50 <mestery> that sounds like a great plan feleouet!
14:41:20 <mestery> Thanks again for all the great Ml2 work from the team!
14:41:29 <rkukura> Next week we need to focus on reviewing and merging
14:41:38 <rkukura> one more thing:
14:41:39 <mestery> rkukura: I agree 100%.
14:41:52 <rkukura> Vote for http://www.openstack.org/rate/Presentation/openstack-neutron-modular-layer-2-plugin-deep-dive
14:42:03 <mestery> rkukura: Nice plug. :)
14:42:37 <Sukhdev> sure will
14:42:39 <feleouet> we'll surely do ;)
14:42:45 <mestery> OK, thanks everyone, and thanks again to rkukura for running next week's ML2 meeting!
14:42:47 <mestery> #endmeeting