16:00:46 <mestery> #startmeeting networking_ml2
16:00:47 <openstack> Meeting started Wed Jan 22 16:00:46 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:51 <openstack> The meeting name has been set to 'networking_ml2'
16:00:56 <mestery> rcurran: Hey there!
16:01:02 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2 Agenda
16:01:22 <mestery> We have what appears at first glance to be a large agenda today, but I think this may be a short meeting, so lets see.
16:01:28 <mestery> #Action Item Review
16:01:34 <mestery> #topic Action Item Review
16:01:51 <mestery> asomya: Here?
16:02:12 <rkukura> hi
16:02:24 <mestery> rkukura: Welcome!
16:02:30 <mestery> So, I don't think asomya is here.
16:02:40 <mestery> He had an action item to revive and work with zang on the TypeDrver refactoring.
16:02:48 <mestery> I'll ping asomya offline to see where that is at.
16:02:58 <mestery> #topic Port Binding Conclusions
16:03:06 <mestery> rkukura: We segway into the next agenda item around port binding :)
16:03:19 <rkukura> Sure
16:03:20 <mestery> rkukura: You had an action item to send an email to the list with details
16:03:26 <mestery> But we can continue the discussion here as well
16:04:00 <rkukura> We covered the details at some length here last week. I've done some further thinking, and it still mostly seems to make sense.
16:04:12 * mestery nods in agreement.
16:04:38 <rkukura> I will send a summary to the list soon, but have been focusing on the stuff needed for vif_security and for sriov right now
16:05:18 <mestery> rkukura: Great!
16:05:27 <rkukura> Basically, just need to make sure we are OK with no global ordering of bind_port() and unbind_port() calls across threads and processes
16:05:29 <mestery> #action rkukura to send summary around ML2 binding to the list.
16:06:32 <rkukura> I've got some more detail on which attributes for current and original binding are valid in what calls for each API action
16:07:08 <rkukura> So I'll summarize this in the email before getting started coding.
16:07:11 <mestery> Cool, thanks rkukura.
16:07:18 <mestery> Any questions on binding from anyone?
16:08:22 <mestery> #topic ovs-firewall-driver update
16:08:24 <mestery> asadoughi: Here?
16:08:31 <rkukura> Note the some other binding-related changes will be coming from the sriov pci-passthru work
16:08:55 <asadoughi> mestery: hi
16:08:57 <sadasu> rkukura: still very much in the works so didn't bring it up earlier
16:09:14 <mestery> asadoughi: Any updates you wanted to share here regarding ovs-firewall and ML2?
16:09:26 <asadoughi> patches laying the foundation for the actual firewall driver are pending review https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/ovs-firewall-driver,n,z
16:09:55 <rkukura> sadasu: I've been going thru irenab's proposal, which I think will be discussed at tomorrow's pci-passthru meeting
16:09:58 <mestery> #info ovs-firewall-driver foundation patches out for review: https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/ovs-firewall-driver,n,z
16:10:13 <asadoughi> actual firewall driver implementation is still in prototype phase, working on seeing what parts i can delegate out to the interested parties, related blueprints
16:10:18 <mestery> asadoughi: Will make a note for the team to review these.
16:10:34 <sadasu> rkukura: yes, thanks for taking a look
16:10:59 <mestery> asadoughi: OK, thanks for the update!
16:11:26 <asadoughi> small general concern: still targetting icehouse-3, but don't know where neutron will be (e.g. current testing/gate issues)
16:11:50 <asadoughi> mestery: that's all
16:11:55 <mestery> asadoughi: Yes, agreed. This could slip to Juno or something.
16:11:58 <mestery> asadoughi: Thanks!
16:12:52 <mestery> #topic New MechanismDrivers
16:13:01 <mestery> So, there is a large amount of new MDs proposed and in various states.
16:13:08 <mestery> Please see the meeting page for links to reviews and BPs
16:13:29 <mestery> rkukura and I were talking yesterday, and we think it would be great for someone from each of these to participate in weekly ML2 meetings.
16:13:42 <mestery> Especially to ensure everyone is aware of things like the port binding changes coming down the pipeline.
16:13:50 <mestery> I'll send a note to openstack-dev with this request as well.
16:14:25 <mestery> In the meantime, reviews of the new MDs with reviews out would be appreciated by their owners.
16:14:30 <rkukura> also to discuss any plugin changes made by or needed by the news drivers
16:14:43 <mestery> Yes, thanks for bringing that up rkukura.
16:15:43 <mestery> #topic Open Discussion
16:15:45 <rkukura> we still have some time, but not much, to make plugin changes that would simplify the drivers, etc.
16:15:57 * mestery nods in agreement with rkukura
16:16:39 * mestery was right about this meeting going short I guess. :0
16:16:46 <mestery> Anything else anyone wants to bring up?
16:16:47 <banix> Just a side question: Should we have tests which make sure the plugin deals with rollbacks when a mechanism driver post-* operation fails; I have a patch to deal with such failures after update operations.
16:16:48 <rkukura> There are number of ml2 fixes in review, some approved and some not, that we should keep an eye on
16:16:48 <asadoughi> so, do we need more hands on deck for ml2 and the gate?
16:17:11 <mestery> banix: That is a good idea.
16:17:32 <rkukura> banix: Do you have a link?
16:17:44 <mestery> asadoughi: More hands on deck for the gate is always a good thing. And of course, specific ML2 issues we should be looking at.
16:18:21 <asadoughi> mestery: any directions with that regard, i haven't been following all the activity
16:18:44 <banix> rkukura; no, haven't submitted the patch as I am still trying to figure out how to add the test code. I have been testing it manually right now.
16:18:50 <mestery> asadoughi: I think the best advice I can give is to hop on #openstack-neutron and ask for status updates there.
16:19:06 <mestery> The most current info is in-channel, as the gate tends to ebb and flow very fast, making IRC the best for current status.
16:19:35 * rkukura is not sure the gate does anything very fast
16:20:25 <rkukura> but /me agrees with mestery
16:20:34 <banix> It is not that things are slow, they do not get through….
16:20:38 <mestery> rkukura: :P
16:21:14 <asadoughi> yeah, how bad is the situation? it seems most are reacting like it's another day in the park, but some are more critical of it?
16:22:30 <asadoughi> i.e. should new code stop getting reviewed, produced until gate is fixed?
16:22:48 <mestery> asadoughi: My understanding is it's pretty bad, the gate needs attention on those bugs affecting it.
16:23:08 <rkukura> I think approvals are blocked at least until i-2 is cut
16:24:01 * mestery nods in agreement.
16:24:12 <asadoughi> hmm, ok, i'll continue discussion in #openstack-neutron later
16:24:16 <mestery> I think it's best if people have cycles to jump into #openstack-neutron and see where help is needed.
16:24:21 <mestery> asadoughi: Cool, thanks!
16:24:24 <mestery> OK, thanks everyone!
16:24:44 <mestery> We'll chat again next week!
16:24:46 <mestery> #endmeeting