16:00:34 <mestery> #startmeeting networking_ml2
16:00:35 <openstack> Meeting started Wed Mar 19 16:00:34 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:39 <openstack> The meeting name has been set to 'networking_ml2'
16:01:10 <mestery> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_March_19.2C_2014 Agenda
16:01:25 <mestery> There are no action items to review from last week per the logs.
16:01:37 <mestery> #topic Migration BP
16:01:46 <mestery> #link https://review.openstack.org/#/c/76533/ Migration Review
16:01:58 <mestery> I still need to find some time to try this out. Has anyone else tried marun's patch out by chance?
16:02:18 <trinaths> Hi
16:03:11 <mestery> OK, if anyone has cycles to try it out, please do.
16:03:12 <rkukura> I found a couple issues with it (via inspection), and marun will be updating, but I think its worth testing now.
16:03:28 <mestery> rkukura: Cool, thanks!
16:03:36 <mestery> Anything else on the migration?
16:04:05 <mestery> #topic Bugs
16:04:18 <mestery> Port binding details bugs are making their way upstream now.
16:04:37 <mestery> This bug (https://bugs.launchpad.net/neutron/+bug/1276395) has one merged and one approved and on it's way upstream now.
16:04:52 <mestery> Thanks rkukura for those!
16:04:59 <mestery> Hopefully the gate settles down a bit and lets the second in today.
16:05:08 <rkukura> Thanks for the reviews, team!
16:05:28 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1276391 Bind Port called in transactions
16:05:37 <mestery> This one is also approved waiting to merge: https://review.openstack.org/#/c/79511/
16:05:51 <mestery> Thanks again rkukura here!
16:06:06 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1227336 Error handling for update ops
16:06:17 <mestery> This one is in review from banix: https://review.openstack.org/#/c/69792/
16:06:19 <rkukura> That's the same patch, its closes the 1st bug and is partial fix for 2nd
16:06:28 <mestery> rkukura: I just realized that too :)
16:06:41 <mestery> Regarding this one: https://review.openstack.org/#/c/69792/ Do we want this for icehouse still?
16:07:51 <banix> rkukura raised a question about how the undo gets reflect into mechanism drivers; I think we need to discuss that as I do not see calling the pre commit again as a solution
16:07:59 <banix> probably won't make it to Icehouse
16:08:00 <rkukura> That's the patch to try to undo an update if any MD's postcommit raises an exception
16:08:20 <mestery> Yes, I think this may be soemthing to discuss in Atlanta at an ML2 session.
16:08:28 <mestery> Should we officially defer this to Juno then?
16:08:34 <rkukura> I'm wondering if the current MDs handle this OK via re-synching or anything?
16:09:14 <banix> rkukura: I looked at a few and I think the answer is no
16:09:22 <Sukhdev> Sorry for being late
16:10:17 <mestery> I think this one warrants more discussion perhaps, so should we move this to Juno then?
16:10:25 <rcurran> +1
16:10:27 <banix> Fine with me
16:10:27 * mestery is inclined to think that given where we're at in Icehouse.
16:10:36 <banix> yes
16:10:46 <mestery> #action mestery to officially move https://launchpad.net/bugs/1227336 to Juno
16:11:07 <mestery> Next bug on the list is VIF security: https://bugs.launchpad.net/nova/+bug/1112912
16:11:10 <rkukura> banix: I'm also a bit worried about how this would interact with the patch I'm working on to move the binding outside a transaction, which adds a 2nd transaction to commit the binding result. Would we be able to undo this whole thing?
16:12:36 <banix> rkukura, then I think we have to deal with that as well… Not sure about the implications.
16:12:38 <rkukura> I think nachi has updated the 1st part of this: https://review.openstack.org/#/c/67281/
16:13:35 <mestery> rkukura: Yes, looks like there are only minor nits now and a clean jenkins run and this can maybe merge.
16:13:43 <mestery> Needs another core other than amotoki on it too.
16:13:55 <rkukura> I'm following it
16:14:25 <banix> wow just noticed the number of jobs at the gate: 70
16:14:32 <mestery> rkukura: Cool, I've looked at versions of this one in the past as well.
16:14:37 <mestery> banix: Yes, gate is having trouble.
16:15:04 <rkukura> I think the verify queue is wedged on a swift job
16:15:28 <irenab> there is a small temporary fix to mlnx MD till nova parts will be available: https://review.openstack.org/#/c/81281/. Will highly appretiate review, hope it can enter Icehouse
16:16:00 <mestery> irenaba: Is this related to the VIF security patch or separate?
16:16:11 <irenab> separate
16:16:27 <mestery> irenab: OK, we're working through the agenda on the wiki, please save updates not on there until the end.
16:16:42 <irenab> sorry, thanks
16:16:49 <mestery> Next item is a binding failure: https://bugs.launchpad.net/neutron/+bug/1244255
16:16:55 <mestery> This one looks to be closed now last time I looked.
16:17:09 <mestery> The LP bug says fix committed
16:17:21 <mestery> irenab: No worries. :)
16:18:06 <mestery> The Nova side of this one is still open I guess.
16:18:17 <mestery> Although it says invalid.
16:18:21 * mestery is confused on the status of this one I guess.
16:19:02 <mestery> rkukura: Are you reading that one the same as me?
16:19:25 <rkukura> mestery: I'm just as confused
16:19:52 <mestery> It's not just me at least. :)
16:19:53 <rkukura> I'm hoping https://review.openstack.org/#/c/80829/ will help it
16:20:25 <mestery> Yes
16:20:43 <mestery> OK, irenab, lets discuss your bug now. :)
16:21:03 <mestery> #link https://review.openstack.org/#/c/81281/ mlnx MD bug fix
16:21:16 <irenab> I have discessed
16:21:28 <irenab> discussed it with rkukura
16:21:28 <rkukura> mestery: How about asking markmcclain about his updates to https://bugs.launchpad.net/neutron/+bug/1244255?
16:21:32 <mestery> irenab: This one looks ok to me, thanks for adding tests!
16:21:42 <irenab> its just temporary till nova parts will get in
16:21:55 <irenab> mestery: thanks!
16:21:57 <mestery> irenab: OK, cool. I'll re-review today.
16:22:10 <mestery> rkukura: markmcclain, if you're here, any time to quickly discuss https://bugs.launchpad.net/neutron/+bug/1244255?
16:22:15 <rkukura> irenab: The issue I had is that binding:profile should not be modified by the plugin/driver, but given its temporary until nova does its part, I'm OK with it
16:22:18 <mestery> markmcclain: rkukura and I are confused as to it's status. :)
16:22:44 * markmcclain reads scrollback
16:23:17 <markmcclain> ok.. so I set it to fix committed because another review had merged
16:23:21 <markmcclain> is this bug not fixed?
16:23:55 <mestery> markmcclain: That's the part we're confused about. :)
16:24:13 <rkukura> markmcclain: Is the fix you are referring to: https://review.openstack.org/#/c/80829/?
16:26:08 <markmcclain> this merged: https://review.openstack.org/#/c/55000/
16:27:52 <mestery> OK, thanks for the clarification markmcclain.
16:27:54 <rkukura> markmcclain: That was back in January. The one I mentioned changes these again, and is approved, pending verify (which is hung on a swift job)
16:28:54 <markmcclain> ok.. I'll keep the bug open until 80829 merges
16:29:18 * mestery ^5s markmcclain and rkukura.
16:29:20 <mestery> Thanks!
16:29:44 <mestery> OK, any other ML2 related bugs to discuss today which were not on the agenda?
16:29:59 <rcurran> https://review.openstack.org/#/c/78774/1
16:30:07 <rcurran> looking for reviewers
16:30:33 <mestery> rcurran: I'll take this one up to review as well.
16:30:46 <rcurran> ty
16:31:40 <mestery> Any other bugs?
16:32:17 <mestery> #topic Open Discussion
16:32:30 <mestery> I put a list of deferred MDs on the agenda, FYI.
16:32:44 <mestery> Also, please note the deadline to submit Design Summit sessions is April 20.
16:33:01 <mestery> Maybe like in Hong Kong we'll have a few sessions of ML2 where we can merge topics which are community ML2 focused.
16:33:08 <asomya> Mestery can you track the type driver refactor on the agenda: https://blueprints.launchpad.net/neutron/+spec/ml2-type-driver-refactor ?
16:33:26 <mestery> #action mestery to track type driver refactor going forward https://blueprints.launchpad.net/neutron/+spec/ml2-type-driver-refactor
16:33:30 <rkukura> asomya: +1
16:33:30 <mestery> asomya: Done, and thanks for the reminder!
16:33:35 <asomya> Thanks, I'm making good progress on it
16:33:40 <mestery> asomya: Awesome!
16:34:09 <mestery> rkukura asomya: I think we're in agreement on the approach there, right?
16:34:10 <rkukura> I plan to submit a session to quickly go over all ML2 BPs that do not have their own sessions, and prioritize what gets in juno.
16:34:28 <mestery> rkukura: Good idea!
16:34:41 <Sukhdev> A general question - If I were to create a multi-segmented network which uses (VLAN and VxLAN) how can I do it?
16:34:56 * banix adding the BP for a new ml2 driver immediately :)
16:35:11 <mestery> banix: :P
16:35:20 <mestery> Sukhdev: Good question, we need documentation around that I believe.
16:35:32 <mestery> Sukhdev: You would have to "bridge" the networks using provider networks currently I believe.
16:35:55 <Sukhdev> mestery: any pointers to the documentation?
16:35:58 <mestery> The support for multi-segment gateways is something I want to add to the ODL ML2 driver in Juno.
16:36:11 <mestery> Sukhdev: There is no documentation. Are you volunteering to write it? :)
16:36:24 <Sukhdev> mestery: :-)
16:36:41 <mestery> But Sukhdev has brought up a good discussion point: Documentation.
16:36:48 <Sukhdev> mestery: investigating - if I am able to figure out - will docuemnt :-)
16:36:55 <mestery> We as an ML2 team should look at what's there and look to fill gaps in before Icehouse ships.
16:37:00 <mestery> Thanks Sukhdev!
16:37:15 <mestery> #action Sukhdev to investigate documenting muilti-segment ML2 networks
16:37:36 <mestery> Anything else for ML2 today?
16:39:01 <mestery> OK, thanks for everyone's continued ML2 efforts!
16:39:15 <mestery> Start thinking about design summit discussions, bugs, and documentation now. :)
16:39:21 <mestery> And we'll be back next week!
16:39:27 <mestery> #endmeeting