16:01:34 <rkukura> #startmeeting networking_ml2
16:01:35 <openstack> Meeting started Wed May  7 16:01:34 2014 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:38 <openstack> The meeting name has been set to 'networking_ml2'
16:02:17 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_May_7.2C_2014
16:03:12 <rkukura> #topic Announcements
16:03:38 <rkukura> Juno Summit next week, so no IRC meeting
16:04:20 <rkukura> Also, if you don’t attend the Neutron IRC meetings, you should be aware a mid-cycle sprint meeting is being planned for Juno
16:04:48 <rkukura> options being considered for date and location are at https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
16:05:50 <rkukura> I think refactoring the neutron core is part of the agenda for this, and ML2 involvement in that would be important
16:06:17 <rkukura> Any questions/comments on these announcements, or any other announcements?
16:06:48 <HenryG> Will ML2 also be affected by the task-based workflow plans?
16:06:49 <rkukura> if not, we’ll move on…
16:07:12 <rkukura> HenryG: good question
16:07:33 <rkukura> I haven’t looked at any specifics of that yet. What do you think?
16:07:54 <Sukhdev> HenryG: elaborate, please
16:08:08 <HenryG> Don't know yet. I plan to attend the task-flow session and see.
16:08:50 <Sukhdev> HenryG: when and where is the session?
16:09:15 <rkukura> Depending on the granularity of tasks being addressed, it could potentially be useful for postcommit processing, and maybe for error recovery
16:09:30 <emagana> Sukhdev: I think is Tuesday lead by markmcclain1 but there is not BP yet
16:09:45 <emagana> so it is a mystery right now
16:09:53 <HenryG> I have not seen a BP for the session yet. The session proposal is http://summit.openstack.org/cfp/details/433
16:10:29 <Sukhdev> I have been trying to dig it up -
16:10:50 <rkukura> defenitely looks relevent to ML2, and could result in significant changes to driver APIs, etc.
16:11:12 <rkukura> Anything else related to announcements?
16:11:17 <HenryG> Info on taskflow here: #link  https://wiki.openstack.org/wiki/TaskFlow
16:12:02 <rkukura> thanks HenryG
16:12:07 <rkukura> #topic Action Items
16:12:38 <rkukura> the only official AI was for me, regarding etherpads for our summit sessions
16:13:03 <rkukura> I added one for the ML2 roadmap itself, and several have been added by others
16:13:48 <rkukura> We’ve got 3 sessions that are mainly focused on ML2, each incorporation several session proposals
16:14:17 <rkukura> One question is whether we should try to do a single etherpad per session, vs. etherpads per session proposal?
16:14:22 <rkukura> Any thoughts?
16:15:00 <emagana> rkukura: single one makes easier to follow up action items
16:15:08 <asadoughi> +1 for etherpads per session proposal
16:15:33 <Sukhdev> rkukura: earlier we thought about going with one per session - either way is OK
16:15:48 <banix> even though the subsessions are related, it may be difficult to bring them into one place. May be multiple leading to sthe session and unifying we get there?
16:16:27 <rkukura> We could certainly start with one etherpad per session, but with a section for each proposal
16:17:51 <banix> rkukura: that would be fine imo
16:17:58 <HenryG> Sounds like a good compromise. At least to get started.
16:18:05 <Sukhdev> rkukura: I think that is good
16:18:07 <rkukura> I think etherpad per session would help foster dicsussion across the entire topic rather than each propsoal separately
16:18:25 <banix> makes sense
16:18:25 <nlahouti_> rkukura: how much details regarding a desing should be added in the etherpad.
16:18:48 <rkukura> Would someone like to volunteer to pull together the etherpads for each of the three sessions?
16:19:20 <banix> I can do it for the modular agent session
16:19:22 <rkukura> nlahouti_: I think a page worth of bullet points per proposal is about the max
16:19:30 <rkukura> banix: Thanks!
16:19:43 <rkukura> I’m happy to do the ML2 roadmap session
16:19:53 <Sukhdev> rkukura: we have only two etherpad as of now
16:20:05 <Sukhdev> do we have the third one created?
16:21:02 <rkukura> someone put together https://etherpad.openstack.org/p/hierarchical_network_topology
16:21:45 <rkukura> This has sections for each of the proposals that went into it
16:21:55 <Sukhdev> rkukura: thanks for pointing this one - I was missing this…this looks good
16:22:12 <rkukura> but we probably should flesh-out each with some bullets to explain the idea, raise issues, etc
16:22:20 <padkrish> rukkura: Yes, this has the three sessions for Friday
16:22:54 <Sukhdev> We need to beef this one up
16:22:59 <rkukura> we’ve moved into the next topic...
16:23:12 <rkukura> #topic ML2 Design Summit Sessions
16:24:25 <rkukura> The agenda page has links to the neutron schedule, the 3 scheduled sessions, and the wiki with the etherpads
16:25:06 <rkukura> I’d like to see the session descriptions updated to be more clear, etc., and can ask mestery about that
16:25:49 <rkukura> Are there any ML2 session proposals were supposedly accepted/merged, but don’t have a home on one of these three session?
16:26:07 <Sukhdev> rkukura: I pointed it to him about one session - he mentioned you need to do it or coordinate with him :-):-)
16:26:31 <rkukura> Sukhdev: OK, if I can, I’ll try
16:27:12 <banix> rkukura: there was a session approved for inclusion but i dont see it in the list. the session on having a unified mechanism driver for SDN controllers. I do NOT think we need to have this but wanted to get clarification on it.
16:27:40 <rkukura> banix: I thiink the intention was to cover that as part of the ML2 roadmap session
16:28:08 <banix> rkukura: yes that was my understanding.
16:28:39 <Sukhdev> rkukura: ML2 Roadmap description is not very clear - this is what I asked Kyle to fix
16:28:39 <rkukura> banix: Lets put the link to the BP/spec on the etherpad for that session, and try to identify any dependencies, and who is working on it
16:29:10 <rkukura> Sukhdev: OK, I’ll see if I can fix that one, and if not, will work with mestery on it
16:29:28 <banix> rkukura: i think this is a simple and limitted of a topic that may not need a session; will follow up later.
16:30:07 <rkukura> banix: That was the goal for the roadmap session proposal - just to raise awareness of efforts that didn’t need their own sessions
16:30:28 <banix> rkukura: ok; makes sense.
16:31:10 <Sukhdev> This is the one for ML2 roadmap - need to beef up https://etherpad.openstack.org/p/ML2_Juno_Roadmap
16:31:24 <rkukura> There were two sessions that we approved that mestery marked as “merging with Isaku's session”
16:31:39 <rkukura> Do we know which session that is?
16:32:03 <rkukura> The proposals are http://summit.openstack.org/cfp/details/395 and http://summit.openstack.org/cfp/details/409
16:32:11 <banix> yeah hold on
16:32:27 <rkukura> These seem agent-related, but I’m not sure if they are in the ML2 agent session, or a different session
16:33:26 <banix> yes the above sessions were the ones
16:33:46 <banix> not in modular agent session
16:34:18 <rkukura> banix: So are these in a separate session?
16:35:06 <yamamoto> this one? http://junodesignsummit.sched.org/event/9a0726f0946e4682bc77427afab44116#.U2pgnF7nwoc
16:35:29 <banix> not sure.
16:35:36 <rkukura> #action banix to organize single etherpad for Modular L2 Agents session
16:36:08 <rkukura> yamamoto: Yes, that looks like it. Thanks!
16:36:20 <banix> yeah yamamoto is right; i think that is the session^^^
16:36:45 <rkukura> #action rkukura to flesh out single etherpad for ML2 Roadmap session
16:37:14 <rkukura> And the hierarchical session already has a single etherpad
16:37:48 <yamamoto> per-proposal etherpads will be removed?
16:37:51 <rkukura> So each session proposer should try to flesh out an outline for discussion at the summit either the appropriate etherpad
16:38:49 <rkukura> yamamoto: If the assignees could move the per-proposal content to the the single etherpad, I think that the links to those can be removed - any reason not to?
16:39:39 <yamamoto> no reason i can think of.
16:39:57 <rkukura> please try to think about how to get the most value out of these summit sessions
16:40:38 <banix> yeah i think for each session the stake holder need to talk and organize as how to present and direct the discussion
16:40:53 <banix> s/holder/holders
16:41:44 <nlahouti_> so this would be the main link : https://etherpad.openstack.org/p/ML2_Juno_Roadmap for the ML2 road map.
16:43:00 <Sukhdev> nlahouti_: that is presently listed under neutron etherpads
16:43:29 <padkrish> rkukura: some session, e.g. hierarchical networks has three topics...so each topic owner gets around 13 or 14 mins? If every topic owner in a etherpad session brainstorms before, it can be presented by one single person after collecting the ideas
16:43:31 <Sukhdev> nlahouti_: I will add content to this later today or tomorrow
16:43:49 <nlahouti_> sukhdev: yes it is under ' ML2 Juno Roadmap'
16:44:14 <nlahouti_> sukhdev: ok
16:44:22 <Sukhdev> padkrish: I think it is a good idea -
16:44:58 <rkukura> padkrish: I’m happy for the proposers in each session to figure out how they want to run that session
16:45:08 <Sukhdev> padkrish: I was thinking we could get together on Monday or Tuesday in Atlanta and hash it out, thoughts?
16:45:45 <padkrish> sukhdev# that's also good...i have proposed a webex session for tomorrow specifically for the hierarchical network session
16:45:54 <rkukura> Remember that these are supposed to be more discussion than presentation, so I don’t think having a single presenter is very imporant
16:46:09 <Sukhdev> padkrish: can you share the webex info?
16:46:25 <padkrish> sukhdev# sure...
16:46:41 <rkukura> padkrish: I was going to look at my calendar regarding the new times - will followup to that email after this meeting
16:46:58 <Sukhdev> I think it is better the subject matter expert presents - rather than just one presenter
16:47:25 <padkrish> rkukura: Totally agree....i want to have it as a discussion for which we need to brainstorm b4...otherwise, it may become a presentation :)
16:47:49 <padkrish> rkukura: Sure, thanks...in which case sukhdev, will update with the new timings
16:48:32 <rkukura> Would be nice for each session to start with an intro that lists the topics and how they are interelated, has the discussion on the topics, then has a couple minutes at the end to see how things all fit together, get people signed up to do the work, identify dependencies/issues, etc.
16:48:33 <Sukhdev> padkrish: my email sukhdev@arista.com
16:48:59 <padkrish> #sukhdev#: Thanks
16:49:17 <rkukura> Anything else on the design summit before we move on to bugs, reviews, etc.?
16:49:56 <rkukura> #topic Bugs
16:50:07 <rkukura> #link https://bugs.launchpad.net/neutron?field.searchtext=ml2
16:50:39 <rkukura> My port binding outside transactions but is at the top of the list
16:51:02 <rkukura> Got some good review feedback, will hopefully get an update pushed before the summit
16:51:40 <rkukura> Is anyone aware of any bugs that need to be dicussed, need assignees, etc?
16:52:55 <rkukura> #topic Spec reviews
16:53:13 <rkukura> I’m way behind on this myself
16:53:26 <rkukura> Any spec reviews anyone would like to discuss?
16:54:03 <rkukura> #topic Code reviews
16:54:28 <nlahouti_> we posted couple for ML2 and got comment and reply to the comment but don't know what know what is next?
16:55:24 <rkukura> nlahouti_: Wondering if it would help to devote good chunk of the ML2 meetings to spec reviews
16:55:40 <Sukhdev> rkukura: sorry - was pulled into another thing. I put my comment on https://review.openstack.org/#/c/91811/
16:55:49 <nlahouti_> rkukura: That would help I believe
16:55:57 <rkukura> We can list the ML2-related spec reviews on the agenda, and raise awareness, get reviews signed up, ...
16:56:18 <irenab> I  have a question related to review https://review.openstack.org/#/c/74464/
16:56:54 <rkukura> irenab: what’s the question?
16:57:04 <irenab> the spec is approved, by patch is still with -2, any advice how to proceed?
16:57:50 <rkukura> irenab: Have you pinged markmcclain on IRC and/or email?
16:58:27 <irenab> rkukura: meanwile via the patch review only, will follow up with email/irc
16:58:33 <rkukura> I think our time focus post-summit needs to be on working through the ML2-related spec reviews
16:58:57 <rkukura> and the spec reviewers should then follow through on the code reviews
16:59:07 <rkukura> #topic Open Discussion
16:59:15 <rkukura> we’ve only got a minute
16:59:20 <rkukura> anything anyone?
16:59:54 <rkukura> thanks everyone!
17:00:01 <yamamoto> thanks
17:00:09 <rkukura> #endmeeting