16:02:16 <Sukhdev> #startmeeting networking_ml2
16:02:17 <openstack> Meeting started Wed May 21 16:02:16 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:21 <openstack> The meeting name has been set to 'networking_ml2'
16:03:01 <Sukhdev> Hi folks, I will be running the meeting today. Bob is here to help me out
16:03:16 <rkukura> By kind to Sukhdev  ;)
16:03:26 <Sukhdev> Agenda is https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_May_21.2C_2014
16:03:27 <rkukura> s/By/Be
16:03:44 <Sukhdev> Yes - listen to rkukura :-)
16:04:41 <Sukhdev> #info Announcements -
16:04:56 <Sukhdev> Mid-cycle code sprint scheduled July 9-11
16:05:26 <Sukhdev> #link https://etherpad.openstack.org/p/neutron-juno-mid-cycle-meeting
16:06:10 <Sukhdev> Please have a look and sign up - if you can help
16:06:30 <Sukhdev> there is a possibility that the changes may impact ML2
16:06:42 <rkukura> Focus is on nova parity I think, along with the core refactoring, which could have major implications for ML2
16:06:55 <Sukhdev> #topic - Action Items from last week - none
16:07:12 <rkukura> Sukhdev: I updated the agenda with 2, but they are both done
16:07:13 <Sukhdev> rkukura: correct - so, be watchful
16:07:52 <Sukhdev> #topic ML2 design summit sessions post-mortem
16:08:39 <Sukhdev> Four etherpads capture the information - be sure to look through them
16:09:03 <Sukhdev> Any question or issue about the etherpads?
16:09:33 <yamamoto> are they supposed to be freezed?
16:09:36 <rkukura> Any thoughts on overall ML2 sessions? Were they helpful?
16:09:57 <yamamoto> ie no more edits?
16:10:11 <banix> yamahata_: i don’t think so; please add cooments; you can mark them appropriately
16:10:15 <Sukhdev> yamamoto: I do not believe they are frozen, feel free to comment
16:10:28 <yamamoto> ok
16:10:29 <banix> yamamoto: ^^^
16:10:38 <trinaths> doubt: will ML2 driver synchronization effect the Mechanism driver codebase too
16:10:40 <Sukhdev> Please update them as you feel appropriate
16:11:02 <Sukhdev> trinaths: At this point, I do not think so
16:11:07 <shivharis> i think the ML2 sessions were very helpful. Folks were eager to know the future directions
16:11:19 <trinaths> okay.. its mentions as a BP in Juno Roadmap
16:11:33 <Sukhdev> shivharis: I felt the same - but, we were rushed a bit ;-)
16:11:49 <shivharis> one confusion that occcured during the course of the summit regarding
16:12:06 <shivharis> plugins being a shim layer to ODL like controllers
16:12:34 <shivharis> I feel it is appropriate for Openstack to be a first class citizen even if
16:12:40 <shivharis> there is not controller involved
16:12:53 <Sukhdev> shivharis: yea, but, somebody corrected it
16:12:54 <shivharis> the LLDP stuff brings about that
16:12:56 <nlahouti> rkukura: it was helpfull. I wish there was more time and  have session to discuss more details on each topics
16:13:33 <shivharis> ML2 is the appropriate place for making it first class, even without ODL etc.
16:13:46 <shivharis> that all
16:13:47 <trinaths> I haven't attended the live sessions.. will there be a oppurtunity to see the videos and presentations .. any link for the same..
16:13:50 <Sukhdev> nlahouti: +1 I felt the same way
16:14:10 <yamamoto> my impression was time/room distribution was not ideal
16:14:14 <banix> trinaths: only for thr general conference
16:14:17 <rkukura> regarding it being rushed and needing more time for details, how can we improve that?
16:14:19 <Sukhdev> trinaths: Design sessions are not recorded
16:14:45 <shivharis> the POD talks were very very helpful
16:14:46 <banix> trinaths: the general conference sessions were recorded and are on youtube already
16:15:05 <Sukhdev> rkukura: If we would have gotten an extra session, it would have helped to spread the topics a bit
16:15:29 <rkukura> shivharis: yes, lots of good progress in the PODs (neutron kind of took over all the tables in the POD room at times)
16:15:33 <trinaths> sukhdev: reg. Design sessions, where can i view ideas/presentations ..
16:15:38 <Sukhdev> shivharis: Agreed. I loved the idea of Pods - in fact, we used them very effectively for ML2 discussions
16:15:56 <banix> with the talk of having coding sessions next time or the one after, i wonder if we lose more slots to regular design sessions
16:16:09 <rkukura> So more session slots would help. Maybe we need to pick fewer proposals too?
16:16:11 <banix> s/to regular/from regular/
16:16:48 <Sukhdev> Any feedback about the PODs?
16:16:55 <rkukura> Did the bundling of related proposals into sessions work, or did we need more time to really understand the individual proposals?
16:17:04 <asadoughi> yes, i'd prefer if we discussed fewer topics at length then many with time constraints
16:17:10 <Sukhdev> trinaths: there is a link which lists all the sessions
16:17:21 <banix> sukhdev: PODs were good; need a better way for scheduling meetings there
16:17:33 <asomya> Sukhdev: We need more tables for Neutron next time in the POD area :)
16:17:41 <rkukura> asomya: +1
16:17:46 <shivharis> rkukura: bundling allowed more 'sessions', but the title of the session did not do justice
16:17:48 <trinaths> Sukhdev: okay.. can you kindly share the link .. please
16:17:52 <Sukhdev> banix: correct
16:17:52 <asomya> rkukura: The bundling worked but the title was a bit misleading
16:18:16 <Sukhdev> trinaths: I will look and send - does anyone have access to the link?
16:18:27 <shivharis> banix: instead of coding, whiteboarding may help more, your opinion?
16:18:27 <asadoughi> rkukura: 3 proposals in 40 min felt much too tight, no more than 2 in one session next time please
16:18:40 <banix> trinaths: https://wiki.openstack.org/wiki/Summit/Juno/Etherpads
16:18:49 <rkukura> I think the bundling of the hierarchical networks session worked prerry well, but the information shating happened first in the POD, so we kind of had a plan by the time the session occurred
16:18:51 <Sukhdev> banix: Thanks
16:19:15 <trinaths> banix: thanks a lot
16:19:33 <Sukhdev> shivharis: we did good amount of whiteboarding in the pods
16:19:38 <rkukura> Maybe its best to present the ideas in the session, then use the POD to collaborate on how they related, etc.
16:19:58 <Sukhdev> rkukura: great idea...
16:19:59 <nlahouti> rkukura: I think one way to do is to have people involved in the topic, dedicate their time in the POD area and have discussion.
16:20:00 <asomya> rkukura: +1
16:20:02 <shivharis> sukhdev: yup, that was a great success
16:20:25 <banix> with the general conference overlapping only 1 day with the design sessions in Paris we may have a bit more time organizing at the summit before the design sessions
16:20:33 <Sukhdev> rkukura: communications about the PODs (and scheduling) can be improved in future
16:20:57 <rkukura> One thing I don’t feel we came out of the summit with is a clear sense of what is realistically going to get done during Juno, and the priorities
16:20:58 <shivharis> IMHO, whiteboarding in PODs, with any number of onlookers/interested folks
16:22:06 <rkukura> marun and some others have been suggesting combining code sprints with the summit - maybe this whiteboarding is similar, where groups with a common interest whiteboard a design and start coding
16:22:10 <Sukhdev> This is all great feedback - we should use for next summit
16:22:42 <banix> also send feedback to the foundation
16:23:18 <Sukhdev> rkukura: yes, whiteboarding, and coding can go hand in hand - if planned correctly
16:23:37 <Sukhdev> OK shall we move on?
16:23:42 <nlahouti> that's correct. It has to be planed in advance.
16:23:53 <Sukhdev> #topic: Bugs
16:24:04 <Sukhdev> https://bugs.launchpad.net/neutron?field.searchtext=ml2
16:24:14 <shivharis> sukhdev: i differ on that, sorry, usually coding needs more think time for good code
16:25:03 <Sukhdev> shivharis: We used the same method during Montreal Tempest coding sprint, and it worked very well
16:25:37 <Sukhdev> shivharis; We used the white board to discuss the design, agreed to the plan and then divided the work and implemented it
16:25:53 <Sukhdev> shivharis: In three days we were able to achieve a lot
16:26:00 <shivharis> sukhdev: ok, i missed that event.
16:26:50 <Sukhdev> Back to bugs - I see a lot of them accumulating
16:26:52 <rkukura> So how should we as the ML2 subteam ensure we are making good progress squashing the bugs?
16:27:18 <rkukura> Do we need some triaging within the subteam prior to these meetings?
16:27:23 <shivharis> first tag all bugs as ML2
16:27:35 <shivharis> all => all relevant
16:28:01 <Sukhdev> shivharis: I believe these are all ML2 bugs
16:28:03 <rkukura> Did someone at the summit volunteer to do initial triage/tagging of all neutron bugs?
16:29:07 <shivharis> don't know, but i can take ownership of ML2 tagging
16:29:12 <Sukhdev> First, we need to ensure they all have an owner
16:29:59 <rkukura> they need tag and importance to be set, and if importance is high enough, they need owners
16:30:11 <Sukhdev> shivharis: cool - thanks…I think they are already tagged, but, if you can scan through them
16:30:32 <yamamoto> are md-specific bugs expected to be ml2-tagged?
16:30:45 <rkukura> shivharis: Do you want to try to estimate importance as they show up, even if they are tagged to ml2 by someone else?
16:30:59 <yamamoto> or is it for ml2 “core” part only?
16:31:32 <shivharis> rkukura: I can, but will need your help to some extent
16:31:44 <rkukura> yamamoto: We’ve tended to use higher priority/importance for ml2 core than for vendor drivers
16:31:57 <Sukhdev> yamamoto: yes they should be ml2 tagged
16:32:30 <rkukura> So at these meetings, should we look for owners for medium and above importance bugs needing them?
16:32:42 <shivharis> suggestion: steps: 1. tag+assign priority 2. search on tags and take ownership. 3. if there are leftovers, assign
16:33:11 <shivharis> rkukura: yes if high priority are left over we should discuss in IRC
16:33:18 <Sukhdev> shivharis: sounds great…..
16:33:48 <rkukura> shivharis: As “ml2 bug czar”, would you be able to drive the bugs section of the agenda in future meetings, getting owners, making sure high importance stuff is making progress, etc?
16:33:56 <Sukhdev> #Action: shivharis to scan all the bugs and tag them and prioritize them
16:34:07 <shivharis> Ok, i'll sign up
16:34:33 <Sukhdev> shivharis: cool - thanks
16:34:49 <Sukhdev> On to next topic
16:34:55 <manishg> also, if some bugs aren't seeing action but are important they can be discussed here in the meeting to make sure some progress is made.
16:35:05 <rkukura> Our only high importance bug right now, binding ports in transactions, will be back in review in the next day or so
16:35:16 <Sukhdev> #topic: Spec Reviews
16:35:42 <Sukhdev> https://review.openstack.org/#/q/status:open+project:openstack/neutron-specs,n,z
16:35:43 <rkukura> I made an attempt to list all the ML2-related specs in the agenda
16:36:16 <rkukura> There are 2 that have been merged, 14 in review, and at least one coming
16:36:21 <Sukhdev> I notice two are merged and others are in review
16:36:31 <Sukhdev> rkukura :-)
16:36:57 <banix> working on the spec for sdn-ve mechanism driver; will update and remove workinprogress soon
16:37:02 <Sukhdev> We, as a team, should review them first before we ask the core reviewers
16:37:23 <rkukura> I’d be happy to by the “ml2 spec czar” and keep this organized for each meeting
16:37:36 <Sukhdev> We should have at least one +1 from our team before we ask the core's
16:37:50 <Sukhdev> rkukura: that will be awesome!!
16:37:52 <rkukura> Maybe even two +1s?
16:38:03 <Sukhdev> rkukura: agreed
16:38:13 <shivharis> 2 +1s, agreed
16:38:22 <banix> Sukhdev: well, the specs get submitted to gerrit and there is a chance others may review first
16:38:28 <manishg> rkukura, Sukhdev - yeah, sounds like good idea for a couple of folks from subteam to first review and then ask core.
16:38:33 <rkukura> I’d really appreciate input on whether this is the right set to track - are some not relevant? are some missing?
16:39:25 <rkukura> we’ve been kicking around the idea of having initial reviews within the subteam to improve scalabiltiy of the entire project - not wasting core reviewer’s time on stuff that isn’t very close to ready
16:39:51 <Sukhdev> banix: that is OK if others jump on it first - but, for all ML2 related specs, we should make sure somebody from our sub-team is on it as well
16:39:58 <manishg> where's the list of specs you narrowed down rkukura?
16:40:06 <banix> Sukhdev: makes sense
16:40:20 <rkukura> maybe next week we can make sure we’ve got at least two subteam reviewers for each spec
16:40:26 <banix> manishg: on the agenda
16:40:28 <rkukura> manishg: In the meeting agenda
16:41:07 <shivharis> rkukura: +1
16:41:13 <Sukhdev> rkukura: that sounds like a good idea, does everybody agree as well?
16:41:14 <yamamoto> what’s an appropriate way to “tag” a spec as ml2-related?
16:41:42 <Sukhdev> yamamoto: good question - suggestions, ideas?
16:41:54 <rkukura> yamamoto: I like having “ML2: …” as the first line of the commit message when its focus is on ML2
16:42:21 <trinaths> rkukura:  +1
16:42:21 <rkukura> But something like the DVR spec impacts ML2, but isn’t owned by ML2, so won’t do this
16:42:48 <yamamoto> rkukura: +1
16:43:03 <zzelle> mention ML2 in the commit message ?
16:43:06 <rkukura> There should be associated lauchpad BPs that can be tagged I think, right?
16:43:30 <zzelle> so we can use message:ml2 as gerrit filter  ?
16:43:42 <shivharis> i think initial bug filer may not be sure where is belongs, so investigating the details can imply ML2
16:43:54 <rkukura> Maybe we still want to track things from lauchpad, and make sure these have links to the gerrit spec reviews
16:44:18 <rkukura> One comment on some of the summit session etherpads is to “not bury this in ML2”
16:44:50 <Sukhdev> rkukura: what did they mean or imply?
16:44:51 <manishg> possible to have something in commit message like "impacts: ml2; api; etc"
16:45:50 <manishg> this was for tagging the specs.  but then we rely on commiter to do the right thing.  same issue with other suggestion about commit message.
16:45:57 <trinaths> in the subject have ml2-specs: <spec name>
16:46:06 <shivharis> i am ok with ML2: ... as commit message
16:46:16 <rkukura> Actually, I don’t see a way to tag BPs in launchpad
16:46:23 <manishg> trinaths - this doesn't cover specs that involve ML2 but aren't only ML2.  e.g. DVR.
16:46:50 <shivharis> how about DVR,ML2: ....
16:47:06 <trinaths> manishg: true. I mean it would be simple when we search gerrit for ml2-specs.
16:47:12 <rkukura> I’ll try to move the list from the agenda into an etherpad that we can use to pull together the links to the spec reviews, the launchpad BPs, and the subteam reviewers assigned to each
16:47:38 <manishg> well, DVR will touch of lot of stuff.  so the tag list could be long (if in subject)
16:47:43 <Sukhdev> rkukura: good idea
16:47:46 <manishg> rkukura +1
16:47:53 <yamamoto> rkukura +1
16:48:01 <trinaths> rkukura +1
16:48:07 <banix> rkukura: that is a good idea
16:48:18 <shivharis> +1
16:48:18 <manishg> maintain a list of spec elwewhere.  so someone should be paying attention to the specs and if there is ml2 involvment, add that to that list.
16:48:19 <rkukura> Sukhdev: you can give me a #action for that
16:48:51 <Sukhdev> #action: rkukura to move all the specs from Action item to an etherpad
16:49:03 <rkukura> This will be the set of specs that touch ML2, not just ones focused on ML2
16:49:22 <shivharis> and add that etherpad link to Agenda
16:49:22 <Sukhdev> rkukura: thanks
16:49:29 <rkukura> Sukhdev: s/Action/Agenda/
16:50:11 <rkukura> Ten minutes left
16:50:32 <Sukhdev> #action: rkukura to move all the specs from Agenda to an ehterpad
16:50:48 <Sukhdev> #topic: Code Reviews
16:50:53 <trinaths> need spec reviews for my MD pending from Icehouse.
16:51:09 <Sukhdev> https://review.openstack.org/#/q/status:open+project:openstack/neutron,n,z
16:51:32 <trinaths> i have code too in place for review. need help of the team for review.
16:52:13 <Sukhdev> trinaths: yours is in the list, right, we will get on to it
16:52:30 <trinaths> sukhdev: okay..
16:52:34 <Sukhdev> trinaths: I will look at it
16:52:43 <Sukhdev> Anything else?
16:52:54 <Sukhdev> #topic: Open Discussion
16:53:05 <Sukhdev> Anything general?
16:53:14 <Sukhdev> we have 6 min. left
16:53:39 <Sukhdev> Looks like we have covered most of it :-)
16:53:44 <banix> I think Sukhdev did a good job chairing the meeting!
16:53:59 <rkukura> banix: +1
16:54:02 <Sukhdev> banix: Thank you…you are so kind
16:54:02 <shivharis> great summit, thanks sukhdev for organizing
16:54:04 <trinaths> banix: true said..
16:54:13 <trinaths> +1
16:54:43 <Sukhdev> You guys are very nice team members - hence, my job was easy - so, the credit goes to you
16:54:52 <yamamoto> what’s the next step for modular agent?
16:54:58 <trinaths> :D
16:55:24 <shivharis> I need help in becoming a power user of IRC, where to look for a tutorial?
16:55:25 <Sukhdev> banix: you want to take that?
16:55:37 <banix> there have been a couple of people interested in this work; will send an email this week to get organized before we send an email to ML
16:55:46 <manishg> yamamoto: modular L2 agent?  is mohammad here?
16:55:53 <banix> as we were asked to do in the design session
16:56:08 <banix> manishg: yes I am here
16:56:17 <rkukura> yamamoto: No spec yet, so getting people to work on one or more specs would be the place to start once there is a plan
16:56:23 <manishg> ah, didn't know your irc name!  okay :)
16:56:33 <Sukhdev> #action: banix to send an email regarding ML2 Modular agent plan and seek interested parties
16:56:58 <Sukhdev> banix: I assigned you an action - hope you are OK
16:57:00 <banix> Sukhdev: sounds good
16:57:16 <Sukhdev> Anything else?
16:57:35 <Sukhdev> We did well - we are right on time
16:57:45 <Sukhdev> #endmeering networking_ml2
16:57:47 <shivharis> thanks, bye all.
16:57:49 <rkukura> Thanks Sukhdev, everyone!
16:57:53 <trinaths> bye all
16:57:57 <rkukura> bye
16:57:59 <yamamoto> thanks
16:58:00 <asomya> bye
16:58:08 <banix> bye
16:58:11 <Sukhdev> #endmeeting networking_ml2