16:03:40 <Sukhdev> #startmeeting networking_ml2
16:03:41 <chuckC> hi
16:03:42 <openstack> Meeting started Wed Jun  4 16:03:40 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:45 <openstack> The meeting name has been set to 'networking_ml2'
16:04:16 <emagana> let's go for it
16:04:18 <Sukhdev> #topic Agenda
16:04:20 <trinaths> Hi ML2ers
16:04:49 <Sukhdev> #topic Announcements
16:05:00 <Sukhdev> I have one announcement -
16:05:17 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2
16:05:29 <Sukhdev> Did you folks look at the new Neutron Policies wiki yet?
16:05:38 <trinaths> Sukhdev: yes
16:05:39 <Sukhdev> rkukura: thanks - I missed that :-)
16:05:45 <banix> Sukhdev: yes, just a quick look
16:05:58 <Sukhdev> #link https://wiki.openstack.org/wiki/NeutronPolicies
16:06:04 <banix> Sukhdev: anything to update there wrt ML2?
16:06:15 <Sukhdev> There is really good info in there -
16:06:16 <shivharis> yes, guick look from me too
16:06:44 <Sukhdev> banix: I was going to ask the team to look at it and feel free to provide the feedback related to ML2 content
16:07:18 <banix> i see the mention of subteams and review process through that
16:07:28 <Sukhdev> When I started with OpenStack - I had to striggle to get this kind of info, so this is good for the new commers :-)
16:07:31 <shivharis> sub-team section needs to be updated with sub-team reviews etc.
16:08:09 <chuckC> NeutronPlugins is just a framework so far, too
16:08:12 <rkukura> shivharis, banix: I’m not sure there is any general agreement on subteam reviews yet
16:08:24 <Sukhdev> Yes, there was a lot of discussion during summit about the sub-team roles - we should provide feedback to get it captured here
16:08:46 <shivharis> rkukura: it can be a good start, to formalize this process
16:09:03 <Sukhdev> shivharis: agreed
16:09:18 <Sukhdev> Anything else on this topic?
16:09:46 <Sukhdev> #topic Action items from last week
16:10:08 <Sukhdev> rkukura: any update on the etherpad update?
16:10:28 <trinaths> sub-team reviews means, the mentioned reviewers will review the spec. right ?
16:10:33 <Sukhdev> I looked at it earlier this week and made some updates
16:10:41 <rkukura> I have not tried to set priorities yet, or anything like that
16:11:06 <rcurran> Sukhdev, is this in regards to https://etherpad.openstack.org/p/Neutron_ML2_Juno_Spec_Tracking
16:11:21 <rkukura> I’d like some input from the sub-team, and then will discuss with mestery what priorities we should assign
16:11:26 <shivharis> rcurran: yes
16:11:41 <rkukura> I think the various vendor-specific drivers need to generally have equal priorities
16:11:54 <Sukhdev> I have noticed no body signed up as reviewer for https://review.openstack.org/#/c/93613/
16:12:11 <nlahouti> sukhdev: looks like list not updated
16:12:23 <rcurran> Sukhdev, ok, dumb q then, are engineers suppose to update this w/ new bp, specs or is just one person doing this work
16:12:27 <rkukura> And BPs that effect the plugin itself, are needed by multiple drivers, and are generally considered useful should be higher priority than the drivers
16:12:49 <rkukura> rcurran: I’d hope we’d all update the etherpad as we do reviews
16:13:06 <banix> rkukura: makes sense
16:13:06 <rkukura> and as we file BPs
16:13:16 <Sukhdev> rcurran: rkukura had taken action to update it intially, but, now, I think any team member should be able to update it ---
16:13:18 <shivharis> rkukura: +1
16:13:20 <rkukura> otherewise it will get more and more out of date
16:13:23 <rcurran> rkukura, i need to add three bp's (all cisco_nexus related)
16:13:39 <rcurran> Sukhdev, ok - i'll add in these three BPs
16:13:46 <Sukhdev> but, I would like rkukura to monitor the priority
16:13:58 <Sukhdev> rcurran: sure
16:14:14 <rkukura> My big question about prioriies is whether we should try to priority within the new feature BPs, and whether the lower priority of these should be same as or below vender driver BPs
16:14:36 <Sukhdev> I would request the team to be reviewers on other specs as well and provide feedback
16:14:40 <rkukura> s/try to priority/try to prioritize/
16:14:59 <banix> I am wondering if having priority is a great idea
16:15:10 <Sukhdev> rkukura: on thought would be based upon the impact on the others
16:15:16 <Sukhdev> s/on/one
16:15:33 <banix> i think wrt  reviews considering the number of us and the number of reviews, the goal should be to hit all during the week
16:15:56 <rkukura> banix: good goal
16:15:59 <banix> dont want to create a queue before getting to the bigger Neutron wide queue
16:16:00 <Sukhdev> banix: this might help get them move along quckly
16:16:36 <rkukura> I’d like to be able to distinguish between things needed by several drivers and things that one person thinks are nice to have
16:16:38 <shivharis> there may be things that may be contentious..
16:16:49 <Sukhdev> On a second thought, if we made sure that we have at least two reviewers on each spec from this team, then we can leave on them to move the process along
16:16:52 <banix> manishg: hi
16:17:03 <manishg> banix: hi
16:17:08 <manishg> sorry , got late today.
16:17:25 <Sukhdev> rkukura: yes, that is what I meant by the impact to others
16:17:28 <rkukura> The priorities we set on the BPs apply to both spec and code review priority, right?
16:17:30 <banix> Sukhdev: yes i think that should be the main goal
16:17:54 <shivharis> rkukura: that is reasonable
16:18:23 <rkukura> I want to make sure reviews for ML2 drivers aren’t so low priority that cores and others outside the team never look
16:18:49 <Sukhdev> rkukura: good point….
16:19:08 <rkukura> Ok, I’ll keep my action item for next week, and will chat with mestery about how we should be assigning these priorities
16:19:13 <Sukhdev> Once the sub-team blesses it, we will coordinate with the cores to get these approved
16:19:33 <Sukhdev> rkukura: Thanks
16:19:48 <Sukhdev> Anything else on this topic?
16:19:55 <rkukura> Ideally, for drivers, core reviews should be mostly a rubber stamp if the subteam reviewers have done their jobs!
16:20:07 <trinaths> rkukura: for ML2 reviews, cores and outsiders need to have good understanding of the work flow rather than simple code review.
16:20:07 <shivharis> #action rkukura to talk to mestery for blueprint priorities
16:20:42 <Sukhdev> #action: rkukura to discuss with Kyle for BP priorities
16:20:49 <rkukura> trinaths: agreed - that’s why sub-team reviews are so important - we are the ones that understand the work flows within ML2 in detail
16:20:57 <Sukhdev> #topic: banix to recruit folks interested in Moduler L2 agent implementation
16:21:03 <banix> There were a few emails on the ML. I have started coding and will have something out for comment/review before the next meeting; something people can comment on and can become the basis for writing the spec.
16:21:07 <Sukhdev> banix: any update?
16:21:08 <trinaths> rkukura: okay..
16:21:43 <banix> matrohon: manishg and yamahata_ have been offering to help and I will get in touch with them and the rest as soon as I have the code out for review
16:21:44 <shivharis> banix: code before spec?
16:22:14 <Sukhdev> shivharis: :-)
16:22:15 <banix> shivharis: not the final code; some sketches, a bit more as to figure out the details and options
16:22:30 <shivharis> :-) I am fine...
16:22:47 <manishg> shivharis: I think some skeleton code is much clearer than docs sometimes :)  (imho)
16:22:49 <Sukhdev> banix: makes sense - kind of like POC..
16:22:52 <banix> during the previous discussions we said we need to work out the details a bit more so that has been my goal
16:23:09 <shivharis> where can i take a peek at the code? I am interestred..
16:23:14 <yamamoto> banix: i have an impression that you are mixing yamahata and me.
16:23:52 <Sukhdev> banix: anything else?
16:23:52 <banix> shivharis: will post to the mailing list when have something to share; well before the next meeting
16:24:04 <banix> Sukhdev: that’s it for me
16:24:12 <rkukura> banix: +1
16:24:20 <Sukhdev> #topic: Bugs
16:24:25 <banix> yamamoto: sorry
16:24:31 <Sukhdev> shivharis: the floor is yours
16:24:37 <shivharis> ok
16:24:53 <shivharis> https://bugs.launchpad.net/neutron/+bug/1227336, thank banix for closure
16:24:55 <uvirtbot> Launchpad bug 1227336 in neutron "ml2 plugin update operations" [Medium,Fix released]
16:25:13 <banix> shivharis: np
16:25:16 <shivharis> also in this situation does the closure require that it will not be fixed?
16:25:44 <shivharis> because it indicated that it is fixed..
16:26:20 <shivharis> moving on.. i dont have an answer to this hoping others had an answer
16:26:22 <banix> shivharis: wasn’t sure what to use; there is a temp fix released; there is a plan to fix for the long run so wont fix didnt make sense
16:26:43 <shivharis> banix: ok
16:26:48 <shivharis> https://bugs.launchpad.net/neutron/+bug/1193861
16:26:49 <uvirtbot> Launchpad bug 1193861 in neutron "ML2 plugin needs to override bulk operations" [Medium,Triaged]
16:27:06 <shivharis> sukhdev: can this bug also have the same fate....
16:27:21 <shivharis> sync work planned should cover this?
16:27:33 <rkukura> I’m not sure this is related to sync
16:28:04 <banix> shivharis: dont think so
16:28:29 <Sukhdev> shivharis: from the description it looks differnt - let me take action to discuss with Andre
16:28:30 <banix> wasn’t this fixed?
16:28:34 <rkukura> Is the description text true?: Bulk operations on the ML2 plugin will simply call each action sequentially within one transaction.
16:28:34 <shivharis> can someone take this and update the stutus on this...
16:29:05 <rkukura> If that is the case, and postcommits are called within that transaction, this is a valid bug
16:29:05 <Sukhdev> #action : Sukhdev to investigate bug 1193861
16:29:06 <uvirtbot> Launchpad bug 1193861 in neutron "ML2 plugin needs to override bulk operations" [Medium,Triaged] https://launchpad.net/bugs/1193861
16:29:19 <shivharis> the title does not do justice, should be fixed
16:29:21 <banix> ignore my last comment; this is a different bug
16:29:57 <Sukhdev> shivharis: I will follow up on this one....
16:30:04 <shivharis> next bug i am following up with Oleg, have not heard back.
16:30:30 <shivharis> https://bugs.launchpad.net/neutron/+bug/1246737, pending response from oleg
16:30:34 <uvirtbot> Launchpad bug 1246737 in neutron "ML2 plugin deletes port even if associated with multiple subnets on subnet deletion" [Medium,Confirmed]
16:31:13 <shivharis> https://bugs.launchpad.net/neutron/+bug/1236127
16:31:14 <uvirtbot> Launchpad bug 1236127 in neutron "ML2 plugin needs additional unit tests" [Medium,In progress]
16:31:20 <shivharis> need new owner...
16:31:32 <shivharis> any takers.. requires unit test
16:32:02 <shivharis> kyle needs to move it to someone..volunteers needed
16:32:44 <shivharis> dead silence. will tackle at a later time....
16:32:59 <Sukhdev> rkukura and I will discuss this with Kyle -
16:33:00 <shivharis> i am done with bugs for now.. more next time..
16:33:00 <rkukura> This might be a good task for someone new wanting to get started on ml2
16:33:00 <chuckC> I can try, but still working on my test environment
16:33:09 <Sukhdev> I was hoping some volunteer will rise :-)
16:33:44 <Sukhdev> chuckC: thanks
16:33:47 <chuckC> np
16:34:02 <shivharis> chuckC: get started, we will muster help for you.
16:34:16 <chuckC> shivharis: thanks
16:34:18 <shivharis> chuckC: thx
16:34:27 <shivharis> sukhdev: i am done
16:34:35 <Sukhdev> shivharis: thanks
16:34:44 <Sukhdev> any question on bugs?
16:34:59 <Sukhdev> #topic: Spec Reviews
16:35:20 <Sukhdev> We discussed about the etherpad earlier
16:35:33 <nlahouti> yamamoto: a question for you: https://review.openstack.org/#/c/89728/ is under your name as sub-team reviewer. Have you had chance to review it?
16:35:37 <Sukhdev> any body has anything more to add?
16:35:56 <rkukura> I’d like to clarify that everyone should update the etherpad as needed, make sure BPs are listed, add yourself as reviewers, etc.
16:36:21 <nlahouti> rkukura: that's great
16:36:34 <trinaths> Sukhdev: for code revies too can you add sub teams from ML2 for those which are already approved.
16:36:42 <Sukhdev> rkukura: can you please sign up for  https://review.openstack.org/#/c/93613/
16:36:43 <rkukura> And when you do a review, please try to update the status line with the general state of the review
16:36:50 <banix> do we do anything proactively when a spec is reviewed within the group and has a few +1s?
16:37:00 <Sukhdev> rkukura: this is the one we discussed during summit in the POD area
16:37:00 <yamamoto> nlahouti: yes i did +1 on it
16:37:28 <rkukura> banix: I was thinking that once we have at least 3 sub-team +1s, and no -1s, we should update the status to something like “ready for core review”
16:37:33 <shivharis> banix: start coding... :-)
16:37:43 <Sukhdev> trinaths: I am hoping the members who sign up for spec review, will also do the code review
16:37:52 <nlahouti> yamamoto: thx for the update. what is next step? can it be approved.
16:38:18 <trinaths> Sukhdev: how abot already approved ones, they dont have sub-team reviewrs. We need to update on that.
16:38:31 <banix> rkukura: i think that is a good idea; so need to keep track of status. i think the owner can update when they see the +1s
16:38:43 <trinaths> [doubt] Am I eligible to do a (no-voting) spec review ?
16:38:57 <banix> trinaths: of course
16:39:12 <rkukura> banix: I agree the owner should do that status update
16:39:35 <Sukhdev> trinaths: feel free to reach to the team members in that case for the reviews
16:39:36 <rkukura> trinaths: Your vote counts within the subteam!
16:39:40 <yamamoto> nlahouti: as it has two +1 already, ask for core review?
16:39:46 <trinaths> banix: okay..
16:39:51 <trinaths> rkukura: sure..
16:40:31 <rkukura> Sukhdev, yamamoto: I’ll review that one
16:40:31 <nlahouti> yamamoto: thx.
16:40:31 <trinaths> I will mail the owner on doubts with respect to specs and post a review.
16:40:49 <Sukhdev> rkukura: cool thanks
16:40:57 <banix> yeah there a re a few spec with a few +1s
16:40:58 <nlahouti> rkukura: thx
16:41:28 <banix> i think we may just have a subsection for sub team approved and the owner can move the spec under that heading after seeing the +1s
16:41:34 <banix> just a suggestion
16:41:45 <shivharis> banix: +1
16:41:52 <rkukura> banix: Makes sense to me!
16:42:11 <rkukura> Whay should the sub-team +1 threshold be?
16:42:13 <yamamoto> banix +1
16:42:15 <Sukhdev> banix: do you want to say anything on the Modular L2 agent BP? - It is on the agenda
16:42:50 <rkukura> I was kind of thinking we’d want 3 +1s just to make sure enough people have had a chance to review it
16:42:51 <banix> Sukhdev: I said what I had earlier; Will have more next week.
16:43:05 <banix> rkukura:  3 +1s sounds reasonable
16:43:23 <banix> Sukhdev: hope that is ok
16:43:50 <Sukhdev> banix: yes - wanted to make sure you get the floor on this - as it is on the agenda
16:44:02 <rkukura> So sub-team members - your vote counts - don’t give your +1 until you feel the spec or code is really ready for core review
16:44:08 <banix> Sukhdev: thanks
16:44:18 <Sukhdev> On to the last topic - on the ML2 sync
16:44:22 <trinaths> but reviews are specific to the reviewer views on the topic. As I see there can be many views for a topic for many. if there are 3 +1s and 1 '-1' what will be the case.
16:44:43 <Sukhdev> rkukura: you had filed a BP for ML2 Sync, right?
16:44:50 <rkukura> Sukhdev: Yes
16:45:06 <Sukhdev> rkukura: can we add that on the etherpad?
16:45:14 <Sukhdev> rkukura: or did I miss it?
16:45:15 <banix> trinaths: will try to answer the -1 and get the reviewer who gave -1 change the vote when satisfied
16:45:31 <shivharis> will it be ok to move "sync", "ml2-agent" to high priority
16:45:33 <trinaths> banix: oka
16:45:39 <rkukura> trinaths: That might be a situation to discuss at this meeting if it cannot be resolved by ansering the comments and/or communicating wit hte reviewer who left the -1
16:45:54 <trinaths> rkukura: okay..
16:46:13 <rkukura> Sukhdev: Thats should be under planned, right?
16:46:29 <Sukhdev> rkukura: I think so
16:46:51 <rkukura> On sync, I think we need to take a close look at the taskflow library and decide whether to try to use it at the plugin level and/or the driver level
16:47:03 <Sukhdev> Want to ask the team a question: Did every body had a chance to review the ML2 Sync spec
16:47:28 <Sukhdev> rkukura: yes - did you have a chance to speak with Mark on that?
16:47:31 <banix> Sukhdev: unfortunately missed it; have a link?
16:48:04 <Sukhdev> banix: it is on the etherpad that we used to present at summit -
16:48:12 <Sukhdev> will look for it and post it again
16:48:19 <banix> Sukhdev: thanks
16:48:41 <rkukura> I’ve been following the email discussion on task-based API, and kind of think that ML2 can address the sync using taskflow independently of decisions on exposing tasks in the API
16:48:51 <Sukhdev> I think we, as a team, need to review it and bless it…..as this will impact almost everybody
16:49:07 <rkukura> Sukhdev: bless what?
16:49:39 <Sukhdev> rkukura: the direction which we want to take in regards to the implementation of the sync
16:50:06 <Sukhdev> rkukura: we have few approaches to consider
16:50:25 <shivharis> rkukura: in which case it is the plugin not the driver, that actually decides it if that is the approach
16:50:34 <rkukura> Sukhdev: Weren’t we going to look into taskflow? If so, should we update the google doc after doing so, then do a formal BP spec once we have concensus on an approach?
16:51:06 <banix> yeah i think the sync operation is a substantial/significant new feature
16:51:13 <shivharis> task level approach looks cleaner
16:51:17 <Sukhdev> rkukura: correct….
16:51:41 <Sukhdev> rkukura: you were going to talk to Mark to get the info on taskflow…any luck on that?
16:51:48 <shivharis> but will it cover all cases and nuances of vendor drivers/hardware?
16:51:55 <rkukura> Sukhdev: not yet - thanks for the reminder
16:52:20 <banix> is there anything beyond the taskflow library and doc itself that we can use to educate ourselves?
16:52:22 <rkukura> shivharis: don’t know yet - haven’t done the investigation
16:52:45 <Sukhdev> rkukura: Shall I assign to action?
16:52:49 <rkukura> banix: The task API email discussion is relevant
16:52:53 <rkukura> sure
16:52:56 <rkukura> Sukhdev: sure
16:53:08 <banix> rkukura: ok thanks
16:53:32 <Sukhdev> #action: rkukura to discuss with Mark regarding taskflow and provide feedback
16:53:43 <Sukhdev> we have 5 min
16:53:52 <Sukhdev> #topic: Open Discussion
16:54:07 <Sukhdev> Any thing on folks mind?
16:54:11 <trinaths> Freescale CI - voting status..
16:54:21 <Sukhdev> trinaths: what about it?
16:54:29 <trinaths> currently non-votin
16:54:29 <rkukura> I see code reviews and open discussion are not on today’s agenda - we need to keep up with these as well as spec reviews
16:54:59 <trinaths> need your reviews on the voting suggestion
16:55:02 <asadoughi> ovs-firewall-driver is being discussed on mailing list.. lots of good feedback being addressed
16:55:06 <Sukhdev> rkukura: good point…
16:55:14 <shivharis> rkukura: i'll volunteer to take that on next meeting...
16:55:42 <Sukhdev> shivharis: cool thanks
16:55:59 <Sukhdev> trinaths: I am still not clear as to what is that you are asking?
16:56:22 <Sukhdev> trinaths: there is tons of info in CI stuff….do you have any specific question>
16:56:23 <trinaths> Sukhdev: how can  I move Freescale CI to voring
16:56:31 <banix> not sure what is the process to get a CI system to voting status
16:56:34 <trinaths> Sukhdev: voting*
16:56:49 <trinaths> as I see its the community decision
16:56:51 <Sukhdev> trinaths: that should be brought up at IRC channel #openstack-infa
16:56:54 <trinaths> from jeremy email
16:57:00 <trinaths> okay..
16:57:03 <banix> i think now the CI systems start as non voting; may need to bring up in Neutron meeting?
16:57:05 <Sukhdev> trinaths: did you discuss this there?
16:57:09 <shivharis> trinath: can you ping anteaya on that, and also report back for edification
16:57:27 <trinaths> reviewers kindly review my  change for ML2 MD
16:57:28 <fungi> trinaths: the process is that whatever project you intend to vote on needs to request that you have voting rights
16:57:38 <trinaths> shivharis: sure will talk to anteaya
16:57:59 <fungi> trinaths: so perhaps a vote in the weekly neutron meeting or get kmestery to request voting access for you if this is neutron-related
16:58:10 <banix> fungi: trinaths yeah thats what i recall; bring up at Neutron IRC call or talk to mestery
16:58:13 <trinaths> fungi: okay.
16:58:28 <mestery> trinaths: Your CI is too new for votring rights IMHO.
16:58:30 <emaganap> trinaths: I believe the voting will be accepted after the community verifies a consistent performance from the CI
16:58:36 <anteaya> trinaths: anteaya will tell you to read this: http://ci.openstack.org/third_party.html#permissions-on-your-third-party-system
16:58:40 <mestery> It hasn't been running long enough yet, and it's had issues over the past 2 weeks. FYI.
16:58:49 <Sukhdev> trinaths: #openstack-neutron and #openstack-infra are the channels
16:58:56 <trinaths> okay.
16:59:18 <mestery> trinaths: Once it's stable, has been running well and correctly, I woudl be supportive of giving it voting rights.
16:59:19 <Sukhdev> trinaths: there you go…. mestery gave you the answer...
16:59:41 <Sukhdev> Folks we are almost out of time…..
16:59:47 <Sukhdev> any last thing?
16:59:58 <Sukhdev> mestery: any last word of wisdom?
17:00:00 <trinaths> mestery: okay
17:00:06 <emaganap> enjoy your day!
17:00:11 <banix> Thanks all and have a great day/night
17:00:14 <trinaths> mestery: patchset 24 did not fail
17:00:17 <mestery> Sukhdev: Nope, that's it, thanks!
17:00:21 <mestery> trinaths: OK, looking again.
17:00:25 <rkukura> thanks Sukhdev!
17:00:28 <Sukhdev> OK folks we are done
17:00:29 <trinaths> thanks all
17:00:34 <shivharis> bye, thanks all
17:00:36 <rkukura> bye
17:00:40 <Sukhdev> #endmeeting networking_ml2