16:02:05 <Sukhdev> #startmeeting networking_ml2
16:02:05 <openstack> Meeting started Wed Jul 23 16:02:05 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:08 <openstack> The meeting name has been set to 'networking_ml2'
16:02:32 <Sukhdev> rkukura: are you here?
16:02:47 <Sukhdev> #topic Agenda
16:03:03 <Sukhdev> #link https://wiki.openstack.org/wiki/Meetings/ML2#Agenda
16:03:26 <emagana> hi folks!
16:03:46 <Sukhdev> #topic Announcements
16:04:09 <Sukhdev> #info: Juno-2 is tomorrow
16:04:26 <Sukhdev> https://launchpad.net/neutron/+milestone/juno-2
16:04:54 <Sukhdev> Spec approvals for Juno deadline is passed now
16:05:06 <Sukhdev> We got bunch of our specs approved and merged
16:05:21 <shivharis> do we have any in exception state?
16:05:25 <Sukhdev> I updated the table to reflect it - we will cover it later in the meeting
16:05:33 <Sukhdev> I believe so
16:05:48 <mestery> FYI: Juno-2 was just released 25 minutes ago, please don't target bugs to Juno-2 anymore. :)
16:06:13 <Sukhdev> mestery: ahead of schedue...
16:06:18 <shivharis> oops... i targeted one for j2, i thought it was tomorrow
16:06:25 <mestery> shivharis: no worries, just letting you know
16:06:28 <shivharis> will back out...
16:06:34 <mestery> shivharis: already did that :)
16:06:38 <Sukhdev> shivharis: was yesterday
16:06:42 <mestery> Sukhdev: We always try to release early :)
16:06:45 <shivharis> mestery: thx
16:07:18 <Sukhdev> I noticed Rich was on vacation and couple of his specs did not make it
16:07:32 <Sukhdev> mestery: can we put those on exception list, please?
16:08:03 <mestery> Sukhdev: At this point, exceptions are going to be very hard to get.
16:08:10 <mestery> Sukhdev: Basically, next to impossible. :)
16:08:26 <Sukhdev> mestery: His Specs were ready to go...
16:08:49 <Sukhdev> mestery: he did not let me know he was on vacation, otherwise, I would have followed up for him
16:09:21 <mestery> I've given +2 on them and replied to the list, but no other cores have stepped up to be the second +2 yet.
16:09:41 <Sukhdev> emagana: can you oblige, please?
16:09:57 <emagana> Sukhdev: Sure!
16:10:10 <Sukhdev> mestery: will that work?
16:10:14 <emagana> I just actually -1 one
16:10:16 <emagana> sorry!
16:10:30 <Sukhdev> emagana: Opps..
16:11:02 <Sukhdev> emagana: there are two specs - listed here https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews#Under_Review
16:11:19 <Sukhdev> Anyways moving on
16:11:32 <Sukhdev> #info - Name of next release is Kilo
16:11:40 <emagana> Sukhdev: I will take a look to the other one
16:11:51 <Sukhdev> emagana: Thanks
16:12:09 <Sukhdev> Anybody wants to make any announcement?
16:12:12 <emagana> kilo  :-( w
16:12:33 <Sukhdev> emagana: as in kilogram, as in 1000's :-)
16:12:55 <emagana> Sukhdev: still don't like it!
16:12:58 <Sukhdev> emagana: Hey we are growing - so, think 1000's :)
16:13:17 <Sukhdev> emagana: community power - majority rules :-)
16:13:22 <banix> this will confuse all Americans
16:13:28 <banix> :)
16:13:39 <Sukhdev> banix: is that a news :-)
16:13:45 <banix> Will probably get twice as much done
16:13:54 <Sukhdev> enough fun - lets move on
16:14:03 <Sukhdev> #topic Bugs
16:14:10 <Sukhdev> shivharis: Hi
16:14:19 <shivharis> need owner for:https://bugs.launchpad.net/neutron/+bug/1327127
16:14:21 <uvirtbot> Launchpad bug 1327127 in neutron "neutron: infinite loop in port create (qpid/ML2 ovs) - Icehouse" [High,Confirmed]
16:14:29 <shivharis> anyone?
16:15:28 <shivharis> then i will go ahead and assign - be ready
16:15:49 <shivharis> https://bugs.launchpad.net/neutron/+bug/1246737 this needs closing... we decided last meeting..
16:15:50 <uvirtbot> Launchpad bug 1246737 in neutron "ML2 plugin deletes port even if associated with multiple subnets on subnet deletion" [Medium,Confirmed]
16:16:32 <shivharis> i seem to get dead silence -
16:16:47 <shivharis> padkrish?
16:16:49 <padkrish> shivharis# i will close it, i put a comment there last week to check if anyone has objections
16:17:05 <Sukhdev> shivharis: sorry was reviewing them :-)
16:17:15 <shivharis> thx, padkrish, please go ahead and close this one
16:17:20 <shivharis> https://bugs.launchpad.net/neutron/+bug/1338202
16:17:23 <uvirtbot> Launchpad bug 1338202 in neutron "ML2 plugin update_port changes binding:profile when not changed" [Medium,In progress]
16:17:34 <shivharis> per mestery this one will be j3 now
16:17:40 <irenab> the fix is pushed for review
16:17:41 <padkrish> shivharis# sure, will do it...i made the status as "opinion" last week :)
16:18:12 <shivharis> irenab: i saw that - was hoping a quick turn around on review
16:18:32 <shivharis> emagana: can u please review 1338202
16:18:32 <irenab> shivharis: me too
16:18:49 <emagana> shivharis: Yes, I will
16:18:57 <shivharis> emagana: thanks
16:19:05 <shivharis> https://bugs.launchpad.net/neutron/+bug/1338202 Status?
16:19:07 <uvirtbot> Launchpad bug 1338202 in neutron "ML2 plugin update_port changes binding:profile when not changed" [Medium,In progress]
16:19:19 <Sukhdev> Folks were busy trying to meet the Spec review deadlines - hopefully, we will get more attention this week
16:19:32 <shivharis> oops typo before...
16:19:55 <shivharis> i understand - i was hoping to make j2 as well for bugs
16:20:23 <shivharis> thats all from me folks... anything that did not make j2 is now j3
16:20:36 <Sukhdev> shivharis: Thanks
16:20:58 <Sukhdev> Any questions on bugs? or any critical one which we missed?
16:21:13 <Sukhdev> #topic Spec Reviews
16:21:27 <Sukhdev> #link https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews#Under_Review
16:21:40 <Sukhdev> I updated this wiki to reflect all the approved specs
16:21:55 <Sukhdev> Please update it, if missed any one
16:22:14 <Sukhdev> We did very well on the approvals
16:22:35 <Sukhdev> I hope we get extension approved for Rich's spec
16:22:58 <Sukhdev> #topic: Code Reviews:
16:23:12 <Sukhdev> #link: https://review.openstack.org/#/q/status:open+project:openstack/neutron,n,z
16:23:33 <Sukhdev> Now that specs are out of the way, we need to focus on the code reviews
16:23:45 <Sukhdev> Keep in mind 8/20 as the deadline
16:24:13 <Sukhdev> Any questions on Specs or Code reviews ?
16:24:39 <Sukhdev> #topic: ML2 Sync
16:25:04 <Sukhdev> #link: https://docs.google.com/document/d/17fATwZkJEonH0pIb1-mPD0UB5RKnJzcHYqkBesJhirE/edit
16:25:19 <Sukhdev> Folks, we need volunteers for this
16:25:53 <Sukhdev> We need to iron out the approach for this and a clean proposal
16:26:17 <rkukura> hi - sorry I’m late
16:26:33 <Sukhdev> rkukura: ah ha - you missed all the fun
16:26:59 <shivharis> Sukhdev: lets talk about the sync stuff next meeting - we were all very busy meeting deadlines
16:27:20 <Sukhdev> shivharis: sure
16:28:08 <Sukhdev> rkukura: we are towards the tail end - want to share some wisdom?
16:28:26 <Sukhdev> #topic: Open Discussion
16:28:35 <armax> hi
16:28:42 <Sukhdev> armax: hi
16:28:49 <armax> rkukura and I have talked about ways to improve the handling of port bindings in the ml2 plugin
16:29:01 <nlahouti> Does anybody know who can approve BP for changes in devstack?
16:29:04 <armax> in preparation of the hiearchical port bingins
16:29:24 <armax> as well as for improving some of the code structure after the dvr introduction
16:29:53 <Sukhdev> nlahouti: #openstack-dev
16:30:00 <armax> working on it, I should be able to push something for review in the next few hours
16:30:15 <rkukura> armax: great - I’ll review today
16:30:20 <armax> rkukura: thanks
16:30:36 <armax> I’ll ping you when it’s ready
16:30:46 <nlahouti> Sukhdev: thx. Do you mean IRC or using the ML?
16:31:04 <asomya> I have to sync up with rkukura on the type driver refactor work, the overlay type driver BP is a no go for Juno and we'll be covering those bits in the refactor and Bob's hierarchicical port bindings patch
16:31:10 <Sukhdev> armax: we will all jump on it and review it
16:31:21 <Sukhdev> nlahouti: IRC
16:31:24 <armax> Sukhdev: sounds good thanks
16:31:27 <rkukura> asomya: yes - have some ideas on that
16:31:32 <nlahouti> Sukhdev: thanks.
16:32:29 <Sukhdev> asomya: I read the comments
16:33:04 <Sukhdev> asomya: I think merging and collaborating with rkukura's work makes a lot of sense
16:33:50 <Sukhdev> asomya: I have an interest in this as well - from the Arista driver point of view
16:34:13 <Sukhdev> Folks, any thing else?
16:34:17 <asomya> Sukhdev: We should sync up soon, considering there's less than a month to deadline
16:34:40 <rkukura> Lets put something on the agenda to go over the plans for hierarchical port binding and the related BPs next week - and try to nail down a plan before that
16:34:41 <Sukhdev> asomya: I agree - can you shoot me an email sukhdev@arista.com?
16:34:52 <asomya> sukhdev: sure
16:35:18 <Sukhdev> rkukura: Shall I assign you action?
16:35:28 <rkukura> yes
16:35:34 <shivharis> asomya: please add shivharis@gmail.com thx
16:35:48 <asomya> shivharis: sure
16:36:31 <Sukhdev> #action: rkukura to put the hierarchical port binding discussion on the agenda for next week's discussion
16:36:51 <Sukhdev> Anything else?
16:37:09 <yamamoto> nothing from me
16:37:28 <Sukhdev> OK folks - lets enjoy the extra time today
16:37:37 <Sukhdev> #endmeeting