16:03:14 <Sukhdev> #startmeeting networking_ml2
16:03:15 <openstack> Meeting started Wed Aug  6 16:03:14 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:18 <openstack> The meeting name has been set to 'networking_ml2'
16:03:57 <Sukhdev> #topic: Agenda
16:04:07 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2#Agenda
16:04:24 <Sukhdev> Today's agenda is short and sweet
16:04:41 <Sukhdev> #topic: Announcements
16:05:04 <Sukhdev> Juno-3 is around the corner - so all focus on code reivews
16:05:34 <Sukhdev> make sure your BPs or bugs are included in here https://launchpad.net/neutron/+milestone/juno-3
16:06:13 <Sukhdev> I do not have any other announcement - any body has anything to announce?
16:06:42 <Sukhdev> moving on
16:06:57 <Sukhdev> #topic: Action Items from last week
16:07:07 <Sukhdev> We have two action item
16:07:46 <Sukhdev> I spent some time cleaning up our wiki to reflect the correct stage of the specs and the code reviews
16:07:54 <Sukhdev> #link: https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews
16:08:17 <amotoki_> Sukhdev: great. can we swap the sections of spec reviews and code reviews?
16:08:19 <Sukhdev> All the Specs that have been deferred to Kilo are listed in first table
16:08:43 <Sukhdev> amotoki_: that thought crossed my mind as well - will do
16:09:11 <Sukhdev> We need to make sure all the approved specs are captured correctly.
16:09:40 <Sukhdev> I looked for the associated patches for the specs and put the links in the wiki - so that it will easy for everybody
16:09:41 <rkukura> Lets also make a section at the bottom for BPs that are completed.
16:10:06 <Sukhdev> Please ensure that when you push a patch, update it - so that folks in this group can review your code
16:10:21 <banix> Sukhdev: great. thanks.
16:10:48 <Sukhdev> rkukura: I actually removed the completed BPs from the list - as i thought we did not need to track them
16:11:27 <shivharis> Sorry guys, just listening in - actually in another meeting, will not be contributing to ml2 today...
16:11:31 <Sukhdev> rkukura: If we feel it make sense to keep them on the wiki, I can put them back
16:11:34 <rkukura> Sukhdev: Are we sure the entire BPs are complete? We need to be careful with BPs involving multiple merges.
16:12:12 <Sukhdev> rkukura: Good point - so far I saw one which was a complete by-itself
16:12:32 <rkukura> I’d prefer to keep the completed ones in a separate section so we can see the progress and move it back if it turns out more work is needed.
16:12:51 <Sukhdev> rkukura: I think it is not a bad idea to keep the completed ones around - this way we can measure our success/progress :-)
16:13:08 <yamamoto> rkukura +1
16:13:55 <Sukhdev> banix and I will work on getting additional table added and swap the first and second table per amotoki_ suggestion
16:14:11 <Sukhdev> Anything else or suggestion on this?
16:14:13 <amotoki_> Sukhdev: What does '-' in the Code column mean?
16:14:14 * banix nods
16:14:47 <Sukhdev> banix: want to answer that?
16:15:03 <banix> means not available
16:15:11 <banix> no code under review
16:15:25 <amotoki_> I think some of them are already completed.
16:15:35 <amotoki_> I can help to track down the status.
16:15:39 <banix> then they should be updated
16:15:54 <banix> amotoki_: sure great
16:16:05 <Sukhdev> amotoki_: Please do - thanks
16:16:39 <Sukhdev> amotoki_: When I updated this table, I was making sure that I add the links to the code which is out there, I did not pay attention if it was completed or not
16:17:07 <Sukhdev> amotoki_: keeping it up to date helps everybody
16:17:37 <Sukhdev> On to the next item in the list
16:17:48 <Sukhdev> rkukura: any update on the second action item?
16:18:24 <Sukhdev> https://bugs.launchpad.net/neutron/+bug/1311470
16:18:27 <uvirtbot> Launchpad bug 1311470 in neutron "Disabling an ML2 type driver can leave orphaned DB records" [Medium,Confirmed]
16:18:53 <rkukura> I haven’t had a chance to update that yet.
16:19:27 <Sukhdev> rkukura: you still plan on doing it?
16:19:37 <rkukura> yes
16:19:59 <Sukhdev> shall I keep the action item open - as a reminder
16:20:18 <rkukura> please
16:20:24 <Sukhdev> #action: rkukura to add comments to https://bugs.launchpad.net/neutron/+bug/1311470
16:20:29 <uvirtbot> Launchpad bug 1311470 in neutron "Disabling an ML2 type driver can leave orphaned DB records" [Medium,Confirmed]
16:20:35 <Sukhdev> #topic: Bugs
16:20:49 <Sukhdev> shivharis: is not available today
16:21:07 <Sukhdev> #link: https://bugs.launchpad.net/neutron?field.searchtext=ml2
16:21:25 <Sukhdev> I updated one of the bugs - that he had assigned to me last weel
16:21:33 <Sukhdev> s/keel/week
16:21:57 <Sukhdev> Anybody has any update or want to discuss any specific bug here?
16:21:58 <nlahouti> rcurran: Is bug#1330598 valid ?
16:23:21 <Sukhdev> nlahouti: that one is intersting
16:23:34 <Sukhdev> rcurran: do you plan on working on it?
16:23:49 <Sukhdev> rcurran: I also wonder if it is a valid one?
16:23:53 <rcurran> i'm trying to get to it
16:23:59 <nlahouti> Sukhdev: I recall rcurran had comment on that and supposed to update the log
16:25:07 <amotoki_> nlahouti: i think it is valid though it is low. good unit test coverage sounds nice.
16:25:11 <Sukhdev> rcurran: here is the link https://bugs.launchpad.net/neutron/+bug/1330598
16:25:12 <uvirtbot> Launchpad bug 1330598 in neutron "ML2 Cisco Nexus MD: Need UT For Multi-Switch Configuration" [Low,Confirmed]
16:25:35 <romilg> I wanted to discuss about one bug here, May I ?
16:25:48 <Sukhdev> romilg: please do
16:25:55 <romilg> thanks :)
16:26:03 <romilg> https://bugs.launchpad.net/neutron/+bug/1224978
16:26:04 <uvirtbot> Launchpad bug 1224978 in neutron "port binding on multi segment networks could lead to agent misconfiguration" [Medium,Fix committed]
16:26:14 <rcurran> thanks Sukhdev (browser issues) ... yes the bug is valid and this will get fixed at some point ... low priority
16:26:14 <romilg> Launchpad bug 1224978 in neutron "port binding on multi segment networks could lead to agent misconfiguration"[Medium,Confirmed]
16:26:31 <romilg> I have checked-in the code
16:26:36 <romilg> pls review
16:27:06 <romilg> https://review.openstack.org/#/c/103546/4
16:27:16 <Sukhdev> rkukura: any thoughts on this bug?
16:27:44 <rkukura> It is a potential issue
16:28:29 <Sukhdev> #action: shivharis: to track https://review.openstack.org/#/c/103546/4
16:28:50 <Sukhdev> romilg: I have added to the action item for shivharis to track this
16:29:00 <romilg> thanks a lot :)
16:29:07 <Sukhdev> Anything else on the bugs?
16:29:27 <Sukhdev> #topic: Spec Reviews:
16:29:46 <Sukhdev> Well this topic will disappear next week -
16:30:10 <yamamoto> i have a bug to mention https://bugs.launchpad.net/neutron/+bug/1352801
16:30:14 <uvirtbot> Launchpad bug 1352801 in neutron "l2pop to stop using tuples everywhere" [High,In progress]
16:30:28 <Sukhdev> I wanted to wish this topic good bye this week - we will bring it back on agenda next release cycle
16:30:46 <Sukhdev> So, we are all on to the code review from now onwards
16:31:01 <Sukhdev> yamamoto: looking
16:32:24 <Sukhdev> yamamoto: I am not familiar with this one - anybody want to shed some light on this?
16:32:34 <amotoki_> I totally agree with armando and carl. It is better to avoid using tuples from the code maintainability and extensibility. Also it makes review easier.
16:33:32 <amotoki_> l2pop code uses a tuple like (ip, device_owner).
16:34:03 <Sukhdev> Shall I add to the action item to follow up as well?
16:35:05 <Sukhdev> #action: shivharis to track bug https://bugs.launchpad.net/neutron/+bug/1352801
16:35:06 <uvirtbot> Launchpad bug 1352801 in neutron "l2pop to stop using tuples everywhere" [High,In progress]
16:35:17 <banix> the suggestion is to replace tuples with what?
16:35:40 <rkukura> dictionaries, I’d guess
16:35:40 <amotoki_> The proposed review https://review.openstack.org/#/c/112178/ describes it much :-)
16:35:54 <banix> i see
16:37:13 <Sukhdev> Lets all review the patch by Carl and consider yamamoto comments on the review
16:37:44 <Sukhdev> that leads to the next topic:
16:38:00 <Sukhdev> #topic: Code Reviews
16:38:06 <carl_baldwin> Sukhdev: Still a WIP, remember that.
16:38:21 <carl_baldwin> But, feedback on the direction I’ve started taking is welcome.
16:38:48 <Sukhdev> carl_baldwin: correct - I noticed
16:39:08 <Sukhdev> #link: https://review.openstack.org/#/q/status:open+project:openstack/neutron,n,z
16:39:28 <Sukhdev> Folks we have until 8/10 to push the code and 9/4 to get it all approved
16:39:40 <Sukhdev> which means only few short weeks
16:39:58 <rkukura> Is 8/10 the feature proposal deadline?
16:40:01 <yamamoto> 8/10?
16:40:13 <Sukhdev> Opps - my bad - it is 8/20
16:40:35 <Sukhdev> yamamoto: yes feature proposal deadline
16:40:56 <banix> what is the fate of ml2 extension support:  #link https://review.openstack.org/#/c/89211/
16:41:14 <Sukhdev> Please do bring up in this meeting - if any critical code review needs attention
16:41:19 <nlahouti> banix: it is on review
16:41:28 <amotoki_> correction 8/20 -> 8/21
16:41:30 <nlahouti> and we are addressing the review comments
16:41:42 <banix> nlahouti: but the -2 remains. you know why?
16:42:18 <Sukhdev> amotoki_: thanks for the correction….I do not know why 8/20 got engraved in my head :-):-)
16:42:33 <nlahouti> banix: I asked markmcclain to remove it as he added while back as the BP is not approved. The BP is approved and he needs to remove -2
16:42:49 <nlahouti> banix: I asked him in neutron meeting for the same
16:43:18 <banix> nlahouti: yes noticed that and since the -2 has remained i am wondering why … that’s all
16:43:36 <nlahouti> banix: I'll remind him again
16:43:40 <banix> ok
16:44:06 <Sukhdev> nlahouti: can you have a chat with him on it- I remember he mentioned he had some concerns
16:44:09 <rkukura> nlahouti: I’d suggest getting the patch updated to address existing comments, then I’ll be happy to contact markmcclain as well.
16:44:21 <amotoki_> on the other hand, comment from armax sounds reasonable. he requested how to use the feature and me too.
16:44:54 <nlahouti> rkukura: sure. I'm actively working on the comments and update the patch today.
16:45:09 <Sukhdev> Anything else on code reviews?
16:45:33 <Sukhdev> #topic: ML2 Hierarchical Port Binding and Dynamic Segments
16:45:58 <Sukhdev> I reviewed the document by rkukura - looks reasonable and refreshed my memory from Atlanta summit
16:46:16 <rkukura> I expect to start coding the port binding today, and hopefully post at least a WIP by the end of the week
16:46:33 <Sukhdev> rkukura: cool
16:46:46 <rkukura> I also did an initial review of asomya’s type driver patch
16:46:57 <Sukhdev> Anything on this topic? Did others have chance to review the material
16:47:12 <rkukura> I suggested that it should be split into multiple patches. Wondering if others concur?
16:47:13 <padkrish> sukhdev# Yes i did
16:47:19 <rcurran> rkukura, will first post include asomya's "customer type driver" which was X'd out in favor or you adding it to your commit
16:47:27 <Sukhdev> rkukura: I am in the middle of it - I reviewed some files - did not finish all
16:48:17 <Sukhdev> padkrish: good
16:48:43 <rkukura> rcurran: Do you mean “custom type driver”? If so, I think that is the refactoring that I’m suggesting asomya break out as a separate patch from the dynamic segment support.
16:48:50 <padkrish> rkukura# Do you think we should have examples/use-cases added to the document, like what we discussed y'day?
16:49:27 <rkukura> padkrish: Are you refering to the draft google document I started about a week ago?
16:49:27 <padkrish> That may help reviewing the code easier for everyone...
16:49:37 <padkrish> rkukura# Yes
16:49:53 <padkrish> this is what i have https://docs.google.com/a/arista.com/document/d/1rqTHiLgV_3bw3nbiggY_xM-xETDsw0aK5rZZVXopSU8/edit?pli=1#
16:49:54 <Sukhdev> padkrish: rkukura mentions about VDP use case in the document, please add examples/use cases
16:49:54 <rkukura> padkrish: I agree the details for the specific use cases would be really helpful.
16:50:45 <padkrish> sukhdev# Yes, i was hinting at more like...the list of MD drivers, type drivers...how the flow looks like for port binding
16:51:05 <padkrish> i can add it to the doc...others can review it...so that we can be on the same page
16:51:05 <rcurran> rkukura, asomya had two BPs up for review, refactor + custom type driver. custom type driver was X'd by kyle in favor of you adding this logic to your BP
16:51:14 <Sukhdev> rkukura: can you give write access to padkrish so that he can add to this document?
16:51:31 <rkukura> Sukhdev: yes, good idea
16:51:51 <padkrish> sukhdev, rkukura# sounds good
16:51:54 <Sukhdev> padkrish: yes, that will be very useful/helpful
16:52:17 <Sukhdev> Anything else on this topic?
16:52:25 <Sukhdev> On to the last topic
16:52:34 <Sukhdev> #topic: Open Discussion
16:52:40 <rcurran> rkukura, https://review.openstack.org/#/c/104341/
16:53:24 <rkukura> rcurran: I think the plan is for each fabric to have its own network_type value and associated type driver
16:53:43 <rkukura> rcurran: But to factor out a common baseclass if that helps
16:54:39 <rcurran> rkukura, asomya is out this week so i'll ask him on his return. during my vacation i noticed his bp was X'd with kyle's comment of "Per discussion with Bob, the Hierarchical Network BP Bob is doing can cover this use case."
16:55:18 <rkukura> rcurran: I had a call with asomya and padkrish yesterday evening, so we are I think on the same page with this
16:55:30 <rcurran> rkukura, ok great
16:56:11 <Sukhdev> padkrish: please capture all your understanding in the document - this will help everybody come to common understanding
16:56:23 <padkrish> #sukhdev# sure
16:56:35 <Sukhdev> padkrish: thanks
16:56:48 <Sukhdev> Anybody wants to say anything else - we have 4 min
16:57:04 <amotoki_> I added the link of google docs to the hierarchical port bidning BP so that everyone can access the doc.
16:57:28 <Sukhdev> amotoki_: excellent idea - thanks
16:57:52 <Sukhdev> Ok folks - I think we are done….
16:57:59 <Sukhdev> #endmeeting