16:02:56 <Sukhdev> #startmeeting networking_ml2
16:02:57 <openstack> Meeting started Wed Aug 20 16:02:56 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:02 <openstack> The meeting name has been set to 'networking_ml2'
16:03:23 <Sukhdev> #topic Agenda
16:03:44 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2#Agenda
16:03:59 <emagana> hello all!
16:04:10 <Sukhdev> #topic: Announcements
16:04:35 <Sukhdev> Juno feature proposal deadline is tomorrow
16:05:01 <Sukhdev> For any approved spec/bp - please ensure that your code is in by tomorrow
16:05:21 <Sukhdev> I looked at our wiki - some of the code links are missing
16:05:51 <Sukhdev> I filed in some, but, not all - the owners should be looking and filling them in
16:06:53 <Sukhdev> emagana did a wonderful job of checking into third party CI's and have put together minimal requirements for Juno
16:07:30 <Sukhdev> Please look at this https://wiki.openstack.org/wiki/NeutronThirdPartyTesting and look for sub-section for Juno minimal requirements
16:07:54 <emagana> Sukhdev: Thanks! Yes, I am also working directly with most of the CI owners. If you have any questions, you can email me directly (avoiding overload the MLs)
16:08:00 <Sukhdev> make sure your CI meets these requirements or expect a big -2 from him :-)
16:08:17 <emagana> emagana: Keep making friends!
16:08:35 <slogan> That's really helpful, thanks for sharing this with us
16:08:36 <amotoki> IPv6 support will change the minimum requirement of dnsmasq 2.63 which is not provided in Ubuntu 12.04.
16:08:43 <Sukhdev> emagana: friends or enemies :-):-)
16:09:06 <amotoki> If anyone runs your third party CI, it may potentially break your CI.
16:09:12 <slogan> can someone remind me of the link where all of the ml2 juno work is tracked?
16:09:14 <emagana> Let's said I won't win any election at this time...
16:09:43 <Sukhdev> amotoki: so the fix is to upgrade to higher version, correct?
16:10:04 <Sukhdev> slogan: we will cover that later
16:10:05 <amotoki> Sukhdev: correct. Upgrading to 14.04 is most recommended way.
16:10:11 <slogan> thx
16:10:31 <amotoki> Ipv6 team will announce it in the next team meeting.
16:10:42 <Sukhdev> amotoki: I just upgraded my CI to 14.04 - others may want to do the same - saves a lots of headache
16:10:52 <irenab> amotoki: this should not fail agent, right?
16:10:52 <emagana> amotoki: I dont think Infra will move to 12.04, will they?
16:11:08 <emagana> sorry, I mean 14.04
16:11:28 <Sukhdev> emagana: infra is already moved to 14.04, I believe
16:11:30 <amotoki> emagana: AFAIK, most tempest jobs are already run on ubuntu 14.04.
16:12:03 <emagana> Thanks! I was not sure about that!
16:12:29 <Sukhdev> So, I just wanted to make sure that everybody is aware of these deadlines and requirements
16:12:53 <Sukhdev> #topic: Action Items from previous Week
16:13:34 <Sukhdev> I updated https://bugs.launchpad.net/neutron/+bug/1311470 to reflect our conclusion from last week's meeting
16:13:35 <uvirtbot> Launchpad bug 1311470 in neutron "Disabling an ML2 type driver can leave orphaned DB records" [Medium,Confirmed]
16:13:55 <rkukura> Sukhdev: Thanks for taking care of my action item! Look fine to me!
16:14:13 <Sukhdev> rkukura: no worries
16:14:45 <Sukhdev> next item - emagana to file doc bug corresponding to https://bugs.launchpad.net/neutron/+bug/1311470
16:14:45 <uvirtbot> Launchpad bug 1311470 in neutron "Disabling an ML2 type driver can leave orphaned DB records" [Medium,Confirmed]
16:14:54 <Sukhdev> emagana: any update?
16:15:31 <emagana> Sukhdev: I will work on this item (and others doc related) next week when I meet in San Antonio with Some of the Docs folks
16:15:52 <emagana> Sukhdev: bottom line, is still in pending status
16:16:03 <Sukhdev> emagana: cool thanks - please update us when you have an update
16:16:15 <emagana> Sukhdev: I will!
16:16:24 <Sukhdev> emagana: this will be included in Juno documentation, right?
16:16:31 <emagana> absolutely!
16:16:59 <Sukhdev> Third item - https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews
16:17:26 <Sukhdev> banix added priority to this table - please ensure it is correct
16:17:44 <Sukhdev> s/priority/priority column
16:17:50 <slogan> I think this is the page I was looking for
16:18:00 <Sukhdev> slogan: correct
16:19:00 <Sukhdev> Everybody, please try to keep this updated with your patch/spec information so that this team can get to it and review it in a timely manner
16:19:23 <Sukhdev> Anything on any of these action items?
16:19:39 <Sukhdev> move right along -
16:19:46 <Sukhdev> #topic: Bugs
16:20:21 <Sukhdev> #link https://review.openstack.org/#/c/113999/
16:20:51 <Sukhdev> banix is working on this to support bulk operations
16:21:18 <Sukhdev> He is not here today, but, has requested that we review this patch
16:21:54 <Sukhdev> our bug czar is missing today, so, I will skip the bugs section this week
16:22:13 <Sukhdev> Unless somebody wants to discuss some specific bug
16:22:22 <Sukhdev> if you do, this is perfect time to speak up
16:22:37 <romilg> I request you to discuss about following bug https://bugs.launchpad.net/neutron/+bug/1224978
16:22:39 <uvirtbot> Launchpad bug 1224978 in neutron "port binding on multi segment networks could lead to agent misconfiguration" [Medium,In progress]
16:22:54 <rcurran> Sukhdev, are we going to track bugs via our wiki or just here
16:23:20 <romilg> #link https://review.openstack.org/#/c/103546/11
16:23:48 <Sukhdev> rcurran: shivharis usually follows them up and lists them on the agenda for discussion here
16:23:50 <romilg> currently there is no milestone set for the above mention bug
16:24:14 <Sukhdev> rcurran: he is off today
16:24:32 <rcurran> Sukhdev, ok - is he looking for specific tags on the bugs
16:24:45 <Sukhdev> rcurran: yes - ML2
16:24:52 <rcurran> ok
16:25:32 <Sukhdev> romilg: did we not have this on agenda last week?
16:27:22 <Sukhdev> romilg: so, this requires code review
16:27:51 <Sukhdev> rkukura: can you look at this, please?
16:27:52 <romilg_> sorry, I  got disconnected
16:28:05 <romilg_> yeah it was there in last week agenda
16:28:19 <Sukhdev> romilg_: no worries
16:28:22 <rkukura> Sukhdev: Yes. I had looked a while back, and will review it in detail.
16:28:31 <romilg_> thanks :)
16:28:43 <Sukhdev> I will review it as well
16:28:55 <Sukhdev> Anything else on the bugs?
16:29:04 <romilg_> Also , I request to set the milestone on the bug 1224978
16:29:06 <uvirtbot> Launchpad bug 1224978 in neutron "port binding on multi segment networks could lead to agent misconfiguration" [Medium,In progress] https://launchpad.net/bugs/1224978
16:29:47 <Sukhdev> romilg_: I think rkukura can updated it when he reviews the code
16:30:02 <Sukhdev> #topic: Code Reviews
16:30:23 <Sukhdev> #link https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews#Under_Review
16:30:24 <romilg_> okie
16:31:03 <Sukhdev> I see three high priority items
16:31:30 <Sukhdev> is asomya here?
16:31:58 <asomya> yes
16:32:10 <Sukhdev> I updated the wiki to include all three patches
16:32:17 <Sukhdev> asomya: want to discuss it?
16:32:24 <asomya> Sukhdev: sure
16:32:55 <asomya> So after extensive discussions with rkukura, we decided to just limit the refactor scope to dynamic segment in Juno. We'll take another pass at it in Kilo for the major refactor work.
16:33:23 <asomya> The current refactor has been broken into 3 pieces: one just consolidating segmentation code from the plugin to the type manager
16:33:40 <asomya> second to implement dynamic segment allocation ability to the type manager and the port context
16:33:51 <asomya> the third one is to add a distinction between provider networks and tenant networks
16:34:14 <Sukhdev> Sorry - this time I got disconnected
16:34:40 <Sukhdev> asomya: I reviewed your earlier patch, but, have not looked at the latest three yet
16:35:08 <asomya> Sulhdev: these are quite similar to the original patch, just broken up and a lot of code has been removed.. so it should be an easier review :)
16:35:14 <Sukhdev> I included them on the wiki for easy access for everybody - to get quicker turn around
16:35:20 <asomya> Sukhdev: Thanks
16:35:39 <Sukhdev> Anybody has any comment on this?
16:35:54 <slogan> I'd be happy to take a crack at reviewing anything that needs reviewing
16:36:27 <nlahouti> markmcclain: Hi, have you had chance to go through our reply in this patch?  https://review.openstack.org/#/c/114412
16:36:30 <Sukhdev> slogan: please take a look at the wiki and review as much as you can
16:37:13 <slogan> what happens with low priority items that don't get reviewed, pushed to Kilo?
16:37:22 <markmcclain> nlahouti: will look this afternoon during conference break
16:37:33 <nlahouti> markmcclain: thx Mark
16:37:35 <sadasu> Could folks pls review https://review.openstack.org/#/c/74134/ ? Thanks for the reviews so far
16:37:52 <sadasu> I have taken care of all comments I have received so far
16:37:53 <rkukura> Sukhdev: There are two other high priority items we haven’t discussed
16:38:03 <Sukhdev> slogan: no, that is not correct - high priority represents the core work - low priority represents vendor specific work
16:38:16 <slogan> oh
16:38:31 <slogan> so for the vendors, high priority :-)
16:38:43 <Sukhdev> rkukura: yes, getting to the next one - so, you spoke at the right time - want to talk about the hierarchical port binding?
16:38:49 <rkukura> slogan: I believe the BPs need to be re-reviewed/approved for the next cycle
16:38:53 <rkukura> Sure
16:39:07 <Sukhdev> slogan: yes :-)
16:39:16 <rkukura> The initial patch is in review: https://review.openstack.org/#/c/115110/
16:39:33 <rkukura> This has the ML2 driver API changes needed for hierarchical port binding
16:40:02 <Sukhdev> rkukura: I started to review it this morning, did not finish it yet :-)
16:40:09 <rkukura> Anypone working on drivers that will make use, in Juno or later, of this should take a look now
16:40:30 <rkukura> The second patch is almost ready to post
16:40:40 <Sukhdev> That includes all of us - we should all review it
16:41:12 <rkukura> The 2nd patch changes the ML2 DB schema to represent the binding info for multiple levels.
16:41:13 <Sukhdev> rkukura: T - 1 and counting :-):-)
16:41:18 <rcurran> rkukura, so will there be a 2nd bug for the "TODO" hierarchical work?
16:41:28 <rcurran> or just another patch
16:41:41 <rcurran> which is what you wrote :-)
16:41:45 <Sukhdev> rcurran: that is what he is getting ready to post
16:41:48 <rkukura> This has been a pain, partly do to the way DVR was incorporated, but I’m down to just one unit test to get working
16:42:23 <rkukura> The 3rd patch will change the binding logic to actually do multiple levels.
16:42:40 <rkukura> I’m expecting to the 2nd out today, and the 3rd today or tomorrow.
16:43:20 <irenab> rkukura: any patch expected for neutron-client?
16:43:36 <rkukura> irenab: No change to REST API
16:43:56 <rkukura> The 3rd patch will likely depend on asomya’s 2nd patch
16:45:07 <Sukhdev> So, for all ML2 driver owners these patches are important - be sure to review them as soon as they are posted
16:45:37 <Sukhdev> rkukura: please ensure to add the link to the wiki when you post it
16:45:38 <rkukura> The obvious concern is that we won’t have time to upgrade any MDs to use hierarchical binding for Juno, but maybe that can be done while existing patches are in review.
16:45:43 <rkukura> Sukhdev: will do
16:46:44 <Sukhdev> rkukura: I want to use them for Kilo for my driver - give them some time to bake
16:47:15 <Sukhdev> Any thing on these two items?
16:47:40 <Sukhdev> The third item - Neutron OVS based Distributed Virtual Router
16:47:53 <Sukhdev> any body from DVR team here?
16:48:17 <Sukhdev> carl_baldwin: are you here?
16:48:35 <rkukura> I think most/all of their planned ML2 changes have already merged, but I could easily be wrong
16:49:01 <Sukhdev> rkukura: I wil add to the action item to follow up with them to ensure it
16:49:05 * carl_baldwin reads back a bit.
16:49:10 <rkukura> I’ve been adding REVISIT comments to code for my 2nd patch regarding some serious issues in the already-merged DVR code
16:49:31 <rkukura> Things like calling precommit but not calling postcommit!
16:49:57 <Sukhdev> rkukura: wow!! that does not sound right
16:50:16 <rkukura> So I’m expecting some cleanup work to be done as bug fixes between now and when Juno ships
16:50:31 <Sukhdev> #action: Sukhdev or rkukura to follow up with DVR team regarding Neutron OVS based Distributed Virtual Router
16:50:52 <carl_baldwin> rkukura: The best way to get that on the DVR team’s radar will be to add ‘l3-dvr-backlog’ tag to a bug report.
16:51:06 <carl_baldwin> From there, we can have a discussion.
16:51:20 <Sukhdev> carl_baldwin: good suggestion - thanks
16:51:50 <rkukura> carl_baldwin I really wish I had been able to spend more time reviewing the DVR patches before they merged, and apologize that I didn’t.
16:52:54 <rkukura> carl_baldwin: I’ve already has some discussions with armax about cleaning up the DB schema in ML2 so there isn’t so much duplication. I hope to work with you guys on that.
16:53:25 <carl_baldwin> rkukura: I understand.  I look forward to working with you on it.
16:54:14 <armax> rkukura, carl_baldwin: I’ll have a look at the patch
16:54:17 <armax> which one is it?
16:54:52 <rkukura> armax: The REVISITs are in the patch I’m expecting to post later today. I will try to file bugs with the tag as well.
16:54:58 <armax> I am not entirely sure what’s going on, but iirc post-commit methods for dvr ports should be called
16:55:22 <rkukura> armax: On delete_port, precommit gets called for every host, but postcommit is only called once.
16:55:30 <carl_baldwin> rkukura: I’d like to have a look at the patch as well when you post it.
16:55:51 <armax> rkukura: I think that’s handled in the l2pop driver, but I might be mistaken
16:56:05 <armax> rkukura: definitely, I am eager to get my eyes on the patch
16:56:32 <rkukura> carl_baldwin, armax: In this patch I’m avoiding changing DVR logic, but moving the driver and segment fields from the [dvr_]port_binding table to a separate table.
16:57:38 <Sukhdev> time check - 3 min
16:57:59 <armax> rkukura: ok
16:58:03 <Sukhdev> #topic Open Discussion
16:58:25 <Sukhdev> Any thing on anybody's mind?
16:59:02 <slogan> In general, is there a need for a vendor who is thinking of doing a simple, VLAN-based ML2 plugin to show up at a design summit?
16:59:10 <sadasu> Could I have some more reviewers for https://review.openstack.org/#/c/74134/?
16:59:12 <slogan> er, mech driver
16:59:19 <Sukhdev> Please ensure to review all the critical patches
16:59:46 <slogan> so, how to identify critical?
17:00:00 <Sukhdev> slogan: VLAN-based ML2 plugin? you mean driver?
17:00:09 <slogan> yep, mech driver
17:00:17 <Sukhdev> sadasu: I reviewed it yesterday
17:00:34 <sadasu> Sukhdev: thanks! I saw that..
17:00:49 <irenab> sadasu: will follow today as well
17:00:49 <slogan> seems like there isn't a need since the driver is not introducing semantics, just implementing a well-defined type driver
17:00:52 <Sukhdev> slogan: like I mentioned earlier - the core impacting - the ones we discussed bit earlier
17:01:00 <slogan> ok
17:01:45 <Sukhdev> slogan: did not quite follow
17:02:12 <Sukhdev> well we are over our time
17:02:21 <Sukhdev> Good meeting - see you next week
17:02:23 <slogan> sukhdev: never mind, it's not a big issue
17:02:27 <Sukhdev> #endmeeting