16:20:54 <rkukura> #startmeeting networking_ml2
16:20:54 <openstack> Meeting started Wed Aug 27 16:20:54 2014 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:20:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:20:58 <openstack> The meeting name has been set to 'networking_ml2'
16:21:05 <rkukura> fungi: Thanks for fixing the bot!
16:21:12 <fungi> yw
16:21:27 * fungi had to move it to a different freenode server which wasn't toes-up
16:21:54 <rkukura> To summarize for the log, we we just discussing the DVR changes to ML2 and some things we’d like to fix between feature freeze and code freeze
16:21:59 <Sukhdev> rkukura: So, the two issues you list will play in only if DVR is configured, right?
16:22:09 <rkukura> Sukhdev: correct
16:22:18 <rkukura> Anything else on this?
16:22:44 <rkukura> #topic Bugs
16:23:11 <rkukura> shivharis: do you want to cover this?
16:23:13 <shivharis> Still on prev. topic, is there a bug for tracking the DVR ML2
16:23:36 <rkukura> #action rkukura to enter bugs for DVR ML2 issues he’s identified
16:23:43 <shivharis> rkukura: thanks
16:23:55 <shivharis> there is only one high bug: https://bugs.launchpad.net/neutron/+bug/1359416 - amotoki?
16:23:56 <uvirtbot`> Launchpad bug 1359416 in neutron "RPC callback should not use mixin approach" [High,In progress]
16:24:19 <amotoki> yes. I believe it help all of us.
16:24:38 <amotoki> The first step of l3-agent callback was merged.
16:25:22 <amotoki> ML2 and most plugins are affected. If there is a degrade, please let me know.
16:25:41 <shivharis> amotoki: what should we look for?
16:26:06 <amotoki> Reviews are https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bug/1359416,n,z
16:26:42 <Sukhdev> amotoki: Thanks for posting the link
16:26:54 <shivharis> amotoki: thanks
16:26:56 <amotoki> I was suggested to move RPC callback and API to api.rpc.handlers because they are no longer rleated to db operatrion.
16:27:26 <amotoki> that's all from me.
16:27:29 <shivharis> Next: https://review.openstack.org/#/c/113999/
16:27:36 <shivharis> amotoki: thx
16:28:01 <shivharis> banix: https://review.openstack.org/#/c/113999/
16:28:17 <Sukhdev> shivharis: I reviewed this one yesterday
16:28:34 <Sukhdev> I listed my concern in the comments
16:28:49 <shivharis> i guess he is not around, appears in good shape, we will need more reviewers
16:28:56 <Sukhdev> does anybody also share the same concern? if not, this looks good
16:29:01 <rkukura> I have same question as Sukhdev
16:29:39 <rkukura> Lets followup on this one on gerrit
16:29:46 <shivharis> so will this affect merge
16:30:00 <shivharis> do we want to wait for full implementation?
16:30:22 <shivharis> rkukura: your call
16:30:48 <amotoki> Ideally network/subnet/port operation should be synced. at least network and port?
16:30:53 <rkukura> I’d like to see banix respond about whether the other resource can/should also be changed
16:31:14 <shivharis> ok, i'll ping him offline
16:31:22 <rkukura> Thanksk
16:31:43 <shivharis> next: any other pressing bugs? or questions?
16:31:49 <rkukura> Any other bugs to discuss?
16:32:21 <rcurran> rkukura, i marked a few w/ the "ml2" tag last week - just need core reviewers
16:32:40 <rkukura> irenab wanted me to mention https://bugs.launchpad.net/neutron/+bug/1360762, which I’m starting to review.
16:32:41 <uvirtbot`> Launchpad bug 1360762 in neutron "Remove binding:profile modification from Mellanox ML2 driver" [Undecided,In progress]
16:32:47 <rcurran> i'd have to find the pointers, not my bugs - cisco_nexus related
16:33:30 <shivharis> rcurran: please add these to the agenda
16:33:32 <rkukura> Given the feature freeze deadline next week, it probably makes sense to prioritize reviewing features over reviewing non-urgent bug fixes right now.
16:33:45 <shivharis> i am done, lets move on
16:34:03 <rkukura> #topic Code Reviews
16:34:23 <rkukura> #link https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews#Under_Review
16:34:55 <rkukura> I’d like to check the status on the non-vendor-specific BP implementations
16:35:07 <Sukhdev> I updated this wiki yesterday - we have a good number of features merged
16:35:31 <Sukhdev> I may have missed some - if I did, please excuse
16:35:35 <rkukura> asomya: I believe the 2nd patch on the type driver refactor (dyanamic segments) is getting close to ready to merge, right?
16:35:46 <rkukura> Sukhdev: thanks!
16:35:53 <asomya> rkukura: Yes, i just pushed out another patch with fixes
16:36:28 <Sukhdev> asomya: I saw a -1 from rkukura and hence did not review it
16:36:37 <Sukhdev> asomya: I did review the third one
16:36:39 <rkukura> And my hierarchical port binding patches depend on asomya’s patches, so I’ve been reviewing these extensively.
16:36:56 <asomya> sukhdev: yeah Bob and i discussed it and i've pushed out anotherone that should have all the concerns addressed
16:37:14 <asomya> as soon as part 2 is approved, i'll rebase part 3
16:37:21 <amotoki> rkukura: I haven't understood why new methods in type drivers are no longer needed.
16:37:24 <Sukhdev> asomya: cool - will review it then
16:38:00 <nlahouti> I would like to bring attention to extensions in ML2  https://review.openstack.org/#/c/89211/
16:38:08 <rkukura> amotoki: asomya’s dynamic segment implementation leverages the partial spec feature, so new methods on TypeDriver aren’t needed.
16:38:20 <rkukura> nlahouti: That’s on the list
16:38:37 <amotoki> rkukura: ah... i got it.
16:38:42 <rkukura> I’ve been working on the 3 hierarchical port binding patches
16:39:24 <Sukhdev> nlahouti: I thought you were working with Mark to get -2 removed?
16:39:34 <rkukura> The 2nd one is the DB patch that still exposes a DB stale data issues and needs some SQL to move data in the migtration
16:40:03 <nlahouti> Sukhdev: unfortunately not success so far. He was busy with conf. last week
16:40:18 <rkukura> But they are functional, and once rebased on asomya’s latest, can be used by dependent patches that need hierarchical binding.
16:40:31 <nlahouti> Sukhdev: and ping'd him today and no response so far.
16:41:09 <Sukhdev> nlahouti: deadline next week and nova parity are the reasons :-)
16:41:16 <rkukura> On nlahouti’s extension drivers, I think it would help to get other reviewers from the ML2 subteam to vote their opinions
16:41:44 <Sukhdev> rkukura: I have been holding off because of Mark's -2
16:41:57 <nlahouti> Sukhdev: what needs to be done do we need any action plan for that?
16:42:09 <rkukura> There has been some interesting discussion with Salvatore about eventually making some of ML2’s built-in extensions into drivers
16:42:46 <shivharis> i dont believe they have bought into it yet, hence the delay
16:42:53 <rkukura> I think both nlahouti and I should continue to stalk markmcclain about removing his -2, and others should go ahead and review
16:43:14 <Sukhdev> rkukura, asomya: I have a question for both of you on the new patches -
16:43:29 <rkukura> Sukhdev: go ahead
16:44:25 <nlahouti> rkukura: can I ask here in here ML2 subteam to review and give their input.
16:44:27 <Sukhdev> With these 6 patches going in, how do you plan to ensure that this does not destablize the existing core base - and impact drivers?
16:44:58 <Sukhdev> nlahouti: will do
16:45:09 <nlahouti> Sukhdev: Thx a lot
16:45:43 <rkukura> Sukhdev: The only impact on existing drivers is in https://review.openstack.org/#/c/115110/, and there is no reason to hold up on reviewing this.
16:45:54 <nlahouti> Sukhdev rkukura: will keep asking markmacclain for review. Hopefully he find time and review it.
16:46:53 <rkukura> #action nlahouti and rkukura to keep after markmclain to remove his -2 on https://review.openstack.org/#/c/89211/, or explain why its not being removed
16:46:56 <Sukhdev> rkukura: I just want to make sure there will be no last minute chaos
16:48:04 <rkukura> Sukhdev: Agreed. Both asomya and I have been trying to structure our patches incrementally, for easy review.
16:48:14 <trinaths> Hi, joined late.
16:48:51 <rkukura> The final hierarchical binding patch that changes the logic is quite small: https://review.openstack.org/#/c/116209/
16:48:53 <Sukhdev> rkukura: Good - I know you are doing your best and very vigilant
16:48:56 <asomya> Sukhdev: to add to that, none of the existing type drivers are being changed in any of the patches
16:49:34 <Sukhdev> asomya: Good - thanks --- we just do not want a chaos in the last days of Juno :-):-)
16:50:25 <amotoki> as far as I see, rkukura's patch tries to keep the impact minimum and existing drivers works unless it wants to support hierarchical binding
16:50:31 <Sukhdev> Lets all review these patches ASAP and get them tested as much as possible
16:50:34 <rkukura> amotoki: Correct.
16:50:51 <rkukura> kevinbenton: Do you have an update on external attachment points?
16:51:33 <rkukura> Or does anyone else?
16:51:35 <Sukhdev> amotoki: I made the same observation as well...
16:53:52 <rkukura> Lets not forget to review the lower priority BP implementations as well!
16:54:07 <rkukura> Anyone want to bring up any other specific feature patches?
16:54:46 <sadasu> https://review.openstack.org/#/c/74134/14 - still looking for reviews
16:55:15 <Sukhdev> sadasu: Are you planning on addressing the comments?
16:55:25 <sadasu> taken care of all commnets I have received so far...will be posting another patch in a couple of hrs
16:55:49 <Sukhdev> sadasu: Will review when new patch is posted
16:56:00 <sadasu> Sukhdev: thanks!
16:56:05 <rkukura> sadasu: Thanks - I’ll plan to review it as soon as I can
16:56:19 <sadasu> rkukura: thanks!
16:56:19 <Sukhdev> sadasu -1 is deterrent for me - I skip the review if I see one :-)
16:56:40 <rkukura> Anythign else on code reviews?
16:56:55 <sadasu> Sukhdev: agreed. ther are no major ones at this point
16:56:56 <rkukura> #topic Open Discussion
16:57:29 <trinaths> when will be last date for code reviews for J-3
16:57:45 <rkukura> trinaths: The feature freeze is 9/4
16:57:58 <rkukura> bug fixes have a couple more weeks
16:58:00 <shivharis> merge before 9/4
16:58:22 <trinaths> rkukura, shivharis : okay. thanks a lot
16:58:23 <amotoki> more precisely merge by the end of Sep 4
16:58:50 <trinaths> amotoki: okay. getting close to that date ..
16:59:12 <Sukhdev> amotoki: we have a lawyer in the house :-):-)
16:59:22 <amotoki> :-)
16:59:25 <trinaths> Sukhdev: :-)
16:59:31 <rkukura> Lets all make an extra affort to review the patches and get comments in ASAP so issues can be fixed and we can get everything merged!
16:59:51 <rkukura> Anything else?
17:00:05 <amotoki> more interestingly timezone used is not defined :-)
17:00:23 <nlahouti> markmcclain: Hi mark Just talking about https://review.openstack.org/#/c/89211/  can you please review it
17:00:39 <Sukhdev> amotoki: you get few hours less, I guess - since you are ahead of us :-)
17:01:06 <rkukura> deadlines are based on the international date line, I think
17:01:10 <trinaths> amotoki
17:01:10 <rkukura> time is up
17:01:14 <rkukura> #endmeeting