16:02:20 <Sukhdev> #startmeeting networking_ml2
16:02:20 <openstack> Meeting started Wed Sep 17 16:02:20 2014 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:24 <openstack> The meeting name has been set to 'networking_ml2'
16:02:49 <Sukhdev> #topic: Agenda
16:03:06 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2#Agenda
16:03:23 <Sukhdev> #topic: Announcements:
16:03:43 <Sukhdev> Anybody has any announcements?
16:03:55 <shivharis> RC1 is tomorrow?
16:04:02 <shivharis> please confirm
16:04:20 <Sukhdev> shivharis: I believe so
16:04:33 <Sukhdev> #link https://launchpad.net/neutron/+milestone/juno-rc1
16:04:47 <Sukhdev> see the content of RC1
16:04:47 <rkukura> hi - sorry I’m late
16:04:51 <shivharis> Sukhdev: thanks
16:05:12 <Sukhdev> rkukura: you will buy cookies for everybody :-)
16:05:34 <rkukura> I’ve got a couple of Doubletree cookies in my backpack
16:05:52 <Sukhdev> rkukura: :-)
16:06:02 <Sukhdev> I have one more announcement
16:06:09 <shivharis> I need the parisian kind..
16:06:30 <Sukhdev> shivharis: you guys settle in the parking lot
16:06:56 <Sukhdev> There is an etherpad for Kilo Summit
16:07:15 <Sukhdev> #link: https://etherpad.openstack.org/p/kilo-neutron-summit-topics
16:07:38 <Sukhdev> You will see there are bunch of ML2 related topics on this already
16:08:24 <Sukhdev> We can use it initially and then move to our own ML2 specific etherpad
16:08:58 <rkukura> I don’t expect there to be much time at the summit for ML2-specific sessions, so we should think about how to make the best use of it.
16:09:06 <shivharis> Or we can just mark them with [ML2]
16:09:07 <Sukhdev> rkukura had an action to create our etherpad - until if it created, we can use this main Neutron
16:09:40 <rkukura> I’d don’t see much point in a separate ML2 etherpad, so lets use the main one.
16:10:00 <Sukhdev> rkukura: I am OK with that
16:10:32 <Sukhdev> Perhaps we should wait and see how big of a list we get for ML2 and then decide
16:11:00 <Sukhdev> rkukura: we may get one or two sessions
16:11:09 <rkukura> one other idea for the summit is to get driver writers together for an hour or two on Friday to talk about the new driver APIs (in Juno and deferred) and things like that.
16:11:22 <amotoki> hi, sorry for late
16:12:02 <shivharis> rkukura: +1
16:12:36 <Sukhdev> rkukura: In Atlanta that was very effective - we can use it for a bigger scope this time
16:13:06 <amotoki> rkukura: sounds good. I hope we can avoid the driver API change at the last minutes of the release in Kilo.
16:13:42 <rkukura> amotoki: +1
16:14:03 <Sukhdev> rkukura: Other than what is on the etherpad, can anybody think of any other topics to be included?
16:15:09 <Sukhdev> We can discuss more about it later in the meeting
16:15:12 <rkukura> Maybe something on generalizing the distributed port binding stuff that was added for DVR
16:15:40 <banix> Will try to get the modular L2 agent work restarted so by the time we get to the summit we have more substantial info; anyone interested please contact me
16:15:49 <rkukura> Also, making DVR work with ML2 network types other than tunnels.
16:16:03 <rkukura> banix: +1
16:16:14 <Sukhdev> banix: yes, we should
16:16:38 <Sukhdev> rkukura: I do not believe these topics are on the etherpad, can you please add them
16:16:47 <rkukura> ok
16:17:07 <shivharis> banix: is the benefit quite limited for this effort
16:17:18 <Sukhdev> any body has any announcement?
16:17:22 <shivharis> banix: not many agent types
16:17:38 <shivharis> banix: lets take it offline
16:17:43 <banix> shivharis: sure
16:17:45 <amotoki> I have a plan to split RPC callback per feature on agent side in kilo.
16:18:10 <Sukhdev> amotoki: should it be on the sessions list?
16:18:30 <amotoki> Sukhdev: I don't think so. It is a kind of refactoring.
16:18:45 <Sukhdev> amotoki: OK
16:18:52 <amotoki> Sukhdev: i commented this on the xcontext of modular L2 agent.
16:19:16 <Sukhdev> amotoki: got it - thanks for clarification
16:19:29 <banix> amotoki: yes, will be in touch; with shivharis padkrish as well
16:19:36 <Sukhdev> OK - lets move on..
16:19:52 <shivharis> amotoki: +1 (versioning will also help)
16:19:53 <Sukhdev> #topic: Actions from last week
16:20:26 <Sukhdev> banix: Any update on the tempest testing for bulk operations?
16:20:28 <banix> the one for me. background: we wanted to see if we need more tempest tests for bulk create options; in particular tests where some mechanism drivers fail (partial fail scenarios); my understanding is tempest is not the place for such tests
16:20:39 <banix> asked mlavalle to join us today
16:20:55 <Sukhdev> mlavalle: are you here?
16:20:58 <mlavalle> banix: hi
16:21:07 <banix> hi mlavalle and thanks for joing us
16:21:37 <banix> Looking at tempest tests I see bulk ops being tested
16:21:49 <mlavalle> banix: correct, they are
16:22:04 <shivharis> mlavalle: we were trying to do negative tests - where does this kind of a test fit in?
16:22:09 <banix> the question was if we should have some tests for partial failure cases where for example one of the mechanism drivers fail
16:23:09 <mlavalle> banix: I assume that the test script would have to mess with the driver and make it fail.... assuming that I don't think tempest is the right tool.... tempest is api based testing
16:23:54 <shivharis> mlavelle: tempest has scenario tests as well
16:24:12 <banix> yeah; one possibility would be having a faulty mechanism (not there but we could add) driver for such tests; in that case one wouldnt need to change the driver;
16:24:16 <shivharis> mlavalle: typo before
16:24:19 <mlavalle> shivharis: correct, but it's all api based
16:24:53 <mlavalle> shivharis: rest api I should say
16:25:12 <Sukhdev> mlavalle: can we come up with a scenario test for this?
16:25:29 <shivharis> mlavalle: got it, maybe tempest can be extended of these kind of tests?
16:25:44 <mlavalle> Sukhdev: of course, we can explore the possibility
16:25:49 <mlavalle> shivharis: ^^^^^
16:26:28 <Sukhdev> mlavalle: The idea is it will be similar to Bulk API test, but, we would want to fail some of the drivers
16:26:35 <mlavalle> Sukhdev, shivharis: let's define the scenario and from there see what tool we c should use.... another alternitve is marun's functional tests
16:27:25 <rkukura> It might be reasonable to have a special driver where failures are triggered by special values being set on some port attribute via the REST API
16:27:34 <mlavalle> Sukhdev, shivharis: i'll be happy to invest some time defining this.... in fact, it is my plan to join the ml2 team for the kilo cycle
16:27:35 <shivharis> you mean negeative functional test
16:27:42 <Sukhdev> banix, shivharis: OK lets discuss it off line and see if can define a reasonable scenario to test it
16:27:55 <rkukura> mlavalle: +2
16:28:03 <Sukhdev> mlavalle: we would love that
16:28:04 <banix> Sukhdev: mlavalle sounds good
16:28:04 <shivharis> Sukhdev, mlavalle: ok
16:28:12 <shivharis> so where does this put banix's patch?
16:28:19 <mlavalle> :-)
16:28:31 <padkrish> any docs, ptrs on marun's functional tests? for what cases is it needed, what does it accomplish that current tests do not etc?
16:29:16 <Sukhdev> #Action: banix to work with mlavalle and others to define scenario test for Bulk Ops testing
16:29:21 <banix> shivharis: let’s talk about that in the bug section (coming up soon :) )
16:29:25 <banix> will do
16:29:31 <mlavalle> padkrish: marun's tests are still experimental... we can start digging in here https://review.openstack.org/#/c/72585/
16:29:37 <Sukhdev> mlavalle, banix: I assigned you and action - hope you are OK
16:29:48 <mlavalle> Sukhdev: perfect!
16:29:49 <banix> Sukhdev: yes on my side
16:30:00 <Sukhdev> Next item:
16:30:12 <Sukhdev> I updated the wiki https://wiki.openstack.org/wiki/Tracking_ML2_Subgroup_Reviews#Under_Review
16:30:21 <shivharis> (30 mins left)
16:30:25 <padkrish> mlavalle# Thanks. i thought it's well established, based on the comments i got!!!
16:30:32 <Sukhdev> Moved all the specs that were deferred to Kilo
16:31:00 <Sukhdev> Please have a look and feel free to update/correct
16:31:03 <shivharis> is there a directory created for this?
16:31:19 <Sukhdev> shivharis: you mean for Kilo specs?
16:31:21 <shivharis> (in neutron-specs_
16:31:25 <shivharis> yes
16:31:57 <Sukhdev> shivharis: I believe so - I have heard chatter on the IRC, but, please confirm - If not, just create it and move it there
16:32:27 <Sukhdev> As to the third item on Action, we already covered the etherpad issue -
16:32:56 <Sukhdev> For now lets use the main one and later we will decide if we need a specific one for ML2
16:33:15 <Sukhdev> rkukura: want to add anything more?
16:33:20 <rkukura> nope
16:33:32 <Sukhdev> Ok - moving on the important part
16:33:43 <Sukhdev> #topic: Bugs/Reviews
16:33:57 <Sukhdev> shivharis: want to chime in?
16:33:58 <shivharis> hi
16:34:36 <shivharis> we had a lot of progress on the bugs during the week. some got merged. thanks to all who contributed, including cores
16:35:10 <shivharis> i was hesitent to ask cores for help when jenkins failed ...
16:35:31 <shivharis> .. but is appears that there is a critical bug out there that may be coming in the way
16:35:53 <banix> neutron jobs have been failing functional tests since yesterday
16:36:10 <shivharis> https://bugs.launchpad.net/neutron/+bug/1370347
16:36:12 <uvirtbot> Launchpad bug 1370347 in neutron "check-neutron-dsvm-functional fails with DistributionNotFound" [Critical,New]
16:36:39 <shivharis> if you have more info please add to it.
16:36:54 <shivharis> Currently the bug is unassigned... :-(
16:37:01 <amotoki> I believe it is one of the hot topics of -neutron channel.
16:37:12 <shivharis> any takers?
16:37:42 <banix> not ml2 specific by the way
16:37:47 <amotoki> not sure. I havent checked whether a patch is proposed to make the fucntional job non-voting.
16:37:47 <shivharis> banix, rcurran: can you add what you experience in your patches
16:38:10 <shivharis> banix: atleast one can add the pointer to the patch/logs
16:38:12 <rcurran> shivharis, i don't have any reviews out
16:38:30 <banix> some time yesterday jenkin jobs started failing
16:38:30 <amotoki> *just due to my absence in the channel this evening.
16:38:33 <rcurran> shivharis, you referring to https://review.openstack.org/#/c/105514/
16:38:39 <shivharis> rcurran: last time you were pushing for 105514
16:38:46 <shivharis> rcurran: yes
16:39:12 <banix> issue may be related to new version of rootwrap; quick fix to make that test non voting
16:39:23 <rcurran> shivharis, covering for another eng - Abishek Subramanian
16:39:34 <shivharis> anyways please add pointers in the bug report to the patches so folks can look at the logs if need be
16:40:05 <shivharis> moving on...
16:40:20 <shivharis> we have until tomorrow for RC1
16:40:36 <shivharis> and 2 high bugs need to be addressed
16:40:44 <shivharis> rkukura: you have one of those
16:40:53 <rkukura> shivharis: yes
16:41:15 <shivharis> rkukura: you will make it right? :-)
16:41:24 <amotoki> Will RC1 be shipped this week? I missed the team meeting yesterday.
16:41:47 <Sukhdev> amotoki, rkukura: can you look at this one https://review.openstack.org/#/c/113999
16:41:57 <banix> amotoki: date was not mentioned during the weekly meeting
16:42:22 <amotoki> banix: thanks.
16:42:24 <rkukura> The complicating factor on the bug I’m working on is the router_id and status fields in the dvr_port_bindings table - if I figure those out, I may have a patch in a day or two.
16:42:31 <banix> amotoki: i meant Neutron weekly meeting; you may be referring to a different meeting
16:42:53 <amotoki> banix: i mean the neutron weekly meeting. we are in the same page.
16:43:15 <rkukura> Sukhdev: I’ll finishing reviewing banix’s patch - hoped to do that on the plane yesterday evening, but no wifi :(
16:43:28 <shivharis> the other high bug is not for ml2 but shows up in the search
16:44:04 <Sukhdev> rkukura: it is almost criminal these days to loose wifi :-):-)
16:44:28 <shivharis> I think overall we look fine for RC1, please see the summary with:
16:44:57 <shivharis> https://bugs.launchpad.net/neutron?field.searchtext=ml2&field.milestone%3Alist=67382
16:44:59 <Sukhdev> banix: You patch looks good - I reviewed it yesterday
16:45:14 <Sukhdev> ^you^your^
16:45:29 <shivharis> so i will look see if i can get cores for 105514 and for banix's patch
16:45:46 <banix> Sukhdev, shivharis thanks
16:45:58 <Sukhdev> shivharis: few of them are here - pasture them, I already did :-):-)
16:46:07 <shivharis> Anyone has bugs/reviews that need help?
16:46:23 <shivharis> please post your links here...
16:46:30 <Sukhdev> shivharis: Thanks for covering for bugs
16:46:50 <shivharis> waiting 60 seconds, then back to you Sukhdev
16:47:20 <Sukhdev> Lets move to last topic of today
16:47:28 <Sukhdev> #topic: Open Discussion
16:47:31 <shivharis> Sukhdev: thats all i have
16:47:39 <Sukhdev> shivharis: Thanks
16:48:07 <Sukhdev> We covered enough about Kilo sessions for ML2 - anybody wants to add anything more?
16:49:01 <Sukhdev> waiting….waiting….waiting...
16:49:17 <Sukhdev> I guess we are done….
16:49:23 <banix> thanks all!
16:49:25 <Sukhdev> Thanks folks….
16:49:31 <Sukhdev> #endmeeting