16:06:10 <rkukura> #startmeeting networking_ml2
16:06:10 <openstack> Meeting started Wed Apr  1 16:06:10 2015 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:13 <openstack> The meeting name has been set to 'networking_ml2'
16:06:22 <rkukura> #topic Agenda
16:06:40 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_March_31.2C_2015
16:07:15 <rkukura> Today is April Fools day, not March 31, in case anyone was wondering
16:07:33 <rkukura> Anything to add to the agenda today?
16:08:03 <rkukura> #topic Announcements
16:08:17 <rkukura> RC's are April 9-23 and Kilo release on April 30
16:08:54 <rkukura> So this is the final stretch to get everything in for kilo.
16:09:29 <rkukura> mestery also sent an email regarding gathering topics for the design summit
16:09:37 <rkukura> #link https://etherpad.openstack.org/p/liberty-neutron-summit-topics
16:10:13 <rkukura> I encourage everyone to look over the list, add comments, items, questions, whatever
16:11:20 <rkukura> There do seem to be a couple items regarding asynchrony, synchronization, etc., but I’m thinking we should add something ML2-specific
16:11:37 <rkukura> Lets discuss that under the ML2 Sync topic in a bit
16:11:45 <rkukura> Does anyone have any other announcements?
16:12:27 <rkukura> #topic Action Items
16:13:10 <rkukura> manishg isn’t here, but had an action item to docusment the ML2 sync discussion points
16:13:16 <rkukura> Is anyone aware of any progress?
16:14:21 <shivharis> manishg: ?
16:14:36 <rkukura> There is also an action item to create an etherpad for driver decomposition discussion
16:15:06 <rkukura> shivharis: manishg isn’t the channel
16:15:14 <rkukura> isn’t on the channel
16:15:33 <shivharis> rkukura: appears so
16:15:46 <rkukura> does someone own the decomposition discussion etherpad?
16:16:19 <rkukura> Or does this just mean to add it to mestery’s etherpad?
16:16:30 <rkukura> Sukhdev: hi
16:16:36 <sadasu> rkukura: are we looking at the next steps for the decomposition?
16:16:48 <shivharis> add to armax etherpad if there is one
16:16:49 <mestery> I'd add it to the broad one for now, there's already a mention of plugin decomp
16:16:54 <Sukhdev> rkukura: Hi
16:17:24 <rkukura> Someone added: “Move plugins back into the tree (ts1 lirpA)”
16:17:51 <shivharis> what is ts1 lirpA?
16:18:01 <rkukura> shivharis: what day is today?
16:18:05 <rcurran> read it backwards
16:18:05 <sadasu> rkukura: April 1st
16:18:08 <shivharis> oops
16:19:03 <rkukura> Anyway, do we think discussion of next steps for ML2 driver decomposition would be useful at the summit?
16:19:17 <shivharis> yes
16:19:33 <shivharis> since we had an issue of how much to leave behind in the shim
16:19:49 <shivharis> there were different opinions - we should sort that out
16:19:54 <rkukura> OK, who wants to take that action?
16:20:02 <shivharis> i'll take it on
16:20:25 <rkukura> #action shivharis to add decomp next steps to summit etherpaf
16:20:29 <rkukura> pad
16:20:52 <rkukura> Anything else on action items?
16:21:10 <rkukura> #topic ML2 Driver decomposition
16:21:34 <rkukura> Anything new on this, other than that we should have a design summit session on next steps?
16:22:10 <rkukura> guess not…
16:22:18 <rkukura> #topic ML2 Sync and error handling
16:22:34 <rkukura> manishg still isn’t here, so I’m not sure we’ll make much progress on this.
16:23:19 <sadasu> is this a topic for a design session during the summit?
16:23:35 <rkukura> #action manishg to document sync and error handling discussion points (carried over from last week)
16:23:50 <rkukura> sadasu: I think we need a design summit session on this
16:24:05 <rkukura> Anyone want to add that, or should I?
16:24:09 <shivharis> sadasu: i think it should be a topic for the summit (are we collecting ML2 summit topics somewhere?)
16:24:35 <shivharis> rkukura: link?
16:24:43 <rkukura> shivharis: I think we should add ML2 topics to https://etherpad.openstack.org/p/liberty-neutron-summit-topics, which we touched on during the announcements before you jointed
16:25:19 <sadasu> I still have questions about why the detection of being out of sync and mitigation cannot be handled within each driver
16:25:20 <shivharis> rkukura: thanks
16:25:40 <sadasu> yes, a design session on this will help
16:25:53 <rkukura> sadasu: So do I, but I think we at least need some facility to expose the sync state via the API
16:26:20 <rkukura> #action rkukura to add ML2 sync and error handling to summit topic etherpad
16:26:55 <sadasu> rkukura: yes
16:27:12 <rkukura> I’d really like us to try to make some progress on this between kilo release and the summit
16:27:24 <sadasu> rkukura: +1
16:27:40 <rkukura> We were talking about scheduling a meeting on it once manishg documented the discussion points, weren’t we?
16:27:59 <shivharis> rkukura: +1
16:28:12 <rkukura> Or we can dedicate one or more of these meetings to it
16:28:22 <shivharis> actually last time we seem to be going all over the place
16:28:41 <shivharis> maybe next meeting discuss this exclusively
16:29:02 <shivharis> other topics can have a very short time allocated
16:30:18 <rkukura> shivharis: I’m wondering if people will be able to prepare sufficiently just before RC1, or if we should do it in two weeks
16:30:35 <rkukura> I know I need to spend some time on it
16:31:21 <rkukura> Do others feel they’ll be ready next week, asssuming manishg is available?
16:31:26 <shivharis> rkukura: i am open the anything that will atleast help us sort the high level requirement, which i feel still needs work
16:32:35 <sadasu> rkukura: +1
16:32:36 <shivharis> Sukhdev has some valid use cases that need to be addressed, API needs to be defined
16:32:50 <shivharis> rkukura: do you want to postpone to week after?
16:33:03 <sadasu> can we start the documentation/discussion with use cases first?
16:33:12 <rkukura> I can be ready to discuss high level requirements next week
16:33:43 <rkukura> sadasu: we should have use cases to capture the requirements
16:34:05 <shivharis> rkukura: for high level i think most of us will be able to do it (but we must have manishg)
16:34:20 <shivharis> i'll try to ping him offline
16:34:35 <rkukura> OK, lets get started on requirements next week unless manishg isn’t available.
16:34:42 <shivharis> +1
16:34:56 <rkukura> Anything else on sync?
16:35:03 <sadasu> should we start an etherpad for this so manishg can contribute during his timezone?
16:35:42 <rkukura> sadasu: +1
16:36:10 <rkukura> #topic Bugs
16:36:15 <shivharis> hi
16:36:16 <rkukura> shivharis: …
16:36:52 <shivharis> thanks to yamahata the bug https://bugs.launchpad.net/neutron/+bug/1435216 is now marked invalid by the filer
16:36:53 <openstack> Launchpad bug 1435216 in neutron "unit tests: KeyError: 'port_security' when building Debian package" [High,Invalid] - Assigned to yalei wang (yalei-wang)
16:37:28 <yamahata> shivharis: thanks for notification. I talked with him and reached to the conclusion.
16:37:56 <shivharis> DB migration bug that recently showed up is being addressed
16:38:17 <shivharis> https://bugs.launchpad.net/neutron/+bug/1436674
16:38:18 <openstack> Launchpad bug 1436674 in neutron " "BOOLEAN" data type is not supported in db2, hits error during db migration" [High,Fix committed] - Assigned to Jun Xie (junxiebj)
16:38:57 <shivharis> everything else (high) pushed out to L1
16:39:10 <shivharis> or marked at a lower priority
16:39:30 <shivharis> I think we look good for Kilo at this time, hope it stays that way
16:39:43 <shivharis> Any questions regarding bugs
16:40:07 <rkukura> I was going to say I was doubting the fix for https://bugs.launchpad.net/neutron/+bug/1367391 was going to be ready in time, and I see its been taking off kilo, which I think makes sense
16:40:08 <openstack> Launchpad bug 1367391 in neutron "ML2 DVR port binding implementation unnecessarily duplicates schema and logic" [Medium,In progress] - Assigned to Robert Kukura (rkukura)
16:40:40 <shivharis> rkukura; this bug can wait
16:41:06 <shivharis> rkukura: this was lowered in priority as well
16:41:25 <rkukura> But I may try to get a small related patch in. Part of the difficulty has been that significant DVR support is not covered by existing unit tests, so I may push a patch ot add the UTs, and fix a couple small issues they’ve turned up.
16:42:13 <shivharis> rkukura: since it is not deemed so critical - it may not be allowed in
16:42:42 <rkukura> shivharis: I would certainly not lower its priority, but I don’t think its realistic to get the full fix in kilo. This code has really become difficult to work on, which is why its taking so much effort.
16:43:08 <rkukura> The issues that have turned up would make ToR switch MDs unlikely to work with DVR.
16:44:00 <shivharis> rkukura: ok
16:44:10 <rkukura> Seems I should file a separate bug for this, and we can see if it makes sense to try to fix for RC1, or maybe backport to kilo afterwards
16:44:52 <shivharis> rkukura: ok, hoping for the best
16:44:56 <rkukura> Anything else on bugs?
16:45:07 <shivharis> i dont have anything else
16:45:12 <rkukura> anyone else?
16:45:18 <rkukura> #topic Open Discussion
16:47:16 <shivharis> fingers crossed, hoping for no new bugs ...
16:47:21 <rkukura> Anything to discuss, or are we done for today?
16:48:57 <rkukura> #endmeeting