16:03:10 <Sukhdev> #startmeeting networking_ml2
16:03:11 <openstack> Meeting started Wed Apr 22 16:03:10 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:14 <openstack> The meeting name has been set to 'networking_ml2'
16:03:33 <Sukhdev> #topic: Agenda
16:03:43 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_April_22.2C_2015
16:04:01 <Sukhdev> #topic: Announcement:
16:04:06 <Sukhdev> I have couple
16:04:26 <Sukhdev> Kilo RC2 is due any day/time now
16:04:43 <Sukhdev> Barring any critical issues, it will become Kilo
16:04:54 <Sukhdev> So, congratulations to all who worked on it
16:05:29 <Sukhdev> If you did not know there is a sprint for Networking Guide documentation
16:05:51 <Sukhdev> Edgar is leading it and it is taking place tomorrow
16:06:16 <Sukhdev> If you few cycles and want to contribute to improve Neutron documentation - this is your chance
16:06:31 <Sukhdev> #link: https://etherpad.openstack.org/p/networking-guide
16:06:49 <Sukhdev> This link give the details of where the help is needed
16:07:09 <Sukhdev> I have no other announcements? Anybody has any
16:07:30 <Sukhdev> other than manishg feeling proud to have fulfilled his civic duty
16:07:51 * Sukhdev wating
16:08:14 <manishg> I was wondering what you're going to say Sukhdev !  haha..
16:08:26 <Sukhdev> #topic: Action Items from previous week(s)
16:09:26 * shivharis1 I am also proud of manishg
16:09:27 <Sukhdev> Since we have been discussing Task Flow for a while, I had an action item to discuss with mestery to include it in the mid-cycle sprint
16:09:47 <manishg> Sukhdev: what's the link to etherpad ?
16:09:56 <Sukhdev> I did have a chat with him and have included it on the agenda
16:10:07 <Sukhdev> I will defer the details until the next topic
16:10:20 <Sukhdev> manishg: hang on  a sec
16:10:34 <Sukhdev> Next item from manishg
16:10:35 <shivharis1> https://etherpad.openstack.org/p/liberty-neutron-summit-topics
16:10:48 <Sukhdev> shivharis1: thanks
16:11:17 <Sukhdev> manishg: I know you been away - have you made any progress on documenting the task flow discussions?
16:11:55 <manishg> Sukhdev: was out and plan to document this in a couple of days.  Have not finished it yet.  Should I put that on etherpad or google doc?
16:12:23 <Sukhdev> manishg: I prefer google doc
16:12:33 <Sukhdev> anybody has objection?
16:12:46 <shivharis1> manishg: google doc is what i like, but take you pick
16:13:10 <manishg> Sukhdev: ok, will do.  I can copy to another format if needed.  comments are easier and more navigable in docs.
16:13:34 <manishg> Sukhdev: once done, should I mail the link to ML ?
16:13:49 <Sukhdev> manishg: We need to use this document to get folks on the same page - hence, they can develop the understanding of the code/ subject
16:14:25 <Sukhdev> manishg: If done before next meeting, yes - otherwise, we can discuss it here
16:14:52 <manishg> Sukhdev: let me document it first and we can get started after that.
16:15:04 <Sukhdev> manishg: i want to use this document as basis for the sprint as well as discussions during the upcoming summit
16:15:35 <Sukhdev> manishg: lets discuss more in the next topic about this
16:15:37 <manishg> Sukhdev: +1
16:15:51 <shivharis1> if you are going to use it for the sprint, then etherpad would be better?
16:16:01 <Sukhdev> shivharis1: had an action item and I notice we have a link to the release notes
16:16:19 <manishg> shivharis1: let's seal the design via docs.  then sprint.
16:16:23 <Sukhdev> shivharis1: We can always have a link to the doc in etherpad
16:16:23 <shivharis1> i have updated the agenda with the answer to my action item
16:16:56 <shivharis1> docs, etherpad np
16:17:01 <Sukhdev> shivharis1: once we done discussing next topic, I will add sufficient details to etherpad - but, we will use doc for more specific details
16:17:17 <shivharis1> fine, np
16:17:31 <Sukhdev> #link: https://wiki.openstack.org/wiki/ReleaseNotes/Kilo
16:17:38 <Sukhdev> shivharis1: Thanks
16:18:29 <Sukhdev> #topic:Neutron Mid-cycle sprint
16:18:48 <Sukhdev> If you do not know it is taking place in Fort Collins in June
16:19:23 <Sukhdev> Since we have been having discussions around Task Flow, the team felt it may be better to implement in the sprint
16:19:39 <Sukhdev> So, here is my thought on this - please see if you agree
16:20:03 <Sukhdev> we use document generated by manishg as the basis for our design discussions
16:20:28 <Sukhdev> We can use the PODs for in-person discussions during summit as well.
16:20:55 <Sukhdev> Once we have nailed down the design/details/agreements - we use the sprint to actually implement/code it
16:20:56 <manishg> Sukhdev: agree.  I'll try to capture the discussion points from here in the doc.
16:21:19 <Sukhdev> mestery is on board with this
16:21:36 <Sukhdev> Now, the question to the team - does it make sense?
16:21:52 <Sukhdev> I wish rkukura was here :-(
16:22:08 * Sukhdev waiting
16:22:45 <sadasu> I think a better time to answer that question would be after seeing the document
16:22:57 <shivharis1> i see no problem in that approach, i only want to make sure the design is extendible
16:23:38 <Sukhdev> shivharis1 sadasu : we can use next few meetings to iron out those details
16:24:28 <Sukhdev> Assuming, we iron out the design - will you be willing to volunteer to help out with the sprint?
16:25:02 <Sukhdev> BTW, we have all the time until summit to iron out the details
16:25:12 <shivharis1> Sukhdev: maybe i have to check with my mgmt
16:25:24 <yamamoto> will it involve MD changes?
16:25:48 <Sukhdev> yamamoto: possibly
16:26:01 <Sukhdev> yamamoto: but, should be all backward compatible
16:26:25 <Sukhdev> changes to MD only if you want to take advantage of this
16:26:37 <shivharis1> that is where the design is essential, and should be well thought out
16:27:16 <yamamoto> which MD will be "converted" to take advantage?
16:27:21 <yamamoto> OVS?
16:27:24 <Sukhdev> shivharis1: I looked at the code which manishg has posted - it fits the bill - but, it is bit hard to understand without documentaiton
16:27:27 <manishg> yamamoto: maybe.  It will be compatible with existing one so not necessary.  But for recovery, one may want to change.  Else it will continue to work as-is.
16:27:51 <manishg> Sukhdev: there's a lot of documentation in the code.  But maybe more background in the doc.
16:28:23 <shivharis1> manishg: yamamoto is asking which MD will be the reference (first) implementation
16:28:29 <yamamoto> shivharis1: yes
16:28:49 <sadasu_> manishg: want to know about diff scenarios that are/aren't supported by the current diffs
16:28:56 <Sukhdev> manishg: correct - make sure start with high level view in the doc - so that people have a better grasp of what is going on and what is in it for them, and, why it would be beneficial for them to use this
16:29:24 <manishg> yamamoto: not decided yet.  waiting on getting agreement first.
16:30:14 <yamamoto> if it's ovs, does it involve agent-side changes?
16:30:16 <manishg> sadasu_ : today if things fail, one just calls delete - and there is no granular control on how to 'undo' actions of MD.  With the new changes, we will be able to do those.
16:30:22 <Sukhdev> yamamoto: initially, there will be dummy MD to demonstrate the use of this
16:30:54 <Sukhdev> sadasu_: that is exactly, this is for
16:31:21 <manishg> yamamoto: no agent-side changes.  but there are some open issues and depending on how those are addressed there maybe requirement to update the RPC i/f - in which case it will impact agent.
16:31:26 <Sukhdev> sadasu_: to deal with error handling and providing the sync mechanism between the front-end and back-end
16:31:58 <yamamoto> Sukhdev: something like logger MD?
16:31:59 <manishg> yamamoto: in general, all it does is make things async (and for the most part the scope is only the plugin).
16:32:40 <Sukhdev> yamamoto: I am not familiar with that MD - sorry
16:33:05 <yamamoto> Sukhdev: neutron.tests.unit.plugins.ml2.drivers.mechanism_logger:LoggerMechanismDriver
16:33:06 <manishg> and to move things out of the db context.  We do this by pre-commit/ post-commit today.  But with these changes, we can return the REST call and not block on MD.
16:33:33 <manishg> for OVS, the MD is just the Agent MD so doesn't do much (from what I remember)
16:34:16 <yamamoto> manishg: ok, its main targets are MDs like ODL?
16:34:43 <manishg> yamamoto: any MD that may block .
16:35:05 <manishg> the issues are captured in the comments here (in general comments) : https://review.openstack.org/#/c/154333/
16:35:33 <manishg> but it will be moved to a doc.
16:36:01 <shivharis1> the MDs that foot the bill are:
16:36:11 <shivharis1> 1. MDs with postcommit that can fail
16:36:23 <shivharis1> 2 MDs that can be restarted
16:36:37 <shivharis1> 3. MDs that have a backend that can go out of sync
16:36:46 <shivharis1> 4. Anything else
16:36:53 <shivharis1> ?
16:37:10 <Sukhdev> shivharis1: thanks - I think you hit the nail on the head
16:37:58 <manishg> shivharis1: looks good.  + MDs that may communicate with backend synchronously.
16:38:07 <yamamoto> i've heard that midonet made their plugin task-based.  its design might be worth to look.
16:38:15 <manishg> one of the goals is to return the REST call as soon as we can.
16:38:28 <manishg> yamamoto: thanks for the tip.  Will look at it.
16:39:36 <Sukhdev> please do share any information you have on the subject - that will be helpful
16:40:28 <Sukhdev> #action: manishg to document task flow discussions and look into the midonet plugin
16:40:57 <Sukhdev> Anything else on this topic?
16:41:26 <Sukhdev> Please do discuss with your employer for the travel approvals, if you can help with this
16:41:59 <Sukhdev> I have attended every single past sprint and have found them to be very useful
16:42:33 <Sukhdev> This is where you get to sit with the core team up close and personal - in real design discussions, etc...
16:42:55 <Sukhdev> So, do think about it -
16:42:59 <manishg> Sukhdev: I'll communicate via etherpad - not planning to join in Vancouver.
16:43:18 <Sukhdev> Anything else?
16:43:22 * Sukhdev waiting
16:43:45 <Sukhdev> #topic: ML2 summit sessions
16:43:59 <Sukhdev> #link: https://etherpad.openstack.org/p/liberty-neutron-summit-topics
16:44:21 <Sukhdev> mestery is finalizing these sessions - please be sure put your name next to the topic
16:44:34 <Sukhdev> this will help him
16:45:11 <shivharis1> actually i did not see any names in the doc
16:45:20 <shivharis1> so i did not add my name
16:45:32 <Sukhdev> shivharis1: please add yours
16:45:52 <shivharis1> ok
16:45:55 <Sukhdev> every body has been asked to add their names
16:46:20 <Sukhdev> shivharis1: since you are representing the team, you can put ML2 team, along with your name
16:46:29 <shivharis1> k
16:46:35 <Sukhdev> this will let mestery know that we all want those sessions
16:46:55 <Sukhdev> Anything else on this?
16:47:06 <Sukhdev> #topic: Bugs
16:47:07 <manishg> Sukhdev: so the higher the number of people, more likely is the session?
16:47:31 <shivharis1> nothing much to report here, things are all go for kilo
16:48:00 <Sukhdev> manishg: well - I am not too sure - it is going to depend upon the time slots, topics, and priorities/need, etc...
16:48:00 <shivharis1> dont see any pressing issue/bugs for the kilo release
16:48:27 <Sukhdev> shivharis1: cool - thanks
16:48:36 <shivharis1> anyone have anything to add, or need any help in bug reviews?
16:48:40 <Sukhdev> anybody has any bug they want to discuss?
16:49:34 <yamamoto> nothing from me
16:49:37 <shivharis1> thats all from me for bugs
16:50:03 <Sukhdev> OK - lets move in that case
16:50:12 <Sukhdev> #topic: Open Discussion
16:50:26 <Sukhdev> Anybody has any thing to discuss?
16:50:41 * Sukhdev waiting
16:50:58 <yamamoto> nothing from me
16:51:08 <Sukhdev> Any issues on Decomposition of MDs?
16:51:21 <Sukhdev> Looks like we are done
16:51:36 <Sukhdev> Thanks for attending folks, this was a good discussion
16:51:40 <Sukhdev> see you next week
16:51:45 <Sukhdev> bye
16:51:48 <Sukhdev> #endmeeting