16:02:43 <Sukhdev> #startmeeting networking_ml2
16:02:44 <openstack> Meeting started Wed Jun  3 16:02:43 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:48 <openstack> The meeting name has been set to 'networking_ml2'
16:03:04 <Sukhdev> #topic: Agenda
16:03:11 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2
16:03:27 <Sukhdev> #topic Announcements:
16:04:30 <Sukhdev> FYI - I kicked off Ironic-neutron integration meetings starting this monday
16:04:45 <Sukhdev> lots of interest from lots of vendors and operators
16:05:05 <Sukhdev> You should drop by next week -
16:05:12 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron
16:05:35 <Sukhdev> Did you know about the new spec process?
16:05:49 <rkukura> Sukhdev: Is this still using the binding:profile port attribute to pass info from ironic->neutron? Are any neutron or ML2 changes envisioned for ironic?
16:06:11 <Sukhdev> rkukura: correct that is the plan
16:06:36 <rkukura> Sukhdev: thanks
16:06:38 <Sukhdev> however, armando discussed with me subscription service in neutron
16:06:59 <Sukhdev> he is asking me to look into that for this
16:07:16 <Sukhdev> Apparently ODL and OVN uses it
16:08:00 <rkukura> I think this is for APIs (like SGs) that ML2 doesn’t currently handle.
16:08:01 <Sukhdev> I plan on looking into this, but, at the moment, I going with binding profile - this makes a whole lot of sense
16:08:32 <Sukhdev> rkukura: correct
16:08:48 <rkukura> Sukhdev: I’ll try to participate in the ironic_neutron meetings
16:09:04 <Sukhdev> rkukura: cool - that will be nice
16:09:11 <shivharis> Sukhdev: count me in
16:09:35 <Sukhdev> shivharis: sounds good - it takes places Mondays at 9am PT
16:10:03 <Sukhdev> Vendor decamp phase 2 - I am sure you are aware of it
16:10:22 <Sukhdev> Here is the proposal - https://review.openstack.org/#/c/187267
16:10:55 <Sukhdev> #topic: Charter of ML2 team for Liberty
16:11:16 <Sukhdev> what do we want to accomplish in Liberty cycle?
16:11:29 <Sukhdev> I listed two items -
16:11:43 <Sukhdev> Task Flow and Decomposition phase 2
16:11:50 <Sukhdev> your thoughts?
16:12:38 <Sukhdev> manish has not shown up - I was hoping he will join in as we go along
16:12:50 <rkukura> I agree with both of those.
16:13:02 <rkukura> Do we know if the QoS effort is likely to impact ML2?
16:13:36 <Sukhdev> rkukura: I have not looked at it closely
16:13:41 <Sukhdev> shivharis: do you know?
16:13:47 <banix_> rkukura: there was discussion of that at neutron call
16:13:54 <rkukura> I’m thinking this might require the followon work for extensions’ sematics to be enforced during port binding, but am not sure
16:14:13 <shivharis> Sukhdev: those are the two that come to mind for now
16:14:30 <Sukhdev> banix_: I missed the meeting - can you fill us in?
16:14:36 <banix_> as is there is some tight connections as far as i could see; suggestion was to untangle
16:14:37 <sadasu> rkukura: at port binding and port updates as far as I understand
16:15:39 <rkukura> Maybe the charter should include a general items of tracking what other neutron efforts require/change in ML2
16:15:55 <banix_> so i havent looked at the spec myself but i thin there was a suggestion to not tie things to ml2 so say other plugins can use it as well. sorry no in-dept knowledge at the moment
16:16:39 <Sukhdev> banix_: oh i see - thanks
16:16:40 <rkukura> banix_: Agree on other plugins being able to do QoS, but I’m thinking it may effect how ML2 does certain things when the ML2 core plugin is used
16:16:45 <banix_> maybe ajo is the person who can fill us in? i may be wrong
16:17:01 <shivharis> where does ml2 agents fit in?
16:17:17 <rkukura> I’ll try to discuss this with ajo over the next couple days
16:17:45 <Sukhdev> rkukura: shall I assign you an action for this? It will be good to have clarity
16:17:50 <rkukura> sure
16:18:30 <Sukhdev> #action: rkukura to discuss with QoS implications with ajo  on ML2
16:19:23 <Sukhdev> So, we will add a misc. item on the charter and depending upon rkukura's findings on Qos, we'll add that as well
16:19:24 <shivharis> banix_: at one point u were looking at modularizing agents?
16:19:53 <banix_> shivharis: correct. were told during the last cycle that that was not on the priority listt
16:20:29 <shivharis> banix_: ok
16:20:45 <Sukhdev> banix_: because too much was going on - you may want to reopen, if you are willing to drive it :-)
16:21:28 <banix_> at Paris, it was decided just refactoring code for cleanup will be for the K cycle. That work didn’t get merged but i believe there are several patches by rosella et al under review
16:22:05 <banix_> Sukhdev: shivharis rkukura do you see any change in that view?
16:22:57 <rkukura> banix_: Not sure, but if/when Rosella’s patches get merged, it can’t hurt to look at next steps.
16:23:30 <shivharis> banix_: i would talk to person who said this is not a priority - capturing the reasons for the decision
16:23:31 <Sukhdev> rkukura +1
16:23:41 <banix_> yeah i think the first thing would be to see those patches merged
16:24:07 <Sukhdev> banix_: do you have cycles?
16:24:51 <banix_> shivharis: i think mainly the amount of work in the cycle was the reason; i was not at that summit and found out about it when I posted on the mailing list; i think armando was the person who responded by saying lets not do anything like that
16:25:02 <banix_> Sukhdev: motor or bi?
16:25:18 <Sukhdev> banix_: all of the above :-)
16:25:45 <shivharis> :-)
16:26:02 <Sukhdev> banix_: seriously, if you have cycles it may be worthwhile to do initial investigation
16:26:05 <banix_> Sukhdev: shivharis yes, i think if we feel the need, we should bring it up in the Neutron call and see what others think
16:26:43 <Sukhdev> banix_: Shall I assign you action to bring it up in neutron call?
16:26:45 <rkukura> I think “supporting” linuxbridge is becoming a priority, so modulazition might support that.
16:26:57 <banix_> Sukhdev: sure
16:27:04 <shivharis> rkukura: agree
16:27:58 <Sukhdev> #action: banix_ to discuss Modular L2 agents topic in Neutron core team and drive the priority
16:28:15 <Sukhdev> anything else we want to consider for Liberty charter?
16:28:30 * Sukhdev waiting
16:28:51 <Sukhdev> #topic Neutron Mid-cycle
16:29:04 <sadasu> Sukhdev: what about the physical topology service ?
16:29:31 <Sukhdev> sadasu: thanks for reminding me that….
16:29:39 <Sukhdev> we discussed it at the summit
16:29:44 <rkukura> sadasu: This would certainly be useful for some ML2 drivers.
16:30:11 <Sukhdev> it is a very much needed service - shivharis said he was going to drive it
16:30:16 <shivharis> arvind and I are working on a proposal that we will bring to the table in about a month
16:30:17 <Sukhdev> shivharis: wake up -
16:31:03 <Sukhdev> shivharis: should we add to the ML2's charter?
16:31:07 <rkukura> Sukhdev: Would ironic integration make use of topology service
16:31:08 <rkukura> ?
16:31:10 <shivharis> wide awake
16:31:15 <shivharis> Sukhdev: yes
16:31:51 <shivharis> Sukhdev: more and more it appears to be even out of the Neutron charter - but you can add this to ML2 for now
16:32:05 <Sukhdev> rkukura: Ironic needs something like physical topology - but, it can not use what is being proposed - as these are off-line machines
16:32:22 <shivharis> the scope is wider and may include nova
16:32:39 <Sukhdev> they can only be registered manually - once, they are powered on, then they could use physical topology service
16:32:42 <shivharis> s/may/will/
16:32:55 <rkukura> Sukhdev: I’d think the goal should be an API/model that captures physical topoology, with various options for populating it
16:33:14 <Sukhdev> shivharis: you will never get anything done if you keep saying scope is wider :-) - just my openion
16:33:26 <asomya> rkukura: Correct, the API and model should only capture the topology and the interconnection between components
16:33:40 <Sukhdev> shivharis: implement it as ML2 charter, once it works, then propose to others
16:33:48 <asomya> can be popluated via API,RPC etc.
16:34:12 <shivharis> Sukhdev: point taken
16:34:27 <Sukhdev> rkukura: I see your point -
16:35:22 <Sukhdev> shivharis, asomya: we are defining an API in Ironic to enter the physical topology information - perhaps you can use that as a manual method to add to physical topology and build around it for the automation part
16:35:46 <shivharis> Sukhdev: any pointer to the API?
16:35:55 <asomya> sukhdev: sounds good, any docs?
16:36:03 <Sukhdev> shivharis: no - it is still being spec'ed out
16:36:13 <shivharis> Sukhdev: ok
16:36:46 <Sukhdev> shivharis asomya: shall I assign you an action to add this on the charter of ML2?
16:36:48 <shivharis> Sukhdev: since i plan to be on the iron meeting it wont be a surprise then
16:36:57 <asomya> sure
16:37:12 <shivharis> Sukhdev: no not yet... we need to properly scope it
16:37:16 <Sukhdev> shivharis- ha ha say Ironic three times :-):-)
16:37:42 <asomya> we can track it with a work item in ML2 but as shiv said we still need to flesh it out with details
16:38:18 <shivharis> iron ironi ironic - got it
16:38:39 <Sukhdev> asomya: understood -BTW, I have a working model of physical topology thing, if you need any help, ping me.
16:39:25 <Sukhdev> #action: asomya and shivharis to add Physical Topology to the ML2 charter for Liberty
16:39:48 <amotoki> Sukhdev: sorry for jumping in. is there any good pointer for physical topology thing? I am aware of baremetal work but i am not sure how these two are related.
16:40:07 <Sukhdev> anything else before we really - move on - btw sadasu thank for reminding and thanks shivharis for sleeping on the wheel :-)
16:40:45 <asomya> amotoki: The spec is not ready yet, we will post something for review soon
16:41:05 <sadasu> :-)
16:41:09 <Sukhdev> amotoki: there is no document yet - we are working on a spec for Ironic port API to specify the physical connectivity information - to be added manually
16:41:36 <amotoki> asomya: thanks :-)  the meeting is overlapped and i haven't captured the sitaution fully.
16:41:58 <shivharis> Sukhdev: we need documents/pointers from you to be specific
16:42:18 <Sukhdev> amotoki: will you joining itonic-neutron integration meetings? they take place Monday at 9am PT
16:42:31 <Sukhdev> shivharis: will do
16:42:36 <amotoki> Sukhdev: yes unless it is not midnight :-)
16:42:57 <Sukhdev> amotoki: same time as this meeting - Mondays
16:43:11 <amotoki> yeah! thanks.
16:43:32 <Sukhdev> amotoki: This is not midnight for you, is it?
16:43:38 <banix_> ameade: isn’t past midnight there?
16:43:46 <banix_> amotoki: isn’t past midnight there?
16:43:57 <amotoki> Sukhdev: but it is acceptable.
16:44:09 <amotoki> one hour later is a bit hard though.
16:44:12 <Sukhdev> amotoki: I picked early time to accomodate aisan counterparts
16:44:17 <shivharis> Sukhdev: you said you have working model of physical topology thing, is it code you have or document?
16:44:30 <amotoki> please move on the next topic!
16:45:11 <Sukhdev> shivharis: neither can be shared - all Arista properioty - this is the first thing I implemented when I joined the company - all is in my head
16:46:06 <Sukhdev> shivharis: but, I can help you guys
16:46:37 <shivharis> Sukhdev: we will handle it ourselves - now need toget into legal trouble
16:47:26 <Sukhdev> I am not going to give you anything properiority - I will help you with ideas/reviews, etc..
16:47:38 <Sukhdev> so, do not worry :-)
16:47:50 <shivharis> Sukdev: will ping for it
16:47:59 <shivharis> Sukhdev: thanks
16:48:21 <Sukhdev> Any how - I want to discuss the neutron mid-cycle next
16:48:55 <Sukhdev> I forgot to do undo - so, we have been discussing all this under neutron mid-cycle topic - sorry about that
16:49:14 <Sukhdev> there are two items on the agenda which are relevant to ML2
16:49:37 <Sukhdev> 1) Decomposition part 2 and, 2) Task Flow
16:49:57 <Sukhdev> manishg (who is not here) can not make to the sprint
16:50:12 <Sukhdev> hence, we have only one relevant item
16:50:15 <manishg> Sukhdev: here.
16:50:42 <Sukhdev> manishg: better late than never :-):) welcome and good to see you are awake :-)
16:51:15 <Sukhdev> so, for task flow, we need manishg, who can not make to Ft. Collins
16:51:34 <Sukhdev> we are considering doing a mid-cycle sprint in Bay Area
16:51:44 <manishg> I'll be traveling around the time the sprint is planned :(  Josh couldn't make it either.
16:52:00 <shivharis> bye guys, go to run, will catch up on the logs
16:52:07 <Sukhdev> wanted to poll as to who will be interested in participating in Bay Area
16:52:29 <Sukhdev> shivharis: thanks
16:52:40 <manishg> we can do conf brdige, etc. for those interested but aren't here.
16:52:45 <rkukura> I’d travel to the Bay area for this
16:52:59 <manishg> or if there aren't too many we could do hangouts too.
16:53:12 <Sukhdev> manishg, shivharis, and I are locals here - so, should be easy
16:53:19 <manishg> Depending on how many folks are interested I could try to figure out where to host it.
16:53:28 <manishg> Josh is local too.
16:54:09 <Sukhdev> sadasu, asomya, banix_  ???
16:54:47 <banix_> Sukhdev: most probably won’t be able to attend in person
16:54:59 <sadasu> can't travel this frequently but would join a hangout session
16:55:23 <asomya> sukhdev: can probably make it , not sure yet
16:55:34 <Sukhdev> sadasu banix_: we can setup a hangout session
16:55:40 <banix_> yeah
16:55:52 <Sukhdev> asomya: if you can check and let manishg know, that would be good
16:55:56 <sadasu> thanks!
16:56:14 <rkukura> Would the goal be to design and implement the ML2 code changes needed to use TaskFlow, and update several drivers to work with this?
16:56:17 <asomya> sukhdev: will do
16:57:00 <Sukhdev> rkukura: correct - we should take one or two drivers and convert them to use task flow -
16:57:12 <manishg> rkukura: yes, we should shoot for that.  The main goal would be to first agree on a design to allow async operations and then update some drivers.
16:57:17 <amotoki> regardless of how the decomp work goes, the work on taskflow sounds a good topic.
16:57:40 <Sukhdev> amotoki: can you travel to Bay Area for this?
16:58:09 <amotoki> Sukhdev: I am not sure I can be there.
16:58:20 <Sukhdev> more the merrier :-)
16:59:01 <manishg> Sukhdev: should we talk about dates?
16:59:02 <Sukhdev> manishg: the next thing is to propose two or three possible time slots
16:59:09 <banix_> one minute left
16:59:14 <manishg> Sukhdev: ok, will do.
16:59:48 <Sukhdev> #action: manishg to propose two or three time slots for mid-cycle sprint for task flow
16:59:58 <Sukhdev> #topic Open Discussion
17:00:11 <Sukhdev> you got last minute to bring up anything
17:00:31 <Sukhdev> I thought it will be short meeting - but, we pushed it all the way
17:00:33 <banix_> thanks all
17:00:45 <Sukhdev> Thanks folks, this was good discussion
17:00:46 <Sukhdev> bye
17:00:47 <rkukura> Thanks Sukhdev!
17:00:47 <banix_> bye
17:00:51 <manishg> bye
17:00:51 <rkukura> bye
17:00:52 <asomya> bye
17:00:52 <Sukhdev> #endmeeting