16:03:32 <rkukura> #startmeeting networking_ml2
16:03:33 <openstack> Meeting started Wed Jun 10 16:03:32 2015 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:37 <openstack> The meeting name has been set to 'networking_ml2'
16:03:56 <rkukura> #topic agenda
16:04:27 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_June_10.2C_2015
16:04:41 <rkukura> Does anyone have anything to add to the agenda?
16:05:25 <rkukura> #topic Announcements
16:05:53 <rkukura> The neutron PTL has instituted a new RFE process for features
16:06:04 <rkukura> #link http://docs.openstack.org/developer/neutron/policies/blueprints.html#neutron-request-for-feature-enhancements
16:06:58 <rkukura> Feature requests are now made initially as launchpad bugs. The community votes by subscribing to the RFE bugs, and can comment on them.
16:08:03 <rkukura> The neutron drivers team reviews them, then a spec may be required.
16:08:50 <rkukura> Also, there is a proposal for further “plugin/driver decomposition” in review.
16:08:59 <rkukura> #link https://review.openstack.org/#/c/187267
16:09:33 <Sukhdev> This will impact some of the drivers who have their DB or config in the neutron tree
16:09:54 <rkukura> My undestanding of this is that the in-tree shim layers will be eliminated, and a mechanism for external DB migrations will be added, so config and DB models can move out of tree.
16:10:51 <rkukura> So basically, ML2 drivers will typically live in other git repos, such as the networking-* repos, and their entry points and all associated code and config will be in those repos.
16:11:26 <rkukura> Are people on-board with this general idea?
16:11:51 <sadasu> rkukura: we knew it was coming
16:12:24 <sadasu> rkukura: ok with general idea
16:12:31 <Sukhdev> I argued it be voluntry vs. mandatory
16:12:47 <Sukhdev> core team feels it should be mandatory
16:13:00 <rkukura> I had originally favored keeping the code that implemented/used the ML2 driver APIs in the neutron repo, but few drivers have taken that approach, so I think this is an improvement over the current very thin shim layers.
16:13:57 <rkukura> If you have comments, please followup on the review.
16:14:07 <rkukura> #topic Action Items
16:14:33 <sadasu> rkukura: I had followed the approach where the ML2 driver APIs are in tree
16:15:18 <sadasu> I hope that the part 2 of decomposition allows drivers to keep them that that way
16:15:23 <rkukura> #undo
16:15:24 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9ac5ad0>
16:16:16 <Sukhdev> sadasu: it is my understanding that it will have to go out
16:16:22 <rkukura> sadasu: If the new approach is manditory, I don’t think it will be possible to keep them that way, but that structure could be moved to the other repo.
16:17:00 <Sukhdev> sadasu: this impacts me as well - I had taken the same approach - hence, I argued :-)
16:17:34 <sadasu> rkukura, Sukhdev: thanks for the info
16:18:10 <rkukura> Lets get comments on the gerrit review, particularly if we want to argue for this to be optional. But making it manditory does kind of address the level playing field concern some vendors have expressed.
16:18:20 <rkukura> OK, lets move on…
16:18:30 <rkukura> #topic Action Items
16:18:51 <rkukura> I had an action to discuss QoS implications for ML2 with ajo.
16:19:11 <rkukura> Sukhdev brought this up at the neutron IRC meeting and ajo did not think there were any.
16:19:23 <rkukura> So I think that one is closed.
16:19:53 <rkukura> banix had an action regarding agents, but is out this week, so we’ll keep it for next week
16:20:09 <rkukura> #action banix to discuss Modular L2 agents topic in Neutron core team and drive the priority
16:20:51 <rkukura> asomya: You and shivharis had an action regarding physical topology - any update?
16:22:12 <rkukura> I don’t see shivharis and asomya hasn’t replied, so we can keep that one for next week
16:22:15 <yamahata> the item in the agent is to update chater only. Is any further thing(e.g. api design) the scope of liberty?
16:22:22 <yamahata> I'm very interested in it.
16:23:05 <rkukura> Is there a specific charter document to update?
16:23:58 <yamahata> Ah, s/to update/to add/.
16:24:03 <rkukura> I’m thinking we’d need to file RFEs (or just specs for liberty-1) for these
16:24:15 <yamahata> I see. thanks
16:24:48 <Sukhdev> yamahata: banix has done some work on it in the past - he has patch out there, which needs to be revived
16:25:06 <yamahata> Link please?
16:25:07 <rkukura> Maybe we should include a section on “Liberty Charter” on the https://wiki.openstack.org/wiki/Meetings/ML2 page where we can track significant featres as part of each weekly meeting.
16:25:17 <asomya> rkukura: sorry, got a call in the middle of this meeting.. Shiv and I are still working on the spec
16:25:57 <rkukura> asomya: thanks
16:26:49 <Sukhdev> rkukura +1 about adding the charter to ML2 wiki
16:27:52 <rkukura> #action rkukura and Sukhdev to add charter section to ML2 wiki, listing major RFEs/specs/BPs being considered for liberty
16:29:09 <rkukura> OK, last AI was manishg proposing dates for a TaskFlow/async/re-sync code sprint
16:29:30 <rkukura> This is the next agenda item, so we’ll move right to it
16:29:31 <yamamoto> yamahata: https://etherpad.openstack.org/p/modular-l2-agent-outline
16:30:15 <rkukura> yamamoto: thanks
16:30:21 <yamahata> yamamoto: thanks, in the context of modular l2 agent. got it.
16:31:20 <manishg> rkukura: I put the dates in the agenda item.  I think due to mid-cycle and long weekend July/13+ is the earliest.
16:31:21 <rkukura> We’ll include modular l2 agent in the charter section, and check status on it each week, at least until we’ve decided what’s happening in liberty
16:31:36 <rkukura> #topic Neutron Mid-Cycle Sprint Discussion
16:32:02 <rkukura> manishg: That was my conclusion as well
16:33:06 <manishg> I'm traveling in late/July-Aug/20 so didn't put anything for Aug but if late Aug works I will add last week of Aug too.
16:34:01 <rkukura> Assuming this sprint is to code using TaskFlow to replace postcommit methods with an async solution, are there others who would definitely want to participate?
16:35:47 <rkukura> Seems we should target July 13-15 if possible.
16:36:21 <manishg> ok then.  I'll work with Sukhdev to figure out other details and update all those listed there.
16:36:30 <rkukura> Please let me, Sukhdev, and manishg know if you’d like to participate. We’ll figure out who can host it.
16:36:50 <Sukhdev> manishg: sorry - got interrupted - back here
16:37:07 <Sukhdev> I looked at my calander - those dates are open
16:37:39 <rkukura> Assuming we do this sprint July 13-15, are there other items we’d want to include beyond the async stuff?
16:38:29 <manishg> I think that would be the main item.
16:38:29 <Sukhdev> rkukura: I think we keep it focused to one or two topics -
16:38:50 <Sukhdev> if asomya and shivharis are up for physical topology part, we can include that as well
16:39:06 <Sukhdev> I will be there and can help with the physical topology part
16:39:47 <asomya> sukhdev: I can make it to that
16:40:27 <Sukhdev> asomya: can you add your name to the list - I only added 4 names to the list (as I was not sure about others)
16:40:32 <rkukura> Sukhdev: Does this physical topology work relate to ironic_neutron?
16:40:41 <Sukhdev> rkukura: no
16:41:10 <asomya> rkukura: this is the generic topology storage and retrieval bit, the ironc stuff might tie into it in the future
16:41:22 <Sukhdev> rkukura: but, if it is available, we can try to see how it can be leveraged for it - in addition to neutron and nova
16:41:27 <rkukura> Sukhdev: OK, so not required, but possibly relatd.
16:41:42 <Sukhdev> rkukura: correct
16:42:01 <Sukhdev> the biggest beneficiary of this will be neutron and nova
16:42:39 <Sukhdev> BTW,  want to check if any of you are going to Ft. Collins sprint?
16:44:25 <rkukura> Sukhdev: I haven’t been planning to, but it seems the agenda has expanded a bit, and it might be worth considering
16:44:57 <Sukhdev> rkukura: I am thinking about going for couple of day - I think it may be worthwhile
16:45:44 <rkukura> OK, anything else on any of the mid-cycles?
16:46:13 <janonymous_> o/
16:46:41 <rkukura> #topic Open Discussion
16:47:07 <rkukura> Speak up, or we’ll end a bit early today!
16:47:23 <Sukhdev> rkukura: want to make an announcement
16:47:31 <rkukura> Sukhdev: OK
16:48:19 <Sukhdev> Folks, If anybody has any interest in L2 Gateway program, we meet alternate mondays at 10AM (PT) on #openstack-meeting-4
16:48:39 <Sukhdev> the next meeting is on 6/22 - please join us and learn about it
16:49:04 <Sukhdev> This allows you to connect virtual networks with physical networks by creating L2 Gateways
16:49:20 <Sukhdev> We need volunteers as well as consumers -
16:49:33 <Sukhdev> We made a presentation in the Summit -
16:49:50 <Sukhdev> If you have not had a chance to watch it, let me know and I can provide the link
16:50:18 <rkukura> Sukhdev: Thanks! I’ll try to at least lurk at that meeting if I can.
16:50:30 <asomya> sukhdev: i'm interested
16:50:43 <rkukura> Anything else before we adjurn?
16:50:54 <Sukhdev> asomya rkukura: this is really cool stuff
16:52:28 <rkukura> Thanks everyone!
16:52:34 <rkukura> #endmeeting