16:02:27 <Sukhdev> #startmeeting networking_ml2
16:02:27 <openstack> Meeting started Wed Jun 17 16:02:27 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:31 <openstack> The meeting name has been set to 'networking_ml2'
16:02:41 <Sukhdev> #topic: Agenda
16:02:48 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/ML2
16:03:13 <Sukhdev> Anybody wants to add anything to agenda?
16:03:29 <Sukhdev> #topic: Announcements:
16:04:14 <Sukhdev> If any of you interested in  VLAN aware VMs topic - they had their meeting yesterday
16:04:40 <Sukhdev> Did anybody here attended the meeting?
16:05:14 <rkukura> Wanted to, but couldn’t attend. Will read the minutes.
16:05:36 <Sukhdev> rkukura: me too, but, fell asleep :-)
16:06:17 <Sukhdev> Another announcement - if anybody is interested in L2 GW topic, next meeting is on 6/22 (next Monday)
16:06:39 <Sukhdev> at 10am PT at #openstack-meeting-4
16:07:28 <Sukhdev> Next one - is anybody is interested in Ironic-Neutron integration topic, next meeting is on 6/22 (next monday)
16:07:47 <Sukhdev> at 9am PT at #openstack-meeting-4
16:08:06 <Sukhdev> Any other announcement?
16:08:35 <Sukhdev> #topic: Action Items from previous week(s)
16:08:47 <Sukhdev> banix: are you here?
16:09:11 <banix> Sukhdev: hi
16:09:20 <Sukhdev> banix: was going to discuss ML2 Agent
16:09:35 <banix> I haven’t followed up on the mailing list I am afraid.
16:09:35 <Sukhdev> banix: want to provide any update - if you have one?
16:09:59 <banix> I am sorry for missing this AI. Will do so today.
16:10:19 <Sukhdev> banix: thanks
16:10:25 <Sukhdev> next item
16:10:36 <Sukhdev> asomya
16:10:48 <Sukhdev> shivharris does not seem to be here
16:10:58 <Sukhdev> asomya: want to give any update?
16:11:09 <Sukhdev> on physical topology topic
16:12:04 <Sukhdev> asomya: are you here?
16:12:12 <asomya> Sukhdev: Shiv and i have fleshed out the proposal a lot more last week
16:12:34 <Sukhdev> asomya: are you in a position to share?
16:12:40 <asomya> we jsut have a few more things to add to it and we should be ready to post something in a week or so
16:13:16 <Sukhdev> asomya: cool - sounds promising….look forward to it
16:13:41 <Sukhdev> Manish does not seem to be here
16:14:19 <Sukhdev> Manish posted some possible dates for the ML2 sprint
16:14:40 <Sukhdev> I can make most of those dates
16:14:46 <Sukhdev> how about others
16:15:12 <Sukhdev> asomya: rkukura : you mentioned you could make it
16:15:26 <rkukura> I can make July 13-15 or I think any of the September dates. Is August out?
16:15:52 <asomya> I can make July 13th
16:16:05 <Sukhdev> rkukura: looks like August is out - as he did not propose any date in August
16:16:39 <rkukura> September seems kind of late to get this merged in libery. When is liberty-3?
16:16:43 <Sukhdev> So, shall we pick July 13 week?
16:17:31 <Sukhdev> rkukura: here is schedule - https://wiki.openstack.org/wiki/Liberty_Release_Schedule
16:17:32 <rkukura> Week fo 7/13 sounds good to me.
16:18:02 <Sukhdev> L3 - first week of sept - so, yes, too late :-)
16:18:17 <rkukura> This will have the most value of vendors have time to update their drivers to take advantage of it.
16:18:27 <rkukura> So lets do 7/13.
16:18:44 <Sukhdev> rkukura: can you follow up with Manish to nail down 7/13?
16:18:52 <rkukura> Sukhdev: sure
16:19:21 <Sukhdev> #action: rkukura to finalize the date of ML2 mid-cycle sprint with manishg
16:20:01 <Sukhdev> rkukura: you may want to set up an etherpad for this as well
16:20:24 <rkukura> yes, and I’ll see if Cisco can host it
16:20:40 <Sukhdev> Next question is - do we limit it to Task Flow or add Physical Topology as well?
16:21:05 <Sukhdev> asomya: will you be ready to a point that we can include physical topology in this sprint?
16:22:04 <Sukhdev> rkukura: when you nail down the details with manish, can you work out if it is at Cisco or Yahoo?
16:22:09 <asomya> suklhdev: yeah we will be ready by then
16:22:45 <rkukura> Combining these sounds good - we can split into teams for each, but help each other out as needed
16:23:11 <Sukhdev> rkukura: so in that case, perhaps having both topics may be a good idea
16:23:54 <Sukhdev> I could potentially pull one more guy from Arista to help out as well
16:24:27 <rkukura> I’ll include both in the etherpad, and we’ll get people to sign up indicating which they are interested in working on
16:24:42 <Sukhdev> rkukura: good idea
16:25:03 <Sukhdev> #topic: Neutron mid-cycle sprint
16:25:24 <Sukhdev> There are two neutron mid-cycle sprints
16:25:56 <Sukhdev> The one next week is more general and the later one is focused only on QoS
16:25:58 <rkukura> Three, if you include the one we are planning!
16:26:09 <Sukhdev> Next week is in Ft. Collins
16:26:22 <Sukhdev> Are any of you going there?
16:26:35 <Sukhdev> #link: https://etherpad.openstack.org/p/neutron-liberty-mid-cycle
16:26:47 <Sukhdev> I will be attending for 2 days
16:26:52 <amotoki_> unfortunately i cant.
16:27:17 <rkukura> I haven’t been planing to go, but might try.
16:27:32 <Sukhdev> amotoki_: it is usually a lot of fun, and very productive - much more than summits
16:27:43 <Sukhdev> rkukura: you should
16:28:09 <Sukhdev> This means I will not be joining this meeting next week -
16:28:24 <Sukhdev> rkukura: it will be on you - :-)
16:28:39 <rkukura> What is intended by “reference plugin decomp”?
16:28:53 <rkukura> Is this moving ML2 and/or the L2 agents to a separate git repo?
16:29:02 <Sukhdev> rkukura: this is the one I am going for
16:29:08 <Sukhdev> rkukura: yes
16:29:41 <Sukhdev> banix: if you can make it, it may be of interest to you as well
16:29:45 <rkukura> Any idea what is planned for “get me a network”?
16:30:10 <Sukhdev> rkukura: no - there was a session at summit, I could not make it
16:30:23 <banix> Sukhdev: unfortunately cannot make it
16:30:41 <Sukhdev> banix: understandable
16:30:42 <amotoki_> we (except me) will have more concrete plan for "get me a network".
16:31:05 <amotoki_> are you aware a spec summarying the summit discussion?
16:31:24 <banix> rkukura: Sukhdev the idea about give me a network is providing a simpler one step thing to get a VM connected
16:31:28 <rkukura> amotoki: I’m not
16:31:35 <banix> amotoki: yes there is one
16:31:41 <banix> let me find it
16:31:52 <amotoki_> #link https://review.openstack.org/#/c/184857/
16:31:53 <rkukura> We tried that with GBP ;)
16:32:17 <banix> #link https://review.openstack.org/#/c/184857/
16:32:32 <banix> this is not really a spec; just summarizing what happened in that session
16:32:41 <banix> but gives you the general idea
16:33:02 <Sukhdev> sounds like a very interesting topic -
16:33:19 <Sukhdev> I had a conflict during summit and hence, missed that session
16:33:55 <banix> mainly asked by users and those coming from nova-network
16:33:59 <Sukhdev> rkukura: it will be your opportunity to find out the details if you go there - :-)
16:34:29 <Sukhdev> banix: this may be interesting for Ironic as well
16:34:37 <rkukura> GBP already does most of this (creating networks, subnets, routers, …) - would just need better integration with nova
16:35:21 <Sukhdev> amotoki: does it use ML2 Plugin - just the front end simpler, is that the idea?
16:35:22 <banix> Sukhdev and rkukura: yes
16:35:53 <amotoki_> the basic idea is that a user want not to take care of network.
16:36:01 <banix> Sukhdev: any plugin should potentially be able to serve this new api
16:36:06 <amotoki_> users just want VMs :-)
16:36:45 <amotoki_> the ml2 plugin can support it, but it is not clear yet about which component/layer should take care of it.
16:36:47 <rkukura> Is the idea that if no —nic params are passed to nova, it would use this new neutron API to set everything up?
16:37:21 <banix> Sukhdev: i dont think there are any concrete plans as to how to implement it. afaik just at discussion stage
16:37:51 <banix> rkukura: that could be one way of getting there
16:37:58 <amotoki_> not sure we have a new neturon API or not. one option is that nova compute netwokr api does, and the other is Neutron supports it.
16:38:09 <amotoki_> all are under discussion.
16:38:19 <Sukhdev> In that case, it would be good to participate/discuss this at the sprint
16:38:25 <amotoki_> you can chime in :-)
16:38:26 <rkukura> amotoki_:  makes sense
16:39:36 <Sukhdev> amotoki_: so, some kind of policy will dictate (when a VM wants to be connected to a network) as to which network to pick/create
16:40:18 <rkukura> Sukhdev: That’s how group-based-policy works :)
16:40:49 <amotoki_> In the summit discussion we mainly focused on the case where a user have no network and how we can do for it.
16:41:01 <Sukhdev> rkukura: yup - that would be my guess - otherwise, I do not know how will one determine which network to use
16:41:32 <amotoki_> and we can support some policy or series of provisioning as Sukhdev mentioned above.
16:41:33 <rkukura> Sounds like some interesting dicussion, but maybe not ready for a code sprint next week - we’ll see
16:42:10 <banix> Sukhdev: one possibility is creating one automatically for the tenant; i guess another possibility is using a shared network....
16:42:21 <Sukhdev> I am thinking they might discuss the design of this - not implementation
16:42:47 <Sukhdev> banix: both are kind of restrictive -
16:43:16 <banix> Sukhdev: all current options remain; this will be something additional for simple use cases mainly
16:43:18 <amotoki_> this operators ML thread may be interesting to you all: http://lists.openstack.org/pipermail/openstack-operators/2015-June/007388.html
16:44:00 <Sukhdev> amotoki_: thanks for sharing it
16:44:11 <banix> something to address the user/operators concern that Neutron is too complicated :)
16:44:16 <Sukhdev> I guess next week will be enlightening :-)
16:44:22 <amotoki_> the thread discusses how users take care of networks. not many users want to take care of networks.
16:45:08 <rkukura> Do these users want to control what VMs can talk to what VMs over what protocols?
16:45:46 <amotoki_> they just want a network on which VMs can talks each other
16:46:03 <amotoki_> and FIP/SNAT works for them.
16:46:05 <rkukura> So no security groups or anything like that even?
16:46:06 <banix> rkukura: probably just having VMs internet connectivity or among themselves would do for some
16:46:50 <amotoki_> rkukura: I think they want just the early phase of EC2, not Amazon VPS.
16:46:56 <Sukhdev> banix: so, this is not for enterprise customers
16:47:03 <banix> rkukura: if any, probably with some sensible defaults
16:47:20 <amotoki_> it is one of typical OpenStack use cases.
16:47:40 <banix> Sukhdev: well, i think it could be. as long as the connectivity and isolation is provided by default they will be ok
16:48:01 <banix> Sukhdev: perhaps for small enterprises :)
16:48:01 <rkukura> banix: both connectivity and isolation?
16:48:19 <Sukhdev> banix: I am lost about isolation - how can that be guaranteed in this model?
16:48:38 <banix> rkukura: connectivity for a given tenant (among his/her VMs) and isolation among tenants
16:48:49 <rkukura> banix: I see
16:49:02 <banix> a tenant comes in say i need 10 VMs.
16:49:20 <Sukhdev> banix: so, this is a network/tenant model - now I get it
16:49:21 <banix> that implies those 10 VMs get connected to each other and the internet and that’s the end of it
16:49:47 <banix> that is my understanding; amotoki can correct me if not correct
16:49:53 <amotoki_> they don't need complex network topology. one isolated tenant network works for them.
16:50:02 <amotoki_> banix: i believe we are in the same page.
16:50:30 <Sukhdev> I think now I am on the same page as well - I was missing this angle - i.e. one network per tenant
16:51:26 <banix> Sukhdev: yeah, but that one network gets created automatically like gbp does for example…. another option is using the shared network but that is for even more limited cases i would think
16:52:17 <banix> no need to do create network, create router, set interface, gateway, etc
16:52:26 <banix> explicitly by user that is
16:52:38 <rkukura> I think GBP has at least proven that these things can all get done implicitly
16:53:16 <banix> rkukura: i think you should bring that to the table whether at the sprint or through mailing list
16:53:22 <amotoki_> I am not familiar with the current status of GBP. If you already have it, it might be a good candidate.
16:53:35 <Sukhdev> This is interesting - more and more I understand, I am liking it :-):-)
16:54:12 <Sukhdev> rkukura: this discussion tells me your presence next will be very good - I mean at the sprint
16:54:29 <Sukhdev> s/next/next week
16:54:30 <rkukura> I’ll try to make it happen
16:54:46 * Sukhdev 6 min left
16:54:57 <Sukhdev> anything else to discuss?
16:55:16 <amotoki_> btw, are there any prioritized spec reviews related to ML2 area?
16:55:32 <amotoki_> I would like to review them.
16:55:54 <Sukhdev> amotoki_: I do not believe so - rkukura ?
16:56:10 <rkukura> I’m not aware of any ML2-specific specs in review right now
16:56:38 <amotoki_> Sukhdev: rkukura: thanks.
16:56:43 <rkukura> We’ll need to do something for the topology and async efforts, but probably the new process.
16:57:00 <rkukura> and for the modular agent
16:58:01 <Sukhdev> anything else?
16:58:20 <Sukhdev> I guess we are done 2 min ahead of schedule :-)
16:58:47 <Sukhdev> Thanks folks, this was a great discussion - rkukura will see you next week - if you make it
16:58:57 <Sukhdev> bye
16:59:00 <banix> bye
16:59:01 <Sukhdev> #endmeeting