16:01:04 <Sukhdev> #startmeeting networking_ml2
16:01:05 <openstack> Meeting started Wed Jul  8 16:01:04 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:08 <openstack> The meeting name has been set to 'networking_ml2'
16:01:32 <Sukhdev> #topic: Agenda
16:01:37 <Sukhdev> #link https://wiki.openstack.org/wiki/Meetings/ML2
16:01:45 <Sukhdev> Good morning folks
16:02:05 <amotoki> hi
16:02:18 <Sukhdev> #topic Announcements
16:02:35 <Sukhdev> I do not have any specific announcement on the agenda
16:02:45 <Sukhdev> does anybody have any announcement?
16:03:03 <shivharis> yes.. hold on
16:03:12 * Sukhdev waiting
16:03:23 <shivharis> the last date for talks is 17th for submissions of talks
16:03:40 <shivharis> am i right?
16:03:52 <Sukhdev> shivharis: for Tokyo summit?
16:03:56 <shivharis> yes
16:04:02 <Sukhdev> shivharis: No it is 15th July
16:04:18 <shivharis> ok, it is fast approaching so best to remind folks
16:04:21 <rkukura> Sukhdev, shivharis: RIght, email says the 15th
16:04:40 <Sukhdev> Good point shivharis  - thanks for reminder
16:04:57 <Sukhdev> BTW, I am proposing one talk for the main session -
16:05:06 <Sukhdev> for design summit - we have lots of time
16:05:34 <rkukura> Sukhdev: What’s your topic?
16:06:02 <Sukhdev> rkukura: not finalized yet - but, it will be on the lines of Ironic/Neutron integration
16:06:12 <shivharis> Arvind and I are proposing topology as a service
16:06:37 <Sukhdev> shivharis: I was thinking of that for design session
16:06:52 <Sukhdev> shivharis: I mean for design session for sure
16:07:06 <shivharis> actually the touch points of this is both in nova and neutron
16:07:32 <shivharis> i am getting Nova folks about this
16:08:01 <Sukhdev> shivharis: you should do the same way as i did in last summit - present in design session for both projects
16:08:27 <shivharis> exactly - Arvind and I were thinking that way
16:08:56 <Sukhdev> shivharis: yup - that will be a good idea
16:08:57 <shivharis> but i dont want to lose the opportunity to do a talk in the general sessions
16:09:24 <Sukhdev> shivharis: sure - you should try that too
16:09:25 <asomya> sukhdev: The main track is to get a broader audience to present the scope of the project
16:10:01 <Sukhdev> asomya: correct - if you can get them to approve it
16:10:12 <amotoki> and sometimes it helps developers understand it.
16:10:30 <Sukhdev> asomya: I think this will be good for both sessions
16:10:36 <shivharis> amotoki: agreed, design talks are a must for both Nova and Neutron
16:10:51 <asomya> Sukhdev: Agreed, maybe we can have both?
16:10:53 <shivharis> Sukhdev: +1
16:11:22 <Sukhdev> shivharis asomya: But, first you have to present it to us - here :-):-)
16:11:32 <shivharis> Sukhdev: +1
16:11:40 <shivharis> +2
16:11:43 <amotoki> shivharis: I am not sure what projects are related to your proposal. only nova and neutron? it is out of scope of this meeting though...
16:11:55 <Sukhdev> anyways, I have it on agenda for today's discussion - so, hold on to your seats :-)
16:12:08 <asomya> amotoki: The first iteration is a bit Neutron and nova focused, the scope can be expanded later to storage etc. as required
16:12:27 <shivharis> asomya: +1
16:12:53 <amotoki> asomya: thanks. I just feel so  from the word "topology as a service".
16:13:03 <Sukhdev> amotoki: why do think it out of scope - I think in Neutron, this is more applicable to ML2 drivers than anything else
16:13:42 <shivharis> Sukhdev: ML2 driver is a consumer
16:13:52 <asomya> Sukhdev: Like amotoki said, it's a generic topology service that can be consumed by any other service .. neutron/ml2 is just one of them
16:13:53 <amotoki> Sukhdev: "out of scope of the meeting" is confusing... sorry, precisely speaking, the current topic is "announcement".
16:14:28 <amotoki> but topology as a service is not specific to ml2.
16:14:35 <Sukhdev> amotoki: ah ha got it - yes, I have this topic on the agenda
16:15:06 <Sukhdev> speaking of that - lets get back on track to the agenda
16:15:21 <Sukhdev> #topic: Action Items
16:15:47 <Sukhdev> rkukura: was going to work with manishg to finalize the ML2 mid-cycle
16:16:09 <manishg> Sukhdev: I think discussion is going via email with all those interested.
16:16:10 <Sukhdev> I noticed we have lots of discussion on this, but, we need to finalize the details and plan
16:16:40 <Sukhdev> I think we have all participants here - shall we finalize it here now?
16:16:47 <manishg> and looks like next week is out.  So likely dates are late Aug or early Sep (due to other conflicts and release schedules).
16:16:57 <manishg> Sukhdev: sure
16:17:17 <Sukhdev> manishg: based upon the emails, it seems like early sept is best -
16:17:32 <manishg> Sukhdev: sounds good to me.  how about others?
16:17:48 <Sukhdev> rkukura made a good point that this will not go into liberty anyway - so, might be better to plan a bit better
16:17:59 <rkukura> Early Sept works best for me at this point
16:18:10 <manishg> week of Sep/7 will be a short week.
16:18:46 <Sukhdev> manishg: is that labor day week?
16:18:47 <amotoki> feature freeze is the first week of Sep.
16:18:52 <amotoki> isn't it too late?
16:19:05 <amotoki> it's just a question
16:19:15 <Sukhdev> amotoki: we are thinking that we will push it for M release -
16:19:19 <manishg> Sukhdev: I think so.
16:19:27 <amotoki> got it.
16:19:56 <shivharis> BTW if you are having issues of hosting, i can arrange taht
16:19:58 <Sukhdev> So, shall we do in the week after the labor day week?
16:20:40 <Sukhdev> shivharis: now we have three bids on the table - shall we start the bidding - I do not take less than $100 bills :-)
16:20:52 <shivharis> $0
16:20:53 <Sukhdev> just kidding :-)
16:21:04 <shivharis> jk
16:21:30 <Sukhdev> who wants to take the action to finalize this - ie. who is hosting, where, when, etc….?
16:21:52 <Sukhdev> rkukura: has already put together an ehterpad for this
16:22:05 <Sukhdev> #link: https://etherpad.openstack.org/p/Neutron_ML2_Mid-Cycle_Sprint
16:22:08 <shivharis> I just need a weeks headstart to arrange
16:22:24 <shivharis> the venue
16:22:33 <rkukura> Is everyone OK with early September in the Bay Area?
16:22:46 <Sukhdev> rkukura: yes
16:23:08 <Sukhdev> shivharis: you are third in the line - $500.00 brings on the top of the line :-)
16:23:15 <rkukura> And the idea of doing the work on a branch, hopefully to merge in early M?
16:24:19 <rkukura> I’ll update the etherpad to try to identify a week in early September
16:24:24 <shivharis> rkukura: +1
16:24:49 <rkukura> I’ll list each week and ask people to put their name with Y or N.
16:24:52 <Sukhdev> rkukura: looks like you are volunteering for planing this
16:24:57 <rkukura> yes
16:25:19 <Sukhdev> yay!!! - thanks rkukura - I will assign you an action
16:25:28 <rkukura> I’d like to nail down the dates by next Wednesday’s meeting
16:25:53 <Sukhdev> #action: rkukura to coordinate with rest of the team to finalize the detailed plan for ML2 mid-cycle sprint
16:26:07 <rkukura> So if you are interested in participating, please get your name onto the etherpad and we’ll include you in any emails.
16:26:26 <Sukhdev> anything else on this topic?
16:26:42 <banix> so lets call it late-cycle. It is more accurate and defenitely more cool.
16:26:52 <Sukhdev> rkukura: I have possible one volunteer from Arista who might join as well -
16:26:52 <rkukura> One last detail is which projects in addition to async will be worked on at the mid-cycle
16:26:59 <shivharis> rkukura: actually put ur name as attending + interested and not attending
16:27:23 <shivharis> split of ML2?
16:27:49 <Sukhdev> rkukura: make sure banix is there to head the cheerleading staff
16:28:16 <rkukura> would be a good idea to move to a separate repo before branching if we are going to do that
16:28:23 <Sukhdev> banix: kidding aside you have a good point
16:28:32 <amotoki> "pre-cycle sprint for M**" rather than "mid-cycle"
16:28:50 <Sukhdev> rkukura: I was thinking stackforge - but, that may be too heavy handed
16:29:23 <rkukura> I think a feature branch in the same repo where ML2 lives would be fine. Any reason to do it in stackforge instead?
16:29:28 <shivharis> github for sure maybe not stackforge
16:29:40 <shivharis> rkukura: like ur idea
16:29:58 <rkukura> We want to be able to easily rebase the branch as other changes are merged
16:30:49 <Sukhdev> I only thought of stack forge so that this can be released as a package and anybody who wants to play with it can pull it from pypi
16:31:17 <rkukura> Sukhdev: Worth considering. Lets get back to that at a future meeting
16:31:20 <Sukhdev> but, I am OK either way - do not want to make it too heavy handed thought
16:31:36 <shivharis> pypi can deal with branches, i think
16:32:09 <Sukhdev> shivharis: not sure - you may be right - may be worth looking into this
16:32:30 <Sukhdev> Any ways - lets move on
16:32:54 <Sukhdev> #topic: L2 modular agent
16:33:20 <Sukhdev> banix: want to give us the details -
16:33:44 <Sukhdev> banix: I mean update -
16:33:59 <banix> Sukhdev: I haven’t made any progress; trying to consolidate wrt ungoing enhancement to the agents
16:35:10 <amotoki> I think "modular agent" has several aspects:
16:35:18 <amotoki> modularity for features
16:35:21 <Sukhdev> yamamoto - anything you want to share?
16:35:25 <amotoki> modularify for backends
16:36:13 <Sukhdev> amotoki: correct
16:36:46 <amotoki> re: the first point, ajo proposal is worth considered.
16:37:33 <yamamoto> Sukhdev: ?
16:37:55 <yamamoto> Sukhdev: about modular agent?  nothing from me
16:38:09 <Sukhdev> yamamoto: sounds good -
16:39:11 <Sukhdev> anything else on this topic?
16:39:23 * Sukhdev waiting
16:39:45 <Sukhdev> #topic: Physical Topology Discussion
16:39:52 <amotoki> banix: could you update the progress in bug 1468803?
16:39:52 <openstack> bug 1468803 in neutron "Modular L2 Agent" [Undecided,Confirmed] https://launchpad.net/bugs/1468803
16:40:01 <amotoki> or it there any place to see?
16:40:15 <Sukhdev> #undo
16:40:16 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9556490>
16:40:37 <banix> amotoki: will do
16:40:49 <Sukhdev> banix amotoki : thanks
16:41:03 <Sukhdev> #topic: Physical Topology Discussion
16:41:18 <Sukhdev> shivharis asomya: Folks want to give us some update?
16:41:33 <Sukhdev> got any link to share? about your work so far?
16:41:48 <shivharis> We are in the process of refining the design
16:42:05 <shivharis> we are discussing this with folks in Nova
16:42:14 <Sukhdev> shivharis: care to share what ever you have?
16:42:34 <shivharis> as discussed earlier it will have touch points in both nova and neutron
16:42:43 <shivharis> possibly cinder as we go forward
16:43:12 <amotoki> shivharis: is it realted to scheduler or more?
16:43:19 <shivharis> we will share it in the next week or two and possibly at the early M meeting we are planning
16:43:38 <shivharis> amotoki: right
16:44:11 <shivharis> the input to db model will be getting info of the host ids from nova
16:44:11 <Sukhdev> shivharis asomya: I am a bit lost here about this service
16:44:43 <Sukhdev> shivharis asomya : Are you actually doing any work to tie it with any of these projects or just a white paper?
16:45:00 <shivharis> we will present the entire picture in the pre-M meeting we are planning
16:45:21 <asomya> Sukhdev: A high level overview, it's a generic topology manager that can store and retrieve topology, anything can ask or store topolgy via the API
16:45:41 <Sukhdev> asomya shivharis: there is a prior work done on this topic by issaku - which was presented in Atlanta summit - have you seen it?
16:45:49 <Sukhdev> is it on the same lines?
16:45:51 <yamahata> Sukhdev: asomya what  first primary use case  do you have in mind?
16:45:52 <shivharis> currently it will be nova and neutron - the design will not exclude cinder
16:46:17 <asomya> yamahata: The primary use case is Neutron and nova
16:46:18 <yamahata> s/Sukhdev/ shivharis /
16:46:57 <yamahata> asomya: VM scheduling?
16:47:06 <shivharis> at a high level there are discovery agents feeding the topology discoverd to a consolidator
16:47:25 <asomya> yamahata: Getting hardware information required by driver and plugins to configure the physical fabric
16:47:42 <amotoki> i think yamahata is asking what is the main target as a high-level goal. what can it achieve?
16:47:43 <shivharis> the consolidator will expose an API that can be queried by any project
16:48:26 <yamahata> asomya: then your first goal is to abstract fabric management?
16:48:51 <yamahata> amotoki: exactly. thanks for explanation.
16:48:52 <shivharis> the main target at a high level to begin with with will be neutron or ML2
16:49:02 <asomya> yamahata: expose it rather than abstract it
16:50:02 <Sukhdev> shivharis asomya : Are you working on a POC, along with a use case, for this or it is just white paper?
16:50:22 <shivharis> POC is underway
16:50:25 <amotoki> i think what asomya means is to export it in a unified/general way
16:50:47 <Sukhdev> shivharis: good
16:51:39 <Sukhdev> shivharis asomya: So, this leads me to the next question - we were planning on working on this during mid-cyle (or late-cyle or pre-cycle) sprint -
16:52:02 <Sukhdev> Do we still need to put on the agenda for the sprint -
16:52:29 <Sukhdev> without having much information about it, it may be hard to dive into the implementation -
16:52:46 <asomya> Sukhdev: This is outside of Neutron, development is independent. we can talk a bit about API refinement etc in the late-cycle
16:54:00 <Sukhdev> asomya: so, this is not really targeted to be implemented in the sprint then, right? just for the discussion - am I getting it right?
16:54:08 <asomya> Sukhdev: correct
16:54:34 <Sukhdev> asomya: thanks - this clears my confusion
16:55:05 <Sukhdev> rkukura: so, you can update the etherpad accordingly so that people have right expoctation
16:55:16 <rkukura> ok
16:55:24 <Sukhdev> anything else on this topic?
16:55:47 <Sukhdev> asomya shivharis: Thanks
16:55:55 <banix> does this relate to metering monitoring efforts?
16:56:05 <banix> already being undertaken
16:56:13 <Sukhdev> banix: no
16:56:22 <banix> I mean there are coceptually similar
16:56:23 <Sukhdev> banix: I do not think so
16:56:36 <banix> s/there/they/
16:57:18 <Sukhdev> banix: I would say - metering will query information from the known components - physical topology will discover components
16:57:27 <Sukhdev> banix: for a lack of better words
16:57:38 <banix> Sukhdev: i see. thanks.
16:58:16 <Sukhdev> physical topology helps you discover how your DC topology looks like so that you can make placement decisions
16:58:41 <Sukhdev> once the VMs are placed, then metering kicks in to monitor how they are performing
16:58:52 <shivharis> time check, 2 mins
16:58:56 <Sukhdev> banix: hope this helps
16:59:05 <Sukhdev> shivharis: thanks
16:59:11 <banix> well, i have to learn more about the proposed project; i see convergence with discovery/monitoring of virtual resources…. but i am probably off the tracks
16:59:13 <Sukhdev> #topic: Ironic Discussion
16:59:21 <Sukhdev> I will be short and sweet -
16:59:43 <amotoki> banix: perhaps it is about network topolgy about virtual reosurces, ie tenants.
16:59:51 <Sukhdev> For those who do not know - there is a lot of work going on in the Ironic/ML2/Neutron integratipon
17:00:28 <banix> Sukhdev: what’s the best way of tracking that work/ learn about them
17:00:43 <amotoki> Sukhdev is making great work.
17:00:43 <Sukhdev> since we are out of time - let me post the link so that you can discover/read on your own
17:00:56 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron
17:01:17 <banix> Sukhdev: thanks
17:01:26 <Sukhdev> banix: the meetings take place every monday at 9am (PT) at #openstack-meeting-4 - please come join us
17:01:49 <Sukhdev> amotoki is one of the active reviewer of the work being done there
17:02:05 <banix> Sukhdev: will try to attend
17:02:29 <Sukhdev> The idea is that ML2 drivers should be able to deal with VMs as well bare metal deployments
17:02:39 <Sukhdev> we are out of time folks
17:02:47 <Sukhdev> thanks for attending the meeting
17:02:54 <Sukhdev> have a wonderful day
17:02:54 <banix> bye
17:02:56 <yamamoto> bye
17:02:59 <Sukhdev> #endmeeting