16:11:20 <rkukura> #startmeeting networking_ml2
16:11:21 <openstack> Meeting started Wed Aug 12 16:11:20 2015 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:11:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:11:25 <openstack> The meeting name has been set to 'networking_ml2'
16:11:51 <rkukura> Hi ML2’ers - only a few of us here todays, so most likely a short meeting
16:12:10 <rkukura> #topic Agenda
16:12:30 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_August_12.2C_2015
16:13:06 <rkukura> Lets ignore the agenda and just hit any topics anyone wants to discuss today.
16:13:12 <rkukura> Any objections?
16:13:27 <rkukura> #topic Announcements
16:13:53 <rkukura> Only announcement that I have is that the Tokyo summit hotel registration has been openned.
16:14:22 <rkukura> #link https://www.openstack.org/summit/tokyo-2015/tokyo-and-travel/#hotels
16:14:28 <sadasu> rkukura: and they are almost gone too :-)
16:14:58 <rkukura> sadasu: I noticed that too when I booked yesterday. I was only able to get a room in the Shinagawa.
16:15:49 <sadasu> so, those who are planning to attend, book your hotels soon!
16:15:51 <rkukura> I contacted the OpenStack event mgmt people, and they did not seem to think everything should already be booked, so maybe its a glitch.
16:16:02 <rkukura> Any other annoucements?
16:16:49 <rkukura> #topic Open Discussion
16:17:05 <rkukura> yamamoto: Would you like to discuss the bug you mentioned?
16:17:21 <yamamoto> sure
16:17:40 <yamamoto> i filed a bug for subnetcontext issue discussed in the prev meeting
16:17:43 <yamamoto> #link https://bugs.launchpad.net/neutron/+bug/1481882
16:17:43 <openstack> Launchpad bug 1481882 in neutron "ML2 SubnetContext lacks network info" [Undecided,New]
16:17:43 <uvirtbot> Launchpad bug 1481882 in neutron "ML2 SubnetContext lacks network info" [Undecided,New]
16:17:44 <uvirtbot> Launchpad bug 1481882 in neutron "ML2 SubnetContext lacks network info" [Undecided,New] https://launchpad.net/bugs/1481882
16:18:38 <rkukura> yamamoto: Have you looked into the fix for this? Is it simply a matter of duplicating the code that’s used for PortContext?
16:18:57 <yamamoto> i haven't looked into the fix yet.
16:19:00 <yamamoto> #link https://review.openstack.org/#/c/211467/
16:19:13 <yamamoto> here's a midonet patch which would use subnetcontext.network
16:19:55 <yamamoto> joe (author of the patch) will submit ml2 patch shortly i guess.
16:20:17 <rkukura> OK, great! I’d like to see that get into liberty-3 if possible.
16:20:34 <iymht> Hi. connection is messy.
16:20:54 <iymht> Is there any poc code for task flow available?
16:21:01 <rkukura> I don’t think there should be any impact on existing mechanism drivers. Does anyone else have concerns with this?
16:21:13 <iymht> If available, I'd like to play with it.
16:21:48 <rkukura> iymht: Yes, there was a WIP patch a while back.
16:22:26 <iymht> rkukura: cool.
16:22:28 <rkukura> Its probably expired, but you should be able to find links to it in the old meeting agendas.
16:22:46 <iymht> I'll check it.
16:23:08 <rkukura> iymht: Are you considering joining the late/pre cycle to work on this?
16:23:23 <iymht> Now there is a discussion on if ODL mech driver should continue to ML2 mech driver or independent plugin.
16:23:33 <iymht> rkukura: Yes, considering.
16:24:03 <rkukura> iymht: Is TaskFlow/sync/async central to that discussion?
16:24:04 <iymht> So I'd like to push task flow effort cailming to stay in ML2.
16:24:56 <rkukura> iymht: Would you consider discussing ODL’s needs at next week’s ML2 meeting?
16:25:26 <iymht> rkukura: no. Only I am aware of task flow effort. So I should explain the current situation.
16:25:50 <rkukura> iymht: OK
16:25:55 <yamamoto> talking about monolithic vs ml2...
16:25:55 <iymht> There is a IRC meeting on Friday, you may want to attend it.
16:26:10 <yamamoto> is there any plan to improve sg api for ml2?
16:26:41 <rkukura> iymht: Can you provide details on that IRC meeting? Is it a regularly scheduled meeting?
16:26:59 <iymht> googling now. the network is slow...
16:27:09 <rkukura> yamamoto: The SG support in ML2 is something I’d hope we could work on for Mitaka
16:27:25 <iymht> https://wiki.opendaylight.org/view/Meetings#Neutron_Northbound
16:28:09 <iymht> armand and others are leading the discussion.
16:28:19 <iymht> Oh, I have to stop wifi. need to drop.
16:28:22 <iymht> landing
16:28:27 <iymht> sorry for dropping
16:28:35 <rkukura> iymht: Thanks - will try to attend
16:29:09 <rkukura> yamamoto: Should we put SG API on the agenda for an upcoming ML2 meeting?
16:29:34 <yamamoto> sure.  let me add an item.
16:30:15 <rkukura> I’d like to start focusing these weekly meetings on specific goals for Mitaka, such as TaskFlow, SG API, …
16:31:02 <sadasu> rkukura:+1
16:31:10 <yamamoto> +1
16:31:11 <rkukura> Would anyone like to discuss anything else before we wrap up for today?
16:31:17 <yamamoto> nothing from me
16:32:27 <rkukura> #action rkukura and Sukhdev to re-organize weekly meeting agenda around goals for upcoming Mitaka cycle as well as anything needed to wrap up for liberty.
16:32:42 <rkukura> OK, thanks everyone!
16:33:20 <rkukura> #endmeeting