16:02:42 <rkukura> #startmeeting networking_ml2
16:02:43 <openstack> Meeting started Wed Sep 30 16:02:42 2015 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:46 <openstack> The meeting name has been set to 'networking_ml2'
16:02:49 <yamahata> hello
16:03:03 <rkukura> #topic Agenda
16:03:12 <Sukhdev_> kevinbenton: we are going to need you today in this meeting - to cover ML2 sprint next week
16:03:27 <rkukura> #link https://wiki.openstack.org/wiki/Meetings/ML2#Meeting_Sept_30.2C_2015
16:03:59 <rkukura> Would anyone like to add/remove anything to/from today’s agenda?
16:05:13 <rkukura> Some of these items have been queued up for a while, so I’m glad to see shivharis, scheuran, and others here today for some updates
16:05:24 <rkukura> OK, lets move on
16:05:31 <rkukura> #topic Announcements
16:05:45 <rkukura> Congrats to armax, our new neutron PTL!
16:05:57 <rkukura> He’s not here, but sometimes lurks in these meetings
16:06:02 <shivharis> armax: congrats!
16:06:12 <rkukura> And many thanks to mestery!
16:06:16 <Sukhdev_> and a huge thank you to mestery
16:06:46 <rkukura> Hopefully everyone (especially those attending) is aware our ML2 pre-cycle sprint is next week at Yahoo!
16:07:22 <rkukura> Because of that, I’m thinking we should skip next weeks regular ML2 IRC meeting.
16:07:29 <rkukura> Any objections to that?
16:08:21 <rkukura> #action rkukura to update agenda skipping next week’s meeting
16:08:32 <rkukura> Any other annoucements?
16:09:11 * rkukura needs to learn to type
16:09:23 <Sukhdev_> Liberty-RC1 is out and RC2 in the oven
16:09:23 <rkukura> #topic ML2 pre-cycle sprint
16:09:29 <rkukura> #undo
16:09:30 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9afcf90>
16:09:40 <rkukura> Sukhdev: thanks
16:10:05 <rkukura> #topic ML2 pre-cycle sprint
16:10:40 <rkukura> #link https://etherpad.openstack.org/p/Neutron_ML2_Mid-Cycle_Sprint
16:11:09 <rkukura> The above link has the most up-to-date info, and any updates will be made there
16:12:26 <rkukura> Looks like we are expecting /me, manishg, harlowja, Sukhdev_, kevinbenton, shivharis, and yamahata to attend in person
16:12:40 <shivharis> rkukura: just curious, what would be the success criteria of the sprint?
16:12:44 <rkukura> Are any others planning to attend either in person or remotely?
16:12:52 <shivharis> rkukura: what are must do's
16:13:08 <yamahata> Yalei and Rui  are planning to attend it remotely
16:13:21 <yamahata> I'm not sure what time they can attend due to timezone, though.
16:13:31 <rkukura> shivharis: My take on that is to come out with a concrete plan for asnyc backend synchronization for ML2 in Mitaka
16:13:47 <shivharis> rkukura: +2
16:14:22 <rkukura> yamahata: Lets followup on the remote attendance via email and see if we need to set anything up
16:14:24 <yamahata> networking-odl has several requirement for backend sync.
16:14:45 <yamahata> rkukura: sure.
16:15:05 <shivharis> any new doc on async that we should have read thoroughly
16:15:17 <rkukura> So we need to get a clear statement of the agreed requirements, evaluate various design options, and hopefully get some prototype code started
16:16:20 <rkukura> shivharis: I’m not aware of anything new, but would encourage everyone attending to refresh their memory on the existing docs and PoC patch linked from the etherpad.
16:16:32 <shivharis> ok
16:17:29 <rkukura> I’d also encourage putting some thought into the requirements and the design options beyond what has already been documents.
16:18:13 <rkukura> Any other questions, comments, concerns, etc., regarding the sprint next week?
16:19:14 <rkukura> Feel free to put thoughts into writing (etherpads, google slides or docs, whatever) or be prepared to whiteboard ideas
16:19:42 * rkukura looks forward to seeing everyone next week!
16:19:47 <rkukura> Anything else on the sprint?
16:19:57 <rkukura> if not, …
16:20:17 <rkukura> #topic Mitaka Design Summit proposals for ML2
16:20:33 <rkukura> #link https://etherpad.openstack.org/p/neutron-mitaka-designsummit
16:21:23 <rkukura> Lets make sure anything anyone feels should get into ML2 during Mitaka is covered on the list I linked above
16:21:56 <rkukura> Does anyone know when/how armax plans to pair this down to a set of sessions?
16:22:18 <armax> rkukura: I’ll be working on those this week and post notes shortly after
16:22:22 <armax> rkukura: bear with me
16:22:41 <rkukura> armax: Thanks
16:24:04 <rkukura> armax: I think the main ML2 items are async, drivers+SGs, and modular L2, so please let us know if you are on the fence about including any of these.
16:24:20 <rkukura> I meant modular L2 agent
16:24:54 <armax> rkukura: ok, as usual the balance to what goes in the summit and doesn’t is always tricky due to shortage of time
16:25:16 <rkukura> armax: Of course many of the other suggested topics impact ML2 as well.
16:25:23 <armax> rkukura: if not all
16:25:47 <armax> one way or another
16:27:38 <rkukura> armax: Feel free to check in on progress at the sprint next week, and see if these topics (async mainly) will need discussion at the summit
16:27:47 <rkukura> Anything else on the summit topics?
16:28:39 <rkukura> #topic Driver API for SGs
16:28:41 <armax> rkukura: ok, thanks for the heads-up
16:28:54 <rkukura> yamamoto_: Do you have any update on this?
16:29:15 <yamamoto_> no progress or updates, sorry
16:30:12 <rkukura> I’m sure there will be some discussion of this at the sprint next week, so maybe we can followup on that at the next IRC meeting
16:31:06 <rkukura> #topic Modular L2 Agent and macvtap
16:31:15 <rkukura> scheuran: Do you have an update on this?
16:31:22 <scheuran> not much
16:31:36 <scheuran> we were producing a number of patchsets to figure out which way to go
16:31:47 <rkukura> or sc68cal
16:31:54 <scheuran> but we still need to sort it out and structure it a bit
16:32:21 <scheuran> I'll try to meet with sc68cal this week to come to first proposal
16:32:36 <rkukura> OK, great
16:32:52 <scheuran> and figure out which refactorings make sense and which not
16:33:21 <rkukura> scheuran: Thanks
16:33:30 <rkukura> Anything else on this?
16:33:40 <scheuran> yeah, maybe one question
16:33:48 <rkukura> sure
16:34:16 <scheuran> was the modular agent planned as an agent with a single plugin (like neutron)
16:34:37 <scheuran> or more something like the ml2 plugin where you can plugin multiple drivers in parallel?
16:35:39 <shivharis> are you going to support multiple hypervisors at the same time?
16:35:51 <rkukura> scheuran: Are there use cases for multiple drivers to work together? Or maybe different kinds of drivers for different purposes?
16:36:04 <scheuran> shivharis, what do you mean by multiple hypervisors?
16:36:18 <scheuran> rkukura, not for macvtap and linuxbridge
16:36:31 <scheuran> but maybe sriov and linuxbridge or sriov and macvtap
16:37:05 <scheuran> not sure if anyone does this, but theoretically it's possible
16:37:22 <shivharis> maybe i misunderstood the point of multiple driver - never mind
16:37:44 <scheuran> as sriov ports are requested with a vnic type =! normal, linuxbridge and macvtap port with vnictype normal
16:37:44 <rkukura> It probably makes sense to support multiple drivers, unless that makes things much more difficult
16:38:27 <scheuran> rkukura, I think it will make things more complex, but I need to have a look what it means
16:38:38 <rkukura> scheuran: OK
16:38:43 <scheuran> ok thanks
16:38:43 <rkukura> Anything else on this?
16:38:47 <scheuran> no
16:39:08 <rkukura> #topic Physical Topology
16:39:18 <rkukura> shivharis: Do you have an update?
16:39:24 <shivharis> sure
16:40:29 <shivharis> Since prior proposals for toplogy discovery seem to have issues
16:41:15 <shivharis> I started to leading the push for a fresh start on this, the flaws that i saw in proposals was related to very close dependecy on neutron
16:41:28 <shivharis> so this new proposal removes that from the equation
16:42:12 <shivharis> asomya and gkotton have been discussing this and have a proposal in place (and some code)
16:42:38 <shivharis> I will share the document to the folks prior to the sprint and we can have a go at it
16:43:08 <shivharis> in short we use a modular approach - with possible driver for
16:43:20 <shivharis> lldp, cdp, bgp and arp
16:43:37 <rkukura> shivharis: Are there competing proposal at this point or are you, asomya, and gkotton on the same page?
16:44:02 <shivharis> no this is one proposal from the 3 of us.
16:44:24 <Sukhdev_> shivharis: are you presenting this at the summit?
16:44:32 <rkukura> shivharis: Is it for a service plugin within neutron or a new standalone service?
16:44:44 <Sukhdev_> shivharis: in design session or regular session?
16:45:01 <shivharis> we have put this on agenda for neutron design session and gary is planning this for nova
16:45:24 <shivharis> this is essentially a standalone service
16:45:54 <shivharis> but we need to start somewhere and begin to socialize it
16:46:31 <shivharis> i will discuss this in the sprint as well
16:46:34 <Sukhdev_> yes, this will be very useful for both nova and neutron
16:46:39 <Sukhdev_> and Ironic as well
16:47:16 <shivharis> right Sukhdev, there are many consumers as you described - also add to it heat
16:47:45 <shivharis> that is all i have for now, will discuss more in the sprint
16:47:54 <rkukura> shivharis: thanks!
16:48:06 <rkukura> Any quesitons or comments on this?
16:48:21 <rkukura> If not…
16:48:23 <Sukhdev_> looking forward to the details -
16:48:31 <rkukura> Sukhdev_: +1
16:48:38 <shivharis> ok
16:48:44 <rkukura> #topic Open Discussion
16:48:59 <Sukhdev_> manishg is here to discuss the logistics for the sprint
16:49:08 <Sukhdev_> manishg: please go ahead
16:49:10 <manishg> Sukhdev_: sorry missed your ping earlier.
16:49:20 <rkukura> manishg: please, go ahead
16:49:24 <Sukhdev_> kevinbenton: are you here?
16:49:40 <manishg> The address etc. are on the etherpad.  Once you show up please call me.  My phone number on etherpad too
16:49:44 <manishg> or the receptionist will do.
16:50:04 <manishg> Are there specifics about the venue, etc. that folks have questions about?
16:50:06 <shivharis> for the task flow - i still feel as before - we need to get  a state transition diagram to make this design stick
16:50:32 <manishg> shivharis: are you planning to attend?
16:50:45 <shivharis> manishg: you bet
16:50:57 <manishg> I think if we go with states, we'll need some state table.
16:51:17 <manishg> depending on the complexity, a diagram may also be needed
16:51:35 <rkukura> manishg: Can we assume plenty of whiteboard space?
16:51:52 <manishg> rkukura, yes. plenty of white board space
16:52:05 <manishg> I'll order more (portable ones) today!
16:52:13 <manishg> just in case we need more...
16:52:17 <Sukhdev_> manishg: if we can have some prep work done, it will make the discussions more productive
16:53:04 <manishg> Sukhdev_ : who are the key folks leading?
16:53:30 <manishg> I thought asoumya was interested in last summit, is he able to join?
16:53:37 <Sukhdev_> manishg: I am looking at you and Josh to lead the task flow discussion
16:53:53 <rkukura> manishg: asomya is interested but not able to attend
16:53:59 <manishg> Taskflow part will be fine I think.  But there are decisions need to be made from ML2 side.
16:54:00 <Sukhdev_> manishg: Hence, a bit of prep work go long ways
16:54:27 <rkukura> I’ve been encouraging everyone to think about the requirements and the design options
16:54:34 <manishg> I think a lot of prep work was done and still out there.  Is there any more update on it?
16:54:49 <rkukura> And to re-read what’s already been written.
16:54:53 <manishg> I think some good discussions happened.  and options documented.
16:55:01 <manishg> rkukura: +1
16:55:15 <Sukhdev_> Our goal for the sprint should be to achive concensus on ML2 sync using task flow
16:55:30 <manishg> it's been a while.  So I think to make it more productive we should be well aware of previous discussions.
16:55:40 <rkukura> manishg, others: Would be good to know who is committed to working on the implementation during Mitaka
16:56:16 <manishg> rkukura: I think once we finalize the design, etc. the effort will be clear and folks can commit then.
16:56:29 <manishg> as the amount of work may depend on the final decisions.
16:56:35 <rkukura> manishg: agreed
16:56:54 <Sukhdev_> everybody - please read this as well - https://docs.google.com/document/d/17fATwZkJEonH0pIb1-mPD0UB5RKnJzcHYqkBesJhirE/edit#bookmark=id.5axbk82zh7nb
16:57:08 <manishg> So I think it would be good to document the main problem, possible solutions and discussion around the selected solutin.
16:57:15 <Sukhdev_> this articulates the ML2 sync requirements
16:57:21 <rkukura> Sukhdev_: that doc is linked on the etherpad
16:57:33 <manishg> Sukhdev_ : thanks.
16:57:54 <rkukura> Lets start with a brainstorming a list of the requrement on the whiteboard, and then trying to identity the must-haves, nice-to-haves, etc.
16:58:01 <manishg> all the attendees should please read this, the patch, and also think about other potential issues.
16:58:17 <manishg> Sukhdev_ : did you have any other prep work in mind?
16:58:28 <manishg> I think this will be a good start.
16:58:47 <rkukura> We’ve got 2 minutes left
16:59:01 <rkukura> Any other questions regarding the logistics for next week?
16:59:26 <Sukhdev_> manishg: essentially a refresher or any diagram what shivharis was elluding to - basically, anything that will help people converge quicky
16:59:35 <rkukura> manishg: Please add your phone # to https://etherpad.openstack.org/p/Neutron_ML2_Mid-Cycle_Sprint if that’s the best way to contact you when we arrive.
17:00:09 <manishg> rkukura: done
17:00:14 <rkukura> We are out of time
17:00:18 <rkukura> Thanks everyone!
17:00:23 <Sukhdev_> Thanks everybody
17:00:23 <manishg> thanks!
17:00:27 <rkukura> #endmeeting