16:03:53 <rkukura> #startmeeting networking_ml2
16:03:54 <openstack> Meeting started Wed Dec 16 16:03:53 2015 UTC and is due to finish in 60 minutes.  The chair is rkukura. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:58 <openstack> The meeting name has been set to 'networking_ml2'
16:04:14 <rkukura> #topic Agenda
16:04:18 <rkukura> #link https://wiki.openstack.org/w/index.php?title=Meetings/ML2&action=edit&section=2
16:04:27 <rkukura> Anyone want to add anything to the agenda?
16:04:51 <rkukura> #topic Announcements
16:05:09 <yamamoto> hi
16:05:41 <rkukura> Sukhdev is is out next two weeks, and I’m out the week after next, so no meeting on 12/30
16:05:56 <rkukura> quick poll - do we want to meet next week, 12/23?
16:06:15 <pc_m> I'm on PTO
16:06:17 <yamamoto> i'll be absent
16:06:32 <yamahata> will be absent
16:06:56 <rkukura> OK, we won’t meet 12/23 or 13/30!
16:07:04 <rkukura> Any other announcements?
16:07:30 <scheuran> will be absent as well
16:08:06 <rkukura> #action rkukura to update agenda indicating no meetings until 2016
16:08:30 <rkukura> #topic Driver API for SecurityGroup
16:08:58 <rkukura> yamamoto: Looks like the enforcement part of this was rejected by neutron-drivers, at least for now
16:09:26 <yamamoto> yea i saw it
16:10:09 <rkukura> yalie, yamamoto: What’s the status on the callbacks part?
16:10:27 <yalie> rkukura: I think callback work fine
16:10:41 <rkukura> OK
16:10:44 <yamahata> https://review.openstack.org/#/c/252755/
16:10:58 <yalie> rkukura: it could give the function that similar with precommit in MD
16:11:46 <rkukura> On the enforcement part, I plan to folowup in https://bugs.launchpad.net/neutron/+bug/1518087 to make the case that a general extension semantics enforcement mechanism is needed, but I doubt this will happen in mitaka.
16:11:46 <openstack> Launchpad bug 1518087 in neutron "[RFE] Method to guarantee that at least one mechanism driver implements security groups" [Wishlist,Won't fix] - Assigned to yalei wang (yalei-wang)
16:11:51 <rkukura> yalie: thanks
16:12:45 <rkukura> Anything else on SGs?
16:13:06 <yalie> rkukura: great, I will continue watch this part
16:13:18 <rkukura> #topic Driver status coalescing/visibility
16:13:54 <yamahata> no update from me
16:14:15 <rkukura> yamahata: thanks. I haven’t heard from asomya or John Joyce yet either
16:14:37 <rkukura> I’d like to see some discussion get started on this, even if its not going to make mitaka
16:15:07 <rkukura> #topic Trunk port binding for VLAN-awere VMs
16:16:15 <rkukura> From the neutron IRC, it sounds like the API for this has been agreed, and it will move forward during mitaka
16:16:48 <rkukura> Any update on this?
16:17:13 <rkukura> Has anyone given any thought to the ML2 portbinding aspect yet? I have not had a chance, but will.
16:17:53 <rkukura> OK, lets move on...
16:18:04 <rkukura> #topic Modular l2 agent & macvtap
16:18:24 <rkukura> scheuran: This seems to be coming along - any update?
16:18:31 <scheuran> not much progress this week
16:18:47 <scheuran> still waiting for the extension manager stuff to move in https://review.openstack.org/250542
16:19:04 <scheuran> I'm confident that we can land it this week
16:19:32 <rkukura> scheuran: I’ll re-review
16:19:50 <scheuran> it would be helpful if you guys could have a look at the linuxbride split patch
16:19:51 <scheuran> https://review.openstack.org/#/c/246318/
16:20:04 <scheuran> especially at the interface between the common part and the linuxbridge impl
16:20:13 <rkukura> scheuran: I see that one is still WIP
16:20:36 <rkukura> and may be having CI issues
16:20:38 <scheuran> yes, I put it to WIP, as I need to rebase it on top of the extension manager thing after that merged
16:21:05 <scheuran> The CI issues are really strange
16:21:12 <rkukura> scheuran: I’d suggest removing the WIP so that it gets more reviewer attention
16:21:27 <scheuran> it's either an ovs test case that's failing or the grenade job...
16:21:35 <scheuran> rkukura, ok
16:21:49 <rkukura> scheuran: Are these CI failures related to the agent changes?
16:22:19 <scheuran> rkukura, no should not! but it makes me thinking, that after 5 rechecks I still have failures...
16:24:00 <scheuran> ok, so I will do another recheck, and remove the WIP as soon as I got an ok from jenkins
16:24:16 <rkukura> scheuran: Sounds good. I’ll re-review.
16:24:28 <rkukura> Anything else on this?
16:24:37 <scheuran> rkukura, I think it's sufficient to focus on the interface for now
16:24:40 <scheuran> rkukura, no, thanks!
16:25:18 <rkukura> I don’t see shivharis or asomya, so I think we’ll skip topology service once again
16:25:37 <rkukura> #topic limited-portsec Discussion
16:26:29 <yalie> this feature is pending on the direction
16:27:11 <yalie> it's difficult to handle with the dependency btween extension, portsec and limited-portsec
16:27:45 <rkukura> yalie, ajo: Do you want to discuss this now?
16:27:54 <yalie> my current work is do all the check in new limited-portsec, but that will also touch the portsec's code
16:28:10 <yalie> yes
16:28:44 <rkukura> yalie: Is that the code currently under review?
16:28:52 <yalie> yes
16:29:25 <yalie> it's a draft code.
16:30:07 <yalie> and ajo has comments on the direction.
16:30:26 <yalie> I think I serach for the wrong name mangelajo.
16:30:52 <yalie> we can discuss off line
16:31:28 <rkukura> yalie: Makes sense, especially since ajo doesn’t seem to be responding now
16:31:40 <rkukura> This one is on my to-review list as well
16:31:41 <yalie> rkukura: okay
16:31:52 <yalie> rkukura: thank you!
16:32:02 <rkukura> Anything else on limited-portsec?
16:32:23 <rkukura> moving along quickly today…
16:32:25 <yalie> rkukura: I have submit searveal patches for it, but because it break compatible I abandone them
16:32:52 <yalie> rkukura: any comments would be appreciated
16:33:30 <rkukura> yalie: OK - I had been loosely following the discussion on the earlier patches, and will review this one in detail
16:33:40 <rkukura> #topic Open Discussion
16:33:42 <yalie> rkukura: thanks!
16:35:30 <rkukura> I’m sure sukhdev would appreciate a reminder to review https://review.openstack.org/#/c/255614/, which I have not personally gotten around to yet
16:36:06 <rkukura> Is Mitchell Jameson here?
16:36:57 <rkukura> Anything to discuss today, or are we done?
16:37:35 <scheuran> nothing from my side
16:37:39 <rkukura> lets wrap it up then…
16:38:00 <rkukura> Enjoy the holidays and time off, and see you all next year!
16:38:05 <rkukura> #endmeeting