14:01:13 <haleyb> #startmeeting networking-ovn
14:01:14 <openstack> Meeting started Tue Jul  9 14:01:13 2019 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <openstack> The meeting name has been set to 'networking_ovn'
14:01:21 <mlavalle> o/
14:01:25 <haleyb> #chair tidwellr
14:01:25 <lajoskatona> o/
14:01:25 <openstack> Current chairs: haleyb tidwellr
14:01:27 <tidwellr> o/
14:01:41 <haleyb> #chair lucasgomes
14:01:46 <openstack> Warning: Nick not in channel: lucasgomes
14:01:47 <openstack> Current chairs: haleyb lucasgomes tidwellr
14:02:03 <haleyb> hi everyone
14:02:10 <haleyb> #topic Announcements
14:02:11 <bcafarel> hey
14:03:19 <haleyb> first i'd like to thank everyone for coming and having an interest in ML2-OVS-DVR/OVN convergence!
14:03:21 <njohnston> o/
14:03:47 <tidwellr> say that 3 times fast ;)
14:04:12 <haleyb> second, i need to make this a short meeting today as we have a company meeting in :27, need to meet the new owners :)
14:04:27 <mlavalle> the new owners are important
14:05:46 <mlavalle> is the merger finalized now?
14:05:51 <haleyb> So logistically this meeting will just be once a month, i'll verify the .ics is correct later, but if we need to make it more often it should be easy enough
14:06:02 <haleyb> mlavalle: yes, closed this morning
14:06:10 <mlavalle> ahhh, congrats
14:06:52 <haleyb> thanks
14:07:16 <mlavalle> https://www.wsj.com/articles/ibms-biggest-purchase-ever-has-high-stakes-for-rometty-11562676754?mod=hp_lista_pos3
14:08:17 <haleyb> #topic ML2-OVS-DVR/OVN convergence
14:08:45 <haleyb> i'm assuming everyone has read the draft, https://review.opendev.org/#/c/658414/
14:10:17 <haleyb> IMO, the goal of these meetings should be to discuss a few things
14:10:23 <haleyb> #1 - the gaps
14:11:08 <haleyb> in addition to the ones in the doc, there will continue to be more as Neutron moves forward
14:11:42 <haleyb> for example, the ethertypes support Nate is adding
14:12:09 <mlavalle> yeah, it's a moving target
14:12:22 <tidwellr> agreed
14:12:47 <haleyb> I was going to nominate myself to keep track of such things, and try to work in parallel to keep OVN "in sync"
14:13:23 <haleyb> i will add them to the etherpad
14:13:28 <mlavalle> I need to learn OVN but as I become more proficient, I'll be more than happy to help on the OVN side
14:13:44 <haleyb> https://etherpad.openstack.org/p/networking-ovn
14:14:13 <tidwellr> is there a way for the networking-ovn-tempest-dsvm-ovs-release to flag things ie skipped tests
14:14:16 <tidwellr> ?
14:14:20 <slaweq> hi, sorry for being late
14:15:16 <tidwellr> just thinking out loud, I wonder if we could piggyback on automation somehow to be able to get a picture of where things stand
14:15:53 <haleyb> tidwellr: that's a good question, i believe there is would just need to make a note on how to do it
14:16:07 <mlavalle> great suggestion
14:16:22 <haleyb> tidwellr: or are you asking about CI status for OVN in general?
14:17:20 <mlavalle> couldn't this be done by running some of the aghents based implementation jobs in OVN?
14:17:33 <slaweq> tidwellr: most of tempest tests have got some extensions required so if there is no extension in the tempest config, test will be skipped
14:17:34 <mlavalle> against OVN, I meant
14:17:59 <slaweq> tidwellr: but we can send DNM patch with same extensions list as we are using in neutron_tempest_plugin dvr multinode job
14:18:09 <slaweq> and then check what tests are failing there
14:18:12 <tidwellr> because "parity" is a moving target, I was just suggesting that neutron/networking-ovn CI results could probably gives us some feedback on status
14:18:28 <tidwellr> slaweq: that's what I was thinking
14:18:28 <slaweq> when we will rebase this patch we can see progress and what gaps we still have
14:18:37 <slaweq> I can proposed such patch if You want
14:18:43 <slaweq> *I can propose
14:19:19 <haleyb> slaweq: thanks, it makes sense now, since we are skipping the things we don't support in OVN
14:19:44 <slaweq> ok, I will propose such DNM patch in networking-ovn repo
14:19:54 <mlavalle> yeap
14:20:06 <mlavalle> it has to be done in the ovn repo
14:21:01 <slaweq> #action slaweq to send DNM patch with CI job to check feature gaps between ovn and ml2/ovs-dvr
14:22:05 <haleyb> great, we can work off that and have owners assign themselves
14:22:47 <mlavalle> yes
14:23:20 <tidwellr> +1
14:24:38 <haleyb> in addition to that, i'd like to look into the future, there's a few things on my list...
14:25:01 <haleyb> first is to create a job in the devstack repo for OVN
14:26:11 <haleyb> it would both serve to see when it gets broken, and hopefully lead to easier stacking with it
14:26:52 * haleyb is at his time deadline
14:27:15 <haleyb> tidwellr: if you want to continue i had added you as chair
14:27:16 * bcafarel suspects a few attendees have similar deadline
14:28:01 <haleyb> #action haleyb to update etherpad with notes discussed here
14:28:08 <tidwellr> this is a good start
14:28:50 <tidwellr> my next topic would be performance and scalability, but it's a little early for that
14:29:10 <haleyb> if we have to we can meet again in 2 weeks as we should decide if the review is enough to get started and merge it, or if there's something missing
14:30:12 <tidwellr> after today I'm thinking every 2 weeks makes sense
14:30:49 <tidwellr> a lot is going to get lost over the next 4 weeks, my $0.02
14:32:06 <mlavalle> ++
14:33:05 <haleyb> the other thing i wanted to discuss was to make sure by the end of the Train cycle we are in a place where we potentially could change the default - more akin to make sure there's not some small change we can make now in that regards, something that isn't back-portable
14:34:34 <haleyb> we can discuss that in two weeks...
14:35:02 <haleyb> i have to go, meeting has started...
14:35:26 <tidwellr> thanks haleyb
14:35:32 <haleyb> thanks for attending, i'll update the invite to be every two weeks since this was so short
14:35:43 <haleyb> #endmeeting