16:00:44 <mestery> #startmeeting networking_policy
16:00:45 <openstack> Meeting started Thu Jan 16 16:00:44 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <openstack> The meeting name has been set to 'networking_policy'
16:00:55 <mestery> #link https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy Agenda
16:01:03 <banix> Hi everybody
16:01:07 <s3wong> Hello
16:01:15 <mestery> We'll wait a minute or two to gather everyone.
16:01:21 <mestery> banix s3wong: Howdy!
16:01:33 <ashaikh> hi guys
16:01:38 <nam_nguyen> Hi all
16:01:41 <songole> Hi all
16:01:54 <prasadv> hello
16:02:18 <mestery> So, we have a short agenda for today.
16:02:37 <mestery> The main thing I wanted to discuss was the PoC, which we started talking about last week.
16:02:41 <mestery> #topic Group Policy PoC
16:02:58 <mestery> #link https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy Neutron Group Policy PoC Document
16:03:01 <alagalah> Good morning all
16:03:06 <mestery> alagalah: Morning!
16:03:17 <mestery> I don't think the document has changed much.
16:03:35 <mestery> But the small subset of us who volunteered to work on the PoC have been discussing over email how to divide the work up.
16:04:06 <banix> I just added the Heat work item; That's all.
16:04:13 <mestery> banix: Thanks!
16:04:14 <alagalah> Count me in
16:04:34 <mestery> So really, we have a high level plan. I think we should put names by the tasks as we discussed.
16:04:57 <mestery> alagalah: Awesome, glad to have you onboard!
16:05:07 <s3wong> mestery: haven't seen your reply - have we finalized on who is doing what?
16:05:09 <alagalah> mestery:  I live to serve :)
16:05:35 <mestery> s3wong: I think there are a few details left, for instance, I don't know if anyone signed up to implement the new extension APIs for GRoup Policy.
16:05:40 <mestery> s3wong: Did you claim that item?
16:05:43 * mestery forgets.
16:05:46 <s3wong> mestery: sure
16:06:08 <mestery> Cool! Can folks who have signed up put their names by the tasks?
16:06:21 <mestery> Also, there was some discussion around coordinating this work.
16:06:26 <mestery> Logistically.
16:06:32 <mestery> s3wong and banix, you guys had some concerns here, right?
16:06:33 <s3wong> I also believe banix volunteered for ML2 driver part
16:06:44 <s3wong> mestery: yes
16:06:47 <banix> Mestery: Let's list the work items you had made
16:07:01 <s3wong> actually, rather, he volunteered for the ML2 plugin part
16:07:13 <songole> We will do the heat plugin
16:07:35 <mestery> songole: Excellent! If you need edit access to the google doc, let me know, but I think I added you there.
16:07:40 <banix> So the main items were: The Ml2 plugin part (I volunteered) which includes the driver I would think
16:07:56 <songole> mestery: Yes, I have access to it.
16:08:08 <s3wong> the extension APIs (which I volunteered)
16:08:15 <banix> The agent side that Mestery volunteered
16:08:26 <s3wong> and the OVS agent (which mestery volunteered)
16:08:35 * mestery nods in agreement.
16:08:41 <banix> and yes the s3wong for Tom Mathews
16:08:51 <banix> sorry ignore the last line
16:08:56 <hemanthravi> mestery: if you there are pieces on the agent side you want us to pick up, we can
16:09:28 <mestery> hemanthravi: OK, cool! Will coordinate with you folks.
16:09:39 <banix> the extension side that s3wong volunteered
16:09:59 <mestery> So, how much of this can we do in parallel?
16:10:17 <alagalah> The key will be not treading on each other's code
16:10:43 <songole> heat is independent and can go in parallel.
16:11:03 <s3wong> My part can be done rather independently - though Heat template would have the APIs as dependency
16:11:04 <banix> So may be we can nail down for the moment the API
16:11:29 <mestery> banix: Yes, good idea. That may be a first step.
16:11:33 <alagalah> I'd like to work with banix on the ML2 driver
16:11:50 <mestery> I can start looking from the agent side right away as well.
16:11:53 <banix> alagalah: Sounds good
16:11:59 <mestery> E.g. the flows we'll need to implement.
16:12:14 <mestery> Can someone refresh my memory on what we'll implement first? Was it security group like constructs?
16:12:38 <s3wong> mestery: for action - just action_type 'security'
16:12:48 <mestery> s3wong: Got it.
16:13:08 <s3wong> but endpoint, endpoint groups, policy, policy-rule will all be part of the PoC
16:13:23 <banix> s3wong: yes
16:14:05 <songole> s3wong: can we work on API proposal this week?
16:14:12 <mestery> OK, this is all good.
16:14:30 <banix> I will also implement the model (based on the model we have in the doc) so they are in code.
16:14:36 <s3wong> songole: of course
16:14:39 <mestery> banix: Awesome, thanks!
16:15:06 <songole> s3wong: thanks.
16:16:23 <mestery> OK, anything else to discuss at this meeting around the PoC?
16:16:33 <songole> I didn't see cli commands for classifier. I am hoping classifier is a neutron object and will have an API.
16:17:25 <banix> songole: yes, it's in the model I believe. What do you mean by cli?
16:17:37 <s3wong> songole: classifier is indeed a neutron object
16:17:38 <banix> we haven't defined the cli as such
16:18:08 <songole> banix: I meant REST API examples
16:19:30 <s3wong> songole: add/modify/delete classifier should be part of the APIs, we should finalize that this week as part of the API proposal
16:19:31 <banix> yes they are Neutron objects
16:20:04 <songole> s3wong banix: got it
16:20:08 * mestery nods in agreement with s3wong and banix.
16:21:14 <alagalah> banix:  I have a pretty full dance card today, want to get together tomorrow to flesh out the details?
16:21:34 <alagalah> banix:  We could do over email if more convenient?
16:21:44 <banix> alagalah: Sounds good.
16:21:45 <s3wong> I will work with the rest of the PoC team to get the first draft of API proposal done over the next week
16:22:15 <banix> s3wong: great
16:22:43 <s3wong> otherwise I wouldn't be able to code them anyway :-)
16:23:00 <banix> We will eventually need a central repository but that can wait for now.
16:23:07 <mestery> s3wong: :)
16:23:21 <s3wong> banix: Sure
16:23:23 <alagalah> Could we use a branch ?
16:23:23 <mestery> banix: Yes, it may get tricky there, we want to strike a balance on this work for sure.
16:23:42 <mestery> We could use a shared github for the work initially.
16:23:51 * alagalah unsure of protocol
16:24:01 <alagalah> mestery:  ok
16:24:01 <banix> mestery: I agree
16:24:02 <s3wong> mestery: are you going to set one up?
16:24:16 <mestery> s3wong: sure, I can take an action item to do that!
16:24:21 * mestery makes note of some action items now.
16:24:37 <banix> or github
16:24:41 <mestery> #action s3wong to work with the rest of hte PoC team to get first draft of API proposal out.
16:24:51 <mestery> #action mestery to setup shared github for PoC work
16:27:44 <mestery> #topic Open Discussion
16:27:49 <mestery> Anything else for this week?
16:28:23 <banix> Not here
16:28:29 <s3wong> all good for me
16:28:36 <alagalah> I think we have our marching orders
16:28:41 <mestery> :)
16:28:44 <mestery> OK, thanks folks!
16:28:48 <s3wong> another week of short meeting!
16:28:48 <mestery> Lets keep the momentum going!
16:28:52 <banix> thanks
16:28:53 <hemanthravi> thanks
16:28:56 <alagalah> thanks
16:28:57 <mestery> s3wong: I like short meetings :)
16:28:58 <songole> thanks
16:28:59 <s3wong> Thanks!
16:28:59 <mestery> #endmeeting