16:01:06 <mestery> #startmeeting networking_policy
16:01:07 <openstack> Meeting started Thu Jan 23 16:01:06 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:10 <openstack> The meeting name has been set to 'networking_policy'
16:01:18 <thinrichs> Hi
16:01:34 <mestery> thinrichs: Hows it going?
16:01:48 <mestery> hi banix!
16:01:49 <thinrichs> Good--busy as always.  How about you?
16:01:51 <mestery> michsmit: yo!
16:01:58 <mestery> thinrichs: Busy but happy :)
16:02:02 <banix> mestery: hi
16:02:03 <michsmit> hi
16:02:07 <banix> hi everybody
16:02:11 <mestery> #link https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy Agenda
16:02:13 <s3wong> hello
16:02:19 <mestery> s3wong: Greetings!
16:02:27 <songole_> Hi all
16:02:28 <mestery> Looks like we have most of the team here.
16:02:36 <mestery> songole_: howdy!
16:03:17 <mestery> #topic Action Item Review
16:04:04 <mestery> So, I setup a shared github for the PoC work for now.
16:04:16 <mestery> I was thinking we could just use a github and merge code there, and then formulate patches for upstream later.
16:04:17 <mestery> Thoughts?
16:04:28 <mestery> #link https://github.com/mestery/neutron/tree/group_policy Shared github repository
16:04:34 <s3wong> mestery: sounds good
16:04:35 <banix> mestery: Thanks. Sounds good.
16:04:44 <mestery> Cool!
16:04:48 <prasadv> mestery: that sounds good
16:04:59 <mestery> So, it's just a clone of upstream Neutron for now, next step is to get the APIs in there I think. :)
16:05:05 <mestery> One more action item to review
16:05:20 <mestery> Thanks to s3wong for setting up the API document
16:05:22 <mestery> #link https://docs.google.com/a/mestery.com/document/d/1b_ywmSTKYW4PBjhkXREPePRgVmz-Uwv_Bb-i7Jaqsu4/edit API Document
16:06:23 <mestery> So, review comments on that document appreciated by folks.
16:06:35 <s3wong> yes, please
16:07:06 <s3wong> and if anyone else wants editing right, please let me know as well (just send request via document)
16:07:13 <mestery> Thanks s3wong.
16:07:17 <mestery> #topic PoC
16:07:24 <mestery> s3wong: Do you have enough info to start coding up the APIs now?
16:08:02 <s3wong> mestery: yes, so I will be doing that over the next week or so
16:08:24 <mestery> s3wong: Great! I'll start looking at the agent side as well for actually implementing things in OVS as well.
16:08:36 <banix> I have *just* started coding the model (the db tables).
16:08:39 <s3wong> (hopefully, other than songole, everyone else can do their part without waiting on me to finish)
16:08:46 <songole_> s3wong: any access restrictions on APIs. admin vs tenant I suppose none.
16:09:08 <s3wong> songole: for now, I don't see any
16:09:23 <mestery> banix: Great! I'll start the agent stuff as well then.
16:09:34 <banix> looks like for now the policy is defined within a tenant
16:10:18 <banix> Is that right? Anything we need to do to have policies defined across tenants? Are we assuming the admin could do that
16:10:47 <prasadv> i think if keystone scoping allows then apis should be allowed right?
16:11:06 <songole_> A tenant could only specify an endpoint in his domain?
16:11:06 <s3wong> banix: I don't think there is anything we defined so far that is cross-tenant. Did I miss something?
16:11:09 <mestery> prasadv: I think that makes sense, in which case admin would be able to work across tenants through keystone
16:11:25 <banix> s3wong: you are correct
16:11:31 <banix> May be not right now but something to think about / discuss.
16:11:59 <thinrichs> Would there ever be a need for an admin to impose network-wide policies, i.e. that apply to every tenant?
16:12:02 <banix> prasadv, mestery: agree
16:12:20 <s3wong> I guess just "external network", if we put that into an endpoint group... (and expecting the group-policy implementation to say create a port on provider router)
16:12:38 <banix> yeah admin will be able to say see endpoints / groups defined by different tenants
16:12:40 <mestery> s3wong: Makes sense
16:13:54 <prasadv> i guess there could be an issue when there is a conflict between what admin configures and say another role restericted to tenant configures
16:14:27 <prasadv> which one takes precedence?
16:14:50 <mestery> prasadv: That gets into the conflict resolution stuff we talked about a few weeks back I think.
16:15:00 <banix> prasadv: So we had a simple conflict resolution mechanism
16:15:15 <banix> that should apply regardless of admin/tenant. Right?
16:15:28 <thinrichs> But I think prasadv brings up an interesting case.
16:15:32 <prasadv> ok. I am thinking this is more of authorization policy right?
16:15:43 <s3wong> prasadv: that is an interesting case - so admin has some security group setup, and tenant's policy conflict with it?
16:15:47 <thinrichs> We wouldn't want our admin to say 'drop', and the tenant to say 'allow', and for the tenant to win out.
16:15:56 <s3wong> I would guess in that case, admin will win?
16:16:10 <mestery> I think in this particular case, keystone policy would have to win out.
16:16:10 <thinrichs> s3wong: that's what we'd want, but right now there's no mechanism for that.
16:16:25 <prasadv> maybe this should be resolved by keystone and not by individual Openstack components
16:16:26 <mestery> e.g. the admin user's group policy configuration supercedes the tenants
16:16:34 <mestery> prasadv: Yes, that exactly.
16:16:49 <banix> mestery: but keystone won't be involved ...
16:16:53 <banix> mestery: ok
16:17:23 <s3wong> mestery: that makes the most sense
16:17:27 <banix> prasadv: I am not sure I see how this works
16:17:29 <thinrichs> I'm confused: so Keystone is now accepting these policy rules we're creating here?
16:17:47 <banix> keystone is not really involved. Is it?
16:17:55 <prasadv> what I mean is whether a user has higher precence in terms of authorization is done by keystone
16:18:13 <prasadv> say admin supercedes tenant role
16:18:33 <banix> prasadv: You are saying keystone is consulted for conflict resolution?
16:18:54 <mestery> When policies are created, won't they will have keystone auth attached to them, right?
16:19:04 <prasadv> not sure now where this role based conflict resolution takes place
16:19:38 <prasadv> i am sure this is not just a problem for neutron alone. This is a common problem across all of openstack right?
16:19:41 <banix> mestery: Ok, carry on
16:19:41 <thinrichs> prasadv: I'm guessing the implementation has to ensure that the policy it eventually enforces takes all these conflict resolution schemes into account.
16:20:17 <thinrichs> Is it possible for 2 different tenant policies to conflict?  Both tenants having VMs on the same machine or something?
16:20:31 <thinrichs> If so, the keystone-based conflict resolution won't work.
16:20:52 <mestery> API calls into Neutron have tenant information attached banix, so we may need to take that into account when doing policy resolution is what I was thinking.
16:21:23 <mestery> thinrichs: I think tenant roles need to be factored into the conflict resolution, but it's not the final resolution story for sure.
16:21:33 <s3wong> mestery: so conflict resolution is done at the API layer here?
16:21:51 <mestery> At least for tenant resolution, maybe it has to be s3wong?
16:22:13 <s3wong> mestery: it appears so, actually
16:22:21 <banix> mestery: so at the creation of policy conflicts are detected?
16:22:41 <mestery> banix: For tenant conflicts, maybe it has to be done then, yes.
16:22:42 <banix> I see what you are saying
16:23:07 <thinrichs> Why do we need to resolve conflicts within the API?  Can we have the API just create a bunch of policies with IDs attached, and the implementation compiles that down into the real policy it is implementing?
16:23:28 <s3wong> banix: more interestingly, if tenant has an 'allow', then later on admin adds an 'deny', we would have to find a way to inform tenant his policy fails?
16:23:29 <mestery> thinrichs: That is the other approach I was thinking yes, not sure which approach has advantages.
16:23:29 <songole_> thinrichs: agree
16:23:36 <banix> so if assume admin creates a policy after a tenant has already created a policy and there is conflict, something we need to figure out what to do then.
16:24:03 <banix> s3wong: that's what i was think about
16:24:04 <thinrichs> We might need that more dynamic version anyway because users can change roles, which would require eliminating conflicts again.  We wouldn't want to lose the policy rules they sent in initially.
16:25:11 <prasadv> thinrichs: shouldnt we just limit it during creation? instead of doing it dynamically?
16:25:38 <thinrichs> What would happen if a user changes roles *after* they finished inserting their policies but they didn't login again?  Would Neutron even know their roles changed and that conflict resolution should be revisited?
16:25:55 <banix> So just to narrow down the problem, our simple resolution method would be fine within a tenant. with checks done at policy creation time. Agree?
16:25:59 <thinrichs> prasadv: Not sure--trying to understand the tradeoffs.
16:26:31 <thinrichs> banix: not sure we'd do it at policy creation time.
16:26:33 <songole_> There could be pert issues with dynamic conflict resolution.
16:26:41 <mestery> thinrichs: Is there a workflow in Horizon/CLI to change a users role? I'm asking because I don't know off-hand.
16:26:46 <thinrichs> banix: Suppose two classifiers overlap--do we reject the policy?
16:26:55 <thinrichs> mestery: I don't know--I assumed user roles could change.
16:27:17 <prasadv> i think keystone provides user to be put into different roles
16:27:17 <mestery> thinrichs: I'm asking because we may be boiling the ocean here without knowing hte workflow in existing OpenStack use cases. :)
16:27:28 <mestery> thinrichs: Want to take an action item to figure that out?
16:27:33 <banix> thinrichs: yes
16:27:43 <mestery> thinrichs: It would help us with resolution I think. :)
16:28:01 <thinrichs> banix: Is it always easy to determine if classifiers overlap?
16:28:21 <banix> that would be a good idea.
16:28:27 <thinrichs> mestery: I'll figure out if roles can be changed in Keystone.
16:28:33 <banix> to look into this more closely
16:28:39 <mestery> #action thinrichs to determine if roles can be changed in keystone
16:28:41 <mestery> thanks thinrichs!
16:28:45 <thinrichs> NP
16:28:58 <mestery> OK, lets move on from that discussion until we figure out the underlying keystone stuff for next week.
16:29:12 <banix> mestery: agree
16:29:17 <s3wong> mestery: yes
16:29:35 <s3wong> conflict resolution is an ongoing topic
16:29:36 <mestery> OK, what else to discuss with regards to PoC this week?
16:29:44 <mestery> Anything else?
16:29:53 <banix> It is really cold around here :)
16:30:06 <mestery> banix: So cold school was canceled again today :)
16:30:06 <s3wong> banix: New York?
16:30:11 <mestery> Minnesota here
16:30:17 <banix> s3wong: yes
16:30:31 * s3wong enjoying sunny California
16:30:48 <banix> Didn't hear the last sentence :)
16:30:50 <thinrichs> BTW here's the info on Keystone.
16:30:51 <mestery> s3wong: :P
16:30:53 <thinrichs> user-project roles can be changed on the fly: http://docs.openstack.org/user-guide-admin/content/admin_cli_manage_projects_users.html
16:30:57 <mestery> thinrichs: that was fast!
16:31:07 <thinrichs> Had some help.
16:31:34 <mestery> thinrichs: :)
16:31:52 <s3wong> thinrichs: seems like we need a mechanism to inform tenants that their policies may be invalidated
16:32:01 <mestery> s3wong: My thoughts exactly
16:32:34 <banix> Let us think more about conflict resolution and perhaps discuss on ML?
16:32:46 <banix> s3wong: Getting complicated
16:32:53 <prasadv> s3wong, mestery: Isnt this a Openstack infrastrcuture issue and not just networking?
16:32:55 <mestery> banix: Agreed!
16:33:00 <mestery> prasadv: Yes
16:33:08 <mestery> banix: Want to start the thread for the group on the ML?
16:33:12 <s3wong> and to avoid confusion, in an event of invalidation, I would say all policies need to be invalidated
16:33:21 <s3wong> for that tenant
16:33:28 <thinrichs> Agreed to take it to the ML.
16:33:39 <s3wong> ML it is!
16:33:42 <mestery> #action banix to start discussion around role changes on the ML
16:34:03 <mestery> Anything else for this week with regards to PoC?
16:34:04 <banix> Will do
16:34:22 <s3wong> Happy coding, guys :-)
16:34:32 <mestery> s3wong! Ha!
16:34:39 <mestery> #topic Open Discussion
16:34:44 <mestery> Anything else or should we call it early this week?
16:35:05 <banix> Thinrichs: Needless to say, please feel free to post to the ML regarding this.
16:35:05 <s3wong> another quick meeting, three in a row!
16:35:13 <mestery> Yes!
16:35:26 <mestery> OK, lets see what we can get done with regards to PoC code for next week then.
16:35:27 <banix> Sounds good
16:35:28 <mestery> Thanks everyone!
16:35:30 <mestery> #endmeeting