16:00:43 <mestery> #startmeeting networking_policy
16:00:44 <openstack> Meeting started Thu Feb 13 16:00:43 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:47 <openstack> The meeting name has been set to 'networking_policy'
16:00:57 <banix> mestery: Hi; made a minor change to the agenda just a minute ago; added a line essentially
16:01:02 <mestery> #link https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy Agenda
16:01:05 <mestery> banix: Great!
16:01:26 <mestery> So, it's been 2 weeks since we've met. The OpenDaylight Summit pulled some of us away for the past two weeks.
16:01:40 <mestery> So, lets review Action Items first.
16:01:43 <mestery> #topic Action Item Review
16:01:51 <mestery> SumitNaiksatam: Here?
16:02:10 <mestery> The shared github has changed from the project page, SumitNaiksatam has setup a new one.
16:02:18 <mestery> I will update the meeting page with the details, apologies for not having done that now.
16:02:29 <mestery> But banix and s3wong are aware of this already.
16:03:05 <banix> mestery: Could you please also write a couple of lines about how the git is to be used; with having own branches wtc
16:03:10 <mestery> FYI: The new link is this: https://github.com/noironetworks/neutron-group-policy
16:03:26 <mestery> banix: Yes, SumitNaiksatam added some notes on that, I'll add an action item to that effect.
16:03:26 <banix> mestery: as Sumit suggested so we are all on the same page
16:03:33 <mestery> Good call.
16:03:37 <banix> mestery: thanks.
16:03:40 <marun> is there a reason not to use stackforge?
16:03:50 <mestery> marun: That's another good question.
16:04:06 <marun> code review on github stinks
16:04:12 <banix> marun: what are the benefits
16:04:16 <banix> marun: I see
16:04:20 <mestery> marun: Do we get gerrit reviews on stackforge?
16:04:25 <marun> we do
16:04:37 <marun> and we can tie into openstack ci
16:04:43 <marun> (presuming we have something to test)
16:04:54 <banix> marun: we do :)
16:05:09 <mestery> marun: Thanks for bringing this up. I think this bears looking into, seems like we should do this.
16:05:19 <banix> +1
16:05:35 <mestery> marun: I'll have SumitNaiksatam talk with you since he setup the other github.
16:05:45 <marun> mestery: ok, sounds good
16:05:46 <mestery> #action SumitNaiksatam and marun to discuss moving shared code to stackforge.
16:05:49 <mestery> Thanks!
16:06:06 <mestery> OK next action item for review.
16:06:28 <mestery> #link https://docs.google.com/document/d/14UyvBkptmrxB9FsWEP8PEGv9kLqTQbsmlRxnqeF9Be8/edit?usp=sharing API Document
16:06:39 <mestery> This is basically taken from the overall Group Policy Document
16:06:53 <mestery> I think, given this, I'd like to deprecate this one and focus on the Group Policy Document.
16:06:54 <mestery> Thoughts?
16:07:09 <mestery> #undo
16:07:10 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x2f42110>
16:07:15 <mestery> #link https://docs.google.com/a/mestery.com/document/d/1b_ywmSTKYW4PBjhkXREPePRgVmz-Uwv_Bb-i7Jaqsu4/edit API Document
16:07:17 <mestery> Sorry, wrong link
16:07:19 <mestery> That's the correct one.
16:07:40 <mestery> banix: Thoughts on this, given the overlap?
16:07:50 <mestery> I wasn't sure what this separate document was buying us.
16:07:51 <banix> mestery: yes sure
16:07:58 <banix> agree
16:08:11 <mestery> #link https://docs.google.com/document/d/1ZbOFxAoibZbJmDWx1oOrOsDcov6Cuom5aaBIrupCD9E/edit?usp=sharing Group Policy Architecture Document
16:08:21 <mestery> s3wong: Are you here by chance?
16:09:02 <mestery> OK, I'll speak with s3wong offline about this.
16:09:06 <banix> we need to review the last doc to make sure it is up to date
16:09:19 <mestery> banix: You mean that the separate API doc hasn't added something different?
16:09:42 <banix> mestery: yes
16:10:04 <mestery> banix: good call. I'll assign an AI for me, you and s3wong to do that.
16:10:19 <banix> sounds good
16:10:26 <mestery> #action banix s3wong mestery to collapse separate API document back into Group Policy Architecture Document
16:10:39 <mestery> Thanks banix
16:11:09 <mestery> OK, that's all I had for action items on the agenda.
16:11:18 <mestery> #topic PoC
16:11:45 <mestery> On the topic of the PoC, s3wong sent out an initial API diff, SumitNaiksatam is in process of adding that into a shared github now.
16:12:03 <mestery> Has anyone else started work on anything else yet?
16:12:18 <banix> I have also worked on the database model for new group policy tables
16:12:21 <alagalah> Not yet
16:12:30 <alagalah> banix: is that documented anywhere?
16:12:37 <mestery> banix: Nice work!
16:12:46 <alagalah> banix: Sorry :) Yes that's awesome!
16:12:54 <banix> I will push up the code as soon as we decide how to do it
16:13:37 <mestery> banix: Great! Lets sort out stackforge vs. github as well.
16:14:04 <mestery> I mean, before the push of your code.
16:14:18 <banix> mestery: yes, then you guys can have a look and see how it is and we can make changes as necessary
16:14:25 <mestery> banix: Cool!
16:15:23 <mestery> We also need to start on the agent side code as well, and eventually implement the new APIs in ML2 and the openvswitch MD.
16:16:13 <banix> mestery: sounds good
16:16:52 <banix> we have people assigned to that part?
16:16:54 <marun> agents, hmmm.  I'll need to follow up afterwards on that topic.
16:17:17 <mestery> marun: Ideally we do this using ODL once that gets into the tree.
16:17:30 * mestery just realized he had moved this meeting to an hour later, and yet most of us showed up at this time ...
16:17:44 <mestery> I was wondering where s3wong and SumitNaiksatam were. :)
16:17:55 <mestery> I wonder if we should continue or come back in 45 minutes?
16:18:07 <banix> so that is what Sumit was referring to! a new time!
16:18:10 <banix> :)
16:18:15 <mestery> Man, I am dense this morning.
16:18:18 <marun> tempest meeting is in 45m :(
16:18:29 <mestery> On this channel? I thought I had checked that!
16:18:37 <banix> I missed that change of time
16:18:48 <marun> no, #openstack-meeting.  but it would be a conflict for me
16:19:00 <mestery> marun: OK.
16:19:09 <mestery> marun: what about 1800 UTC? Is that better?
16:19:23 <marun> mestery: yes, better
16:20:06 <mestery> So, 1800UTC on Thursday's is booked, unless we get another IRC channel for meetings. :)
16:20:23 <mestery> The FWaaS meeting is at 1800UTC on Wednesday
16:20:41 <mestery> Does Monday/Friday work for people?
16:20:46 <mestery> OR should we try 1900 UTC :)
16:21:09 <mestery> 1900 UTC is free on most days for this meeting.
16:21:31 <banix> mestery: 1900 UTC on Thurs works for me
16:22:13 <marun> i have no potential conflicts m/w/f
16:22:24 <mestery> marun: At 1900 UTC?
16:22:48 <marun> i can't make it today, but usually that time is fine
16:23:53 <mestery> OK, looks like Thursday 1900 UTC is the best time for this meeting going forward then.
16:24:04 <mestery> I'll send out an updated meeting invite, and this time BCC banix so he gets a copy :)
16:24:16 <mestery> #action mestery to move this meeting to 1900 UTC Thursday going forward
16:24:21 <banix> mestery: thanks :)
16:24:48 * cgoncalves waves and agrees :)
16:24:53 <mestery> :)
16:25:24 <mestery> OK, since s3wong and SumitNaiksatam aren't here, I propose we adjourn this now, and for today, come back in 35 minutes for a quick syncup with those folks and others as well.
16:25:26 <mestery> Sound ok to everyone?
16:25:37 <alagalah> ack
16:25:40 <banix> yes
16:25:46 <alagalah> I won't be here but I'll read the transcript later today
16:26:08 <mestery> alagalah and marun: Thanks for dropping by to the early version of this one, we'll look forward to seeing you folks next week at the new 1900 UTC slot. :)
16:26:17 <marun> :)
16:26:17 <mestery> OK, we'll see everyone back here in 35 minutes!
16:26:19 <mestery> Thanks!
16:26:21 <mestery> #endmeeting